]> git.pld-linux.org Git - packages/LiVES.git/blob - LiVES.spec
69fe646837c101ba10deeebce087342bf405f742
[packages/LiVES.git] / LiVES.spec
1 # TODO
2 # - unfortunately it crashes in weed_plugin_info_init (alien_overlay.wo)
3 # - some platform-independent left in %{_libdir}
4 # - LiVES req LiVES-plugins which req LiVES; it sucks
5
6 %define         _sname          lives
7
8 Summary:        LiVES - the Linux Video Editing System
9 Summary(pl.UTF-8):      LiVES - Linuksowy System Edycji Video
10 Name:           LiVES
11 Version:        0.9.8.4
12 Release:        0.1
13 License:        GPL v2
14 Group:          X11/Applications/Multimedia
15 Source0:        http://www.xs4all.nl/%7Esalsaman/lives/current/%{name}-%{version}.tar.bz2
16 # Source0-md5:  585f7a8d8a3e2b71a886fc04de3a79a3
17 Source1:        %{name}.desktop
18 Patch0:         %{name}-FHS.patch
19 Patch1:         %{name}-automake.patch
20 URL:            http://www.xs4all.nl/~salsaman/lives/
21 BuildRequires:  SDL-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake >= 1:1.7
24 BuildRequires:  gettext-devel >= 0.14.1
25 BuildRequires:  gtk+2-devel >= 2.0.0
26 BuildRequires:  libtheora-devel
27 BuildRequires:  libtool
28 BuildRequires:  libvisual-devel
29 BuildRequires:  mjpegtools-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  sed >= 4.0
32 BuildRequires:  xorg-util-imake
33 Requires:       %{name}-plugins = %{version}-%{release}
34 Requires:       ImageMagick >= 5
35 Requires:       ffmpeg
36 Requires:       mplayer >= 0.90rc1
37 Requires:       ogmtools
38 Requires:       perl-base
39 Requires:       python >= 1:2.3
40 Requires:       sox
41 Requires:       transcode
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 # workaround for the next change
45 %define         _localedir      %{_usr}/share/locale
46 # platform-dependent plugins in %{_datadir}
47 %define         _datadir        %{_libdir}
48 %define         _themesdir      %{_datadir}/%{_sname}/themes
49 # shared objects without .so (e.g. SDL), which we don't want to provide
50 %define         _noautoprovfiles        ^%{_datadir}/%{_sname}/.*
51
52 %description
53 LiVES began as the Linux Video Editing System. Since it now runs on
54 more operating systems, LiVES is a Video Editing System. It is
55 designed to be simple to use, yet powerful. It is small in size, yet
56 it has many advanced features.
57
58 %description -l pl.UTF-8
59 LiVES zaczynał jako Linuksowy System Edycji Video. Obecnie można
60 również uruchomić go na większej liczbie systemów operacyjnych.
61 Zaprojektowany został tak, by być zarówno prostym w użyciu jak i mimo
62 niewielkiego rozmiaru posiadać zaawansowane funkcje.
63
64 %package plugins
65 Summary:        Plugins for LiVES
66 Summary(pl.UTF-8):      Wtyczki dla LiVES
67 Group:          X11/Applications/Multimedia
68 Requires:       %{name} = %{version}-%{release}
69
70 %description plugins
71 Plugins for LiVES.
72
73 %description plugins -l pl.UTF-8
74 Wtyczki (plugins) dla LiVES.
75
76 %package themes
77 Summary:        Themes for LiVES
78 Summary(pl.UTF-8):      Motywy dla LiVES
79 Group:          Themes/GTK+
80 Requires:       %{name} = %{version}-%{release}
81
82 %description themes
83 Themes for LiVES.
84
85 %description themes -l pl.UTF-8
86 Motywy dla LiVES.
87
88 %prep
89 %setup -qn %{_sname}-%{version}
90 %patch0 -p1
91 %patch1 -p1
92
93 # wrrr
94 sed -i -e 's,/share/,/%{_lib}/,' po/pxgettext po/make_rfx_builtin_list.pl
95
96 %build
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__automake}
100 # hack: DATADIRNAME defined too late in configure
101 %configure \
102         DATADIRNAME=share
103 %{__make} \
104         CFLAGS="%{rpmcflags} -fPIC"
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_desktopdir}
109 install -d $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
110 for i in lives-plugins/plugins/effects/RFXscripts/*.script ; do
111         ./build-lives-rfx-plugin $i $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
112 done
113
114 # hack: override localedir because of redefined datadir
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT \
117         localedir=%{_localedir}
118
119 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
120 mv $RPM_BUILD_ROOT%{_docdir}/%{_sname}-%{version} \
121         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
122
123 mv -f $RPM_BUILD_ROOT%{_localedir}/de{_DE,}
124 mv -f $RPM_BUILD_ROOT%{_localedir}/nl{_NL,}
125
126 %find_lang %{_sname}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -f %{_sname}.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED NEWS RFX OMC
134 %attr(755,root,root) %{_bindir}/*
135 %dir %{_datadir}/%{_sname}
136 %{_datadir}/%{_sname}/icons
137 %{_datadir}/%{_sname}/default.keymap
138 %{_desktopdir}/%{name}.desktop
139 %dir %{_themesdir}
140 %{_themesdir}/default
141
142 %files themes
143 %defattr(644,root,root,755)
144 %{_themesdir}/camera
145 %{_themesdir}/cutting_room
146 %{_themesdir}/greenish
147 %{_themesdir}/pinks
148 %{_themesdir}/sunburst
149 %{_themesdir}/editor
150
151 %files plugins
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_datadir}/%{_sname}/plugins
This page took 0.11881 seconds and 3 git commands to generate.