]> git.pld-linux.org Git - packages/LiVES.git/blob - LiVES.spec
05a9a13436f0882decc16228a613d33fd0ade2b8
[packages/LiVES.git] / LiVES.spec
1
2 # TODO
3 # - some platform-independent left in %{_libdir}
4
5 %define         _sname          lives
6
7 Summary:        LiVES - the Linux Video Editing System
8 Summary(pl.UTF-8):   LiVES - Linuksowy System Edycji Video
9 Name:           LiVES
10 Version:        0.9.6
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications/Multimedia
14 Source0:        http://www.xs4all.nl/%7Esalsaman/lives/current/%{name}-%{version}.tar.bz2
15 # Source0-md5:  71bc3a29d0d37a8ca88370a3499741d4
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-FHS.patch
18 URL:            http://www.xs4all.nl/~salsaman/lives/
19 BuildRequires:  SDL-devel
20 BuildRequires:  automake >= 1:1.7
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  gettext-devel >= 0.14.1
23 BuildRequires:  gtk+2-devel >= 2.0.0
24 BuildRequires:  libtheora-devel
25 BuildRequires:  libtool
26 BuildRequires:  libvisual-devel
27 BuildRequires:  mjpegtools-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  xorg-util-imake
31 Requires:       %{name}-plugins = %{version}-%{release}
32 Requires:       ImageMagick >= 5
33 Requires:       ffmpeg
34 Requires:       mplayer >= 0.90rc1
35 Requires:       ogmtools
36 Requires:       perl-base
37 Requires:       python >= 1:2.3
38 Requires:       sox
39 Requires:       transcode
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # workaround for the next change
43 %define         _localedir      %{_usr}/share/locale
44 # platform-dependent plugins in %{_datadir}
45 %define         _datadir        %{_libdir}
46 %define         _themesdir      %{_datadir}/%{_sname}/themes
47 # shared objects without .so (e.g. SDL), which we don't want to provide
48 %define         _noautoprovfiles        ^%{_datadir}/%{_sname}/.*
49
50 %description
51 LiVES began as the Linux Video Editing System. Since it now runs on
52 more operating systems, LiVES is a Video Editing System. It is
53 designed to be simple to use, yet powerful. It is small in size, yet
54 it has many advanced features.
55
56 %description -l pl.UTF-8
57 LiVES zaczynał jako Linuksowy System Edycji Video. Obecnie można
58 również uruchomić go na większej liczbie systemów operacyjnych.
59 Zaprojektowany został tak, by być zarówno prostym w użyciu jak
60 i mimo niewielkiego rozmiaru posiadać zaawansowane funkcje.
61
62 %package plugins
63 Summary:        Plugins for LiVES
64 Summary(pl.UTF-8):   Wtyczki dla LiVES
65 Group:          X11/Applications/Multimedia
66 Requires:       %{name} = %{version}-%{release}
67
68 %description plugins
69 Plugins for LiVES.
70
71 %description plugins -l pl.UTF-8
72 Wtyczki (plugins) dla LiVES.
73
74 %package themes
75 Summary:        Themes for LiVES
76 Summary(pl.UTF-8):   Motywy dla LiVES
77 Group:          Themes/GTK+
78 Requires:       %{name} = %{version}-%{release}
79
80 %description themes
81 Themes for LiVES.
82
83 %description themes -l pl.UTF-8
84 Motywy dla LiVES.
85
86 %prep
87 %setup -qn %{_sname}-%{version}
88 %patch0 -p1
89
90 # wrrr
91 sed -i -e 's,/share/,/%{_lib}/,' po/pxgettext po/make_rfx_builtin_list.pl
92
93 %build
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__automake}
97 # hack: DATADIRNAME defined too late in configure
98 %configure \
99         DATADIRNAME=share
100 %{__make} \
101         CFLAGS="%{rpmcflags} -fPIC"
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_desktopdir}
106 install -d $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
107 for i in lives-plugins/plugins/effects/RFXscripts/*.script ; do
108         ./build-lives-rfx-plugin $i $RPM_BUILD_ROOT%{_datadir}/lives/plugins/effects/rendered
109 done
110
111 # hack: override localedir because of redefined datadir
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         localedir=%{_localedir}
115
116 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
117 mv $RPM_BUILD_ROOT%{_docdir}/%{_sname}-%{version} \
118         $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
119
120 mv -f $RPM_BUILD_ROOT%{_localedir}/{cz,cs}
121 mv -f $RPM_BUILD_ROOT%{_localedir}/nl{_NL,}
122
123 %find_lang %{_sname}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files -f %{_sname}.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS BUGS CHANGELOG FEATURES GETTING.STARTED NEWS RFX OMC
131 %attr(755,root,root) %{_bindir}/*
132 %dir %{_datadir}/%{_sname}
133 %{_datadir}/%{_sname}/icons
134 %{_desktopdir}/%{name}.desktop
135 %dir %{_themesdir}
136 %{_themesdir}/default
137
138 %files themes
139 %defattr(644,root,root,755)
140 %{_themesdir}/camera
141 %{_themesdir}/cutting_room
142 %{_themesdir}/greenish
143 %{_themesdir}/pinks
144 %{_themesdir}/sunburst
145 %{_themesdir}/editor
146
147 %files plugins
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_datadir}/%{_sname}/plugins
This page took 0.080819 seconds and 2 git commands to generate.