]> git.pld-linux.org Git - packages/GLStats.git/blob - GLStats.spec
- updated to 0.3.2
[packages/GLStats.git] / GLStats.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # build and package API docs (empty as of 0.3.1)
4 #
5 Summary:        Generic OpenGL overlay statistics renderer
6 Summary(pl.UTF-8):      Ogólna biblioteka do renderowania statystyk na nakładce OpenGL
7 Name:           GLStats
8 Version:        0.3.2
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 #Source0Download: https://github.com/Eyescale/GLStats/tags
13 Source0:        https://github.com/Eyescale/GLStats/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  4af2acee59974144ae2cad2930af14aa
15 Patch0:         %{name}-cmake.patch
16 Patch1:         %{name}-shared.patch
17 Patch2:         %{name}-update.patch
18 URL:            https://github.com/Eyescale/GLStats/
19 BuildRequires:  Eyescale-CMake >= 2018.2
20 BuildRequires:  Lunchbox-devel >= 1.10
21 BuildRequires:  Servus-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  cmake >= 2.8
24 %{?with_apidocs:BuildRequires:  doxygen}
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  pkgconfig
27 Requires:       Lunchbox >= 1.10
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Generic OpenGL overlay statistics renderer.
32
33 %description -l pl.UTF-8
34 Ogólna biblioteka do renderowania statystyk na nakładce OpenGL.
35
36 %package devel
37 Summary:        Header files for GLStats library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GLStats
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       Lunchbox-devel >= 1.10
42 Requires:       libstdc++-devel
43
44 %description devel
45 Header files for GLStats library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki GLStats.
49
50 %package apidocs
51 Summary:        GLStats API documentation
52 Summary(pl.UTF-8):      Dokumentacja API biblioteki GLStats
53 Group:          Documentation
54
55 %description apidocs
56 API documentation for GLStats library.
57
58 %description apidocs -l pl.UTF-8
59 Dokumentacja API biblioteki GLStats.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66
67 ln -s %{_datadir}/Eyescale-CMake CMake/common
68 %{__rm} .gitexternals
69
70 %build
71 install -d build
72 cd build
73 %cmake ..
74
75 %{__make}
76
77 %if %{with apidocs}
78 doxygen doc/Doxyfile
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} -C build install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc LICENSE.txt README.md
96 %attr(755,root,root) %{_libdir}/libGLStats.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libGLStats.so.1
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libGLStats.so
102 %{_includedir}/GLStats
103 %dir %{_datadir}/GLStats
104 %{_datadir}/GLStats/CMake
105
106 %if %{with apidocs}
107 %files apidocs
108 %defattr(644,root,root,755)
109 %doc build/doc/html/*
110 %endif
This page took 0.089958 seconds and 4 git commands to generate.