]> git.pld-linux.org Git - packages/GConf2.git/blob - GConf2.spec
- R: pkgconfig for -devel
[packages/GConf2.git] / GConf2.spec
1 #
2 # TODO:
3 # - install evoldap.scheme ?
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNOME2 configuration database system
9 Summary(pl):    System konfiguracyjnej bazy danych dla GNOME 2
10 Summary(pt_BR): Sistema de Configuração do GNOME 2
11 Summary(ru):    óÉÓÔÅÍÁ ËÏÎÆÉÇÕÒÁÃÉÉ GNOME 2
12 Name:           GConf2
13 Version:        2.12.1
14 Release:        2
15 License:        LGPL
16 Group:          X11/Applications
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/GConf/2.12/GConf-%{version}.tar.bz2
18 # Source0-md5:  247110de013ed24b17cf4191eb6daec5
19 Source1:        %{name}-merge-tree.xinit
20 Patch0:         %{name}-NO_MAJOR_VERSION.patch
21 Patch1:         %{name}-path.patch
22 URL:            http://www.gnome.org/
23 BuildRequires:  ORBit2-devel >= 1:2.12.3
24 BuildRequires:  autoconf
25 BuildRequires:  automake >= 1:1.7
26 BuildRequires:  gettext-devel
27 BuildRequires:  gtk+2-devel >= 2:2.8.3
28 BuildRequires:  gtk-doc >= 1.4-2
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel >= 1:2.6.21
31 BuildRequires:  perl-base
32 BuildRequires:  pkgconfig
33 BuildRequires:  popt-devel
34 BuildRequires:  rpmbuild(macros) >= 1.197
35 Obsoletes:      libGConf2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GConf2 is a configuration database system, functionally similar to the
40 Windows registry but lots better. :-) It's being written for the
41 GNOME2 desktop but does not require GNOME2; configure should notice if
42 GNOME2 is not installed and compile the basic GConf2 library anyway.
43
44 %description -l pl
45 GConf2 jest systemem konfiguracyjnej bazy danych, funkcjonalnie
46 podobnej do rejestru Windows, ale o wiele lepszej :-). Jest pisana dla
47 desktopu GNOME2, ale nie wymaga GNOME2; skrypt configure powinien
48 wykryæ brak GNOME2 i skompilowaæ tylko wersjê podstawow± GConf2.
49
50 %description -l pt_BR
51 Gconf2 é o sistema de banco de dados de configuração do GNOME2.
52
53 %package devel
54 Summary:        GConf2 includes, etc
55 Summary(pl):    Pliki nag³ówkowe GConf2
56 Summary(pt_BR): Sistema de Configuração do GNOME2 - arquivos para desenvolvimento
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       ORBit2-devel >= 1:2.12.3
60 Requires:       gtk-doc-common
61 Requires:       libxml2-devel >= 1:2.6.21
62 Requires:       pkgconfig
63 Obsoletes:      libGConf2-devel
64
65 %description devel
66 GConf2 includes etc.
67
68 %description devel -l pl
69 Pliki nag³ówkowe GConf2.
70
71 %description devel -l pt_BR
72 Sistema de Configuração do GNOME2 - arquivos para desenvolvimento.
73
74 %package static
75 Summary:        GConf2 static libraries
76 Summary(pl):    Biblioteki statyczne GConf2
77 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com gconf2
78 Group:          X11/Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 GConf2 static libraries.
83
84 %description static -l pl
85 Biblioteki statyczne GConf2.
86
87 %description static -l pt_BR
88 Bibliotecas estáticas para desenvolvimento com gconf
89
90 %prep
91 %setup -q -n GConf-%{version}
92 %patch0 -p1
93 %patch1 -p1
94
95 %build
96 rm -f acinclude.m4
97 %{__glib_gettextize}
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoheader}
101 %{__autoconf}
102 %{__automake}
103 %configure \
104         --with-html-dir=%{_gtkdocdir} \
105         %{!?with_static_libs:--disable-static} \
106 %ifarch ppc
107         --disable-gtk-doc
108 %else
109         --enable-gtk-doc
110 %endif
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_sysconfdir}{/gconf/schemas,/X11/xinit/xinitrc.d}
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/GConf2-merge-tree
122
123 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
124
125 %find_lang %{name}
126
127 # no *.{la,a} for modules - shut up check-files
128 rm -f $RPM_BUILD_ROOT%{_libdir}/GConf2/lib*.{la,a}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README
139 %attr(755,root,root) %{_bindir}/gconf*
140 %attr(755,root,root) %{_libdir}/gconf-sanity-check-2
141 %attr(755,root,root) %{_libdir}/gconfd-2
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143 %dir %{_libdir}/GConf2
144 %attr(755,root,root) %{_libdir}/GConf2/lib*.so
145 %{_sysconfdir}/gconf
146 %attr(755,root,root) %{_sysconfdir}/X11/xinit/xinitrc.d/*
147 %{_datadir}/sgml/gconf
148 %{_mandir}/man1/*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %doc ChangeLog TODO
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_libdir}/lib*.la
155 %{_includedir}/gconf2
156 %{_aclocaldir}/*.m4
157 %{_pkgconfigdir}/*.pc
158 %{_gtkdocdir}/gconf
159
160 %if %{with static_libs}
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/lib*.a
164 %endif
This page took 0.038905 seconds and 4 git commands to generate.