]> git.pld-linux.org Git - packages/GConf2.git/blob - GConf2.spec
e43a860a28d8644d830a6e0e7bedc06831c4e444
[packages/GConf2.git] / GConf2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        GNOME2 configuration database system
6 Summary(pl):    System konfiguracyjnej bazy danych dla GNOME 2
7 Summary(pt_BR): Sistema de Configuração do GNOME 2
8 Summary(ru):    óÉÓÔÅÍÁ ËÏÎÆÉÇÕÒÁÃÉÉ GNOME 2
9 Name:           GConf2
10 Version:        2.10.0
11 Release:        5
12 License:        LGPL
13 Group:          X11/Applications
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/GConf/2.10/GConf-%{version}.tar.bz2
15 # Source0-md5:  a7cd37be4e317195a6668a086fc72033
16 Patch0:         %{name}-NO_MAJOR_VERSION.patch
17 Patch1:         %{name}-path.patch
18 Patch2:         %{name}-shutdown.patch
19 URL:            http://www.gnome.org/
20 BuildRequires:  ORBit2-devel >= 1:2.12.1
21 BuildRequires:  autoconf
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  gettext-devel
24 BuildRequires:  gtk+2-devel >= 2:2.6.4
25 BuildRequires:  gtk-doc >= 1.3
26 BuildRequires:  libtool
27 BuildRequires:  libxml2-devel >= 1:2.6.19
28 BuildRequires:  perl-base
29 BuildRequires:  pkgconfig
30 BuildRequires:  popt-devel
31 BuildRequires:  rpmbuild(macros) >= 1.197
32 Obsoletes:      libGConf2
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GConf2 is a configuration database system, functionally similar to the
37 Windows registry but lots better. :-) It's being written for the
38 GNOME2 desktop but does not require GNOME2; configure should notice if
39 GNOME2 is not installed and compile the basic GConf2 library anyway.
40
41 %description -l pl
42 GConf2 jest systemem konfiguracyjnej bazy danych, funkcjonalnie
43 podobnej do rejestru Windows, ale o wiele lepszej :-). Jest pisana dla
44 desktopu GNOME2, ale nie wymaga GNOME2; skrypt configure powinien
45 wykryæ brak GNOME2 i skompilowaæ tylko wersjê podstawow± GConf2.
46
47 %description -l pt_BR
48 Gconf2 é o sistema de banco de dados de configuração do GNOME2.
49
50 %package devel
51 Summary:        GConf2 includes, etc
52 Summary(pl):    Pliki nag³ówkowe GConf2
53 Summary(pt_BR): Sistema de Configuração do GNOME2 - arquivos para desenvolvimento
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       ORBit2-devel >= 1:2.12.1
57 Requires:       gtk-doc-common
58 Requires:       libxml2-devel >= 1:2.6.19
59 Obsoletes:      libGConf2-devel
60
61 %description devel
62 GConf2 includes etc.
63
64 %description devel -l pl
65 Pliki nag³ówkowe GConf2.
66
67 %description devel -l pt_BR
68 Sistema de Configuração do GNOME2 - arquivos para desenvolvimento.
69
70 %package static
71 Summary:        GConf2 static libraries
72 Summary(pl):    Biblioteki statyczne GConf2
73 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com gconf2
74 Group:          X11/Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 GConf2 static libraries.
79
80 %description static -l pl
81 Biblioteki statyczne GConf2.
82
83 %description static -l pt_BR
84 Bibliotecas estáticas para desenvolvimento com gconf
85
86 %prep
87 %setup -q -n GConf-%{version}
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 %build
93 rm -f acinclude.m4
94 %{__glib_gettextize}
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoheader}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         --with-html-dir=%{_gtkdocdir} \
102         %{!?with_static_libs:--disable-static} \
103 %ifarch ppc
104         --disable-gtk-doc
105 %else
106         --enable-gtk-doc
107 %endif
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
119
120 %find_lang %{name}
121
122 # no *.{la,a} for modules - shut up check-files
123 rm -f $RPM_BUILD_ROOT%{_libdir}/GConf2/lib*.{la,a}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS NEWS README
134 %attr(755,root,root) %{_bindir}/gconf*
135 %attr(755,root,root) %{_libdir}/gconf-sanity-check-2
136 %attr(755,root,root) %{_libdir}/gconfd-2
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138 %dir %{_libdir}/GConf2
139 %attr(755,root,root) %{_libdir}/GConf2/lib*.so
140 %{_sysconfdir}/gconf
141 %{_datadir}/sgml/gconf
142 %{_mandir}/man1/*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc ChangeLog TODO
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_libdir}/lib*.la
149 %{_includedir}/gconf2
150 %{_aclocaldir}/*.m4
151 %{_pkgconfigdir}/*.pc
152 %{_gtkdocdir}/gconf
153
154 %if %{with static_libs}
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
158 %endif
This page took 0.084609 seconds and 3 git commands to generate.