]> git.pld-linux.org Git - packages/FSViewer.git/blob - FSViewer.spec
34983db443512839b1f5080d592f0981ce1f212e
[packages/FSViewer.git] / FSViewer.spec
1 %define name fsviewer
2 %define version 0.1.1
3 %define release 1
4 %define serial 3
5 %define prefix /usr
6
7 Summary:        FSViewer is a NeXT FileViewer lookalike for Window Maker.
8 Name:           %{name}
9 Version:        %{version}
10 Release:        %{release}
11 Serial:         %{serial}
12 Copyright:      GPL
13 Group:          X11/Utilities
14 URL:            http://www.csn.ul.ie/~clernong/projects/fsviewer.html
15 Vendor:         George Clernon <clernong@tinet.ie>
16 Source:         http://www.csn.ul.ie/~clernong/download/FSViewer.app-%{version}.tar.gz
17 Prefix:         %{prefix}
18 BuildRoot:      /tmp/%{name}-%{version}-root
19
20 %description
21 FSViewer is a NeXT FileViewer lookalike for Window Maker. Viewing is currently 
22 supported via browser mode. It has been written in C using the WINGs library.  
23
24 **** For Use With Window Maker 0.51.x ****
25
26 %prep
27 %setup -q -n FSViewer.app-%{version}
28 CFLAGS=$RPM_OPT_FLAGS \
29 ./configure --prefix=%{prefix}
30
31 %build
32 make
33
34 %install
35 if [ -e $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
36 mkdir -p $RPM_BUILD_ROOT%{prefix}/{bin,share}
37 make prefix=$RPM_BUILD_ROOT%{prefix} install
38 install -m 644 FSViewer $RPM_BUILD_ROOT%{prefix}/share/FSViewer.app/FSViewer
39
40 %post
41 cat <<EOM
42
43 ==============================================================================
44 You must copy %{prefix}/share/FSViewer.app/FSViewer to ~/GNUstep/Defaults/
45 ==============================================================================
46
47 EOM
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(-,root,root)
54 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
55 %{prefix}/bin/fsviewer
56 %{prefix}/share/FSViewer.app
57
58 %changelog
59 * Wed Feb 23 1999 Ryan Weaver <ryanw@infohwy.com>
60   [fsviewer-0.1.1-1]
61 - FSViewer.app-0.1.1 (19990223)
62 - o Commented out FSDisk related code in FSUtils.c, should fix
63     some multi-platform compilation problems.
64 - o Added a patch to automatically detect HOME dir.
65 - o Fixed a bug that crashes the app if the inital path contains a
66     long path component.
67 - o Zombie process are now cleaned up.
68 - o Fixed WMJustified bug (should be WAJustified) in inspector.c and 
69     iconInspector.c
70 - o Implemented Revert in attributes inspector.
71 - o Initial launch path is now the users home dir.
72 - o Now checks return value of getpwuid and getgrgid calls in 
73     attribsInspector.c, used to seg fault if either group or user
74     was unknown.
75 - o Disabled hiding of app via 'h' key, leaving it up to Window Maker 
76     and changed the quit key from 'q' to '^q' to prevent accidents :).
77 - o Added in a "Console" menu option under the "Tools" menu. It launches
78     an xterm at the current directory.
79 - o The window and miniwindow icon titles are set with the current 
80     selection.
81 - o Added in rudimentary magic files support. This allows certain kinds
82     of unknown files to be viewed. 
83 - o Fixed bug wrt to displaying/hiding dot files.
84 - o Added in file filtering.
85
86 * Wed Feb  3 1999 Ryan Weaver <ryanw@infohwy.com>
87   [fsviewer-0.1.0-1]
88 - FSViewer.app-0.1.0 (19990201)
89 - o Reorganised the initialisation of the app.
90 - o Multiple Windows can be opened.
91 - o Display hidden files.
92 - o Permissions can be set from attributes inspector.
93 - o Icons can be set for extensions from File Extension
94     inspector.
95 - o Added legal panel.
96 - o Added info panel (broke app for other platforms though).
97 - o Tidied up code for file browsing to easily add other
98     views.
99 - o In the process of moving odds and ends to FSUtils.c
100 - o Rewrote the scrollview code that displays the current path.
101 - o The window(s) can be resized in both width and height.
102 - o Using nodename from utsname struct as the hostname.
103 - o Using timestampWidget instead of timestamp in attribsInspector 
104     as it can display the year.
105 - o Updated the configure script to take into account datadir value
106     when generating the FSViewer default file.
107 - o Added in Cut, Copy, Paste, Rename, Delete and Link.
108 - o Inspector window now updates automatically if it is open.
109 - o Added in the shelf.
110 - o Added new file/directory creation.
111 - o Before launching an app, the pwd is changed to the selected dir.
112 - o Added in the Tools submenu and moved the Inspector there.
113 - o Created icons and src sub directories.
114
115 * Fri Dec 18 1998 Ryan Weaver <ryanw@infohwy.com>
116   [fsviewer-0.0.2-1]
117 - FSViewer.app-0.0.2 (19981217)
118 - o Added in more checks to the configure script.
119 - o Replaced basename with GetNameFromPathname.
120 - o Using strrchr instead of rindex.
121 - o Searches the Window Maker defaults domain for IconPath
122 -   instead of PixmapPath
123 - o Using "/" if environment variable HOSTNAME is not set.
124 - o Added command line option to start FSViewer at a specified
125 -   path.
126
127
128 * Thu Dec 10 1998 Ryan Weaver <ryanw@infohwy.com>
129   [fsviewer-19981214-1]
130 - First RPM
131 - 14/12/98
132     The source code for FSViewer is now available. This is a preliminary
133   release. It's not guaranteed to do anything. Hopefully it will compile and
134   run straight out of the box. I'm currently working on getting it to compile
135   on my Sun at work.
This page took 0.075782 seconds and 3 git commands to generate.