]> git.pld-linux.org Git - packages/ElectricFence.git/blob - ElectricFence.spec
-typo
[packages/ElectricFence.git] / ElectricFence.spec
1 Summary:        A debugger which detects memory allocation violations
2 Summary(de):    Debugger zum Erkennen von Speicherzugriffsverletzungen
3 Summary(es):    Electric Fence biblioteca de depuración de memoria en C
4 Summary(fr):    Bibliothèque C de débuggage mémoire Electric Fence
5 Summary(pl):    Biblioteka do wykrywania b³edów alokacji pamiêci
6 Summary(pt_BR): Electric Fence biblioteca de depuração de memória em C
7 Summary(tr):    C için bellek hatasý ayýklama kitaplýðý
8 Name:           ElectricFence
9 Version:        2.2.2
10 Release:        3
11 Copyright:      GPL
12 Group:          Development/Debuggers
13 Group(pl):      Programowanie/Odpluskwiacze
14 Source:         ftp://perens.com/pub/ElectricFence/Beta/%{name}-%{version}.tar.gz
15 Patch0:         ElectricFence-longjmp.patch
16 Patch1:         ElectricFence-no_bash.spec
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 If you know what malloc() violations are, you'll be interested in
21 ElectricFence. ElectricFence is a tool which can be used for C programming
22 and debugging. It uses the virtual memory hardware of your system to detect
23 when software overruns malloc() buffer boundaries, and/or to detect any
24 accesses of memory released by free(). ElectricFence will then stop the
25 program on the first instruction that caused a bounds violation and you can
26 use your favorite debugger to display the offending statement.
27
28 This package will install ElectricFence, which you can use if you're
29 searching for a debugger to find malloc() violations.
30
31 %description -l de
32 Wenn Sie wissen, was malloc()-Verletzungen sind, sind Sie wahrscheinlich an
33 ElectricFence interessiert. ElectricFence ist ein Tool, das zur C-
34 Programmierung und zum Debugging benutzt werden kann. Es benutzt virtuelle
35 Speicherhardware, um zu erkennen, wenn Software malloc()-Buffergrenzen
36 übersteigt, und wenn Speicher mit free() freigegeben wird. ElectricFence
37 beendet das Programm bei der Instruktion, die die Speicherverletzung
38 ausgelöst hat, und Sie können Ihren Lieblingsdebugger benutzen, um den
39 Befehl anzuzeigen.
40
41 %description -l es
42 Electric Fence es una biblioteca que puede ser usada para programación y
43 depuración en C. Tu lo "linkas" en tiempo de compilación y te avisará sobre
44 posibles problemas, como liberación de memoria no alocada, etc.
45
46 %description -l fr
47 Electric Fence est une bibliothéque utilisée pour la programmation en C et
48 le débogage. Vous pouvez la lier à la compilation et elle vous avertira des
49 problèmes éventuels de désallocation de mémoire, etc.
50
51 %description -l pl
52 Electric Fence jest bibliotek± pomocn± podczas programowania w
53 jêzyku C i "odpluskwianiu".
54 Pakiet zawiera bibliotekê wspó³dzielon±, która mo¿e byæ za³adowana przez
55 zmienn± LD_PRELOAD w trakcie uruchamiania dowolnego programu dziêki temu nie
56 potrzeba linkowaæ z t± bibliotek± ¶ledzonego programu. Pakiet zawiera tak¿e
57 skrypt pow³oki ef, który ³aduje do pamiêci przez LD_PRELOAD bibliotekê
58 libefence i uruchamia program przekazany do tego skryptu jako parametr.
59
60 %description -l pt_BR
61 Electric Fence é uma biblioteca que pode ser usada para programação e
62 depuração em C. Você o "linka" em tempo de compilação e ele o avisará sobre
63 possíveis problemas como liberação de memória não alocada, etc.
64
65 %description -l tr
66 Electric Fence, C'de programlama ve hata ayýklama için kullanýlabilen bir
67 kitaplýktýr. Derleme esnasýnda programýnýza baðlarsanýz, sizi ortaya
68 çýkabilecek sorunlar (var olmayan bir bellek parçasýnýn serbest býrakýlmasý
69 gibi) konusunda uyarýr.
70
71 %package static
72 Summary:        Satatic Electric Fence library
73 Summary(pl):    Biblioteka statyczna Electric Fence
74 Group:          Development/Debuggers
75 Group(pl):      Programowanie/Odpluskwiacze
76
77 %description static
78 Satatic Electric Fence library.
79
80 %description -l pl static
81 Biblioteka statyczna Electric Fence.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 %build
89 make CFLAGS="$RPM_OPT_FLAGS"
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib,share/man/man3}
94
95 make    BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
96         LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
97         MAN_INSTALL_DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
98         install
99
100 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*so.*.*
101
102 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
103         README CHANGES
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc *gz
114 %attr(755,root,root) %{_bindir}/ef
115 %attr(755,root,root) %{_libdir}/lib*.so.*.*
116 %{_mandir}/man3/*
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/lib*.a
This page took 0.049823 seconds and 4 git commands to generate.