]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
86a075ad7364d214745b97e1c490ea86deffb115
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # Conditional build:
3 %bcond_without  mpg     # don't build support for MPG/MPEG3
4 #
5 Summary:        DirectFB - Hardware graphics acceleration
6 Summary(pl):    DirectFB - Wspomaganie grafiki
7 Name:           DirectFB
8 Version:        0.9.20
9 Release:        3
10 Epoch:          1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  e42e8ae43f0ad873643f73cc0a9ae7d0
15 Source1:        http://www.directfb.org/download/DirectFB/DFBTutorials-0.5.0.tar.gz
16 # Source1-md5:  13e443a64bddd68835b574045d9025e9
17 Patch0:         %{name}-am.patch
18 Patch1:         %{name}-pmake.patch
19 URL:            http://www.directfb.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  freetype-devel >= 2.0.2
24 BuildRequires:  libjpeg-devel >= 6b
25 %{?with_mpg:BuildRequires:      libmpeg3-devel}
26 BuildRequires:  libpng-devel >= 1.0
27 BuildRequires:  libtool
28 BuildRequires:  zlib-devel >= 1.1.3
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         dfbdir  %{_libdir}/directfb-%{version}
32
33 %description
34 DirectFB hardware graphics acceleration - libraries.
35
36 %description -l pl
37 Wspomaganie grafiki DirectFB - biblioteki.
38
39 %package devel
40 Summary:        DirectFB - development package
41 Summary(pl):    DirectFB - pliki nag³ówkowe
42 Group:          Development/Libraries
43 Requires:       %{name} = %{epoch}:%{version}
44
45 %description devel
46 DirectFB header files.
47
48 %description devel -l pl
49 Pliki nag³ówkowe dla DirectFB.
50
51 %package static
52 Summary:        DirectFB static libraries
53 Summary(pl):    Statyczne biblioteki DirectFB
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{epoch}:%{version}
56
57 %description static
58 DirectFB static libraries.
59
60 %description static -l pl
61 Statyczne biblioteki DirectFB.
62
63 %package doc
64 Summary:        DirectFB - documentation
65 Summary(pl):    DirectFB - dokumentacja
66 Group:          Development/Libraries
67
68 %description doc
69 DirectFB documentation and tutorials.
70
71 %description doc -l pl
72 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
73
74 %package core-sdl
75 Summary:        SDL core system for DirectFB
76 Summary(pl):    System SDL dla DirectFB
77 Group:          Libraries
78 Requires:       %{name} = %{epoch}:%{version}
79
80 %description core-sdl
81 This package contains SDL core system module for DirectFB.
82
83 %description core-sdl -l pl
84 Ten pakiet zawiera modu³ systemu SDL dla DirectFB.
85
86 %package font-ft2
87 Summary:        FreeType2 font provider for DirectFB
88 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
89 Group:          Libraries
90 Requires:       %{name} = %{epoch}:%{version}
91
92 %description font-ft2
93 This package contains FreeType2 font provider for DirectFB.
94
95 %description font-ft2 -l pl
96 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
97 bibliotekê FreeType2.
98
99 %package image-jpeg
100 Summary:        JPEG image provider for DirectFB
101 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
102 Group:          Libraries
103 Requires:       %{name} = %{epoch}:%{version}
104
105 %description image-jpeg
106 This package contains JPEG image provider for DirectFB.
107
108 %description image-jpeg -l pl
109 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
110
111 %package image-png
112 Summary:        PNG image provider for DirectFB
113 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
114 Group:          Libraries
115 Requires:       %{name} = %{epoch}:%{version}
116
117 %description image-png
118 This package contains PNG image provider for DirectFB.
119
120 %description image-png -l pl
121 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
122
123 %package video-libmpeg3
124 Summary:        MPEG video provider for DirectFB
125 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz MPEG
126 Group:          Libraries
127 Requires:       %{name} = %{epoch}:%{version}
128
129 %description video-libmpeg3
130 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
131 DirectFB. It uses libmpeg3 library.
132
133 %description video-libmpeg3 -l pl
134 Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
135 (MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3.
136
137 %prep
138 %setup -q -a1
139 %patch0 -p1
140 %patch1 -p1
141
142 %build
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoconf}
146 %{__automake}
147 CPPFLAGS="-I/usr/include/libmpeg3"
148 # MMX and SSE are detected at runtime, so it's safe to enable
149 %configure \
150         --disable-maintainer-mode \
151         --enable-shared \
152         --enable-static \
153         --enable-fast-install \
154         --disable-debug \
155         %{!?with_mpg:--disable-libmpeg3} \
156         --enable-sdl \
157 %ifarch %{ix86}
158 %ifnarch i386 i486
159         --enable-mmx \
160 %endif
161 %ifnarch i386 i486 i586
162         --enable-sse
163 %endif
164 %endif
165
166 %{__make}
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %files
184 %defattr(644,root,root,755)
185 # dbfdump and dfbg require multi-application core - useless now
186 %attr(755,root,root) %{_bindir}/dfbinfo
187 %attr(755,root,root) %{_libdir}/lib*.so.*.*
188 %dir %{dfbdir}
189 %dir %{dfbdir}/gfxdrivers
190 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
191 %dir %{dfbdir}/inputdrivers
192 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_joystick.so
193 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_keyboard.so
194 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_lirc.so
195 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ps2mouse.so
196 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_serialmouse.so
197 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sonypi.so
198 %dir %{dfbdir}/interfaces
199 %dir %{dfbdir}/interfaces/IDirectFBFont
200 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
201 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
202 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
203 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
204 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
205 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
206 %dir %{dfbdir}/systems
207 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_fbdev.so
208 %{_datadir}/directfb-%{version}
209 %{_mandir}/man5/*
210
211 %files devel
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_bindir}/directfb-config
214 %attr(755,root,root) %{_bindir}/directfb-csource
215 %attr(755,root,root) %{_libdir}/*.so
216 %{_libdir}/*.la
217 %{_includedir}/directfb
218 %{_includedir}/directfb-internal
219 %{_pkgconfigdir}/*
220 %{_mandir}/man1/directfb-csource.1*
221
222 %files static
223 %defattr(644,root,root,755)
224 %{_libdir}/lib*.a
225 %{dfbdir}/gfxdrivers/*.*a
226 %{dfbdir}/inputdrivers/*.*a
227 %{dfbdir}/interfaces/*/*.*a
228 %{dfbdir}/systems/*.*a
229
230 %files doc
231 %defattr(644,root,root,755)
232 %doc docs/html/*
233 %{_examplesdir}/%{name}-%{version}
234
235 %files core-sdl
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sdlinput.so
238 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_sdl.so
239
240 %files font-ft2
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
243
244 %files image-jpeg
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
247
248 %files image-png
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
251
252 %if %{with mpg}
253 %files video-libmpeg3
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.so
256 %endif
This page took 0.092769 seconds and 3 git commands to generate.