]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
69a607cb080468a29f0c44f23b6ffaaf8b8db952
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # TODO:
3 #       - fix x86-64 int32<->ptr64 casts.
4 #
5 #       tree.c:88: warning: cast from pointer to integer of different size
6 #       tree.c:102: warning: cast from pointer to integer of different size
7 #       fonts.c:144: warning: cast to pointer from integer of different size
8 #       fonts.c:211: warning: cast to pointer from integer of different size
9 #       gfxcard.c:1451: warning: cast to pointer from integer of different size
10 #       fbdev.c:459: warning: cast from pointer to integer of different size
11 #       fbdev.c:578: warning: cast from pointer to integer of different size
12 #       fbdev.c:708: warning: cast from pointer to integer of different size
13 #       idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
14 #       idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
15 #       idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
16 #
17 # Conditional build:
18 %bcond_with     multi           # build Multi-application core (requires working /dev/fusion*)
19 #
20 Summary:        DirectFB - Hardware graphics acceleration
21 Summary(pl):    DirectFB - Wspomaganie grafiki
22 Name:           DirectFB
23 Version:        1.0.0
24 Release:        4
25 Epoch:          1
26 License:        LGPL v2+
27 Group:          Libraries
28 Source0:        http://www.directfb.org/downloads/Core/%{name}-%{version}.tar.gz
29 # Source0-md5:  ad746c49dc89ba6f99df71b17bbb1dc8
30 Source1:        http://www.directfb.org/downloads/Extras/DFBTutorials-0.5.0.tar.gz
31 # Source1-md5:  13e443a64bddd68835b574045d9025e9
32 Patch0:         %{name}-am.patch
33 Patch1:         %{name}-pmake.patch
34 Patch2:         %{name}-fix.patch
35 Patch3:         %{name}-gcc4.patch
36 Patch4:         %{name}-llh-ppc.patch
37 URL:            http://www.directfb.org/
38 BuildRequires:  SDL-devel
39 BuildRequires:  XFree86-devel
40 BuildRequires:  autoconf >= 2.52
41 BuildRequires:  automake
42 BuildRequires:  freetype-devel >= 2.0.2
43 BuildRequires:  libjpeg-devel >= 6b
44 BuildRequires:  libpng-devel >= 1.0
45 BuildRequires:  libtool
46 BuildRequires:  libvncserver-devel
47 %{?with_multi:BuildRequires:    linux-fusion-devel}
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  sysfsutils-devel >= 1.3.0-3
50 BuildRequires:  zlib-devel >= 1.1.3
51 %{?with_multi:Provides: DirectFB(multi)}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         dfbdir  %{_libdir}/directfb-1.0-0
55
56 %define         specflags       -fno-strict-aliasing
57
58 %ifarch %{ix86}
59 # gcc running out of registers with -O0 in generic_mmx.h
60 %define         debugcflags     -O1 -g
61 %endif
62
63 %description
64 DirectFB hardware graphics acceleration - libraries.
65
66 %description -l pl
67 Wspomaganie grafiki DirectFB - biblioteki.
68
69 %package devel
70 Summary:        DirectFB - development package
71 Summary(pl):    DirectFB - pliki nag³ówkowe
72 Group:          Development/Libraries
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74 Requires:       zlib-devel >= 1.1.3
75
76 %description devel
77 DirectFB header files.
78
79 %description devel -l pl
80 Pliki nag³ówkowe dla DirectFB.
81
82 %package static
83 Summary:        DirectFB static libraries
84 Summary(pl):    Statyczne biblioteki DirectFB
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
87
88 %description static
89 DirectFB static libraries.
90
91 %description static -l pl
92 Statyczne biblioteki DirectFB.
93
94 %package doc
95 Summary:        DirectFB - documentation
96 Summary(pl):    DirectFB - dokumentacja
97 Group:          Development/Libraries
98
99 %description doc
100 DirectFB documentation and tutorials.
101
102 %description doc -l pl
103 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
104
105 %package core-sdl
106 Summary:        SDL core system for DirectFB
107 Summary(pl):    System SDL dla DirectFB
108 Group:          Libraries
109 Requires:       %{name} = %{epoch}:%{version}-%{release}
110
111 %description core-sdl
112 This package contains SDL core system module for DirectFB.
113
114 %description core-sdl -l pl
115 Ten pakiet zawiera modu³ systemu SDL dla DirectFB.
116
117 %package core-vnc
118 Summary:        VNC core system for DirectFB
119 Summary(pl):    System VNC dla DirectFB
120 Group:          Libraries
121 Requires:       %{name} = %{epoch}:%{version}-%{release}
122
123 %description core-vnc
124 This package contains VNC core system module for DirectFB.
125
126 %description core-vnc -l pl
127 Ten pakiet zawiera modu³ systemu VNC dla DirectFB.
128
129 %package core-x11
130 Summary:        X11 core system for DirectFB
131 Summary(pl):    System X11 dla DirectFB
132 Group:          Libraries
133 Requires:       %{name} = %{epoch}:%{version}-%{release}
134
135 %description core-x11
136 This package contains X11 core system module for DirectFB.
137
138 %description core-x11 -l pl
139 Ten pakiet zawiera modu³ systemu X11 dla DirectFB.
140
141 %package font-ft2
142 Summary:        FreeType2 font provider for DirectFB
143 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
144 Group:          Libraries
145 Requires:       %{name} = %{epoch}:%{version}-%{release}
146
147 %description font-ft2
148 This package contains FreeType2 font provider for DirectFB.
149
150 %description font-ft2 -l pl
151 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
152 bibliotekê FreeType2.
153
154 %package image-jpeg
155 Summary:        JPEG image provider for DirectFB
156 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
157 Group:          Libraries
158 Requires:       %{name} = %{epoch}:%{version}-%{release}
159
160 %description image-jpeg
161 This package contains JPEG image provider for DirectFB.
162
163 %description image-jpeg -l pl
164 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
165
166 %package image-png
167 Summary:        PNG image provider for DirectFB
168 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
169 Group:          Libraries
170 Requires:       %{name} = %{epoch}:%{version}-%{release}
171
172 %description image-png
173 This package contains PNG image provider for DirectFB.
174
175 %description image-png -l pl
176 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
177
178 %package input-elo
179 Summary:        ELO touchscreen input driver for DirectFB
180 Summary(pl):    Sterownik wej¶ciowy do touchscreenów ELO dla DirectFB
181 Group:          Libraries
182 Requires:       %{name} = %{epoch}:%{version}-%{release}
183
184 %description input-elo
185 ELO touchscreen input driver for DirectFB.
186
187 NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
188 unless you don't have ELO device connected to this port. It can mess
189 with other devices connected to this port (mouse, modem etc.).
190
191 %description input-elo -l pl
192 Sterownik wej¶ciowy do touchscreenów ELO dla DirectFB.
193
194 UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc
195 nie nale¿y go instalowaæ, je¶li urz±dzenie ELO nie jest pod³±czone do
196 tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi urz±dzeniami
197 pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
198
199 %package input-dynapro
200 Summary:        Dynapro touchscreen input driver for DirectFB
201 Summary(pl):    Sterownik wej¶ciowy do touchscreenów Dynapro dla DirectFB
202 Group:          Libraries
203 Requires:       %{name} = %{epoch}:%{version}-%{release}
204
205 %description input-dynapro
206 Dynapro touchscreen input driver for DirectFB.
207
208 NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
209 unless you don't have Dynapro device connected to this port. It can
210 mess with other devices connected to this port (mouse, modem etc.).
211
212 %description input-dynapro -l pl
213 Sterownik wej¶ciowy do touchscreenów Dynapro dla DirectFB.
214
215 UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc
216 nie nale¿y go instalowaæ, je¶li urz±dzenie Dynapro nie jest pod³±czone
217 do tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi
218 urz±dzeniami pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
219
220 %package input-gunze
221 Summary:        Gunze touchscreen input driver for DirectFB
222 Summary(pl):    Sterownik wej¶ciowy do touchscreenów Gunze dla DirectFB
223 Group:          Libraries
224 Requires:       %{name} = %{epoch}:%{version}-%{release}
225
226 %description input-gunze
227 Gunze touchscreen input driver for DirectFB.
228
229 NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
230 unless you don't have Gunze device connected to this port. It can mess
231 with other devices connected to this port (mouse, modem etc.).
232
233 %description input-gunze -l pl
234 Sterownik wej¶ciowy do touchscreenów Gunze dla DirectFB.
235
236 UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc
237 nie nale¿y go instalowaæ, je¶li urz±dzenie Gunze nie jest pod³±czone
238 do tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi
239 urz±dzeniami pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
240
241 %package input-mutouch
242 Summary:        MuTouch touchscreen input driver for DirectFB
243 Summary(pl):    Sterownik wej¶ciowy do touchscreenów MuTouch dla DirectFB
244 Group:          Libraries
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246
247 %description input-mutouch
248 MuTouch touchscreen input driver for DirectFB.
249
250 NOTE: it needs "mut-device" setting in directfbrc in order to work.
251
252 %description input-mutouch -l pl
253 Sterownik wej¶ciowy do touchscreenów MuTouch dla DirectFB.
254
255 UWAGA: do dzia³ania potrzebuje ustawienia "mut-device" w directfbrc.
256
257 %package input-ucb1x00
258 Summary:        UCB1x00 touchscreen input driver for DirectFB
259 Summary(pl):    Sterownik wej¶ciowy do touchscreenów UCB1x00 dla DirectFB
260 Group:          Libraries
261 Requires:       %{name} = %{epoch}:%{version}-%{release}
262
263 %description input-ucb1x00
264 UCB1x00 touchscreen input driver for DirectFB.
265
266 %description input-ucb1x00 -l pl
267 Sterownik wej¶ciowy do touchscreenów UCB1x00 dla DirectFB.
268
269 %package input-wm97xx
270 Summary:        WM97xx touchscreen input driver for DirectFB
271 Summary(pl):    Sterownik wej¶ciowy do touchscreenów WM97xx dla DirectFB
272 Group:          Libraries
273 Requires:       %{name} = %{epoch}:%{version}-%{release}
274
275 %description input-wm97xx
276 WM97xx touchscreen input driver for DirectFB.
277
278 %description input-wm97xx -l pl
279 Sterownik wej¶ciowy do touchscreenów WM97xx dla DirectFB.
280
281 %prep
282 %setup -q -a1
283 %patch0 -p1
284 %patch1 -p1
285 %patch2 -p1
286 %patch3 -p1
287 %patch4 -p1
288
289 %build
290 %{__libtoolize}
291 %{__aclocal}
292 %{__autoconf}
293 %{__automake}
294 # MMX and SSE are detected at runtime, so it's safe to enable
295 %configure \
296         --with-inputdrivers=dynapro,elo-input,gunze,joystick,keyboard,linuxinput,lirc,mutouch,penmount,ps2mouse,serialmouse,sonypijogdial,ucb1x00,wm97xx \
297         %{!?debug:--disable-debug} \
298         --enable-linux-input \
299         %{?with_multi:--enable-multi} \
300         --enable-mutouch \
301         --enable-sdl \
302         --enable-shared \
303         --enable-static \
304         --enable-unique \
305         --enable-video4linux2 \
306         --enable-voodoo \
307         --enable-x11 \
308         --enable-zlib \
309 %ifarch %{ix86} %{x8664}
310 %ifnarch i386 i486
311         --enable-mmx \
312 %endif
313 %ifnarch i386 i486 i586
314         --enable-sse
315 %endif
316 %endif
317
318 %{__make} \
319         X11_LIBS=%{_prefix}/X11R6/%{_lib}
320
321 %install
322 rm -rf $RPM_BUILD_ROOT
323 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_sysconfdir}}
324
325 %{__make} install -j1 \
326         DESTDIR=$RPM_BUILD_ROOT
327
328 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
329
330 touch $RPM_BUILD_ROOT%{_sysconfdir}/directfbrc
331
332 %clean
333 rm -rf $RPM_BUILD_ROOT
334
335 %post   -p /sbin/ldconfig
336 %postun -p /sbin/ldconfig
337
338 %files
339 %defattr(644,root,root,755)
340 %doc AUTHORS ChangeLog NEWS README TODO
341 %attr(755,root,root) %{_bindir}/dfbdump
342 %attr(755,root,root) %{_bindir}/dfbg
343 %attr(755,root,root) %{_bindir}/dfbinfo
344 %attr(755,root,root) %{_bindir}/dfbinput
345 %attr(755,root,root) %{_bindir}/dfblayer
346 %attr(755,root,root) %{_bindir}/dfbpenmount
347 %attr(755,root,root) %{_bindir}/dfbproxy
348 %attr(755,root,root) %{_bindir}/dfbscreen
349 %attr(755,root,root) %{_bindir}/dfbsummon
350 %attr(755,root,root) %{_bindir}/mkdfiff
351 %attr(755,root,root) %{_bindir}/mkdgiff
352 %attr(755,root,root) %{_bindir}/uwmdump
353 %attr(755,root,root) %{_libdir}/libdirect-*.so.*.*.*
354 %attr(755,root,root) %{_libdir}/libdirectfb-*.so.*.*.*
355 %attr(755,root,root) %{_libdir}/libfusion-*.so.*.*.*
356 %attr(755,root,root) %{_libdir}/libuniquewm-*.so.*.*.*
357 %attr(755,root,root) %{_libdir}/libvoodoo-*.so.*.*.*
358 %dir %{dfbdir}
359 %dir %{dfbdir}/gfxdrivers
360 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
361 %dir %{dfbdir}/inputdrivers
362 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_joystick.so
363 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_keyboard.so
364 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_linux_input.so
365 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_lirc.so
366 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_penmount.so
367 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ps2mouse.so
368 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_serialmouse.so
369 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sonypi.so
370 %dir %{dfbdir}/interfaces
371 %dir %{dfbdir}/interfaces/IDirectFB
372 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFB/lib*.so
373 %dir %{dfbdir}/interfaces/IDirectFBDataBuffer
374 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDataBuffer/lib*.so
375 %dir %{dfbdir}/interfaces/IDirectFBDisplayLayer
376 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBDisplayLayer/lib*.so
377 %dir %{dfbdir}/interfaces/IDirectFBEventBuffer
378 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBEventBuffer/lib*.so
379 %dir %{dfbdir}/interfaces/IDirectFBFont
380 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
381 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_dgiff.so
382 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_dispatcher.so
383 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_requestor.so
384 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
385 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dfiff.so
386 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_dispatcher.so
387 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
388 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
389 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_requestor.so
390 %dir %{dfbdir}/interfaces/IDirectFBInputDevice
391 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBInputDevice/lib*.so
392 %dir %{dfbdir}/interfaces/IDirectFBPalette
393 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBPalette/lib*.so
394 %dir %{dfbdir}/interfaces/IDirectFBScreen
395 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBScreen/lib*.so
396 %dir %{dfbdir}/interfaces/IDirectFBSurface
397 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBSurface/lib*.so
398 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
399 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_gif.so
400 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
401 %dir %{dfbdir}/interfaces/IDirectFBWindow
402 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBWindow/lib*.so
403 %dir %{dfbdir}/systems
404 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_fbdev.so
405 %dir %{dfbdir}/wm
406 %attr(755,root,root) %{dfbdir}/wm/*.so
407 %{_datadir}/directfb-%{version}
408 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/directfbrc
409 %{_mandir}/man1/dfbg.1*
410 %{_mandir}/man5/*
411
412 %files devel
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_bindir}/directfb-config
415 %attr(755,root,root) %{_bindir}/directfb-csource
416 %attr(755,root,root) %{_libdir}/libdirect.so
417 %attr(755,root,root) %{_libdir}/libdirectfb.so
418 %attr(755,root,root) %{_libdir}/libfusion.so
419 %attr(755,root,root) %{_libdir}/libuniquewm.so
420 %attr(755,root,root) %{_libdir}/libvoodoo.so
421 %{_libdir}/libdirect.la
422 %{_libdir}/libdirectfb.la
423 %{_libdir}/libfusion.la
424 %{_libdir}/libuniquewm.la
425 %{_libdir}/libvoodoo.la
426 %{_includedir}/directfb
427 %{_includedir}/directfb-internal
428 %{_pkgconfigdir}/*.pc
429 %{_mandir}/man1/directfb-csource.1*
430
431 %files static
432 %defattr(644,root,root,755)
433 %{_libdir}/lib*.a
434 %{dfbdir}/gfxdrivers/*.[alo]*
435 %{dfbdir}/inputdrivers/*.[alo]*
436 %{dfbdir}/interfaces/*/*.[alo]*
437 %{dfbdir}/systems/*.[alo]*
438 %{dfbdir}/wm/*.[alo]*
439
440 %files doc
441 %defattr(644,root,root,755)
442 %doc docs/html/*.{html,png}
443 %{_examplesdir}/%{name}-%{version}
444
445 %files core-sdl
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_sdlinput.so
448 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_sdl.so
449
450 %files core-vnc
451 %defattr(644,root,root,755)
452 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_vncinput.so
453 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_vnc.so
454
455 %files core-x11
456 %defattr(644,root,root,755)
457 %doc systems/x11/README
458 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_x11input.so
459 %attr(755,root,root) %{dfbdir}/systems/libdirectfb_x11.so
460
461 %files font-ft2
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
464
465 %files image-jpeg
466 %defattr(644,root,root,755)
467 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
468
469 %files image-png
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
472
473 %files input-elo
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_elo.so
476
477 %files input-dynapro
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_dynapro.so
480
481 %files input-gunze
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_gunze.so
484
485 %files input-mutouch
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_mutouch.so
488
489 %files input-ucb1x00
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_ucb1x00_ts.so
492
493 %files input-wm97xx
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_wm97xx_ts.so
This page took 0.078697 seconds and 3 git commands to generate.