]> git.pld-linux.org Git - packages/DirectFB.git/blob - DirectFB.spec
4962fb214bfe2961f4a2b8120f7dbb6c5a4b3140
[packages/DirectFB.git] / DirectFB.spec
1 #
2 # Conditional build:
3 # _without_mpg          - don't build support for MPG/MPEG3
4 #
5 Summary:        DirectFB - Hardware graphics acceleration
6 Summary(pl):    DirectFB - Wspomaganie grafiki
7 Name:           DirectFB
8 Version:        0.9.18
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://www.directfb.org/download/%{name}/%{name}-%{version}.tar.gz
13 # Source0-md5:  c90296dcf7fea2865baef5351e7003c5
14 Source1:        http://www.directfb.org/download/DirectFB/DFBTutorials-0.5.0.tar.gz
15 # Source1-md5:  13e443a64bddd68835b574045d9025e9
16 Patch0:         %{name}-am.patch
17 Patch1:         %{name}-pmake.patch
18 URL:            http://www.directfb.org/
19 #BuildRequires: SDL-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  freetype-devel >= 2.0.2
23 BuildRequires:  libjpeg-devel >= 6b
24 %{!?_without_mpg:BuildRequires: libmpeg3-devel}
25 BuildRequires:  libpng-devel >= 1.0
26 BuildRequires:  libtool
27 BuildRequires:  zlib-devel >= 1.1.3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         dfbdir  %{_libdir}/directfb-%{version}
31
32 %description
33 DirectFB hardware graphics acceleration - libraries.
34
35 %description -l pl
36 Wspomaganie grafiki DirectFB - biblioteki.
37
38 %package devel
39 Summary:        DirectFB - development package
40 Summary(pl):    DirectFB - pliki nag³ówkowe
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}
43
44 %description devel
45 DirectFB header files.
46
47 %description devel -l pl
48 Pliki nag³ówkowe dla DirectFB.
49
50 %package static
51 Summary:        DirectFB static libraries
52 Summary(pl):    Statyczne biblioteki DirectFB
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}
55
56 %description static
57 DirectFB static libraries.
58
59 %description static -l pl
60 Statyczne biblioteki DirectFB.
61
62 %package doc
63 Summary:        DirectFB - documentation
64 Summary(pl):    DirectFB - dokumentacja
65 Group:          Development/Libraries
66
67 %description doc
68 DirectFB documentation and tutorials.
69
70 %description doc -l pl
71 Dokumentacja dla systemu DirectFB wraz z wprowadzeniem.
72
73 %package font-ft2
74 Summary:        FreeType2 font provider for DirectFB
75 Summary(pl):    DirectFB - wtyczka dostarczaj±ca fonty poprzez FreeType2
76 Group:          Libraries
77 Requires:       %{name} = %{version}
78
79 %description font-ft2
80 This package contains FreeType2 font provider for DirectFB.
81
82 %description font-ft2 -l pl
83 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± fonty poprzez
84 bibliotekê FreeType2.
85
86 %package image-jpeg
87 Summary:        JPEG image provider for DirectFB
88 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê JPEG
89 Group:          Libraries
90 Requires:       %{name} = %{version}
91
92 %description image-jpeg
93 This package contains JPEG image provider for DirectFB.
94
95 %description image-jpeg -l pl
96 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê JPEG.
97
98 %package image-png
99 Summary:        PNG image provider for DirectFB
100 Summary(pl):    DirectFB - wtyczka dostarczaj±ca grafikê PNG
101 Group:          Libraries
102 Requires:       %{name} = %{version}
103
104 %description image-png
105 This package contains PNG image provider for DirectFB.
106
107 %description image-png -l pl
108 Ten pakiet zawiera wtyczkê dla DirectFB dostarczaj±c± grafikê PNG.
109
110 %package video-libmpeg3
111 Summary:        MPEG video provider for DirectFB
112 Summary(pl):    DirectFB - wtyczka dostarczaj±ca obraz MPEG
113 Group:          Libraries
114 Requires:       %{name} = %{version}
115
116 %description video-libmpeg3
117 This package contains MPEG (MPEG-1 and MPEG-2) video provider for
118 DirectFB. It uses libmpeg3 library.
119
120 %description video-libmpeg3 -l pl
121 Ten pakiet zawiera wtyczkê dla DirectFB dostarczajac± obraz MPEG
122 (MPEG-1 i MPEG-2) przy u¿yciu biblioteki libmpeg3. 
123
124 %prep
125 %setup -q -a1
126 %patch0 -p1
127 %patch1 -p1
128
129 %build
130 rm -f missing
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__automake}
135 CPPFLAGS="-I/usr/include/libmpeg3"
136 # SDL core disabled (used directly, not through plugin - too many deps)
137 # MMX and SSE are detected at runtime, so it's safe to enable
138 %configure \
139         --disable-maintainer-mode \
140         --enable-shared \
141         --enable-static \
142         --disable-fast-install \
143         --disable-debug \
144         %{?_without_mpg:--disable-libmpeg3} \
145         --disable-sdl \
146 %ifarch i586 i686 athlon
147         --enable-mmx \
148 %endif
149 %ifarch i686 athlon
150         --enable-sse
151 %endif
152
153 %{__make}
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 cp -rf DFBTutorials* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %files
171 %defattr(644,root,root,755)
172 # dbfdump and dfbg require multi-application core - useless now
173 %attr(755,root,root) %{_bindir}/dfbinfo
174 %attr(755,root,root) %{_libdir}/lib*.so.*.*
175 %dir %{dfbdir}
176 %dir %{dfbdir}/gfxdrivers
177 %attr(755,root,root) %{dfbdir}/gfxdrivers/*.so
178 %{dfbdir}/gfxdrivers/*.la
179 %dir %{dfbdir}/inputdrivers
180 %attr(755,root,root) %{dfbdir}/inputdrivers/*.so
181 %{dfbdir}/inputdrivers/*.la
182 %dir %{dfbdir}/interfaces
183 %dir %{dfbdir}/interfaces/IDirectFBFont
184 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.so
185 %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_default.la
186 %dir %{dfbdir}/interfaces/IDirectFBImageProvider
187 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.so
188 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_gif.la
189 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.so
190 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_mpeg2.la
191 %dir %{dfbdir}/interfaces/IDirectFBVideoProvider
192 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.so
193 %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_v4l.la
194 %{_datadir}/directfb-%{version}
195 %{_mandir}/man5/*
196
197 %files devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/directfb-config
200 %attr(755,root,root) %{_bindir}/directfb-csource
201 %attr(755,root,root) %{_libdir}/*.so
202 %{_libdir}/*.la
203 %{_includedir}/directfb
204 %{_includedir}/directfb-internal
205 %{_pkgconfigdir}/*
206 %{_mandir}/man1/directfb-csource.1*
207
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/lib*.a
211 %{dfbdir}/gfxdrivers/*.a
212 %{dfbdir}/inputdrivers/*.a
213 %{dfbdir}/interfaces/*/*.a
214
215 %files doc
216 %defattr(644,root,root,755)
217 %doc docs/html/*
218 %{_examplesdir}/%{name}-%{version}
219
220 %files font-ft2
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.so
223 %{dfbdir}/interfaces/IDirectFBFont/libidirectfbfont_ft2.la
224
225 %files image-jpeg
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.so
228 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_jpeg.la
229
230 %files image-png
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.so
233 %{dfbdir}/interfaces/IDirectFBImageProvider/libidirectfbimageprovider_png.la
234
235 %if 0%{!?_without_mpg:1}
236 %files video-libmpeg3
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.so
239 %{dfbdir}/interfaces/IDirectFBVideoProvider/libidirectfbvideoprovider_libmpeg3.la
240 %endif
This page took 0.1003 seconds and 3 git commands to generate.