]> git.pld-linux.org Git - packages/ClanLib.git/blob - ClanLib.spec
- added apssing LDFALGS="-s" to ./configure enviroent.
[packages/ClanLib.git] / ClanLib.spec
1 Summary:        ClanLib, the platform independent game SDK.
2 Summary(pl):    ClanLib, niezale¿ny od platformy SDK do gier
3 Name:           ClanLib
4 Version:        0.1.16
5 Release:        1
6 Copyright:      LGPL
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 Source:         http://dark.x.dtu.dk/clansoft/clanlib/download/%{name}-%{version}.tar.gz
10 URL:            http://clanlib.org
11 BuildRequires:  libpng-devel
12 BuildRequires:  zlib-devel
13 BuildRequires:  Hermes-devel
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  XFree86-devel
16 BuildRoot:      /tmp/%{name}-%{version}-root
17
18 %description
19 The ClanLib SDK is designed to provide an platform independent game SDK using
20 a lot cleaner (and object oriented) interface than the traditional way it is
21 done in DirectX, SDL and such. The goals is to avoid game developers
22 constantly reinventing the wheel by providing smarter ways to eg. load
23 surfaces.
24
25 %description -l pl
26 ClanLib SDK jest projektowany jako niezale¿ny od platformy SDK dla gier.
27 Stosuje prosty (i zorienrowany obiektowo) interfejs, przejrzystszy ni¿
28 DirectX, SDL i inne.
29
30 %package devel
31 Summary:        ClanLib development package
32 Summary(pl):    pakiet programistyczny dla ClanLib
33 Group:          Development/Libraries
34 Group(pl):      Programowanie/Biblioteki
35 Requires:       %{name} = %{version}
36
37 %description devel
38 This is the development add-on package that includes the header files needed
39 to compile new ClanLib applications.
40
41 %description -l pl devel
42 Programistyczne dodatki do ClanLib-a, zawieraj± pliki nag³ówkowe potrzebne
43 do kompilacji programów korzystaj±cych z ClanLib.
44
45 %package static
46 Summary:        ClanLib development package
47 Summary(pl):    pakiet programistyczny dla ClanLib
48 Group:          Development/Libraries
49 Group(pl):      Programowanie/Biblioteki
50 Requires:       %{name}-devel = %{version}
51
52 %description static
53 This is the development add-on package that includes the header files needed
54 to compile new ClanLib applications.
55
56 %description -l pl static
57 Programistyczne dodatki do ClanLib-a, zawieraj± pliki nag³ówkowe potrzebne
58 do kompilacji programów korzystaj±cych z CleanLib.
59
60 %prep
61 %setup -q
62
63 %build
64 LDFLAGS="-s"; export LDFLAGS
65 %configure \
66         --enable-static \
67         --enable-shared
68 make
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 make    install \
73         LIB_PREFIX="$RPM_BUILD_ROOT%{_libdir}" \
74         BIN_PREFIX="$RPM_BUILD_ROOT%{_bindir}" \
75         INC_PREFIX="$RPM_BUILD_ROOT%{_includedir}"
76
77 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so*
78
79 gzip -9nf README TODO CREDITS
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_libdir}/lib*.so*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %doc *gz
94 %attr(755,root,root) %{_bindir}/datafile_compiler
95 %{_includedir}/ClanLib
96
97 #%files static
98 #%defattr(644,root,root,755)
99 #%{_libdir}/lib*.a
This page took 0.133088 seconds and 4 git commands to generate.