]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
ea414851d3bc93b3dabc2e3312e6a886eb17390c
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 # - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
5 # - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
6 #
7 # Conditional build:
8 %bcond_without  xercesc         # build XercesParser
9 %bcond_with     ogre            # build samples with ogre3d
10 %bcond_with     samples         # build samples
11 #
12 Summary:        CEGUI - a free library providing windowing and widgets
13 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
14 Name:           CEGUI
15 Version:        0.6.2
16 Release:        1
17 License:        LGPL v2.1+ (with MIT parts)
18 Group:          Libraries
19 Source0:        http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}b.tar.gz
20 # Source0-md5:  4fbd95e5a2ac1c7acf2a8f5df3ac6b93
21 Source1:        http://dl.sourceforge.net/crayzedsgui/%{name}-%{version}-DOCS.tar.gz
22 # Source1-md5:  5c6b54b9472ffaefc27ed4a9b8fefe25
23 Patch0:         %{name}-link.patch
24 Patch1:         %{name}-gcc43.patch
25 URL:            http://www.cegui.org.uk/
26 BuildRequires:  DevIL-devel
27 BuildRequires:  FreeImage-devel
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  OpenGL-glut-devel
30 BuildRequires:  SILLY-devel >= 0.1.0
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  corona-devel >= 1.0.2
34 BuildRequires:  expat-devel
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  glew-devel
37 BuildRequires:  irrlicht-devel >= 1.4
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.5
40 BuildRequires:  libxml2-devel >= 1:2.6
41 BuildRequires:  lua51-devel >= 5.1
42 %if %{with ogre}
43 BuildRequires:  ogre-devel >= 1.0.0
44 BuildRequires:  ois-devel
45 %endif
46 BuildRequires:  pcre-devel >= 5.0
47 BuildRequires:  pkgconfig
48 # for irrlicht renderer
49 BuildRequires:  xorg-lib-libXxf86vm-devel
50 %if %{with xercesc}
51 BuildRequires:  xerces-c-devel
52 %endif
53 Requires:       irrlicht >= 1.4
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 CEGUI stands for Crazy Eddie's Gui System; a free library providing
58 windowing and widgets for graphics APIs / engines where such
59 functionality is not natively available, or severely lacking. The
60 library is object orientated, written in C++, and targeted at games
61 developers who should be spending their time creating great games, not
62 building GUI sub-systems!
63
64 %description -l pl.UTF-8
65 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
66 zapewniającą okienka i widgety dla graficznych API i silników tam,
67 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
68 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
69 skierowana dla programistów gier, którzy powinni spędzać czas na
70 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
71
72 %package devel
73 Summary:        Development files for CEGUI
74 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       freetype-devel >= 2.0
78 Requires:       libstdc++-devel
79 Requires:       pcre-devel >= 5.0
80
81 %description devel
82 CEGUI headers.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe CEGUI.
86
87 %package docs
88 Summary:        Documentation files for CEGUI
89 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
90 Group:          Documentation
91 Requires:       %{name} = %{version}-%{release}
92
93 %description docs
94 CEGUI documentation.
95
96 %description docs -l pl.UTF-8
97 Dokumentacja CEGUI.
98
99
100 %prep
101 %setup -q -b 1
102 %patch0 -p1
103 %patch1 -p1
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --with-default-image-codec=FreeImageImageCodec \
113         --with-default-xml-parser=LibxmlParser \
114         %{!?with_samples:--disable-samples} \
115         %{!?with_ogre:--without-ogre-renderer} \
116         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog README
135 # libs
136 %attr(755,root,root) %{_libdir}/libCEGUIBase.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase.so.1
138 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer.so.0
140 # plugins
141 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libCEGUICoronaImageCodec.so.0
143 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
144 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDevILImageCodec.so.0
146 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
147 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libCEGUIExpatParser.so.0
149 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
150 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libCEGUIFalagardWRBase.so.1
152 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
153 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libCEGUIFreeImageImageCodec.so.0
155 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
156 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer.so.0
158 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
159 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libCEGUILibxmlParser.so.0
161 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
162 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule.so.1
164 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
165 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libCEGUISILLYImageCodec.so.0
167 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
168 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libCEGUITGAImageCodec.so.0
170 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
171 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libCEGUITinyXMLParser.so.0
173 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
174 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libCEGUIXercesParser.so.0
176 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
177 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libCEGUItoluapp.so.1
179 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
180
181 %files docs
182 %defattr(644,root,root,755)
183 %doc documentation
184 %dir %{_datadir}/%{name}
185 %dir %{_datadir}/%{name}/XMLRefSchema
186 %{_datadir}/%{name}/XMLRefSchema/*.xsd
187 %{_datadir}/%{name}/XMLRefSchema/Readme.txt
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
192 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
193 %{_libdir}/libCEGUIBase.la
194 %{_libdir}/libCEGUIOpenGLRenderer.la
195 # plugins - but as their headers are included...
196 %{_libdir}/libCEGUICoronaImageCodec.la
197 %{_libdir}/libCEGUIDevILImageCodec.la
198 %{_libdir}/libCEGUIExpatParser.la
199 %{_libdir}/libCEGUIFalagardWRBase.la
200 %{_libdir}/libCEGUIFreeImageImageCodec.la
201 %{_libdir}/libCEGUIIrrlichtRenderer.la
202 %{_libdir}/libCEGUILibxmlParser.la
203 %{_libdir}/libCEGUILuaScriptModule.la
204 %{_libdir}/libCEGUISILLYImageCodec.la
205 %{_libdir}/libCEGUITGAImageCodec.la
206 %{_libdir}/libCEGUITinyXMLParser.la
207 %{_libdir}/libCEGUIXercesParser.la
208 %{_libdir}/libCEGUItoluapp.la
209 %{_includedir}/%{name}
210 %{_pkgconfigdir}/CEGUI.pc
211 %{_pkgconfigdir}/CEGUI-OPENGL.pc
This page took 0.070069 seconds and 3 git commands to generate.