]> git.pld-linux.org Git - packages/Atlas-C++.git/blob - Atlas-C++.spec
- rel 0.2, fixed %files a bit, builds for me, (no idea if work properly yet)
[packages/Atlas-C++.git] / Atlas-C++.spec
1 # TODO:
2 # add tutorial subpackage
3 # check if atlas_convert should be in %files and in which package
4 Summary:        C++ reference implementation of the Atlas protocol
5 Summary(pl):    Implementacja protoko³u Atlas
6 Name:           Atlas-C++
7 Version:        0.6.0rc2
8 Release:        0.2
9 License:        LGPL
10 Group:          Libraries
11 Source0:        http://dl.sourceforge.net/worldforge/%{name}-%{version}.tar.bz2
12 # Source0-md5:  4b1d3094f17bb01a9460278897dc17cd
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
21 communications layer designed to be used in the WorldForge MMORPG
22 gaming system. This library is suitable for linking to either clients
23 xor servers.
24
25 %description -l pl
26 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
27 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
28 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
29
30 %package devel
31 Summary:        Header files for Atlas-C++ development
32 Summary(pl):    Pliki nag³ówkowe do biblioteki Atlas-C++
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       libstdc++-devel
36
37 %description devel
38 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
39 communications layer designed to be used in the WorldForge MMORPG
40 gaming system. This library is suitable for linking to either clients
41 or servers.
42
43 This package contains the header files needed to develop programs that
44 use these Atlas-C++
45
46 %description devel -l pl
47 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
48 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
49 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
50
51 Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
52 u¿ywaj±cych bibliotek Atlas-C++.
53
54 %package static
55 Summary:        Static libraries for Atlas-C++ development
56 Summary(pl):    Statyczne biblioteki Atlas-C++
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
62 communications layer designed to be used in the WorldForge MMORPG
63 gaming system. This library is suitable for linking to either clients
64 or servers.
65
66 This package contains the static Atlas-C++ libraries.
67
68 %description static -l pl
69 Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
70 komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
71 tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
72
73 Pakiet zawiera statyczne biblioteki Atlas-C++.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoheader}
82 %{__autoconf}
83 %{__automake}
84 %configure \
85         --enable-static
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog NEWS README
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 #%attr(755,root,root) %{_bindir}/atlas-config
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %{_libdir}/lib*.la
110 %{_includedir}/Atlas*
111 #%{_aclocaldir}/atlas.m4
112 %{_pkgconfigdir}/atlascpp*.pc
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/lib*.a
This page took 0.060778 seconds and 3 git commands to generate.