]> git.pld-linux.org Git - packages/Apache-Gallery.git/blob - Apache-Gallery.spec
39dc5b988953e523adc1308b4481cb4480774eba
[packages/Apache-Gallery.git] / Apache-Gallery.spec
1 # TODO:
2 # - prepare subpackage with virtual
3 # - configuration for apache
4 # - switch to vendordirs and apache 2.x or apache1 (depending on which mod_perl is supported)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         apxs            /usr/sbin/apxs
8 Summary:        An Apache module for creating an online gallery
9 Summary(pl):    Modu³ Apache'a do tworzenia galerii online
10 Name:           Apache-Gallery
11 Version:        0.8
12 Release:        0.6
13 License:        Artistic
14 Group:          Applications/Graphics
15 Source0:        http://apachegallery.dk/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  21ec1b8b11240dc6e3dbba19c6330120
17 #Source1:       %{name}.conf
18 URL:            http://apachegallery.dk/
19 BuildRequires:  apache-mod_perl
20 BuildRequires:  perl-Image-Imlib2 >= 1.00
21 BuildRequires:  perl-Image-Info
22 BuildRequires:  perl-Image-Size
23 BuildRequires:  perl-Text-Template
24 BuildRequires:  perl-devel
25 BuildRequires:  perl-libapreq
26 BuildRequires:  rpm-perlprov >= 3.0.3-16
27 Requires:       apache-mod_perl
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _noautoreq      'perl(APR::Table)' 'perl(Apache2)' 'perl(Apache::Const)' 'perl(Apache::RequestIO)' 'perl(Apache::RequestRec)' 'perl(Apache::SubRequest)'
31 %define         _apacheicons    /home/httpd/icons/gallery
32
33 %description
34 Apache::Gallery is a mod_perl handler that sits on top of your
35 DocumentRoot and creates an image gallery of the files and directories
36 there. It creates an thumbnail index of each directory and allows
37 viewing of pictures in different resolutions. Pictures are resized on
38 the fly and cached.
39
40 %description -l pl
41 Apache::Gallery to procedura obs³ugi dla modu³u mod_perl po³o¿ona w
42 DocumentRoot, tworz±ca galeriê obrazów z umieszczonych tam plików i
43 katalogów. Tworzy indeks z miniaturkami z ka¿dego katalogu i pozwala
44 na ogl±danie obrazków w ró¿nych rozdzielczo¶ciach. Obrazki s±
45 przeskalowywane w locie i buforowane.
46
47 %prep
48 %setup -q
49
50 %build
51 %{__perl} Makefile.PL
52 %{__make}
53 %{__make} test
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name}/templates/{new,default},%{_apacheicons}}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install templates/new/*.{css,tpl} $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/new/
63 install templates/default/*.{css,tpl} $RPM_BUILD_ROOT%{_datadir}/%{name}/templates/default/
64 install htdocs/*.png $RPM_BUILD_ROOT%{_apacheicons}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 #%post
70 #if [ -f /var/lock/subsys/httpd ]; then
71 #       /etc/rc.d/init.d/httpd restart 1>&2
72 #else
73 #       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
74 #fi
75
76 #%preun
77 #if [ "$1" = "0" ]; then
78 #       if [ -f /var/lock/subsys/httpd ]; then
79 #               /etc/rc.d/init.d/httpd restart 1>&2
80 #       fi
81 #fi
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Changes INSTALL README TODO UPGRADE
86 %{perl_sitelib}/Apache/Gallery.pm
87 %dir %{_datadir}/%{name}
88 %dir %{_datadir}/%{name}/templates
89 %dir %{_datadir}/%{name}/templates/new
90 %{_datadir}/%{name}/templates/new/*.tpl
91 %{_datadir}/%{name}/templates/new/*.css
92 %dir %{_datadir}/%{name}/templates/default
93 %{_datadir}/%{name}/templates/default/*.tpl
94 %{_datadir}/%{name}/templates/default/*.css
95 %{_apacheicons}/*.png
96 %{_mandir}/man3/*.3*
This page took 0.035664 seconds and 3 git commands to generate.