]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blob - AfterStep-APPS.spec
fe56b1de6eaf54658257a3002604b5e549110c01
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
1 Summary:        Applets you can use with AfterStep and compatible window managers
2 Summary(pl):    Aplety, których mo¿esz u¿ywaæ z AfterStepem oraz innymi zarz±dcami okien, które s± z nim kompatybilne
3 Name:           AfterStep-APPS
4 Version:        991125
5 Release:        3
6 License:        GPL
7 Group:          X11/Window Managers/Tools
8 Group(de):      X11/Fenstermanager/Werkzeuge
9 Group(pl):      X11/Zarz±dcy Okien/Narzêdzia
10 Source0:        http://www.tigr.net/afterstep/as-apps/download/as-apps-%{version}.tar
11 Patch0:         %{name}-1.5beta1-glibc.patch
12 Patch1:         ascp-paths.patch
13 Patch2:         as-apps-compile.patch
14 Patch3:         aterm-utmp.patch
15 Patch4:         xiterm-utmp.patch
16 Prereq:         /sbin/ldconfig
17 Requires:       /usr/sbin/utempter
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _prefix         /usr/X11R6
21 %define         _mandir         /usr/X11R6/man
22
23 %description
24 What's a cool window manager without some cool applets? Well... it's
25 still cool, but these applets which can be used in the Wharf module
26 for AfterStep or Window Maker can add both spice and productivity to
27 your preferred window manager, such as a handy clock and information
28 about system resources.
29
30 If you've installed the AfterStep packages, you should also install
31 these packages. Enjoy!
32
33 %description -l pl
34 Czym jest fajny zarz±dca okien bez fajnych apletów? Có¿... jest nadal
35 fajnym zarz±dc± okien, ale aplety, które mog± byæ u¿ywane w module
36 Wharf AfterStepa lub Window Makera, mog³yby zwiêkszyæ efektywno¶æ i
37 efektowno¶æ twojego ulubionego zarz±dcy okien.
38
39 Je¿eli masz zainstalowanego AfterStepa to powiniene¶ zainstalowaæ
40 tak¿e ten pakiet. Mi³ej zabawy!
41
42 %prep
43 %setup -q -c
44 rm -f *.asc
45 for archive in *.tar.gz ; do
46         tar xzf $archive
47         rm -f $archive
48 done
49 %patch0 -p1
50 %patch1 -p1
51 %patch3 -p0
52 %patch4 -p1
53
54 %build
55 for package in `ls` ; do
56     cd $package 
57     case $package in
58         ascd-* )
59             ./configure << EOF
60 1
61
62 1
63
64 EOF
65             patch -p2 -b --suffix .compile < %{PATCH2}
66             xmkmf
67             make Makefiles CXXDEBUGFLAGS="%{rpmcflags}" \
68                 CDEBUGFLAGS="%{rpmcflags}"
69             make MANDIR=%{_mandir}/man1 \
70                 BINDIR=%{_bindir} \
71                 SHLIBDIR=%{_libdir} \
72                 CXXDEBUGFLAGS="%{rpmcflags}" \
73                 CDEBUGFLAGS="%{rpmcflags}"
74             ;;
75         
76         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
77             # we don't compile these
78             ;;
79
80         aterm*)
81             %configure --enable-utmp
82             make
83             ;;
84
85         xiterm*)
86             # cough cough, hack hack -- ewt
87             %configure \
88                 --enable-xpm-background \
89                 --enable-utmp \
90                 --enable-wtmp \
91                 --enable-menubar \
92                 --enable-next-scroll
93             xmkmf
94             make Makefiles
95             cd src
96             sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
97                Makefile > Makefile.foo
98             sed -e "s/-lsocket //" Makefile.foo > Makefile
99             make CXXDEBUGFLAGS="%{rpmcflags}" \
100                 CDEBUGFLAGS="%{rpmcflags}"
101             ;;
102         asclock*)
103             CFLAGS="%{rpmcflags}" ./configure --prefix=%{_prefix} << EOF
104 classic
105
106 EOF
107              make CFLAGS="%{rpmcflags}"
108              ;;
109         *)
110             #just about every other thing supports autoconf
111             %configure
112             make
113             ;;
114     esac
115     cd ..
116 done
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
121
122 for package in `ls` ; do
123     cd $package 
124     case $package in
125         ascd-* | xiterm*)
126             make install install.man \
127                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
128                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
129                 MANDIR=%{_mandir}/man1 \
130                 BINDIR=%{_bindir} \
131                 SHLIBDIR=%{_libdir} \
132                 DESTDIR=$RPM_BUILD_ROOT 
133             ;;
134
135         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
136             # we don't install this
137             ;;
138
139         ascp-* )
140             make install \
141                 ASCP_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
142                 ASCP_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
143                 prefx=$RPM_BUILD_ROOT \
144                 DESTDIR=$RPM_BUILD_ROOT
145             ;;
146         
147         asppp* | aterm* )
148             make install \
149                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
150                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
151                 DESTDIR=$RPM_BUILD_ROOT
152             ;;
153         *)
154             make install install.man \
155                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
156                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
157                 DESTDIR=$RPM_BUILD_ROOT
158             ;;
159     esac
160     cd ..
161 done
162 rm -f $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}/{sessreg,xpmroot,qplot}*
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %files
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/*
173 %{_datadir}/afterstep/*
174 %{_mandir}/man1/*
This page took 0.084793 seconds and 3 git commands to generate.