]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blob - AfterStep-APPS.spec
a835c2802bb5b3a3fd5d99d2a11b78b9c5fd7cd2
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
1 Summary:        Applets you can use with AfterStep and compatible window managers.
2 Summary(pl):    Aplety, których mo¿esz u¿ywaæ z AfterStepem oraz innymi zarz±dcami okien, które s± z nim kompatybilne
3 Name:           AfterStep-APPS
4 Version:        991125
5 Release:        3
6 License:        GPL
7 Group:          X11/Window Managers/Tools
8 Group(pl):      X11/Zarz±dcy Okien/Narzêdzia
9 Source0:        http://www.tigr.net/afterstep/as-apps/download/as-apps-%{version}.tar
10 Patch0:         %{name}-1.5beta1-glibc.patch
11 Patch1:         ascp-paths.patch
12 Patch2:         as-apps-compile.patch
13 Patch3:         aterm-utmp.patch
14 Patch4:         xiterm-utmp.patch
15 Prereq:         /sbin/ldconfig
16 Requires:       /usr/sbin/utempter
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _prefix /usr/X11R6
20 %define         _mandir /usr/X11R6/man
21
22 %description
23 What's a cool window manager without some cool applets? Well... it's
24 still cool, but these applets which can be used in the Wharf module
25 for AfterStep or Window Maker can add both spice and productivity to
26 your preferred window manager, such as a handy clock and information
27 about system resources.
28
29 If you've installed the AfterStep packages, you should also install
30 these packages. Enjoy!
31
32 %description -l pl
33 Czym jest fajny zarz±dca okien bez fajnych apletów? Có¿... jest nadal
34 fajnym zarz±dc± okien, ale aplety, które mog± byæ u¿ywane w module
35 Wharf AfterStepa lub Window Makera, mog³yby zwiêkszyæ efektywno¶æ i
36 efektowno¶æ twojego ulubionego zarz±dcy okien.
37
38 Je¿eli masz zainstalowanego AfterStepa to powiniene¶ zainstalowaæ
39 tak¿e ten pakiet. Mi³ej zabawy!
40
41 %prep
42 %setup -q -c
43 rm -f *.asc
44 for archive in *.tar.gz ; do
45         tar xzf $archive
46         rm -f $archive
47 done
48 %patch0 -p1
49 %patch1 -p1
50 %patch3 -p0
51 %patch4 -p1
52
53 %build
54 for package in `ls` ; do
55     cd $package 
56     case $package in
57         ascd-* )
58             ./configure << EOF
59 1
60
61 1
62
63 EOF
64             patch -p2 -b --suffix .compile < %{PATCH2}
65             xmkmf
66             make Makefiles CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
67                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
68             make MANDIR=%{_mandir}/man1 \
69                 BINDIR=%{_bindir} \
70                 SHLIBDIR=%{_libdir} \
71                 CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
72                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
73             ;;
74         
75         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
76             # we don't compile these
77             ;;
78
79         aterm*)
80             %configure --enable-utmp
81             make
82             ;;
83
84         xiterm*)
85             # cough cough, hack hack -- ewt
86             %configure \
87                 --enable-xpm-background \
88                 --enable-utmp \
89                 --enable-wtmp \
90                 --enable-menubar \
91                 --enable-next-scroll
92             xmkmf
93             make Makefiles
94             cd src
95             sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
96                Makefile > Makefile.foo
97             sed -e "s/-lsocket //" Makefile.foo > Makefile
98             make CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
99                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
100             ;;
101         asclock*)
102             CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} << EOF
103 classic
104
105 EOF
106              make CFLAGS="$RPM_OPT_FLAGS"
107              ;;
108         *)
109             #just about every other thing supports autoconf
110             %configure
111             make
112             ;;
113     esac
114     cd ..
115 done
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
120
121 for package in `ls` ; do
122     cd $package 
123     case $package in
124         ascd-* | xiterm*)
125             make install install.man \
126                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
127                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
128                 MANDIR=%{_mandir}/man1 \
129                 BINDIR=%{_bindir} \
130                 SHLIBDIR=%{_libdir} \
131                 DESTDIR=$RPM_BUILD_ROOT 
132             ;;
133
134         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
135             # we don't install this
136             ;;
137
138         ascp-* )
139             make install \
140                 ASCP_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
141                 ASCP_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
142                 prefx=$RPM_BUILD_ROOT \
143                 DESTDIR=$RPM_BUILD_ROOT
144             ;;
145         
146         asppp* | aterm* )
147             make install \
148                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
149                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
150                 DESTDIR=$RPM_BUILD_ROOT
151             ;;
152         *)
153             make install install.man \
154                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
155                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
156                 DESTDIR=$RPM_BUILD_ROOT
157             ;;
158     esac
159     cd ..
160 done
161 rm -f $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}/{sessreg,xpmroot,qplot}*
162 strip --strip-unneeded $RPM_BUILD_ROOT%{_bindir}/*
163
164 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post -p /sbin/ldconfig
170 %postun -p /sbin/ldconfig
171
172 %files
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/*
175 %{_datadir}/afterstep/*
176 %{_mandir}/man1/*
This page took 0.175348 seconds and 3 git commands to generate.