]> git.pld-linux.org Git - packages/zabbix.git/blame_incremental - zabbix.spec
R: php(openssl) in -frontend-php
[packages/zabbix.git] / zabbix.spec
... / ...
CommitLineData
1# TODO:
2# - initscript for zabbix-server, zabbix-proxy and zabbix-java
3# - unpackaged files:
4# /lib/systemd/system/zabbix_java.service
5# /usr/bin/zabbix_js
6# /var/lib/zabbix/zabbix.db
7#
8# Conditional build:
9%bcond_without pgsql # enable PostgreSQL support
10%bcond_without sqlite3 # enable sqlite3 support
11%bcond_without mysql # enable MySQL support
12%bcond_without java # disable java support
13%bcond_without agent2 # disable bulding of Go based agent2
14
15%define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
16%define any_database %{with pgsql}%{with mysql}%{with sqlite3}
17
18%ifnarch %{go_arches}
19%undefine with_agent2
20%endif
21
22%{?with_java:%{?use_default_jdk}}
23
24%define php_min_version 7.2.5
25Summary: Zabbix - network monitoring software
26Summary(pl.UTF-8): Zabbix - oprogramowanie do monitorowania sieci
27Name: zabbix
28Version: 5.4.3
29Release: 3
30License: GPL v2+
31Group: Networking/Utilities
32# https://www.zabbix.com/download_sources
33Source0: https://cdn.zabbix.com/zabbix/sources/stable/5.4/%{name}-%{version}.tar.gz
34# Source0-md5: 5dccb536c164e45c7d5c1a5a9d64be43
35Source100: go-vendor.tar.xz
36# Source100-md5: 61f2ee9647280765b622a5e1e8cdfbba
37Source1: %{name}-apache.conf
38Source2: %{name}_server.service
39Source3: %{name}_agentd.service
40Source4: %{name}_proxy.service
41Source5: %{name}_java.service
42Source6: %{name}.tmpfiles
43Source7: %{name}_agentd.init
44Source8: %{name}_agent2.init
45%if 0
46cd src/go/
47go mod vendor
48tar -caf ~/go-vendor.tar.xz -C ../../ src/go/vendor
49%endif
50Patch0: config.patch
51Patch1: sqlite3_dbname.patch
52Patch2: always_compile_ipc.patch
53Patch3: go-destdir.patch
54Patch4: go-vendor.patch
55URL: https://www.zabbix.com/
56BuildRequires: OpenIPMI-devel
57BuildRequires: autoconf
58BuildRequires: automake >= 1:1.15
59BuildRequires: curl-devel
60BuildRequires: iksemel-devel
61%{?with_java:%{?use_jdk:%buildrequires_jdk}%{!?use_jdk:BuildRequires: jdk}}
62BuildRequires: rpm-build >= 4.6
63%{?with_java:BuildRequires: rpm-pld-macros-javaprov}
64%{?with_agent2:BuildRequires: golang >= 1.13}
65BuildRequires: libevent-devel
66BuildRequires: libssh2-devel
67BuildRequires: libtool
68BuildRequires: libxml2-devel
69%{?with_mysql:BuildRequires: mysql-devel}
70BuildRequires: net-snmp-devel
71BuildRequires: openldap-devel >= 2.4.6
72BuildRequires: openssl-devel >= 0.9.7d
73BuildRequires: pcre-devel
74%{?with_pgsql:BuildRequires: postgresql-devel}
75BuildRequires: rpmbuild(macros) >= 2.021
76%{?with_sqlite3:BuildRequires: sqlite3-devel}
77BuildRequires: tar >= 1:1.22
78BuildRequires: unixODBC-devel
79BuildRequires: xz
80BuildRequires: zlib-devel
81Requires: %{name}-agentd = %{version}-%{release}
82Requires: %{name}-frontend-php = %{version}-%{release}
83Requires: %{name}-server = %{version}-%{release}
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86%define _sysconfdir /etc/%{name}
87%define _appdir %{_datadir}/%{name}
88%define _webapps /etc/webapps
89%define _webapp %{name}
90
91%description
92Zabbix is software that monitors numerous parameters of a network and
93the servers on that network. It is a useful tool for monitoring the
94health and integrity of servers. Zabbix uses a flexible notification
95mechanism that allows users to configure email based alerts for
96virtually any event. All monitored parameters are stored in a
97database. Zabbix offers excellent reporting and data visualisation
98features based on the stored data. Zabbix supports both polling and
99trapping. All Zabbix reports and statistics, as well as configuration
100parameters, are accessed through a web-based front end.
101
102%description -l pl.UTF-8
103Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
104serwerów sieciowych. Jest przydatny przy monitorowaniu działania
105serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
106pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
107dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
108przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
109oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
110odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
111statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
112
113%package common
114Summary: Common files for Zabbix monitoring software
115Summary(pl.UTF-8): Wspólne pliki dla oprogramowania monitorującego Zabbix
116Group: Networking/Utilities
117Requires(postun): /usr/sbin/groupdel
118Requires(postun): /usr/sbin/userdel
119Requires(pre): /bin/id
120Requires(pre): /usr/bin/getgid
121Requires(pre): /usr/sbin/groupadd
122Requires(pre): /usr/sbin/useradd
123Provides: group(zabbix)
124Provides: user(zabbix)
125
126%description common
127Common files for Zabbix monitoring software.
128
129%description common -l pl.UTF-8
130Wspólne pliki dla oprogramowania monitorującego Zabbix.
131
132%package agentd
133Summary: Zabbix Agent
134Summary(pl.UTF-8): Agenta Zabbiksa
135Group: Networking/Utilities
136Requires: %{name}-common = %{version}-%{release}
137Requires: systemd-units >= 38
138Obsoletes: zabbix-agent-inetd
139Obsoletes: zabbix-agent-standalone
140Requires(post,preun): /sbin/chkconfig
141Requires: rc-scripts
142
143%description agentd
144Zabbix agent collects data from the local system for a Zabbix server.
145
146%description agentd -l pl.UTF-8
147Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
148
149%package agent2
150Summary: Zabbix Agent 2
151Group: Networking/Utilities
152URL: https://www.zabbix.com/documentation/current/manual/concepts/agent2
153Requires: %{name}-common = %{version}-%{release}
154Requires(post,preun): /sbin/chkconfig
155Requires: rc-scripts
156
157%description agent2
158Zabbix agent 2 is a new generation of Zabbix agent and may be used in
159place of Zabbix agent.
160
161Zabbix agent 2 has been developed to:
162- reduce the number of TCP connections
163- have greater check concurrency
164- be easily extendible with plugins.
165
166A plugin should be able to:
167- provide trivial checks consisting of only a few simple lines of code
168- provide complex checks consisting of long-running scripts and
169 standalone data gathering with periodic sending back of the data
170- be a drop-in replacement for Zabbix agent (in that it supports all
171 the previous functionality)
172
173Passive checks work similarly to Zabbix agent. Active checks support
174scheduled/flexible intervals and check concurrency within one active
175server.
176
177%package frontend-php
178Summary: PHP frontend for Zabbix
179Summary(pl.UTF-8): Interfejs PHP dla Zabbiksa
180Group: Applications/WWW
181Requires: php(bcmath)
182Requires: php(core) >= %{php_min_version}
183Requires: php(ctype)
184Requires: php(gd)
185Requires: php(gettext)
186Requires: php(json)
187Requires: php(mbstring)
188Requires: php(openssl)
189Requires: php(pcre)
190Requires: php(session)
191Requires: php(sockets)
192Requires: php(xml)
193Requires: php(xmlreader)
194Requires: php(xmlwriter)
195Requires: webapps
196Requires: webserver(alias)
197Requires: webserver(indexfile)
198Requires: webserver(php)
199Suggests: php(mysql)
200Suggests: php(pgsql)
201Suggests: php(sqlite3)
202# used with sqlite3
203Suggests: php(sysvsem)
204BuildArch: noarch
205
206%description frontend-php
207This package provides web based (PHP) frontend for Zabbix.
208
209%description frontend-php -l pl.UTF-8
210Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
211
212%package get
213Summary: Program retrieving data from Zabbix agent
214Summary(pl.UTF-8): Program odpytujÄcy agenta Zabbiksa
215Group: Networking/Utilities
216
217%description get
218This package provides a program retrieving data from Zabbix agent.
219
220%description get -l pl.UTF-8
221Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
222
223%package proxy
224Summary: Zabbix proxy
225Summary(pl.UTF-8): Proxy do Zabbiksa
226Group: Networking/Utilities
227Requires: %{name}-common = %{version}-%{release}
228Requires: systemd-units >= 38
229Requires: zabbix-proxy(db) = %{version}-%{release}
230
231%description proxy
232This package provides the Zabbix proxy.
233
234%description proxy -l pl.UTF-8
235Ten pakiet zawiera proxy Zabbix.
236
237%package proxy-mysql
238Summary: MySQL support for Zabbix proxy
239Summary(pl.UTF-8): Obsługa MySQL dla proxy do Zabbiksa
240Group: Networking/Utilities
241Provides: %{name}-proxy(db) = %{version}-%{release}
242Obsoletes: zabbix-proxy-postgresql
243Obsoletes: zabbix-proxy-sqlite3
244
245%description proxy-mysql
246This package provides the Zabbix proxy binary with MySQL support.
247
248%description proxy-mysql -l pl.UTF-8
249Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
250
251%package proxy-postgresql
252Summary: PostgreSQL support for Zabbix proxy
253Summary(pl.UTF-8): Obsługa PostgreSQL dla proxy do Zabbiksa
254Group: Networking/Utilities
255Provides: %{name}-proxy(db) = %{version}-%{release}
256Obsoletes: zabbix-proxy-mysql
257Obsoletes: zabbix-proxy-sqlite3
258
259%description proxy-postgresql
260This package provides the Zabbix proxy binary with PostgreSQL support.
261
262%description proxy-postgresql -l pl.UTF-8
263Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
264
265%package proxy-sqlite3
266Summary: SQLite 3 support for Zabbix proxy
267Summary(pl.UTF-8): Obsługa SQLite 3 dla proxy do Zabbiksa
268Group: Networking/Utilities
269Provides: %{name}-proxy(db) = %{version}-%{release}
270Obsoletes: zabbix-proxy-mysql
271Obsoletes: zabbix-proxy-postgresql
272
273%description proxy-sqlite3
274This package provides the Zabbix proxy binary with SQLite 3 support.
275
276%description proxy-sqlite3 -l pl.UTF-8
277Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
278
279%package sender
280Summary: Zabbix sender
281Summary(pl.UTF-8): Program zawiadamiający Zabbiksa
282Group: Networking/Utilities
283
284%description sender
285This package provides the Zabbix sender.
286
287%description sender -l pl.UTF-8
288Ten pakiet zawiera program zawiadamiający Zabbiksa.
289
290%package server
291Summary: Zabbix server
292Summary(pl.UTF-8): Serwer Zabbiksa
293Group: Networking/Utilities
294Requires: %{name}-common = %{version}-%{release}
295Requires: %{name}-server(db) = %{version}-%{release}
296Requires: systemd-units >= 38
297Obsoletes: zabbix-suckerd
298Obsoletes: zabbix-trapper-inetd
299Obsoletes: zabbix-trapper-standalone
300
301%description server
302This package provides the Zabbix server.
303
304%description server -l pl.UTF-8
305Ten pakiet zawiera serwer Zabbiksa.
306
307%package server-mysql
308Summary: MySQL support for Zabbix server
309Summary(pl.UTF-8): Obsługa MySQL sla serwera Zabbiksa
310Group: Networking/Utilities
311Provides: %{name}-server(db) = %{version}-%{release}
312Obsoletes: zabbix-server-postgresql
313Obsoletes: zabbix-server-sqlite3
314
315%description server-mysql
316This package provides the Zabbix server binary for use with MySQL
317database.
318
319%description server-mysql -l pl.UTF-8
320Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
321
322%package server-postgresql
323Summary: PostgreSQL support for Zabbix server
324Summary(pl.UTF-8): Obsługa PostgreSQL sla serwera Zabbiksa
325Group: Networking/Utilities
326Provides: %{name}-server(db) = %{version}-%{release}
327Obsoletes: zabbix-server-mysql
328Obsoletes: zabbix-server-sqlite3
329
330%description server-postgresql
331This package provides the Zabbix server binary for use with PostgreSQL
332database.
333
334%description server-postgresql -l pl.UTF-8
335Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
336
337%package java
338Summary: Zabbix Java Gateway
339Group: Networking/Utilities
340Requires: %{name}-common = %{version}-%{release}
341Requires: systemd-units >= 38
342
343%description java
344This package provides the Zabbix Java Gateway.
345
346%prep
347%setup -q -a100
348%patch0 -p1
349%patch1 -p1
350%patch2 -p1
351%patch3 -p1
352%patch4 -p1
353
354%build
355%{__libtoolize}
356%{__aclocal} -I m4
357%{__autoconf}
358%{__autoheader}
359%{__automake}
360
361configure() {
362 %configure \
363 %{?with_java:ac_cv_prog_JAVAC=%{java_home}/bin/javac} \
364 %{?with_java:ac_cv_prog_JAR=%{java_home}/bin/jar} \
365 --enable-dependency-tracking \
366 --enable-agent \
367 %{__enable_disable agent2} \
368 --enable-ipv6 \
369 %{__enable_disable java} \
370 --with-ldap \
371 --with-libcurl \
372 --with-libevent \
373 --with-libpcre \
374 --with-libxml2 \
375 --with-net-snmp \
376 --with-openipmi \
377 --with-openssl \
378 --with-ssh2 \
379 --with-unixodbc \
380 "$@"
381}
382
383configure \
384 --disable-server \
385 --disable-proxy
386
387%{__make}
388
389for database in %{databases} ; do
390 if [ "$database" = "sqlite3" ] ; then
391 enable_server=""
392 else
393 enable_server="--enable-server"
394 fi
395 configure \
396 --with-$database \
397 $enable_server \
398 --enable-proxy
399
400 %{__make}
401
402 if [ "$enable_server" ] ; then
403 %{__make} install \
404 -C src/zabbix_server \
405 DESTDIR=$PWD/install-${database}
406 fi
407
408 %{__make} install \
409 -C src/zabbix_proxy \
410 DESTDIR=$PWD/install-${database}
411done
412
413%install
414rm -rf $RPM_BUILD_ROOT
415install -d \
416 $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_agent2.conf.d,/etc/webapps/%{_webapp}} \
417 $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_appdir}/frontends/php} \
418 $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
419
420%{__make} install \
421 DESTDIR=$RPM_BUILD_ROOT \
422 ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
423
424for database in %{databases} ; do
425 if [ "$database" != "sqlite3" ] ; then
426 cp -p install-$database/%{_sbindir}/zabbix_server \
427 $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
428 fi
429 cp -p install-$database/%{_sbindir}/zabbix_proxy \
430 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
431done
432
433if [ -n "$database" ] ; then
434 ln -sf zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
435 ln -sf zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
436fi
437
438%if %{with sqlite3}
439install -d $RPM_BUILD_ROOT/var/lib/zabbix
440touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
441%endif
442
443cp -r ui/* $RPM_BUILD_ROOT%{_appdir}/frontends/php
444
445cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
446cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
447
448install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
449install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
450install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
451install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agent2
452install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
453install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
454
455cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
456
457mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
458ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/frontend,%{_appdir}/frontends/php/conf}
459touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
460
461%if %{with java}
462mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
463ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/zabbix_java.conf,%{_datadir}/zabbix_java/settings.sh}
464mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
465ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback.xml,%{_datadir}/zabbix_java/lib/logback.xml}
466mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
467ln -s --relative $RPM_BUILD_ROOT{%{_sysconfdir}/java-logback-console.xml,%{_datadir}/zabbix_java/lib/logback-console.xml}
468
469cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
470#!/bin/sh
471
472exec %{_datadir}/zabbix_java/startup.sh "$@"
473EOF
474
475cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
476#!/bin/sh
477
478exec %{_datadir}/zabbix_java/shutdown.sh "$@"
479EOF
480%endif
481
482%clean
483rm -rf $RPM_BUILD_ROOT
484
485%triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
486%webapp_register apache %{_webapp}
487
488%triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
489%webapp_unregister apache %{_webapp}
490
491%triggerin frontend-php -- apache < 2.2.0, apache-base
492%webapp_register httpd %{_webapp}
493
494%triggerun frontend-php -- apache < 2.2.0, apache-base
495%webapp_unregister httpd %{_webapp}
496
497%pre common
498%groupadd -g 111 zabbix
499%useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
500%addusertogroup -q zabbix proc
501
502%postun common
503if [ "$1" = "0" ]; then
504 %userremove zabbix
505 %groupremove zabbix
506fi
507
508%post server-mysql
509if [ "$1" = 1 ]; then
510 %banner -e %{name}-server <<-EOF
511 You should create database for Zabbix.
512
513 Running these should be fine in most cases:
514 mysqladmin create zabbix
515 zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
516 zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
517 zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
518EOF
519fi
520ln -sf zabbix_server-mysql %{_sbindir}/zabbix_server || :
521
522%post server-postgresql
523if [ "$1" = 1 ]; then
524 %banner -e %{name}-server <<-EOF
525 You should create database for Zabbix.
526
527 Running these should be fine in most cases:
528
529 createuser zabbix
530 createdb -O zabbix zabbix
531 zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
532 zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
533 zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
534EOF
535fi
536ln -sf zabbix_server-postgresql %{_sbindir}/zabbix_server || :
537
538%post server
539%systemd_post zabbix_server.service
540
541%preun server
542%systemd_preun zabbix_server.service
543
544%postun server
545if [ "$1" = "0" ]; then
546 if [ -L %{_sbindir}/zabbix_server ] ; then
547 rm -f %{_sbindir}/zabbix_server || :
548 fi
549fi
550%systemd_reload
551
552%post agentd
553/sbin/chkconfig --add zabbix_agentd
554%service zabbix_agentd restart
555%systemd_post zabbix_agentd.service
556
557%preun agentd
558if [ "$1" = "0" ]; then
559 %service -q zabbix_agentd stop
560 /sbin/chkconfig --del zabbix_agentd
561fi
562%systemd_preun zabbix_agentd.service
563
564%postun agentd
565%systemd_reload
566
567%post agent2
568/sbin/chkconfig --add zabbix_agent2
569%service zabbix_agent2 restart
570
571%preun agent2
572if [ "$1" = "0" ]; then
573 %service -q zabbix_agent2 stop
574 /sbin/chkconfig --del zabbix_agent2
575fi
576
577%post proxy-mysql
578ln -sf zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
579
580%post proxy-postgresql
581ln -sf zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
582
583%post proxy-sqlite3
584ln -sf zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
585
586%post proxy
587%systemd_post zabbix_proxy.service
588
589%preun proxy
590%systemd_preun zabbix_proxy.service
591
592%postun proxy
593%systemd_reload
594
595%post java
596%systemd_post zabbix_java.service
597
598%preun java
599%systemd_preun zabbix_java.service
600
601%postun java
602%systemd_reload
603
604%files
605%defattr(644,root,root,755)
606%doc AUTHORS ChangeLog README
607
608%files common
609%defattr(644,root,root,755)
610%doc AUTHORS ChangeLog README
611%attr(751,root,zabbix) %dir %{_sysconfdir}
612%attr(751,root,http) %dir %{_sysconfdir}/frontend
613%dir %{_appdir}
614%dir %{_appdir}/frontends
615%dir %attr(770,root,zabbix) /var/run/zabbix
616%dir %attr(775,root,zabbix) /var/log/zabbix
617%{systemdtmpfilesdir}/zabbix.conf
618
619%files agentd
620%defattr(644,root,root,755)
621%doc conf/zabbix_agentd/*.conf
622%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
623%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
624%attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
625%attr(755,root,root) %{_sbindir}/zabbix_agentd
626%{_mandir}/man8/zabbix_agentd*
627%{systemdunitdir}/zabbix_agentd.service
628
629%if %{with agent2}
630%files agent2
631%defattr(644,root,root,755)
632%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent2.conf
633%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agent2.conf.d
634%attr(754,root,root) /etc/rc.d/init.d/zabbix_agent2
635%attr(755,root,root) %{_sbindir}/zabbix_agent2
636%{_mandir}/man8/zabbix_agent2.8*
637%endif
638
639%files frontend-php
640%defattr(644,root,root,755)
641%attr(750,root,http) %dir %{_webapps}/%{_webapp}
642%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
643%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
644%ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
645%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
646%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
647%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
648%{_appdir}/frontends/php
649
650%files get
651%defattr(644,root,root,755)
652%attr(755,root,root) %{_bindir}/zabbix_get
653%{_mandir}/man1/zabbix_get*
654
655%if %{any_database}
656%files proxy
657%defattr(644,root,root,755)
658%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
659%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
660%ghost %{_sbindir}/zabbix_proxy
661%{_mandir}/man8/zabbix_proxy*
662%{systemdunitdir}/zabbix_proxy.service
663%endif
664
665%if %{with mysql}
666%files proxy-mysql
667%defattr(644,root,root,755)
668%attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
669%endif
670
671%if %{with pgsql}
672%files proxy-postgresql
673%defattr(644,root,root,755)
674%attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
675%endif
676
677%if %{with sqlite3}
678%files proxy-sqlite3
679%defattr(644,root,root,755)
680%attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
681%endif
682
683%files sender
684%defattr(644,root,root,755)
685%attr(755,root,root) %{_bindir}/zabbix_sender
686%{_mandir}/man1/zabbix_sender*
687
688%if %{any_database}
689%files server
690%defattr(644,root,root,755)
691%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
692%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
693%ghost %{_sbindir}/zabbix_server
694%{_mandir}/man8/zabbix_server*
695%{systemdunitdir}/zabbix_server.service
696%endif
697
698%if %{with mysql}
699%files server-mysql
700%defattr(644,root,root,755)
701%doc database/mysql/*.sql
702%attr(755,root,root) %{_sbindir}/zabbix_server-mysql
703%endif
704
705%if %{with pgsql}
706%files server-postgresql
707%defattr(644,root,root,755)
708%doc database/postgresql/*.sql
709%attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
710%endif
711
712%if %{with java}
713%files java
714%defattr(644,root,root,755)
715%attr(755,root,root) %{_sbindir}/zabbix_java-start
716%attr(755,root,root) %{_sbindir}/zabbix_java-stop
717%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
718%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
719%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
720%dir %{_datadir}/zabbix_java
721%{_datadir}/zabbix_java/bin
722%{_datadir}/zabbix_java/lib
723%{_datadir}/zabbix_java/settings.sh
724%attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
725%attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
726%{systemdunitdir}/zabbix_java.service
727%endif
This page took 0.041398 seconds and 4 git commands to generate.