]> git.pld-linux.org Git - packages/xbmc.git/blame_incremental - xbmc.spec
- patch to get goom visualisation usable
[packages/xbmc.git] / xbmc.spec
... / ...
CommitLineData
1#
2# TODO:
3# - fix build flags - some files are compiled with -O3 and without rpm*flags
4# - fix linking argument order
5# - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6# only libXrandr 1.1 - with no gamma support; it causes application crash
7# on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8# - add and/or fix users/groups permissions
9# - split to subpackages?
10# - check how it works with external python libraries
11#
12# Conditional build:
13%bcond_with external_python
14%bcond_without goom
15
16Summary: XBMC
17Name: xbmc
18Version: 10.0
19Release: 0.3
20License: GPL v3
21Group: Applications/Multimedia
22Source0: http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
23# Source0-md5: 728fb514e5f43f27bb880305061b4e72
24Source1: goom_icon.png
25# Source1-md5: 8c0ffe2055f2cfde1189687d12a68aa8
26URL: http://xbmc.org
27Patch0: %{name}-nobash.patch
28Patch1: %{name}-python27.patch
29Patch2: %{name}-subtitle_tags.patch
30Patch3: %{name}-goom_enable.patch
31BuildRequires: SDL_image-devel
32BuildRequires: SDL_mixer-devel
33BuildRequires: a52dec-libs-devel
34BuildRequires: alsa-lib-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: avahi-devel
38BuildRequires: boost-devel
39BuildRequires: bzip2-devel
40BuildRequires: cmake
41BuildRequires: curl-devel
42BuildRequires: dbus-devel
43BuildRequires: enca-devel
44BuildRequires: faac-devel
45BuildRequires: faad2-devel
46BuildRequires: ffmpeg-devel
47BuildRequires: flac-devel
48BuildRequires: fontconfig-devel
49BuildRequires: freetype-devel
50BuildRequires: fribidi-devel
51BuildRequires: gawk
52BuildRequires: gettext-autopoint
53BuildRequires: gettext-devel
54BuildRequires: glew-devel
55BuildRequires: gperf
56BuildRequires: gtk+-devel
57BuildRequires: hal-devel
58BuildRequires: jasper-devel
59BuildRequires: libao-devel
60BuildRequires: libcdio-devel
61BuildRequires: libdts-devel
62BuildRequires: libjpeg-devel
63BuildRequires: libmad-devel
64BuildRequires: libmicrohttpd-devel
65BuildRequires: libmms-devel
66BuildRequires: libmodplug-devel
67BuildRequires: libmpeg2-devel
68BuildRequires: libogg-devel
69BuildRequires: libpng-devel
70BuildRequires: libsamplerate-devel
71BuildRequires: libsmbclient-devel
72BuildRequires: libtiff-devel
73BuildRequires: libtool
74BuildRequires: libvdpau-devel
75BuildRequires: libvorbis-devel
76BuildRequires: lzo-devel
77BuildRequires: mysql-devel
78%ifarch %{ix86}
79BuildRequires: nasm
80%endif
81BuildRequires: openssl-devel
82BuildRequires: pcre-cxx-devel
83BuildRequires: pkgconfig
84BuildRequires: pulseaudio-devel
85BuildRequires: python-devel
86BuildRequires: rpm-pythonprov
87BuildRequires: rpmbuild(macros) >= 1.566
88# used internally
89BuildRequires: sed >= 4.0
90BuildRequires: sqlite3-devel
91BuildRequires: unzip
92BuildRequires: wavpack-devel
93BuildRequires: xmms-devel
94BuildRequires: xorg-lib-libXinerama-devel
95BuildRequires: xorg-lib-libXrandr-devel
96BuildRequires: xorg-lib-libXtst-devel
97BuildRequires: zip
98BuildRequires: zlib-devel
99Requires: /usr/bin/glxinfo
100Requires: lsb-release
101Requires: xorg-app-xdpyinfo
102BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104%description
105
106%prep
107%setup -q
108%patch0 -p1
109%undos xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
110%patch1 -p1
111%patch2 -p1
112%patch3 -p1
113
114%build
115./bootstrap
116%configure \
117 --disable-debug \
118 --enable-external-libraries \
119 --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
120 --%{?with_goom:en}%{!?with_goom:dis}able-goom
121%{__make}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/xbmc/addons/visualization.goom/icon.png
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%posttrans
134%banner -e xbmc <<EOF
135WARNING!
136If you use nvidia binary drivers be sure that SDL is compiled without
137XRandR and VidMode gamma ramps support.
138This means that you need to rebuild it with command:
139builder -bb --without new_gamma_ramp SDL
140EOF
141
142%files
143%defattr(644,root,root,755)
144#doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
145
146#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
147%attr(755,root,root) %{_bindir}/*
148%{_datadir}/%{name}
149%attr(755,root,root) %{_libdir}/%{name}
150%{_docdir}/%{name}
151%{_desktopdir}/%{name}.desktop
152%{_iconsdir}/hicolor/256x256/apps/%{name}.png
153%{_iconsdir}/hicolor/48x48/apps/%{name}.png
154%{_datadir}/xsessions/XBMC.desktop
This page took 0.068693 seconds and 5 git commands to generate.