]> git.pld-linux.org Git - packages/waf.git/blame_incremental - waf.spec
up to 1.8.7
[packages/waf.git] / waf.spec
... / ...
CommitLineData
1Summary: The Waf build system
2Summary(pl.UTF-8): System budowania Waf
3Name: waf
4Version: 1.8.7
5Release: 1
6# note: waf book is on CC-BY-NC-ND (not included in binary package)
7License: BSD
8Group: Development/Building
9#Source0Download: http://code.google.com/p/waf/downloads/list
10Source0: ftp://ftp.waf.io/pub/release/%{name}-%{version}.tar.bz2
11# Source0-md5: 223962fea8e8bfac6b259f1bd1c7b27b
12Patch0: %{name}-path.patch
13URL: http://code.google.com/p/waf/
14BuildRequires: python >= 1:2.6
15BuildRequires: python-modules >= 1:2.6
16BuildRequires: rpm-pythonprov
17BuildRequires: rpmbuild(macros) >= 1.234
18Requires: python(abi) = %{py_ver}
19BuildArch: noarch
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Waf is a general-purpose build system which was modelled from Scons.
24Though it comes last in the arena of the build systems, we believe
25that Waf is a vastly superior alternative to its competitors
26(Autotools, Scons, Cmake, Ant, etc) for building software,
27
28%description -l pl.UTF-8
29Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
30Scons. Mimo że pojawił się jako ostatni na arenie systemów budowania,
31autorzy wierzą, że przewyższa alternatywne narzędzia (Autotools,
32Scons, Cmake, Ant itp.).
33
34%prep
35%setup -q
36%patch0 -p1
37
38%build
39# check waf-light
40extras=
41for f in waflib/extras/*.py ; do
42 tool=$(basename "$f" .py)
43 if [ "$tool" != "__init__" ]; then
44 extras="${extras:+$extras,}$tool"
45 fi
46done
47./waf-light --make-waf --strip --tools="$extras"
48
49%install
50rm -rf $RPM_BUILD_ROOT
51install -d $RPM_BUILD_ROOT%{_datadir}/waf/waflib/{Tools,extras}
52
53cp -p waflib/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib
54cp -p waflib/Tools/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/Tools
55cp -p waflib/extras/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/extras
56
57install -D -p waf-light $RPM_BUILD_ROOT%{_bindir}/waf
58
59%py_comp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
60%py_ocomp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
67%doc ChangeLog README TODO
68%attr(755,root,root) %{_bindir}/waf
69%{_datadir}/waf
This page took 0.085148 seconds and 4 git commands to generate.