]> git.pld-linux.org Git - packages/vtk.git/blame_incremental - vtk.spec
- updated files
[packages/vtk.git] / vtk.spec
... / ...
CommitLineData
1# TODO:
2# - handle VTK_USE_MPEG2_ENCODER (see CMakeLists.txt)
3# - handle MPI and VTK_USE_PARALLEL_BGL (Parallel Boost Graph Library, BR: boost >= 1.40)
4# - more system libraries? (check for VTK_THIRD_PARTY_SUBDIR in Utilities/CMakeLists.txt)
5# - CUDA for Accelerators/Piston (on bcond)
6# - NVCtrlLib for Rendering/OpenGL (on bcond)
7# - VTK_USE_SYSTEM_XDMF2=ON ? (but our xdmf-devel seems not compatible)
8#
9# Conditional build
10%bcond_without java # Java wrappers
11%bcond_without ffmpeg # FFMPEG .avi saving support
12%bcond_with OSMesa # build with OSMesa (https://bugzilla.redhat.com/show_bug.cgi?id=744434)
13%bcond_with system_proj # use system PROJ.4 (needs 4.3 with exposed internals, not ready for 4.4+)
14#
15Summary: Toolkit for 3D computer graphics, image processing, and visualization
16Summary(pl.UTF-8): Zestaw narzędzi do trójwymiarowej grafiki, przetwarzania obrazu i wizualizacji
17Name: vtk
18Version: 6.3.0
19Release: 0.1
20License: BSD
21Group: Libraries
22Source0: http://www.vtk.org/files/release/6.3/VTK-%{version}.tar.gz
23# Source0-md5: 0231ca4840408e9dd60af48b314c5b6d
24Source1: http://www.vtk.org/files/release/6.3/VTKData-%{version}.tar.gz
25# Source1-md5: b164200226805aeb741703a8168afdda
26Patch0: %{name}-chemistry.patch
27Patch1: gdal2.patch
28URL: http://www.vtk.org/
29%{?with_OSMesa:BuildRequires: Mesa-libOSMesa-devel}
30BuildRequires: OpenGL-GLX-devel
31BuildRequires: OpenGL-devel
32BuildRequires: QtCore-devel >= 4.5.0
33BuildRequires: QtGui-devel >= 4.5.0
34BuildRequires: QtNetwork-devel >= 4.5.0
35BuildRequires: QtOpenGL-devel >= 4.5.0
36BuildRequires: QtSql-devel >= 4.5.0
37BuildRequires: QtWebKit-devel >= 4.5.0
38BuildRequires: QtXmlPatterns-devel >= 4.5.0
39BuildRequires: R
40BuildRequires: boost-devel >= 1.39
41BuildRequires: cmake >= 2.8.8
42BuildRequires: doxygen
43BuildRequires: expat-devel
44%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
45BuildRequires: fontconfig-devel
46BuildRequires: freetype-devel >= 2
47BuildRequires: gdal-devel
48BuildRequires: gl2ps-devel >= 1.3.8
49BuildRequires: gnuplot
50BuildRequires: graphviz
51BuildRequires: hdf5-devel
52%if %{with java}
53BuildRequires: jdk >= 1.5
54BuildRequires: jpackage-utils
55%endif
56BuildRequires: jsoncpp-devel
57BuildRequires: libjpeg-devel
58BuildRequires: libogg-devel
59BuildRequires: libpng-devel
60BuildRequires: libstdc++-devel
61BuildRequires: libtheora-devel
62BuildRequires: libtiff-devel
63BuildRequires: libxml2-devel >= 2
64BuildRequires: motif-devel
65BuildRequires: mysql-devel
66BuildRequires: netcdf-cxx-devel >= 4
67# some code using it exists (Domains/Chemistry), but is not included in cmakefiles
68#BuildRequires: openqube-devel
69BuildRequires: perl-base
70BuildRequires: postgresql-devel
71%{?with_system_proj:BuildRequires: proj-devel >= 4.3, proj-devel < 4.4}
72BuildRequires: python-devel >= 2
73BuildRequires: python-sip-devel
74BuildRequires: qt4-build >= 4.5.0
75BuildRequires: qt4-qmake >= 4.5.0
76BuildRequires: rpmbuild(macros) >= 1.605
77BuildRequires: sip
78BuildRequires: sip-PyQt4
79BuildRequires: tcl-devel
80BuildRequires: tk-devel
81BuildRequires: unixODBC-devel
82BuildRequires: wget
83BuildRequires: xorg-lib-libICE-devel
84BuildRequires: xorg-lib-libSM-devel
85BuildRequires: xorg-lib-libX11-devel
86BuildRequires: xorg-lib-libXScrnSaver-devel
87BuildRequires: xorg-lib-libXext-devel
88BuildRequires: xorg-lib-libXft-devel
89BuildRequires: xorg-lib-libXt-devel
90BuildRequires: zlib-devel
91BuildConflicts: libXNVCtrl-devel
92Requires: gl2ps >= 1.3.8
93BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95%define skip_post_check_so lib.*Python.*\.so.*
96
97%description
98The Visualization ToolKit (VTK) is an object oriented software system
99for 3D computer graphics, image processing, and visualization. VTK
100includes a textbook, a C++ class library, and several interpreted
101interface layers including Tcl/Tk, Java, and Python. VTK supports a
102wide variety of visualization algorithms including scalar, vector,
103tensor, texture, and volumetric methods. It also supports advanced
104modeling techniques like implicit modeling, polygon reduction, mesh
105smoothing, cutting, contouring, and Delaunay triangulation. Moreover,
106dozens of imaging algorithms have been integrated into the system.
107This allows mixing 2D imaging / 3D graphics algorithms and data.
108
109%description -l pl.UTF-8
110Visualization TookKit (VTK) to obiektowo zorientowany system
111oprogramowania do trójwymiarowej grafiki komputerowej, przetwarzania
112obrazu i wizualizacji. VTK zawiera książkę, bibliotekę klas C++ oraz
113kilka interpretowanych warstw interfejsów, w tym dla Tcl/Tk, Javy i
114Pythona. VTK obsługuje szeroki zakres algorytmów wizualizacji, w tym
115metody skalarne, wektorowe, tensorowe, teksturowe i wolumetryczne.
116Obsługuje także zaawansowane techniki modelowania, takie jak
117modelowanie implicite, redukcja wielokątów, wygładzanie siatki,
118przycinanie, konturowanie i triangulacja Delaunaya. Co więcej, wiele
119algorytmów obrazowania zostało zintegrowanych z systemem. Pozwala to
120na mieszanie algorytmów obrazowania 2D i grafiki 3D.
121
122%package devel
123Summary: VTK header files for building C++ code
124Summary(pl.UTF-8): Pliki nagłówkowe VTK dla C++
125Group: Development
126Requires: %{name} = %{version}-%{release}
127Requires: libstdc++-devel
128
129%description devel
130This provides the VTK header files required to compile C++ programs
131that use VTK to do 3D visualisation.
132
133%description devel -l pl.UTF-8
134Ten pakiet dostarcza pliki nagłówkowe VTK do kompilowania programów
135C++ używających VTK do wizualizacji 3D.
136
137%package qt
138Summary: Qt bindings and Qt Designer plugin for VTK
139Summary(pl.UTF-8): Wiązania Qt oraz wtyczka Qt Designera do VTK
140Group: X11/Libraries
141Requires: %{name} = %{version}-%{release}
142Requires: QtCore >= 4.5.0
143Requires: QtGui >= 4.5.0
144Requires: QtNetwork >= 4.5.0
145Requires: QtOpenGL >= 4.5.0
146Requires: QtSql >= 4.5.0
147Requires: QtWebKit >= 4.5.0
148
149%description qt
150Qt bindings and Qt Designer plugin for VTK.
151
152%description qt -l pl.UTF-8
153Wiązania Qt oraz wtyczka Qt Designera do VTK.
154
155%package qt-devel
156Summary: Header files for VTK Qt bindings
157Summary(pl.UTF-8): Pliki nagłówkowe wiązań Qt do VTK
158Group: X11/Development/Libraries
159Requires: %{name}-devel = %{version}-%{release}
160Requires: %{name}-qt = %{version}-%{release}
161Requires: QtCore-devel >= 4.5.0
162Requires: QtGui-devel >= 4.5.0
163Requires: QtOpenGL-devel >= 4.5.0
164Requires: QtSql-devel >= 4.5.0
165
166%description qt-devel
167Header files for VTK Qt bindings.
168
169%description qt-devel -l pl.UTF-8
170Pliki nagłówkowe wiązań Qt do VTK.
171
172%package java
173Summary: Java bindings for VTK
174Summary(pl.UTF-8): Wiązania Javy do VTK
175Group: Development/Languages/Java
176Requires: %{name} = %{version}-%{release}
177# or separate qt parts?
178Requires: %{name}-qt = %{version}-%{release}
179
180%description java
181This package contains Java bindings for VTK.
182
183%description java -l pl.UTF-8
184Ten pakiet zawiera wiązania Javy do VTK.
185
186%package java-devel
187Summary: Header files for Java VTK binding
188Summary(pl.UTF-8): Pliki nagłówkowe wiązania Javy do VTK
189Group: Development/Libraries
190Requires: %{name}-devel = %{version}-%{release}
191Requires: %{name}-java = %{version}-%{release}
192# <jni.h>
193Requires: jdk
194
195%description java-devel
196Header files for Java VTK binding.
197
198%description java-devel -l pl.UTF-8
199Pliki nagłówkowe wiązania Javy do VTK.
200
201%package python
202Summary: Python bindings for VTK
203Summary(pl.UTF-8): Wiązania Pythona do VTK
204Group: Libraries
205Requires: %{name} = %{version}-%{release}
206# or separate qt parts again?
207Requires: %{name}-qt = %{version}-%{release}
208Obsoletes: vtk-python-qt < 6.0.0-1
209Obsoletes: vtk-python-sip < 6.0.0-1
210
211%description python
212This package contains Python bindings for VTK.
213
214%description python -l pl.UTF-8
215Ten pakiet zawiera wiązania Pythona do VTK.
216
217%package python-devel
218Summary: Header files for Python VTK binding
219Summary(pl.UTF-8): Pliki nagłówkowe wiązania Pythona do VTK
220Group: Development/Libraries
221Requires: %{name}-devel = %{version}-%{release}
222Requires: %{name}-python = %{version}-%{release}
223Requires: python-devel
224
225%description python-devel
226Header files for Python VTK binding.
227
228%description python-devel -l pl.UTF-8
229Pliki nagłówkowe wiązania Pythona do VTK.
230
231%package tcl
232Summary: Tcl bindings for VTK
233Summary(pl.UTF-8): Wiązania języka Tcl do VTK
234Group: Libraries
235Requires: %{name} = %{version}-%{release}
236# or separate qt parts?
237Requires: %{name}-qt = %{version}-%{release}
238
239%description tcl
240This package contains Tcl bindings for VTK.
241
242%description tcl -l pl.UTF-8
243Ten pakiet zawiera wiązania języka Tcl do VTK.
244
245%package tcl-devel
246Summary: Header files for Tcl VTK bindings
247Summary(pl.UTF-8): Pliki nagłówkowe wiązania języka Tcl do VTK
248Group: Development/Libraries
249Requires: %{name}-devel = %{version}-%{release}
250Requires: %{name}-tcl = %{version}-%{release}
251Requires: tcl-devel
252Requires: tk-devel
253
254%description tcl-devel
255Header files for Tcl VTK bindings.
256
257%description tcl-devel -l pl.UTF-8
258Pliki nagłówkowe wiązania języka Tcl do VTK.
259
260%package examples
261Summary: C++, Tcl and Python example programs/scripts for VTK
262Summary(pl.UTF-8): Przykładowe programy/skrypty w C++, Tcl-u i Pythonie dla VTK
263Group: Development/Libraries
264Requires: %{name} = %{version}-%{release}
265Requires: %{name}-data = %{version}-%{release}
266
267%description examples
268This package contains all the examples from the VTK source. To compile
269the C++ examples you will need to install the vtk-devel package as
270well. The Python and Tcl examples can be run with the corresponding
271packages (vtk-python, vtk-tcl).
272
273%description examples -l pl.UTF-8
274Ten pakiet zawiera wszystkie przykłady ze źródeł VTK. Do skompilowania
275przykładów w C++ trzeba doinstalować pakiet vtk-devel. Przykłady w
276Pythonie i Tcl-u można uruchamiać przy użyciu odpowiednich pakietów
277(vtk-python, vtk-tcl).
278
279%package test-suite
280Summary: Test programs for VTK
281Summary(pl.UTF-8): Programy testowe dla VTK
282Group: Development/Libraries
283Requires: %{name} = %{version}-%{release}
284Requires: %{name}-data = %{version}-%{release}
285
286%description test-suite
287This package contains all testing programs from the VTK source. The
288source code of these programs can be found in the vtk-examples
289package.
290
291%description test-suite -l pl.UTF-8
292Ten pakiet zawiera wszystkie programy testowe ze źródeł VTK. Kod
293źródłowy tych programów można znaleźć w pakiecie vtk-examples.
294
295%package data
296Summary: Data files for VTK
297Summary(pl.UTF-8): Pliki danych dla VTK
298Group: Development/Libraries
299%if "%{_rpmversion}" >= "5"
300BuildArch: noarch
301%endif
302
303%description data
304This package contains all the data from the VTKData repository. These
305data are required to run various examples from the vtk-examples
306package.
307
308%description data -l pl.UTF-8
309Ten pakiet zawiera wszystkie dane z repozytorium VTKData. Dane te są
310potrzebne do uruchamiania różnych przykładów z pakietu vtk-examples.
311
312%prep
313%setup -q -n VTK-%{version} -b 1
314%patch0 -p1
315%patch1 -p1
316
317# Replace relative path ../../../VTKData with destination filesystem path
318grep -Erl '(\.\./)+VTKData' Examples | xargs \
319 perl -pi -e 's,(\.\./)+VTKData,%{_datadir}/vtk-6.3,g'
320
321# Save an unbuilt copy of the Example's sources for %doc
322mkdir vtk-examples
323cp -a Examples vtk-examples
324# Don't ship Win32 examples
325%{__rm} -r vtk-examples/Examples/GUI/Win32
326find vtk-examples -type f | xargs chmod -R a-x
327
328%build
329export CFLAGS="%{rpmcflags} -D_UNICODE"
330export CXXFLAGS="%{rpmcxxflags} -D_UNICODE"
331%if %{with java}
332export JAVA_HOME=%{java_home}
333%endif
334
335mkdir -p build
336cd build
337%cmake .. \
338 -Wno-dev \
339 -DBUILD_DOCUMENTATION:BOOL=ON \
340 -DBUILD_EXAMPLES:BOOL=ON \
341 -DBUILD_SHARED_LIBS:BOOL=ON \
342 -DBUILD_TESTING:BOOL=ON \
343 -DCMAKE_C_COMPILER:PATH="%{__cc}" \
344 -DCMAKE_CXX_COMPILER:PATH="%{__cxx}" \
345 -DCMAKE_SKIP_RPATH:BOOL=ON \
346 -DOPENGL_INCLUDE_PATH:PATH=%{_includedir}/GL \
347 -DPYTHON_INCLUDE_PATH:PATH=%{py_incdir} \
348 -DPYTHON_LIBRARY:FILEPATH=%{_libdir}/libpython%{py_ver}.so \
349 -DPYTHON_UTIL_LIBRARY:PATH=%{_libdir}/libutil.so \
350 -DTCL_INCLUDE_PATH:PATH=%{_includedir} \
351 -DTCL_LIBRARY:PATH=%{_libdir}/libtcl.so \
352 -DTK_INCLUDE_PATH:PATH=%{_includedir} \
353 -DTK_LIBRARY:PATH=%{_libdir}/libtk.so \
354 -DVTK_DATA_ROOT:PATH=%{_datadir}/vtk-6.3 \
355 -DVTK_CUSTOM_LIBRARY_SUFFIX="" \
356 -DVTK_INSTALL_ARCHIVE_DIR:PATH=%{_lib}/vtk \
357 -DVTK_INSTALL_INCLUDE_DIR:PATH=include/vtk \
358 -DVTK_INSTALL_LIBRARY_DIR:PATH=%{_lib}/vtk \
359 -DVTK_INSTALL_PACKAGE_DIR:PATH=%{_lib}/cmake/vtk \
360 -DVTK_INSTALL_TCL_DIR:PATH=share/tcl%{tcl_version}/vtk \
361 -DVTK_INSTALL_PYTHON_MODULE_DIR:PATH=%{py_sitedir} \
362 -DVTK_INSTALL_QT_DIR=/%{_lib}/qt4/plugins/designer \
363 -DVTK_FFMPEG_HAS_OLD_HEADER:BOOL=OFF \
364 %{?with_OSMesa:-DVTK_OPENGL_HAS_OSMESA:BOOL=ON} \
365 -DVTK_WRAP_PYTHON:BOOL=ON \
366 -DVTK_PYTHON_SETUP_ARGS="--prefix=/usr --root=$RPM_BUILD_ROOT" \
367 -DVTK_USE_SYSTEM_LIBRARIES:BOOL=ON \
368 -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
369 -DVTK_USE_RENDERING:BOOL=ON \
370 -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
371 -DVTK_USE_SYSTEM_XDMF2:BOOL=OFF \
372 %{!?with_system_proj:-DVTK_USE_SYSTEM_LIBPROJ4:BOOL=OFF} \
373%if %{with java}
374 -DVTK_WRAP_JAVA:BOOL=ON \
375 -DJAVA_INCLUDE_PATH:PATH=$JAVA_HOME/include \
376 -DJAVA_INCLUDE_PATH2:PATH=$JAVA_HOME/include/linux \
377 -DJAVA_AWT_INCLUDE_PATH:PATH=$JAVA_HOME/include \
378%else
379 -DVTK_WRAP_JAVA:BOOL=OFF \
380%endif
381 -DVTK_WRAP_PYTHON:BOOL=ON \
382 %{?with_sip:-DVTK_WRAP_PYTHON_SIP:BOOL=ON} \
383 -DVTK_WRAP_TCL:BOOL=ON \
384 -DVTK_Group_Imaging:BOOL=ON \
385 -DVTK_Group_Qt:BOOL=ON \
386 -DVTK_Group_Rendering:BOOL=ON \
387 -DVTK_Group_StandAlone:BOOL=ON \
388 -DVTK_Group_Tk:BOOL=ON \
389 -DVTK_Group_Views:BOOL=ON \
390 -DModule_vtkFiltersReebGraph:BOOL=ON \
391 -DModule_vtkFiltersStatisticsGnuR:BOOL=ON \
392 %{?with_ffmpeg:-DModule_vtkIOFFMPEG:BOOL=ON} \
393 -DModule_vtkIOGDAL:BOOL=ON \
394 -DModule_vtkIOGeoJSON:BOOL=ON \
395 -DModule_vtkIOMySQL:BOOL=ON \
396 -DModule_vtkIOODBC:BOOL=ON \
397 -DModule_vtkIOParallelExodus:BOOL=ON \
398 -DModule_vtkIOParallelLSDyna:BOOL=ON \
399 -DModule_vtkIOPostgreSQL:BOOL=ON \
400 -DModule_vtkIOVPIC:BOOL=ON \
401 -DModule_vtkIOXdmf2:BOOL=ON \
402 -DModule_vtkInfovisBoost:BOOL=ON \
403 -DModule_vtkInfovisBoostGraphAlgorithms:BOOL=ON \
404 -DModule_vtkRenderingFreeTypeFontConfig:BOOL=ON \
405 -DModule_vtkRenderingMatplotlib:BOOL=ON \
406 -DModule_vtkRenderingParallel:BOOL=ON
407# TODO: -DModule_vtkAcceleratorsDax:BOOL=ON (BR: FindDax.cmake, maybe http://www.daxtoolkit.org/ ?)
408# TODO: -DModule_vtkAcceleratorsPiston:BOOL=ON (on bcond, BR: CUDA)
409# TODO: -DModule_vtkFiltersParallelFlowPaths:BOOL=ON (BR: MPI)
410# TODO: -DModule_vtkFiltersParallelStatistics:BOOL=ON (BR: MPI)
411# TODO: -DModule_vtkInfovisParallel:BOOL=ON (BR: MPI)
412# TODO: -DModule_vtkRenderingParallelLIC:BOOL=ON (BR: MPI)
413
414%{__make}
415
416%install
417rm -rf $RPM_BUILD_ROOT
418install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ld.so.conf.d,%{_examplesdir}/%{name}-%{version}}
419
420%{__make} -C build install \
421 DESTDIR=$RPM_BUILD_ROOT
422
423# ld config
424echo %{_libdir}/vtk > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
425
426for f in $(cd build/ExternalData/Testing ; find Data -type l); do
427 install -Dp build/ExternalData/Testing/$f $RPM_BUILD_ROOT%{_datadir}/vtk-6.3/$f
428done
429
430# Install utilities
431install build/bin/lproj $RPM_BUILD_ROOT%{_bindir}
432
433# Install examples
434for f in \
435AmbientSpheres \
436Arrays \
437BalloonWidget \
438BandedContours \
439Cone \
440Cone2 \
441Cone3 \
442Cone4 \
443Cone5 \
444Cone6 \
445Cube \
446Cylinder \
447Delaunay3D \
448Delaunay3DAlpha \
449DiffuseSpheres \
450DumpXMLFile \
451FilledContours \
452FixedPointVolumeRayCastMapperCT \
453GPURenderDemo \
454Generate2DAMRDataSetWithPulse \
455Generate3DAMRDataSetWithPulse \
456GenerateCubesFromLabels \
457GenerateModelsFromLabels \
458HierarchicalBoxPipeline \
459ImageDataLIC2DDemo \
460ImageSlicing \
461LabeledMesh \
462Medical1 \
463Medical2 \
464Medical3 \
465Medical4 \
466MultiBlock \
467ParticleReader \
468RGrid \
469SGrid \
470SimpleView \
471Slider \
472Slider2D \
473SpecularSpheres \
474StructuredGridLIC2DDemo \
475SurfaceLICDemo \
476TimeRenderer \
477TimeRenderer2 \
478TubesWithVaryingRadiusAndColors \
479finance ; do
480 install build/bin/$f $RPM_BUILD_ROOT%{_bindir}
481done
482
483# Install test binaries
484for f in build/bin/*Tests build/bin/Test* build/bin/VTKBenchMark ; do
485 install $f $RPM_BUILD_ROOT%{_bindir}
486done
487
488install build/bin/VTKJavaExecutable $RPM_BUILD_ROOT%{_bindir}
489install build/bin/vtkpython $RPM_BUILD_ROOT%{_bindir}
490
491# unwanted doxygen files and misplaced verdict docs
492%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vtk-6.3/{doxygen,verdict}
493
494# only *.pyc are built by default, add *.pyo
495%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/vtk
496%py_postclean
497
498%clean
499rm -rf $RPM_BUILD_ROOT
500
501%post -p /sbin/ldconfig
502%postun -p /sbin/ldconfig
503
504%post qt -p /sbin/ldconfig
505%postun qt -p /sbin/ldconfig
506
507%post java -p /sbin/ldconfig
508%postun java -p /sbin/ldconfig
509
510%post python -p /sbin/ldconfig
511%postun python -p /sbin/ldconfig
512
513%post tcl -p /sbin/ldconfig
514%postun tcl -p /sbin/ldconfig
515
516%files
517%defattr(644,root,root,755)
518%doc README.md vtkLogo.jpg vtkBanner.gif Wrapping/Tools/README*
519%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf.d/vtk-%{_arch}.conf
520%dir %{_libdir}/vtk
521%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so.1
522%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so.1
523%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so.1
524%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so.1
525%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so.1
526%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so.1
527%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so.1
528%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so.1
529%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so.1
530%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so.1
531%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so.1
532%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so.1
533%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so.1
534%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so.1
535%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL.so.1
536%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so.1
537%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so.1
538%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so.1
539%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so.1
540%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so.1
541%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so.1
542%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so.1
543%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so.1
544%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so.1
545%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so.1
546%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so.1
547%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so.1
548%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so.1
549%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so.1
550%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so.1
551%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so.1
552%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so.1
553%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so.1
554%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so.1
555%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so.1
556%attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so.1
557%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so.1
558%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so.1
559%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so.1
560%attr(755,root,root) %{_libdir}/vtk/libvtksys.so.1
561%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so.1
562%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so.1
563%exclude %{_libdir}/vtk/libvtk*Java.so.1
564%exclude %{_libdir}/vtk/libvtk*Python2?D.so.1
565%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
566%exclude %{_libdir}/vtk/libvtk*TCL.so.1
567
568%files devel
569%defattr(644,root,root,755)
570%doc Utilities/Upgrading/*
571%attr(755,root,root) %{_bindir}/lproj
572%attr(755,root,root) %{_bindir}/vtkEncodeString
573%attr(755,root,root) %{_bindir}/vtkHashSource
574%attr(755,root,root) %{_bindir}/vtkParseOGLExt
575%attr(755,root,root) %{_bindir}/vtkWrapHierarchy
576%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCore.so
577%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*.so
578%attr(755,root,root) %{_libdir}/vtk/libvtkDICOMParser.so
579%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistry.so
580%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*.so
581%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCore.so
582%attr(755,root,root) %{_libdir}/vtk/libvtkIO*.so
583%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*.so
584%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*.so
585%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*.so
586%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExample.so
587%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCore.so
588%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingAnnotation.so
589%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContext2D.so
590%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingContextOpenGL.so
591%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingCore.so
592%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeType.so
593%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingFreeTypeFontConfig.so
594%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingGL2PS.so
595%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingImage.so
596%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLIC.so
597%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLOD.so
598%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingLabel.so
599%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingOpenGL.so
600%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingParallel.so
601%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolume.so
602%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingVolumeOpenGL.so
603%attr(755,root,root) %{_libdir}/vtk/libvtkTesting*.so
604%attr(755,root,root) %{_libdir}/vtk/libvtkVPIC.so
605%attr(755,root,root) %{_libdir}/vtk/libvtkViewsContext2D.so
606%attr(755,root,root) %{_libdir}/vtk/libvtkViewsCore.so
607%attr(755,root,root) %{_libdir}/vtk/libvtkViewsGeovis.so
608%attr(755,root,root) %{_libdir}/vtk/libvtkViewsInfovis.so
609%attr(755,root,root) %{_libdir}/vtk/libvtkalglib.so
610%attr(755,root,root) %{_libdir}/vtk/libvtkexoIIc.so
611%attr(755,root,root) %{_libdir}/vtk/libvtkftgl.so
612%attr(755,root,root) %{_libdir}/vtk/libvtkmetaio.so
613%attr(755,root,root) %{_libdir}/vtk/libvtkproj4.so
614%attr(755,root,root) %{_libdir}/vtk/libvtksqlite.so
615%attr(755,root,root) %{_libdir}/vtk/libvtksys.so
616%attr(755,root,root) %{_libdir}/vtk/libvtkverdict.so
617%attr(755,root,root) %{_libdir}/vtk/libvtkxdmf2.so
618%exclude %{_libdir}/vtk/libvtk*Java.so
619%exclude %{_libdir}/vtk/libvtk*Python2?D.so
620%exclude %{_libdir}/vtk/libvtkWrappingPython2?Core.so
621%exclude %{_libdir}/vtk/libvtk*TCL.so
622%{_libdir}/vtk/libvtkWrappingTools.a
623%dir %{_includedir}/vtk
624%{_includedir}/vtk/VPIC
625%{_includedir}/vtk/DICOM*.h
626%{_includedir}/vtk/DatabaseSchemaWith2Tables.h
627%{_includedir}/vtk/alglib
628%{_includedir}/vtk/vtklibproj4
629%{_includedir}/vtk/vtkmetaio
630%{_includedir}/vtk/vtkverdict
631%{_includedir}/vtk/vtksqlite
632%{_includedir}/vtk/vtksys
633%{_includedir}/vtk/vtkxdmf2
634%{_includedir}/vtk/vtk*.h
635%{_includedir}/vtk/vtk*.txx
636%exclude %{_includedir}/vtk/vtkEventQtSlotConnect.h
637%exclude %{_includedir}/vtk/vtkGUISupportQt*.h
638%exclude %{_includedir}/vtk/vtkJavaUtil.h
639%exclude %{_includedir}/vtk/vtkWrappingJavaModule.h
640%exclude %{_includedir}/vtk/vtkPython*.h
641%exclude %{_includedir}/vtk/vtkQImageToImageSource.h
642%exclude %{_includedir}/vtk/vtkQt*.h
643%exclude %{_includedir}/vtk/vtkRenderingQtModule.h
644%exclude %{_includedir}/vtk/vtkTcl*.h
645%exclude %{_includedir}/vtk/vtkTk*.h
646%exclude %{_includedir}/vtk/vtkViewsQtModule.h
647%{_libdir}/cmake/vtk
648
649%files qt
650%defattr(644,root,root,755)
651%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so.1
652%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so.1
653%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so.1
654%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so.1
655%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so.1
656%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so.1
657%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libQVTKWidgetPlugin.so
658
659%files qt-devel
660%defattr(644,root,root,755)
661%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQt.so
662%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtOpenGL.so
663%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtSQL.so
664%attr(755,root,root) %{_libdir}/vtk/libvtkGUISupportQtWebkit.so
665%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingQt.so
666%attr(755,root,root) %{_libdir}/vtk/libvtkViewsQt.so
667%{_includedir}/vtk/QFilterTreeProxyModel.h
668%{_includedir}/vtk/QVTK*.h
669%{_includedir}/vtk/vtkEventQtSlotConnect.h
670%{_includedir}/vtk/vtkGUISupportQt*.h
671%{_includedir}/vtk/vtkQImageToImageSource.h
672%{_includedir}/vtk/vtkQt*.h
673%{_includedir}/vtk/vtkRenderingQtModule.h
674%{_includedir}/vtk/vtkViewsQtModule.h
675
676%if %{with java}
677%files java
678%defattr(644,root,root,755)
679%attr(755,root,root) %{_bindir}/VTKJavaExecutable
680%attr(755,root,root) %{_bindir}/vtkParseJava
681%attr(755,root,root) %{_bindir}/vtkWrapJava
682# common library
683%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so.1
684# java modules
685%attr(755,root,root) %{_libdir}/vtk/libvtkChartsCoreJava.so
686%attr(755,root,root) %{_libdir}/vtk/libvtkCommon*Java.so
687%attr(755,root,root) %{_libdir}/vtk/libvtkDomainsChemistryJava.so
688%attr(755,root,root) %{_libdir}/vtk/libvtkFilters*Java.so
689%attr(755,root,root) %{_libdir}/vtk/libvtkGeovisCoreJava.so
690%attr(755,root,root) %{_libdir}/vtk/libvtkIO*Java.so
691%attr(755,root,root) %{_libdir}/vtk/libvtkImaging*Java.so
692%attr(755,root,root) %{_libdir}/vtk/libvtkInfovis*Java.so
693%attr(755,root,root) %{_libdir}/vtk/libvtkInteraction*Java.so
694%attr(755,root,root) %{_libdir}/vtk/libvtkLocalExampleJava.so
695%attr(755,root,root) %{_libdir}/vtk/libvtkParallelCoreJava.so
696%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreterJava.so
697%attr(755,root,root) %{_libdir}/vtk/libvtkRendering*Java.so
698%attr(755,root,root) %{_libdir}/vtk/libvtkTestingRenderingJava.so
699%attr(755,root,root) %{_libdir}/vtk/libvtkViews*Java.so
700%{_libdir}/vtk/vtk.jar
701
702%files java-devel
703%defattr(644,root,root,755)
704%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingJava.so
705%{_includedir}/vtk/vtkJavaUtil.h
706%{_includedir}/vtk/vtkWrappingJavaModule.h
707%endif
708
709%files python
710%defattr(644,root,root,755)
711%doc Wrapping/Python/README*
712%attr(755,root,root) %{_bindir}/vtkWrapPython
713%attr(755,root,root) %{_bindir}/vtkWrapPythonInit
714%attr(755,root,root) %{_bindir}/vtkpython
715%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so.1
716%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so.1
717# RenderingMatplotlib requires PythonInterpreter
718%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so.1
719%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingPythonTkWidgets-6.3.so
720%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so.1
721%dir %{py_sitedir}/vtk
722%{py_sitedir}/vtk/*.py[co]
723%dir %{py_sitedir}/vtk/gtk
724%{py_sitedir}/vtk/gtk/*.py[co]
725%dir %{py_sitedir}/vtk/qt4
726%{py_sitedir}/vtk/qt4/*.py[co]
727%dir %{py_sitedir}/vtk/test
728%{py_sitedir}/vtk/test/*.py[co]
729%dir %{py_sitedir}/vtk/tk
730%{py_sitedir}/vtk/tk/*.py[co]
731%dir %{py_sitedir}/vtk/util
732%{py_sitedir}/vtk/util/*.py[co]
733%dir %{py_sitedir}/vtk/wx
734%{py_sitedir}/vtk/wx/*.py[co]
735%attr(755,root,root) %{py_sitedir}/vtk/vtk*Python.so
736
737%files python-devel
738%defattr(644,root,root,755)
739%attr(755,root,root) %{_libdir}/vtk/libvtk*Python2?D.so
740%attr(755,root,root) %{_libdir}/vtk/libvtkPythonInterpreter.so
741%attr(755,root,root) %{_libdir}/vtk/libvtkRenderingMatplotlib.so
742%attr(755,root,root) %{_libdir}/vtk/libvtkWrappingPython2?Core.so
743%{_includedir}/vtk/PyVTK*.h
744%{_includedir}/vtk/vtkPython*.h
745
746%files tcl
747%defattr(644,root,root,755)
748%doc Wrapping/Tcl/README*
749%attr(755,root,root) %{_bindir}/vtkWrapTcl
750%attr(755,root,root) %{_bindir}/vtkWrapTclInit
751%attr(755,root,root) %{_bindir}/vtk
752%{_datadir}/tcl%{tcl_version}/vtk
753%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so.1
754
755%files tcl-devel
756%defattr(644,root,root,755)
757%attr(755,root,root) %{_libdir}/vtk/libvtk*TCL.so
758%{_includedir}/vtk/vtkTcl*.h
759%{_includedir}/vtk/vtkTk*.h
760
761%files test-suite
762%defattr(644,root,root,755)
763%attr(755,root,root) %{_bindir}/*Tests
764%attr(755,root,root) %{_bindir}/Test*
765%attr(755,root,root) %{_bindir}/VTKBenchMark
766
767%files examples
768%defattr(644,root,root,755)
769%attr(755,root,root) %{_bindir}/AmbientSpheres
770%attr(755,root,root) %{_bindir}/Arrays
771%attr(755,root,root) %{_bindir}/Cone
772%attr(755,root,root) %{_bindir}/Cone2
773%attr(755,root,root) %{_bindir}/Cone3
774%attr(755,root,root) %{_bindir}/Cone4
775%attr(755,root,root) %{_bindir}/Cone5
776%attr(755,root,root) %{_bindir}/Cone6
777%attr(755,root,root) %{_bindir}/Cube
778%attr(755,root,root) %{_bindir}/Cylinder
779%attr(755,root,root) %{_bindir}/DiffuseSpheres
780%attr(755,root,root) %{_bindir}/HierarchicalBoxPipeline
781%attr(755,root,root) %{_bindir}/Medical1
782%attr(755,root,root) %{_bindir}/Medical2
783%attr(755,root,root) %{_bindir}/Medical3
784%attr(755,root,root) %{_bindir}/Medical4
785%attr(755,root,root) %{_bindir}/MultiBlock
786%attr(755,root,root) %{_bindir}/RGrid
787%attr(755,root,root) %{_bindir}/SGrid
788%attr(755,root,root) %{_bindir}/SimpleView
789%attr(755,root,root) %{_bindir}/SpecularSpheres
790%attr(755,root,root) %{_bindir}/finance
791%attr(755,root,root) %{_bindir}/BalloonWidget
792%attr(755,root,root) %{_bindir}/BandedContours
793%attr(755,root,root) %{_bindir}/Delaunay3D
794%attr(755,root,root) %{_bindir}/Delaunay3DAlpha
795%attr(755,root,root) %{_bindir}/DumpXMLFile
796%attr(755,root,root) %{_bindir}/FilledContours
797%attr(755,root,root) %{_bindir}/FixedPointVolumeRayCastMapperCT
798%attr(755,root,root) %{_bindir}/GPURenderDemo
799%attr(755,root,root) %{_bindir}/Generate2DAMRDataSetWithPulse
800%attr(755,root,root) %{_bindir}/Generate3DAMRDataSetWithPulse
801%attr(755,root,root) %{_bindir}/GenerateCubesFromLabels
802%attr(755,root,root) %{_bindir}/GenerateModelsFromLabels
803%attr(755,root,root) %{_bindir}/ImageDataLIC2DDemo
804%attr(755,root,root) %{_bindir}/ImageSlicing
805%attr(755,root,root) %{_bindir}/LabeledMesh
806%attr(755,root,root) %{_bindir}/ParticleReader
807%attr(755,root,root) %{_bindir}/Slider
808%attr(755,root,root) %{_bindir}/Slider2D
809%attr(755,root,root) %{_bindir}/StructuredGridLIC2DDemo
810%attr(755,root,root) %{_bindir}/SurfaceLICDemo
811%attr(755,root,root) %{_bindir}/TimeRenderer
812%attr(755,root,root) %{_bindir}/TimeRenderer2
813%attr(755,root,root) %{_bindir}/TubesWithVaryingRadiusAndColors
814%{_examplesdir}/%{name}-%{version}
815
816%files data
817%defattr(644,root,root,755)
818%dir %{_datadir}/vtk-6.3
819%{_datadir}/vtk-6.3/Data
820%{_datadir}/vtk-6.3/vtkDomainsChemistry
This page took 0.098187 seconds and 4 git commands to generate.