]> git.pld-linux.org Git - packages/ufraw.git/blame_incremental - ufraw.spec
- added openmp patch (fix gcc 9+ OpenMP compatibility); release 12
[packages/ufraw.git] / ufraw.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without gimp # GIMP plugin
4%bcond_without openmp # OpenMP support
5#
6Summary: RAW photo loader
7Summary(pl.UTF-8): Narzędzie do wczytywania zdjęć w formacie RAW
8Name: ufraw
9Version: 0.22
10Release: 13
11License: GPL v2+
12Group: Applications/Graphics
13Source0: http://downloads.sourceforge.net/ufraw/%{name}-%{version}.tar.gz
14# Source0-md5: c30767cae2c44310f2a3d67d7a76f2c3
15Patch0: 05_fix_build_due_to_unsigned_char.patch
16Patch1: ufraw-find_green.patch
17Patch2: ufraw-lf-destroy.patch
18Patch3: ufraw-multipliers.patch
19Patch4: exiv2-0.27.patch
20Patch5: %{name}-include.patch
21Patch6: %{name}-openmp.patch
22URL: http://ufraw.sourceforge.net/
23BuildRequires: automake
24BuildRequires: bzip2-devel
25BuildRequires: cfitsio-devel
26BuildRequires: exiv2-devel >= 0.20
27%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
28BuildRequires: gettext-tools
29%{?with_gimp:BuildRequires: gimp-devel >= 2.6.0}
30BuildRequires: glib2-devel >= 1:2.12
31BuildRequires: gtk+2-devel >= 2:2.12
32BuildRequires: gtkimageview-devel >= 1.6
33BuildRequires: jasper-devel
34BuildRequires: lcms2-devel >= 2
35BuildRequires: lensfun-devel >= 0.2.5
36%{?with_openmp:BuildRequires: libgomp-devel}
37BuildRequires: libjpeg-devel
38BuildRequires: libpng-devel >= 1.2
39BuildRequires: libstdc++-devel
40BuildRequires: libtiff-devel >= 4
41BuildRequires: perl-tools-pod
42BuildRequires: pkgconfig >= 1:0.9.0
43BuildRequires: zlib-devel
44Requires(post,postun): desktop-file-utils
45Requires(post,postun): shared-mime-info >= 0.21
46Requires(post,preun): GConf2 >= 2.16.0
47Requires: exiv2-libs >= 0.20
48Requires: glib2 >= 1:2.12
49Requires: gtk+2 >= 1:2.12
50Requires: gtkimageview >= 1.6
51Requires: lcms2 >= 2
52Requires: lensfun >= 0.2.5
53Obsoletes: cinepaint-plugin-ufraw
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56%if %{with gimp}
57%define gimp_plugindir %(gimptool --gimpplugindir)/plug-ins
58%endif
59
60%description
61UFRaw is a utility to read and manipulate raw images from digital
62cameras. It can be used by itself or as a GIMP plug-in. It reads raw
63images using Dave Coffin's raw conversion utility DCRaw. And it
64supports basic color management using Little CMS, allowing the user to
65apply color profiles.
66
67%description -l pl.UTF-8
68UFRaw to narzędzie do czytania i przetwarzania zdjęć w formacie RAW
69różnych aparatów cyfrowych. Może być używane samodzielnie lub jako
70wtyczka programu GIMP. Zdjęcia w formacie RAW są wczytywane za pomocą
71programu DCRaw Dave'a Coffina. Użytkownik ma możliwość stosowania
72profili kolorów dzięki bibliotece Little CMS.
73
74%package batch
75Summary: RAW photo loader batch software
76Summary(pl.UTF-8): Program do wsadowego przetwarzania zdjęć w formacie RAW
77Group: Applications/Graphics
78Requires: exiv2 >= 0.20
79Requires: glib2 >= 1:2.12
80Requires: lcms2 >= 2
81Requires: lensfun >= 0.2.5
82
83%description batch
84RAW photo loader batch software.
85
86%description batch -l pl.UTF-8
87Program do wsadowego przetwarzania zdjęć w formacie RAW.
88
89%package -n gimp-plugin-ufraw
90Summary: RAW photo loader GIMP plugin
91Summary(pl.UTF-8): Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW
92Group: Applications/Graphics
93Requires: exiv2 >= 0.20
94Requires: gimp >= 2.6.0
95Requires: glib2 >= 1:2.12
96Requires: gtk+2 >= 1:2.12
97Requires: gtkimageview >= 1.6
98Requires: lcms2 >= 2
99Requires: lensfun >= 0.2.5
100
101%description -n gimp-plugin-ufraw
102RAW photo loader GIMP plugin.
103
104%description -n gimp-plugin-ufraw -l pl.UTF-8
105Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW.
106
107%prep
108%setup -q
109%patch0 -p1
110%patch1 -p1
111%patch2 -p1
112%patch3 -p1
113%patch4 -p1
114%patch5 -p1
115%patch6 -p1
116
117%build
118cp -f /usr/share/automake/mkinstalldirs .
119%configure \
120 --disable-silent-rules \
121 %{!?with_openmp:--disable-openmp} \
122 --enable-contrast \
123 --enable-dst-correction \
124 --enable-extras \
125 --enable-mime \
126 --with-gimp%{!?with_gimp:=no} \
127 --with-gtk
128
129%{__make}
130
131%install
132rm -rf $RPM_BUILD_ROOT
133install -d $RPM_BUILD_ROOT%{_desktopdir}
134
135%{__make} install \
136 DESTDIR=$RPM_BUILD_ROOT \
137 schemasdir=%{_sysconfdir}/gconf/schemas
138
139install ufraw.desktop $RPM_BUILD_ROOT%{_desktopdir}
140%{__rm} $RPM_BUILD_ROOT%{_bindir}/dcraw
141
142%find_lang %{name}
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post
148%gconf_schema_install ufraw.schemas
149%update_desktop_database_post
150
151%preun
152%gconf_schema_uninstall ufraw.schemas
153
154%postun
155%update_desktop_database_postun
156
157%files -f %{name}.lang
158%defattr(644,root,root,755)
159%doc README TODO
160%attr(755,root,root) %{_bindir}/nikon-curve
161%attr(755,root,root) %{_bindir}/ufraw
162%{_desktopdir}/ufraw.desktop
163%{_pixmapsdir}/ufraw.png
164%{_sysconfdir}/gconf/schemas/%{name}.schemas
165%{_datadir}/appdata/ufraw.appdata.xml
166%{_mandir}/man1/ufraw.1*
167
168%files batch
169%defattr(644,root,root,755)
170%attr(755,root,root) %{_bindir}/ufraw-batch
171
172%if %{with gimp}
173%files -n gimp-plugin-ufraw
174%defattr(644,root,root,755)
175%attr(755,root,root) %{gimp_plugindir}/ufraw-gimp
176%endif
This page took 0.091168 seconds and 4 git commands to generate.