]> git.pld-linux.org Git - packages/tora.git/blame_incremental - tora.spec
- fix building with qscintilla 2.11
[packages/tora.git] / tora.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with oracle # build with oracle support
4%bcond_with instantclient # build oracle support with oracle-instantclient
5
6Summary: A graphical toolkit for database developers and administrators
7Summary(pl.UTF-8): Zestaw graficznych narzędzi dla programistów i administratorów baz danych
8Name: tora
9Version: 2.1.3
10Release: 9
11License: GPL v2
12Group: Applications/Databases/Interfaces
13Source0: http://downloads.sourceforge.net/tora/%{name}-%{version}.tar.gz
14# Source0-md5: ea4a75a9daeaf58492413e3f7fe40293
15Source1: %{name}.desktop
16Patch0: %{name}-postgresql.patch
17Patch1: %{name}-gcc.patch
18Patch2: %{name}-build.patch
19Patch3: gethostname.patch
20Patch4: qscintilla.patch
21URL: http://tora.sourceforge.net/
22BuildRequires: QtCore-devel
23BuildRequires: QtGui-devel
24BuildRequires: QtNetwork-devel
25BuildRequires: QtSql-devel
26BuildRequires: QtXml-devel
27BuildRequires: cppunit-devel
28%{?with_instantclient:BuildRequires: oracle-instantclient-devel}
29BuildRequires: pcre-devel
30BuildRequires: postgresql-devel
31BuildRequires: qscintilla2-qt4-devel
32BuildRequires: qt4-build
33BuildRequires: qt4-linguist
34BuildRequires: texinfo
35BuildRequires: xorg-lib-libICE-devel
36Suggests: QtSql-pgsql
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%if %{with oracle}
40# ORACLE_HOME is required for oracle
41%define _preserve_env %_preserve_env_base ORACLE_HOME
42%endif
43
44%description
45TOra features a schema browser, SQL worksheet, PL/SQL editor and
46debugger, storage manager, rollback segment monitor, instance manager,
47and SQL output viewer. Via qt3 it can access PostgreSQL and MySQL
48directly. Any other database systems can be accessed via ODBC.
49
50%description -l pl.UTF-8
51TOra zawiera przeglądarkę schematów, arkusz roboczy SQL, edytor i
52debugger PL/SQL, zarządcę danych, monitor segmentów wycofań, zarządcę
53instancji i przeglądarkę wyjścia SQL. Poprzez qt3 może współpracować
54bezpośrednio z bazami PostgreSQL i MySQL. Inne systemy baz danych mogą
55być obsługiwane poprzez ODBC.
56
57%prep
58%setup -q
59%patch0 -p1
60%patch1 -p1
61%patch2 -p1
62%patch3 -p1
63%patch4 -p1
64
65rm -f src/moc_*
66
67%build
68%{__libtoolize}
69%{__aclocal} -I config/m4
70%{__autoconf}
71%{__automake}
72%configure \
73 --libdir=%{_datadir}/%{name} \
74 --with-qt-libraries=%{_libdir} \
75%if %{with oracle}
76 %if %{with instantclient}
77 --with-instant-client \
78 --with-oracle-includes=%{_includedir}/oracle/client \
79 --with-oracle-libraries=%{_libdir} \
80 %endif
81 --with-oracle
82%else
83 --without-oracle
84%endif
85
86%{__make}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
91%{__make} install \
92 DESTDIR=$RPM_BUILD_ROOT
93
94cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
95cp -p src/icons/tora.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
96cp -a src/templates $RPM_BUILD_ROOT%{_datadir}/%{name}
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/postshell
102-/usr/sbin/fix-info-dir -c %{_infodir}
103
104%postun -p /sbin/postshell
105-/usr/sbin/fix-info-dir -c %{_infodir}
106
107%files
108%defattr(644,root,root,755)
109%doc BUGS NEWS README TODO
110%attr(755,root,root) %{_bindir}/*
111%dir %{_datadir}/%{name}
112%{_datadir}/%{name}/help
113%{_datadir}/%{name}/templates
114%{_datadir}/%{name}/*.qm
115%{_desktopdir}/*.desktop
116%{_pixmapsdir}/*.xpm
117%{_infodir}/tora*
This page took 0.022503 seconds and 4 git commands to generate.