]> git.pld-linux.org Git - packages/systemd.git/blame_incremental - systemd.spec
- cleanup network compat services so they actually work as expected
[packages/systemd.git] / systemd.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without audit # without audit support
4%bcond_without cryptsetup # without cryptsetup support
5%bcond_without gtk # build gtk tools
6%bcond_without pam # PAM authentication support
7%bcond_without selinux # without SELinux support
8%bcond_without tcpd # libwrap (tcp_wrappers) support
9
10Summary: A System and Service Manager
11Summary(pl.UTF-8): systemd - zarządca systemu i usług dla Linuksa
12Name: systemd
13Version: 38
14Release: 9.4
15License: GPL v2+
16Group: Base
17Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
18# Source0-md5: 68c66dce5a28c0efd7c210af5d11efed
19Source1: %{name}-sysv-convert
20Source2: systemd_booted.c
21Source3: ifup@.service
22Source4: network-post.service
23Source5: network.service
24Patch0: target-pld.patch
25Patch1: config-pld.patch
26Patch2: shut-sysv-up.patch
27Patch3: virt-libvirt.patch
28Patch4: pld-sysv-network.patch
29URL: http://www.freedesktop.org/wiki/Software/systemd
30BuildRequires: acl-devel
31%{?with_audit:BuildRequires: audit-libs-devel}
32BuildRequires: autoconf >= 2.63
33BuildRequires: automake >= 1:1.11
34%{?with_cryptsetup:BuildRequires: cryptsetup-luks-devel}
35BuildRequires: dbus-devel >= 1.3.2
36BuildRequires: docbook-style-xsl
37%if %{with gtk}
38BuildRequires: glib2-devel >= 1:2.26.1
39BuildRequires: gtk+2-devel >= 2:2.24.0
40BuildRequires: libgee-devel
41BuildRequires: libnotify-devel >= 0.7.0
42%endif
43BuildRequires: gperf
44BuildRequires: intltool >= 0.40.0
45BuildRequires: libcap-devel
46%{?with_selinux:BuildRequires: libselinux-devel}
47BuildRequires: libtool >= 2:2.2
48%{?with_tcpd:BuildRequires: libwrap-devel}
49BuildRequires: libxslt-progs
50BuildRequires: m4
51%{?with_pam:BuildRequires: pam-devel}
52BuildRequires: pkgconfig >= 0.9.0
53BuildRequires: rpmbuild(macros) >= 1.527
54BuildRequires: udev-devel >= 172
55# not required for building from release (which contains *.c for *.vala)
56#BuildRequires: vala >= 0.10.0
57Requires: %{name}-libs = %{version}-%{release}
58Requires: %{name}-units = %{version}-%{release}
59Requires: SysVinit-tools
60Requires: agetty
61Requires: dbus >= 1.3.2
62Requires: dbus-systemd
63Requires: filesystem >= 4.0
64Requires: rc-scripts >= 0.4.5.1-7
65Requires: setup >= 2.8.0-2
66Requires: udev-core >= 1:172
67Requires: udev-systemd >= 1:172
68Requires: udev-libs >= 1:172
69Suggests: ConsoleKit-systemd
70Suggests: fsck >= 2.20
71# python modules required by systemd-analyze
72Suggests: python-dbus
73Suggests: python-modules
74Suggests: rsyslog-systemd
75Provides: udev-acl
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78%define _libexecdir %{_prefix}/lib
79
80%description
81systemd is a system and service manager for Linux, compatible with
82SysV and LSB init scripts. systemd provides aggressive parallelization
83capabilities, uses socket and D-Bus activation for starting services,
84offers on-demand starting of daemons, keeps track of processes using
85Linux cgroups, supports snapshotting and restoring of the system
86state, maintains mount and automount points and implements an
87elaborate transactional dependency-based service control logic. It can
88work as a drop-in replacement for sysvinit.
89
90%description -l pl.UTF-8
91systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
92skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
93paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
94oferuje uruchamianie usług na życzenie, monitoruje procesy używając
95linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
96(restore) stanu systemu, zarządza (auto)mount pointami oraz
97implementuje starannie opracowaną transakcjonalną, bazującą na
98zależnościach logikę kontroli usług. Może pracować jako zastępca dla
99sysvinit.
100
101%package init
102Summary: systemd /sbin/init and LSB/SysV compatibility symlinks
103Summary(pl.UTF-8): /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
104Group: Base
105Requires: systemd
106Provides: readahead = 1:1.5.7-3
107Provides: virtual(init-daemon)
108Obsoletes: SysVinit
109Obsoletes: readahead < 1:1.5.7-3
110Obsoletes: virtual(init-daemon)
111
112%description init
113Install this package when you are ready to final switch to systemd.
114
115%description init -l pl.UTF-8
116Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
117przejścia na systemd.
118
119%package units
120Summary: Configuration files, directories and installation tool for systemd
121Summary(pl.UTF-8): Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
122Group: Base
123Requires(post): coreutils
124Requires(post): gawk
125Requires: pkgconfig
126
127%description units
128Basic configuration files, directories and installation tool for the
129systemd system and service manager.
130
131This is common config, use %{_sysconfdir}/systemd/system to override.
132
133%description units -l pl.UTF-8
134Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
135zarządcy systemu i usług systemd.
136
137Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
138poprzez katalog %{_sysconfdir}/systemd/system.
139
140%package gtk
141Summary: Graphical frontend for systemd
142Summary(pl.UTF-8): Graficzny interfejs do systemd
143Group: Base
144Requires: %{name} = %{version}-%{release}
145Requires: polkit
146
147%description gtk
148Graphical front-end for systemd.
149
150%description gtk -l pl.UTF-8
151Graficzny interfejs do systemd.
152
153%package libs
154Summary: Shared systemd libraries
155Summary(pl.UTF-8): Biblioteki współdzielone systemd
156Group: Libraries
157
158%description libs
159Shared systemd libraries.
160
161%description libs -l pl.UTF-8
162Biblioteki współdzielone systemd.
163
164%package devel
165Summary: Header files for systemd libraries
166Summary(pl.UTF-8): Pliki nagłówkowe bibliotek systemd
167Group: Development/Libraries
168Requires: %{name}-libs = %{version}-%{release}
169
170%description devel
171Header files for systemd libraries.
172
173%description devel -l pl.UTF-8
174Pliki nagłówkowe bibliotek systemd.
175
176%package -n bash-completion-systemd
177Summary: bash-completion for systemd
178Summary(pl.UTF-8): Bashowe dopełnianie składni dla systemd
179Group: Applications/Shells
180Requires: %{name}
181Requires: bash-completion
182
183%description -n bash-completion-systemd
184bash-completion for systemd.
185
186%description -n bash-completion-systemd -l pl.UTF-8
187Bashowe dopełnianie składni dla systemd
188
189%prep
190%setup -q
191%patch0 -p1
192%patch1 -p1
193%patch2 -p1
194%patch3 -p1
195%patch4 -p1
196cp -p %{SOURCE2} src/systemd_booted.c
197
198%build
199%{__aclocal} -I m4
200%{__autoconf}
201%{__autoheader}
202%{__automake}
203%configure \
204 %{__enable_disable audit} \
205 %{__enable_disable cryptsetup libcryptsetup} \
206 %{__enable_disable gtk} \
207 %{__enable_disable pam} \
208 %{__enable_disable selinux} \
209 %{__enable_disable tcpd tcpwrap} \
210 --disable-silent-rules \
211 --disable-static \
212 --with-distro=pld \
213 --with-rootprefix= \
214 --with-rootlibdir=/%{_lib}
215
216%{__make}
217./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
218
219%install
220rm -rf $RPM_BUILD_ROOT
221
222%{__make} install \
223 DESTDIR=$RPM_BUILD_ROOT
224
225./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
226
227# Create SysV compatibility symlinks. systemctl/systemd are smart
228# enough to detect the way they were called
229install -d $RPM_BUILD_ROOT/sbin
230ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
231ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
232ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
233ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
234ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
235ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
236ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
237
238ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
239# disable random and console SYSV service
240ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/random.service
241ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/console.service
242
243# add static (non-NetworkManager) networking
244install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system/ifup@.service
245install %{SOURCE4} $RPM_BUILD_ROOT/lib/systemd/system/network-post.service
246install %{SOURCE5} $RPM_BUILD_ROOT/lib/systemd/system/network.service
247
248# All wants links are created at %post to make sure they are not owned
249# and hence overriden by rpm if the user deletes them (missingok?)
250%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
251
252# do not cover /media (system-specific removable mountpoints) for now
253# needs %post code to convert existing /media structure to tmpfiles
254%{__rm} $RPM_BUILD_ROOT/lib/systemd/system/local-fs.target.wants/media.mount
255# do not cover /var/run until packages need rpm-provided-only subdirectories
256%{__rm} $RPM_BUILD_ROOT/lib/systemd/system/local-fs.target.wants/var-run.mount
257
258# it is in rc-scripts pkg
259%{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
260
261# Make sure these directories are properly owned:
262# - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
263# - syslog _might_ be used by some syslog implementation (none for now),
264# - isn't dbus populated by dbus-systemd only (so to be moved there)?
265install -d $RPM_BUILD_ROOT/lib/systemd/system/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
266
267# Create new-style configuration files so that we can ghost-own them
268touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
269
270# Install SysV conversion tool for systemd
271install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
272
273install -d $RPM_BUILD_ROOT/var/log
274:> $RPM_BUILD_ROOT/var/log/btmp
275:> $RPM_BUILD_ROOT/var/log/wtmp
276
277%if %{without gtk}
278%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
279%endif
280
281%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
282%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
283%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
284
285%clean
286rm -rf $RPM_BUILD_ROOT
287
288%post
289/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
290/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
291
292%postun
293if [ $1 -ge 1 ]; then
294 /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
295fi
296
297%post libs -p /sbin/ldconfig
298%postun libs -p /sbin/ldconfig
299
300%post units
301if [ $1 -eq 1 ]; then
302 # Try to read default runlevel from the old inittab if it exists
303 runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
304 if [ -z "$runlevel" ] ; then
305 target="/lib/systemd/system/graphical.target"
306 else
307 target="/lib/systemd/system/runlevel$runlevel.target"
308 fi
309
310 # And symlink what we found to the new-style default.target
311 ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
312fi
313# Enable the services we install by default.
314/bin/systemctl enable \
315 getty@.service \
316 network.service \
317 network-post.service \
318 remote-fs.target \
319 systemd-readahead-replay.service \
320 systemd-readahead-collect.service >/dev/null 2>&1 || :
321
322# Find and enable all installed interfaces
323mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
324for f in /etc/sysconfig/interfaces/ifcfg-* ; do
325 ff=$(basename $f)
326 ff=${ff##ifcfg-}
327 case "$ff" in
328 *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
329 continue
330 ;;
331 *)
332 DEVICE="" ; ONBOOT="" ; USERS=""
333 . $f 2>/dev/null
334 [ ${USERS:-no} != no ] && continue
335 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
336 ln -s /lib/systemd/system/ifup@.service \
337 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
338 fi
339 ;;
340 esac
341done
342
343%preun units
344if [ $1 -eq 0 ] ; then
345 /bin/systemctl disable \
346 getty@.service \
347 network.service \
348 network-post.service \
349 remote-fs.target \
350 systemd-readahead-replay.service \
351 systemd-readahead-collect.service >/dev/null 2>&1 || :
352
353 %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
354 %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
355fi
356
357%postun units
358if [ $1 -ge 1 ]; then
359 /bin/systemctl daemon-reload > /dev/null 2>&1 || :
360fi
361
362%files
363%defattr(644,root,root,755)
364%doc DISTRO_PORTING README TODO
365/etc/dbus-1/system.d/org.freedesktop.hostname1.conf
366/etc/dbus-1/system.d/org.freedesktop.locale1.conf
367/etc/dbus-1/system.d/org.freedesktop.login1.conf
368/etc/dbus-1/system.d/org.freedesktop.systemd1.conf
369/etc/dbus-1/system.d/org.freedesktop.timedate1.conf
370%ghost %config(noreplace) %{_sysconfdir}/machine-id
371%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
372%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
373%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
374%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
375%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
376%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
377%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
378%dir %{_sysconfdir}/systemd/user
379/etc/xdg/systemd
380%attr(755,root,root) /bin/systemd
381%attr(755,root,root) /bin/systemd-ask-password
382%attr(755,root,root) /bin/systemd-journalctl
383%attr(755,root,root) /bin/systemd-loginctl
384%attr(755,root,root) /bin/systemd-machine-id-setup
385%attr(755,root,root) /bin/systemd-notify
386%attr(755,root,root) /bin/systemd-tty-ask-password-agent
387%attr(755,root,root) %{_bindir}/systemd-analyze
388%attr(755,root,root) %{_bindir}/systemd-cgls
389%attr(755,root,root) %{_bindir}/systemd-nspawn
390%attr(755,root,root) %{_bindir}/systemd-stdio-bridge
391%attr(755,root,root) %{_bindir}/systemd-sysv-convert
392%attr(755,root,root) /lib/systemd/systemd-*
393%dir /lib/systemd/system-generators
394%attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
395%dir /lib/systemd/system-shutdown
396/lib/udev/rules.d/99-systemd.rules
397/lib/udev/rules.d/70-uaccess.rules
398/lib/udev/rules.d/71-seat.rules
399/lib/udev/rules.d/73-seat-late.rules
400%dir %{_libexecdir}/systemd
401%{_libexecdir}/systemd/user
402%dir %{_libexecdir}/systemd/user-generators
403%config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
404%{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
405%{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
406%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
407%{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
408%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
409%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
410%{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
411%{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
412%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
413%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
414%{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
415%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
416%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
417%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
418%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
419%dir %{_datadir}/systemd
420%{_datadir}/systemd/kbd-model-map
421%{_mandir}/man1/systemd.1*
422%{_mandir}/man1/systemd-*.1*
423%{_mandir}/man3/sd_booted.3*
424%{_mandir}/man3/sd_is_fifo.3*
425%{_mandir}/man3/sd_is_socket.3
426%{_mandir}/man3/sd_is_socket_inet.3
427%{_mandir}/man3/sd_is_socket_unix.3
428%{_mandir}/man3/sd_listen_fds.3*
429%{_mandir}/man3/sd_notify.3*
430%{_mandir}/man3/sd_notifyf.3
431%{_mandir}/man3/sd_readahead.3*
432%{_mandir}/man5/binfmt.d.5*
433%{_mandir}/man5/hostname.5*
434%{_mandir}/man5/locale.conf.5*
435%{_mandir}/man5/machine-id.5*
436%{_mandir}/man5/machine-info.5*
437%{_mandir}/man5/modules-load.d.5*
438%{_mandir}/man5/os-release.5*
439%{_mandir}/man5/sysctl.d.5*
440%{_mandir}/man5/systemd.*.5*
441%{_mandir}/man5/systemd-logind.conf.5*
442%{_mandir}/man5/timezone.5*
443%{_mandir}/man5/vconsole.conf.5*
444%{_mandir}/man7/daemon.7*
445%{_mandir}/man7/sd-daemon.7*
446%{_mandir}/man7/sd-login.7*
447%{_mandir}/man7/sd-readahead.7*
448%{_mandir}/man7/systemd.special.7*
449%attr(640,root,root) %ghost /var/log/btmp
450%attr(664,root,utmp) %ghost /var/log/wtmp
451
452%if %{with pam}
453%attr(755,root,root) /%{_lib}/security/pam_systemd.so
454%{_mandir}/man8/pam_systemd.8*
455%endif
456
457%files init
458%defattr(644,root,root,755)
459%attr(755,root,root) /sbin/halt
460%attr(755,root,root) /sbin/init
461%attr(755,root,root) /sbin/poweroff
462%attr(755,root,root) /sbin/reboot
463%attr(755,root,root) /sbin/runlevel
464%attr(755,root,root) /sbin/shutdown
465%attr(755,root,root) /sbin/telinit
466%{_mandir}/man1/init.1
467%{_mandir}/man8/halt.8*
468%{_mandir}/man8/poweroff.8
469%{_mandir}/man8/reboot.8
470%{_mandir}/man8/runlevel.8*
471%{_mandir}/man8/shutdown.8*
472%{_mandir}/man8/telinit.8*
473
474%files units
475%defattr(644,root,root,755)
476%dir %{_sysconfdir}/binfmt.d
477%dir %{_sysconfdir}/modules-load.d
478%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
479%dir %{_sysconfdir}/sysctl.d
480%dir %{_sysconfdir}/systemd
481%dir %{_sysconfdir}/systemd/system
482%dir %{_sysconfdir}/tmpfiles.d
483%dir %{_libexecdir}/binfmt.d
484%dir %{_libexecdir}/modules-load.d
485%dir %{_libexecdir}/sysctl.d
486%attr(755,root,root) /bin/systemctl
487%attr(755,root,root) /bin/systemd-tmpfiles
488%attr(755,root,root) /bin/systemd_booted
489%{_mandir}/man1/systemctl.1*
490%{_mandir}/man5/tmpfiles.d.5*
491%{_mandir}/man8/systemd-tmpfiles.8*
492%{_npkgconfigdir}/systemd.pc
493
494/lib/systemd/system/*.automount
495/lib/systemd/system/*.mount
496/lib/systemd/system/*.path
497/lib/systemd/system/*.service
498/lib/systemd/system/*.socket
499/lib/systemd/system/*.target
500/lib/systemd/system/*.timer
501%dir /lib/systemd/system/*.wants
502%config(noreplace,missingok) /lib/systemd/system/*.wants/*
503
504%if %{with gtk}
505%files gtk
506%defattr(644,root,root,755)
507%attr(755,root,root) %{_bindir}/systemadm
508%attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
509%{_mandir}/man1/systemadm.1*
510%endif
511
512%files libs
513%defattr(644,root,root,755)
514%attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
515%attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
516%attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
517%attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
518%attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
519%attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
520%attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
521%attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
522
523%files devel
524%defattr(644,root,root,755)
525%attr(755,root,root) %{_libdir}/libsystemd-daemon.so
526%attr(755,root,root) %{_libdir}/libsystemd-id128.so
527%attr(755,root,root) %{_libdir}/libsystemd-journal.so
528%attr(755,root,root) %{_libdir}/libsystemd-login.so
529%{_includedir}/%{name}
530%{_pkgconfigdir}/libsystemd-daemon.pc
531%{_pkgconfigdir}/libsystemd-id128.pc
532%{_pkgconfigdir}/libsystemd-journal.pc
533%{_pkgconfigdir}/libsystemd-login.pc
534%{_mandir}/man3/sd_get_seats.3*
535%{_mandir}/man3/sd_get_sessions.3*
536%{_mandir}/man3/sd_get_uids.3*
537%{_mandir}/man3/sd_is_mq.3*
538%{_mandir}/man3/sd_login_monitor_flush.3*
539%{_mandir}/man3/sd_login_monitor_get_fd.3*
540%{_mandir}/man3/sd_login_monitor_new.3*
541%{_mandir}/man3/sd_login_monitor_unref.3*
542%{_mandir}/man3/sd_pid_get_owner_uid.3*
543%{_mandir}/man3/sd_pid_get_session.3*
544%{_mandir}/man3/sd_pid_get_unit.3*
545%{_mandir}/man3/sd_seat_can_multi_session.3*
546%{_mandir}/man3/sd_seat_get_active.3*
547%{_mandir}/man3/sd_seat_get_sessions.3*
548%{_mandir}/man3/sd_session_get_seat.3*
549%{_mandir}/man3/sd_session_get_uid.3*
550%{_mandir}/man3/sd_session_is_active.3*
551%{_mandir}/man3/sd_uid_get_seats.3*
552%{_mandir}/man3/sd_uid_get_sessions.3*
553%{_mandir}/man3/sd_uid_get_state.3*
554%{_mandir}/man3/sd_uid_is_on_seat.3*
555
556%files -n bash-completion-systemd
557%defattr(644,root,root,755)
558/etc/bash_completion.d/systemd-bash-completion.sh
This page took 0.03125 seconds and 4 git commands to generate.