]> git.pld-linux.org Git - packages/subversion.git/blame_incremental - subversion.spec
- updated to 1.5.3
[packages/subversion.git] / subversion.spec
... / ...
CommitLineData
1# TODO:
2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4# - finish ruby
5#
6# Conditional build:
7%bcond_with net_client_only # build only net client
8%bcond_without neon # use serf instead of neon
9%bcond_without python # build without python bindings (broken)
10%bcond_without perl # build without perl bindings
11%bcond_without ruby # build without ruby bindings
12%bcond_without apache # build without apache support (webdav, etc)
13%bcond_without javahl # build without javahl support (Java high-level bindings)
14%bcond_without tests # don't perform "make check"
15#
16%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
17%undefine with_javahl
18%endif
19#
20%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
21%define apxs /usr/sbin/apxs
22%define pdir SVN
23%define pnam _Core
24#
25%if %{with neon}
26%define webdavlib neon
27%else
28%define webdavlib serf
29%endif
30#
31Summary: A Concurrent Versioning system similar to but better than CVS
32Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
33Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
34Name: subversion
35Version: 1.5.3
36Release: 1
37License: Apache/BSD-like
38Group: Development/Version Control
39Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
40# Source0-md5: b6e1e1398fe650dfa9a4b52d23c92707
41Source1: %{name}-dav_svn.conf
42Source2: %{name}-authz_svn.conf
43Source3: %{name}-svnserve.init
44Source4: %{name}-svnserve.sysconfig
45# current subversion tarball has correct *.swg files
46# but after regeneration these are broken again, so
47# we still need this script
48Source5: %{name}-convert-typemaps-to-ifdef.py
49Patch0: %{name}-home_etc.patch
50Patch1: %{name}-DESTDIR.patch
51Patch2: %{name}-ruby-datadir-path.patch
52URL: http://subversion.tigris.org/
53%if %{with net_client_only}
54%global apache_modules_api 0
55%else
56%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
57BuildRequires: automake
58BuildRequires: db-devel >= 4.1.25
59BuildRequires: rpmbuild(macros) >= 1.268
60%if %{with perl}
61BuildRequires: perl-devel >= 1:5.8.0
62BuildRequires: rpm-perlprov >= 4.1-13
63BuildRequires: swig-perl >= 1.3.24
64%endif
65%{?with_javahl:BuildRequires: jdk}
66%endif
67BuildRequires: apr-devel >= 1:1.0.0
68BuildRequires: apr-util-devel >= 1:1.2.8-3
69BuildRequires: autoconf >= 2.59
70BuildRequires: bison
71BuildRequires: cyrus-sasl-devel
72BuildRequires: expat-devel
73BuildRequires: gettext-devel
74BuildRequires: libtool >= 1.4-9
75BuildRequires: sed >= 4.0
76BuildRequires: texinfo
77BuildRequires: which
78%if %{with neon}
79BuildRequires: neon-devel >= 0.26.0
80%else
81BuildRequires: serf-devel
82%endif
83BuildRequires: python >= 2.2
84BuildRequires: python-modules >= 2.2
85%if %{with python}
86BuildRequires: python-devel >= 2.2
87BuildRequires: swig-python >= 1.3.24
88%endif
89%if %{with ruby}
90BuildRequires: ruby-devel
91BuildRequires: swig-ruby >= 1.3.24
92%endif
93Requires: %{name}-libs = %{version}-%{release}
94BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96%define _libexecdir %{_libdir}/svn
97%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
98%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
99
100%description
101The goal of the Subversion project is to build a version control
102system that is a compelling replacement for CVS in the open source
103community.
104
105Our goals are:
106- All current CVS features.
107- Directories, renames, and file meta-data are versioned.
108- Symbolic links, etc, are supported
109- Commits are truly atomic.
110- Branching and tagging are cheap (constant time) operations
111- Repeated merges are handled gracefully
112- Support for plug-in client side diff programs
113- Natively client/server
114- Client/server protocol sends diffs in both directions
115- Costs are proportional to change size, not project size
116- Internationalization
117- Progressive multi-lingual support
118
119%description -l pl.UTF-8
120Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
121zamiennika dla CVS.
122
123Cele projektu to:
124- Wszystkie aktualne możliwości CVS.
125- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
126- Obsługa dowiązań symbolicznych itp.
127- Commity są w pełni atomowe.
128- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
129- Dobra obsługa powtarzanego łączenia (merge).
130- Obsługa wtyczek diff po stronie klienta.
131- Natywny klient/serwer.
132- Klient/Serwer przesyłają diffy w obu kierunkach.
133- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
134- Internacjonalizacja.
135- Postępujące wsparcie dla wielu języków.
136
137%description -l pt_BR.UTF-8
138O objetivo do projeto Subversion é construir um sistema de controle de
139versões que seja um substituto para o CVS (Concurrent Versioning
140System) na comunidade opensource, fornecendo grandes melhorias.
141
142%package libs
143Summary: Subversion libraries and modules
144Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
145Group: Libraries
146%{?with_neon:Requires: neon >= 0.26.0}
147Obsoletes: libsubversion0
148
149%description libs
150Subversion libraries and modules.
151
152%description libs -l pl.UTF-8
153Biblioteka subversion oraz ładowalne moduły.
154
155%package devel
156Summary: Header files and develpment documentation for subversion
157Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
158Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
159Group: Development/Libraries
160Requires: %{name}-libs = %{version}-%{release}
161Requires: apr-util-devel >= 1:1.0.0
162%{?with_neon:Requires: neon-devel >= 0.26.0}
163Obsoletes: libsubversion0-devel
164
165%description devel
166Header files and develpment documentation for subversion.
167
168%description devel -l pl.UTF-8
169Pliki nagłówkowe i dokumetacja do subversion.
170
171%description devel -l pt_BR.UTF-8
172Este pacote provê os arquivos necessários para desenvolvedores
173interagirem com o Subversion.
174
175%package static
176Summary: Static subversion library
177Summary(pl.UTF-8): Biblioteka statyczna subversion
178Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
179Group: Development/Libraries
180Requires: %{name}-devel = %{version}
181Obsoletes: libsubversion0-static-devel
182
183%description static
184Static subversion library.
185
186%description static -l pl.UTF-8
187Biblioteka statyczna subversion.
188
189%description static -l pt_BR.UTF-8
190Este pacote provê um cliente estático do subversion.
191
192%package svnserve
193Summary: Subversion svnserve
194Summary(pl.UTF-8): Subversion svnserve
195Group: Networking/Daemons
196Requires(post,preun): /sbin/chkconfig
197Requires(postun): /usr/sbin/groupdel
198Requires(postun): /usr/sbin/userdel
199Requires(pre): /bin/id
200Requires(pre): /usr/bin/getgid
201Requires(pre): /usr/lib/rpm/user_group.sh
202Requires(pre): /usr/sbin/groupadd
203Requires(pre): /usr/sbin/useradd
204Requires(pre): /usr/sbin/usermod
205Requires: %{name} = %{version}-%{release}
206Requires: rc-scripts
207Provides: group(svn)
208Provides: user(svn)
209
210%description svnserve
211Subversion svnserve server.
212
213%description svnserve -l pl.UTF-8
214Serwer subversion svnserve.
215
216%package tools
217Summary: Subversion tools and scripts
218Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
219Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
220Group: Applications
221%pyrequires_eq python
222Requires: %{name} = %{version}-%{release}
223Requires: python-rcsparse >= 0.1-0.20031026.0
224Requires: python-subversion = %{version}
225
226%description tools
227Subversion tools and scripts.
228
229%description tools -l pl.UTF-8
230Narzędzia oraz skrypty dla subversion.
231
232%package -n bash-completion-subversion
233Summary: bash completion for subversion
234Summary(pl.UTF-8): Dopełnienia basha dla subversion
235Group: Applications/Shells
236Requires: %{name} = %{version}-%{release}
237Requires: bash-completion
238Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
239
240%description -n bash-completion-subversion
241Bash completion for subversion.
242
243%description -n bash-completion-subversion -l pl.UTF-8
244Dopełnienia basha dla subversion.
245
246%package -n java-subversion
247Summary: Subversion Java bindings
248Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
249Group: Development/Languages/Java
250Requires: %{name}-libs = %{version}-%{release}
251
252%description -n java-subversion
253This is a set of Java classes which provide the functionality of
254subversion-libs, the Subversion libraries. It is useful if you want
255to, for example, write a Java class that manipulates a Subversion
256repository or working copy. See the 'subversion' package for more
257information.
258
259%description -n java-subversion -l pl.UTF-8
260Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
261subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
262pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
263roboczą. Więcej informacji w pakiecie subversion.
264
265%package -n python-subversion
266Summary: Subversion Python bindings
267Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
268Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
269Group: Development/Languages/Python
270%pyrequires_eq python
271Requires: %{name}-libs = %{version}-%{release}
272Obsoletes: subversion-python
273
274%description -n python-subversion
275Subversion Python bindings.
276
277%description -n python-subversion -l pl.UTF-8
278Dowiązania do Subversion dla Pythona.
279
280%description -n python-subversion -l pt_BR.UTF-8
281Módulos Python para acessar os recursos do Subversion.
282
283%package -n perl-subversion
284Summary: Subversion Perl bindings
285Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
286Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
287Group: Development/Languages/Perl
288Requires: %{name}-libs = %{version}-%{release}
289Obsoletes: subversion-perl
290
291%description -n perl-subversion
292Subversion Perl bindings.
293
294%description -n perl-subversion -l pl.UTF-8
295Dowiązania do Subversion dla Perla.
296
297%description -n perl-subversion -l pt_BR.UTF-8
298Módulos Perl para acessar os recursos do Subversion.
299
300%package -n ruby-subversion
301Summary: Subversion Ruby bindings
302Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
303Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
304Group: Development/Languages
305Requires: %{name}-libs = %{version}-%{release}
306Obsoletes: subversion-ruby
307
308%description -n ruby-subversion
309Subversion Ruby bindings.
310
311%description -n ruby-subversion -l pl.UTF-8
312Dowiązania do Subversion dla języka Ruby.
313
314%description -n ruby-subversion -l pt_BR.UTF-8
315Módulos Ruby para acessar os recursos do Subversion.
316
317%package -n apache-mod_dav_svn
318Summary: Apache module: Subversion Server
319Summary(pl.UTF-8): Moduł apache: Serwer Subversion
320Group: Networking/Daemons
321Requires: %{name} = %{version}-%{release}
322Requires: apache(modules-api) = %apache_modules_api
323Requires: apache-mod_dav
324
325%description -n apache-mod_dav_svn
326Apache module: Subversion Server.
327
328%description -n apache-mod_dav_svn -l pl.UTF-8
329Moduł apache: Serwer Subversion.
330
331%package -n apache-mod_authz_svn
332Summary: Apache module: Subversion Server - path-based authorization
333Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
334Group: Networking/Daemons
335Requires: apache(modules-api) = %apache_modules_api
336Requires: apache-mod_dav_svn = %{version}-%{release}
337
338%description -n apache-mod_authz_svn
339Apache module: Subversion Server - path-based authorization.
340
341%description -n apache-mod_authz_svn -l pl.UTF-8
342Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
343
344%prep
345%setup -q
346rm -rf apr apr-util neon
347%patch0 -p0
348%patch1 -p1
349%patch2 -p0
350
351sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
352
353# serf.m4 macro is broken and ignores --without serf
354%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
355
356%build
357rm subversion/bindings/swig/proxy/*.swg
358cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
359cp -f /usr/share/automake/config.sub ac-helpers
360chmod +x ./autogen.sh && ./autogen.sh
361
362%configure \
363 --with-editor=vi \
364 --with-zlib=%{_libdir} \
365%if %{with net_client_only}
366 --without-apache \
367 --without-swig \
368 --without-apxs \
369 --without-berkeley-db \
370%else
371 --disable-runtime-module-search \
372 --disable-mod-activation \
373%if %{with apache}
374 --with-apxs=%{_sbindir}/apxs \
375%else
376 --without-apache \
377 --without-apxs \
378 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
379%endif
380%if !%{with python} && !%{with perl} && !%{with ruby}
381 --without-swig \
382%endif
383 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
384%endif
385 --with-jdk="%{java_home}" \
386%if %{with neon}
387 --without-serf \
388 --with-neon=%{_prefix} \
389 --disable-neon-version-check \
390%else
391 --with-serf=%{_prefix} \
392 --without-neon \
393%endif
394 --with-apr=%{_bindir}/apr-1-config \
395 --with-apr-util=%{_bindir}/apu-1-config
396
397%{__make} -j1
398
399%if !%{with net_client_only}
400# python
401%if %{with python}
402%{__make} swig-py \
403 swig_pydir=%{py_sitedir}/libsvn \
404 swig_pydir_extra=%{py_sitedir}/svn
405%endif
406# perl
407%if %{with perl}
408%{__make} swig-pl-lib
409odir=$(pwd)
410cd subversion/bindings/swig/perl/native
411%{__perl} Makefile.PL INSTALLDIRS=vendor
412%{__make} -j1
413cd $odir
414%endif
415%if %{with javahl}
416%{__make} -j1 javahl \
417 javahl_javadir="%{_javadir}"
418%endif
419# ruby
420%if %{with ruby}
421%{__make} swig-rb
422%endif
423%endif
424
425%if %{with tests}
426%{__make} check
427%if %{with python}
428%{__make} check-swig-py
429%endif
430%if %{with perl}
431%{__make} check-swig-pl
432%endif
433%if %{with ruby}
434%{__make} check-swig-rb
435%endif
436%endif
437
438%install
439rm -rf $RPM_BUILD_ROOT
440install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
441 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
442 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
443 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
444
445%{__make} install -j1 \
446%if %{with javahl}
447 install-javahl \
448 javahl_javadir="%{_javadir}" \
449%endif
450%if !%{with net_client_only}
451%if %{with python}
452 install-swig-py \
453%endif
454%if %{with ruby}
455 install-swig-rb install-swig-rb-doc \
456%endif
457%endif
458 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
459 DESTDIR=$RPM_BUILD_ROOT \
460 swig_pydir=%{py_sitedir}/libsvn \
461 swig_pydir_extra=%{py_sitedir}/svn
462
463%if !%{with net_client_only} && %{with perl}
464%{__make} install-swig-pl-lib \
465 DESTDIR=$RPM_BUILD_ROOT
466%{__make} -C subversion/bindings/swig/perl/native install \
467 DESTDIR=$RPM_BUILD_ROOT \
468 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
469 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
470%endif
471
472%if %{with apache}
473install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
474install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
475install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
476install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
477%endif
478
479%if !%{with net_client_only}
480install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
481%if %{with python}
482%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
483%py_comp $RPM_BUILD_ROOT%{py_sitedir}
484find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
485install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
486%endif
487%endif
488
489install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
490install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
491
492%find_lang %{name}
493
494rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
495rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
496
497%clean
498rm -rf $RPM_BUILD_ROOT
499
500%pre svnserve
501%groupadd -g 86 svn
502%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
503
504%post libs -p /sbin/ldconfig
505%postun libs -p /sbin/ldconfig
506
507%post devel -p /sbin/postshell
508-/usr/sbin/fix-info-dir -c %{_infodir}
509
510%postun devel -p /sbin/postshell
511-/usr/sbin/fix-info-dir -c %{_infodir}
512
513%post -n perl-subversion -p /sbin/ldconfig
514%postun -n perl-subversion -p /sbin/ldconfig
515
516%post -n python-subversion -p /sbin/ldconfig
517%postun -n python-subversion -p /sbin/ldconfig
518
519%post svnserve
520/sbin/chkconfig --add svnserve
521%service svnserve restart "svnserve daemon"
522
523%preun svnserve
524if [ "$1" = "0" ]; then
525 %service svnserve stop
526 /sbin/chkconfig --del svnserve
527fi
528
529%postun svnserve
530if [ "$1" = "0" ]; then
531 %userremove svn
532 %groupremove svn
533fi
534
535%post -n apache-mod_dav_svn
536%service -q httpd restart
537
538%preun -n apache-mod_dav_svn
539if [ "$1" = "0" ]; then
540 %service -q httpd restart
541fi
542
543%files
544%defattr(644,root,root,755)
545%doc BUGS CHANGES COPYING INSTALL README
546%doc doc/*/*.html
547%doc tools/hook-scripts/*.{pl,py,example}
548%doc tools/hook-scripts/mailer/*.{py,example}
549%doc tools/xslt/*
550%attr(755,root,root) %{_bindir}/svn
551%attr(755,root,root) %{_bindir}/svnadmin
552%attr(755,root,root) %{_bindir}/svndumpfilter
553%attr(755,root,root) %{_bindir}/svnlook
554%attr(755,root,root) %{_bindir}/svnsync
555%attr(755,root,root) %{_bindir}/svnversion
556%{_mandir}/man1/svn.1*
557%{_mandir}/man1/svnadmin.1*
558%{_mandir}/man1/svndumpfilter.1*
559%{_mandir}/man1/svnlook.1*
560%{_mandir}/man1/svnsync.1*
561%{_mandir}/man1/svnversion.1*
562
563%files libs -f %{name}.lang
564%defattr(644,root,root,755)
565%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
566%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
567%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
568%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
569%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
570%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
571%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
572%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
573%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
574%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
575%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
576%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
577%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
578%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
579%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
580%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
581%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
582%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
583%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
584%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
585%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
586%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
587%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
588%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
589%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
590%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
591%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
592%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
593
594%files devel
595%defattr(644,root,root,755)
596%attr(755,root,root) %{_libdir}/libsvn_client-1.so
597%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
598%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
599%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
600%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
601%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
602%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
603%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
604%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
605%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
606%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
607%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
608%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
609%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
610%{_libdir}/libsvn_client-1.la
611%{_libdir}/libsvn_delta-1.la
612%{_libdir}/libsvn_diff-1.la
613%{_libdir}/libsvn_fs-1.la
614%{_libdir}/libsvn_fs_base-1.la
615%{_libdir}/libsvn_fs_fs-1.la
616%{_libdir}/libsvn_fs_util-1.la
617%{_libdir}/libsvn_ra-1.la
618%{_libdir}/libsvn_ra_local-1.la
619%{_libdir}/libsvn_ra_%{webdavlib}-1.la
620%{_libdir}/libsvn_ra_svn-1.la
621%{_libdir}/libsvn_repos-1.la
622%{_libdir}/libsvn_subr-1.la
623%{_libdir}/libsvn_wc-1.la
624%{_includedir}/%{name}-1
625%{_examplesdir}/%{name}-%{version}
626
627%files static
628%defattr(644,root,root,755)
629%{_libdir}/libsvn_client-1.a
630%{_libdir}/libsvn_delta-1.a
631%{_libdir}/libsvn_diff-1.a
632%{_libdir}/libsvn_fs-1.a
633%{_libdir}/libsvn_fs_base-1.a
634%{_libdir}/libsvn_fs_fs-1.a
635%{_libdir}/libsvn_fs_util-1.a
636%{_libdir}/libsvn_ra-1.a
637%{_libdir}/libsvn_ra_local-1.a
638%{_libdir}/libsvn_ra_%{webdavlib}-1.a
639%{_libdir}/libsvn_ra_svn-1.a
640%{_libdir}/libsvn_repos-1.a
641%{_libdir}/libsvn_subr-1.a
642%{_libdir}/libsvn_wc-1.a
643
644%if !%{with net_client_only}
645%files svnserve
646%defattr(644,root,root,755)
647%attr(755,root,root) %{_bindir}/svnserve
648%{_mandir}/man5/svnserve.conf.5*
649%{_mandir}/man8/svnserve.8*
650%dir %attr(750,svn,svn) /home/services/subversion
651%dir %attr(750,svn,svn) /home/services/subversion/repos
652%if %{with apache}
653%attr(754,root,root) /etc/rc.d/init.d/svnserve
654%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
655%endif
656
657%files tools
658%defattr(644,root,root,755)
659%attr(755,root,root) %{_bindir}/svn-hot-backup
660
661%files -n bash-completion-subversion
662%defattr(644,root,root,755)
663/etc/bash_completion.d/%{name}
664
665%if %{with javahl}
666%files -n java-subversion
667%defattr(644,root,root,755)
668%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
669%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
670%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
671%{_javadir}/svn-javahl.jar
672%endif
673
674%if %{with python}
675%files -n python-subversion
676%defattr(644,root,root,755)
677%doc tools/backup/*.py tools/examples/*.py
678%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
679%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
680%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
681%dir %{py_sitedir}/libsvn
682%{py_sitedir}/libsvn/*.py[co]
683%dir %{py_sitedir}/svn
684%{py_sitedir}/svn/*.py[co]
685%attr(755,root,root) %{py_sitedir}/libsvn/*.so
686%{_examplesdir}/python-%{name}-%{version}
687%endif
688
689%if %{with perl}
690%files -n perl-subversion
691%defattr(644,root,root,755)
692%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
693%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
694%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
695%{perl_vendorarch}/SVN
696%dir %{perl_vendorarch}/auto/SVN
697%dir %{perl_vendorarch}/auto/SVN/*
698%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
699%{perl_vendorarch}/auto/SVN/*/*.bs
700%{_mandir}/man3/*.3pm*
701%endif
702
703%if %{with ruby}
704%files -n ruby-subversion
705%defattr(644,root,root,755)
706%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
707%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
708%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
709%dir %{_libdir}/ruby/site_ruby/svn
710%{_libdir}/ruby/site_ruby/svn/*.rb
711%dir %{_libdir}/ruby/site_ruby/svn/ext
712%attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
713%{_datadir}/ri/*.*/system/OptionParser
714%{_datadir}/ri/*.*/system/Svn
715%{_datadir}/ri/*.*/system/Time
716%{_datadir}/ri/*.*/system/Uconv
717%{_datadir}/ri/*.*/system/*.rid
718%{_datadir}/ri/*.*/system/Kernel/*
719%endif
720
721%if %{with apache}
722%files -n apache-mod_dav_svn
723%defattr(644,root,root,755)
724%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
725%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
726
727%files -n apache-mod_authz_svn
728%defattr(644,root,root,755)
729%doc subversion/mod_authz_svn/INSTALL
730%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
731%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
732%endif
733
734%endif # net_client_only
This page took 0.03529 seconds and 4 git commands to generate.