]> git.pld-linux.org Git - packages/subversion.git/blame_incremental - subversion.spec
- perl 5.10 workaround
[packages/subversion.git] / subversion.spec
... / ...
CommitLineData
1# TODO:
2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4# - finish ruby
5#
6# Conditional build:
7%bcond_with net_client_only # build only net client
8%bcond_with serf # use serf instead of neon
9%bcond_without python # build without python bindings (broken)
10%bcond_without perl # build without perl bindings
11%bcond_without ruby # build without ruby bindings
12%bcond_without apache # build without apache support (webdav, etc)
13%bcond_without javahl # build without javahl support (Java high-level bindings)
14%bcond_without tests # don't perform "make check"
15#
16%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
17%undefine with_javahl
18%endif
19#
20%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
21%define apxs /usr/sbin/apxs
22%define pdir SVN
23%define pnam _Core
24#
25Summary: A Concurrent Versioning system similar to but better than CVS
26Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
27Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
28Name: subversion
29Version: 1.5.1
30Release: 1
31License: Apache/BSD-like
32Group: Development/Version Control
33Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
34# Source0-md5: 8dbdaa625d6b18887702885df07fc87e
35Source1: %{name}-dav_svn.conf
36Source2: %{name}-authz_svn.conf
37Source3: %{name}-svnserve.init
38Source4: %{name}-svnserve.sysconfig
39Source5: %{name}-convert-typemaps-to-ifdef.py
40Patch0: %{name}-home_etc.patch
41Patch1: %{name}-DESTDIR.patch
42Patch2: %{name}-ruby-datadir-path.patch
43URL: http://subversion.tigris.org/
44%if %{with net_client_only}
45%global apache_modules_api 0
46%else
47%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
48BuildRequires: automake
49BuildRequires: db-devel >= 4.1.25
50BuildRequires: rpmbuild(macros) >= 1.268
51%if %{with perl}
52BuildRequires: perl-devel >= 1:5.8.0
53BuildRequires: rpm-perlprov >= 4.1-13
54BuildRequires: swig-perl >= 1.3.24
55%endif
56%{?with_javahl:BuildRequires: jdk}
57%endif
58BuildRequires: apr-devel >= 1:1.0.0
59BuildRequires: apr-util-devel >= 1:1.2.8-3
60BuildRequires: autoconf >= 2.59
61BuildRequires: bison
62BuildRequires: cyrus-sasl-devel
63BuildRequires: expat-devel
64BuildRequires: gettext-devel
65BuildRequires: libtool >= 1.4-9
66%if %{with serf}
67BuildRequires: serf-devel
68%else
69BuildRequires: neon-devel >= 0.26.0
70%endif
71BuildRequires: python >= 2.2
72BuildRequires: python-modules >= 2.2
73%if %{with python}
74BuildRequires: python-devel >= 2.2
75BuildRequires: sed >= 4.0
76BuildRequires: swig-python >= 1.3.24
77%endif
78%{?with_ruby:BuildRequires: ruby-devel}
79%{?with_ruby:BuildRequires: swig-ruby >= 1.3.24}
80BuildRequires: texinfo
81BuildRequires: which
82Requires: %{name}-libs = %{version}-%{release}
83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85%define _libexecdir %{_libdir}/svn
86%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
87%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
88
89%description
90The goal of the Subversion project is to build a version control
91system that is a compelling replacement for CVS in the open source
92community.
93
94Our goals are:
95- All current CVS features.
96- Directories, renames, and file meta-data are versioned.
97- Symbolic links, etc, are supported
98- Commits are truly atomic.
99- Branching and tagging are cheap (constant time) operations
100- Repeated merges are handled gracefully
101- Support for plug-in client side diff programs
102- Natively client/server
103- Client/server protocol sends diffs in both directions
104- Costs are proportional to change size, not project size
105- Internationalization
106- Progressive multi-lingual support
107
108%description -l pl.UTF-8
109Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
110zamiennika dla CVS.
111
112Cele projektu to:
113- Wszystkie aktualne możliwości CVS.
114- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
115- Obsługa dowiązań symbolicznych itp.
116- Commity są w pełni atomowe.
117- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
118- Dobra obsługa powtarzanego łączenia (merge).
119- Obsługa wtyczek diff po stronie klienta.
120- Natywny klient/serwer.
121- Klient/Serwer przesyłają diffy w obu kierunkach.
122- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
123- Internacjonalizacja.
124- Postępujące wsparcie dla wielu języków.
125
126%description -l pt_BR.UTF-8
127O objetivo do projeto Subversion é construir um sistema de controle de
128versões que seja um substituto para o CVS (Concurrent Versioning
129System) na comunidade opensource, fornecendo grandes melhorias.
130
131%package libs
132Summary: Subversion libraries and modules
133Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
134Group: Libraries
135%{!?with_serf:Requires: neon >= 0.26.0}
136Obsoletes: libsubversion0
137
138%description libs
139Subversion libraries and modules.
140
141%description libs -l pl.UTF-8
142Biblioteka subversion oraz ładowalne moduły.
143
144%package devel
145Summary: Header files and develpment documentation for subversion
146Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
147Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
148Group: Development/Libraries
149Requires: %{name}-libs = %{version}-%{release}
150Requires: apr-util-devel >= 1:1.0.0
151%{!?with_serf:Requires: neon-devel >= 0.26.0}
152Obsoletes: libsubversion0-devel
153
154%description devel
155Header files and develpment documentation for subversion.
156
157%description devel -l pl.UTF-8
158Pliki nagłówkowe i dokumetacja do subversion.
159
160%description devel -l pt_BR.UTF-8
161Este pacote provê os arquivos necessários para desenvolvedores
162interagirem com o Subversion.
163
164%package static
165Summary: Static subversion library
166Summary(pl.UTF-8): Biblioteka statyczna subversion
167Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
168Group: Development/Libraries
169Requires: %{name}-devel = %{version}
170Obsoletes: libsubversion0-static-devel
171
172%description static
173Static subversion library.
174
175%description static -l pl.UTF-8
176Biblioteka statyczna subversion.
177
178%description static -l pt_BR.UTF-8
179Este pacote provê um cliente estático do subversion.
180
181%package svnserve
182Summary: Subversion svnserve
183Summary(pl.UTF-8): Subversion svnserve
184Group: Networking/Daemons
185Requires(post,preun): /sbin/chkconfig
186Requires(postun): /usr/sbin/groupdel
187Requires(postun): /usr/sbin/userdel
188Requires(pre): /bin/id
189Requires(pre): /usr/bin/getgid
190Requires(pre): /usr/lib/rpm/user_group.sh
191Requires(pre): /usr/sbin/groupadd
192Requires(pre): /usr/sbin/useradd
193Requires(pre): /usr/sbin/usermod
194Requires: %{name} = %{version}-%{release}
195Requires: rc-scripts
196Provides: group(svn)
197Provides: user(svn)
198
199%description svnserve
200Subversion svnserve server.
201
202%description svnserve -l pl.UTF-8
203Serwer subversion svnserve.
204
205%package tools
206Summary: Subversion tools and scripts
207Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
208Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
209Group: Applications
210%pyrequires_eq python
211Requires: %{name} = %{version}-%{release}
212Requires: python-rcsparse >= 0.1-0.20031026.0
213Requires: python-subversion = %{version}
214
215%description tools
216Subversion tools and scripts.
217
218%description tools -l pl.UTF-8
219Narzędzia oraz skrypty dla subversion.
220
221%package -n bash-completion-subversion
222Summary: bash completion for subversion
223Summary(pl.UTF-8): Dopełnienia basha dla subversion
224Group: Applications/Shells
225Requires: %{name} = %{version}-%{release}
226Requires: bash-completion
227Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
228
229%description -n bash-completion-subversion
230Bash completion for subversion.
231
232%description -n bash-completion-subversion -l pl.UTF-8
233Dopełnienia basha dla subversion.
234
235%package -n java-subversion
236Summary: Subversion Java bindings
237Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
238Group: Development/Languages/Java
239Requires: %{name}-libs = %{version}-%{release}
240
241%description -n java-subversion
242This is a set of Java classes which provide the functionality of
243subversion-libs, the Subversion libraries. It is useful if you want
244to, for example, write a Java class that manipulates a Subversion
245repository or working copy. See the 'subversion' package for more
246information.
247
248%description -n java-subversion -l pl.UTF-8
249Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
250subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
251pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
252roboczą. Więcej informacji w pakiecie subversion.
253
254%package -n python-subversion
255Summary: Subversion Python bindings
256Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
257Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
258Group: Development/Languages/Python
259%pyrequires_eq python
260Requires: %{name}-libs = %{version}-%{release}
261Obsoletes: subversion-python
262
263%description -n python-subversion
264Subversion Python bindings.
265
266%description -n python-subversion -l pl.UTF-8
267Dowiązania do Subversion dla Pythona.
268
269%description -n python-subversion -l pt_BR.UTF-8
270Módulos Python para acessar os recursos do Subversion.
271
272%package -n perl-subversion
273Summary: Subversion Perl bindings
274Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
275Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
276Group: Development/Languages/Perl
277Requires: %{name}-libs = %{version}-%{release}
278Obsoletes: subversion-perl
279
280%description -n perl-subversion
281Subversion Perl bindings.
282
283%description -n perl-subversion -l pl.UTF-8
284Dowiązania do Subversion dla Perla.
285
286%description -n perl-subversion -l pt_BR.UTF-8
287Módulos Perl para acessar os recursos do Subversion.
288
289%package -n ruby-subversion
290Summary: Subversion Ruby bindings
291Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
292Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
293Group: Development/Languages
294Requires: %{name}-libs = %{version}-%{release}
295Obsoletes: subversion-ruby
296
297%description -n ruby-subversion
298Subversion Ruby bindings.
299
300%description -n ruby-subversion -l pl.UTF-8
301Dowiązania do Subversion dla języka Ruby.
302
303%description -n ruby-subversion -l pt_BR.UTF-8
304Módulos Ruby para acessar os recursos do Subversion.
305
306%package -n apache-mod_dav_svn
307Summary: Apache module: Subversion Server
308Summary(pl.UTF-8): Moduł apache: Serwer Subversion
309Group: Networking/Daemons
310Requires: %{name} = %{version}-%{release}
311Requires: apache(modules-api) = %apache_modules_api
312Requires: apache-mod_dav
313
314%description -n apache-mod_dav_svn
315Apache module: Subversion Server.
316
317%description -n apache-mod_dav_svn -l pl.UTF-8
318Moduł apache: Serwer Subversion.
319
320%package -n apache-mod_authz_svn
321Summary: Apache module: Subversion Server - path-based authorization
322Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
323Group: Networking/Daemons
324Requires: apache(modules-api) = %apache_modules_api
325Requires: apache-mod_dav_svn = %{version}-%{release}
326
327%description -n apache-mod_authz_svn
328Apache module: Subversion Server - path-based authorization.
329
330%description -n apache-mod_authz_svn -l pl.UTF-8
331Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
332
333%prep
334%setup -q
335rm -rf apr apr-util neon
336%patch0 -p0
337%patch1 -p1
338%patch2 -p0
339
340%build
341rm subversion/bindings/swig/proxy/*.swg
342cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
343cp -f /usr/share/automake/config.sub ac-helpers
344chmod +x ./autogen.sh && ./autogen.sh
345
346%configure \
347 --with-editor=vi \
348 --with-zlib=%{_libdir} \
349%if %{with net_client_only}
350 --without-apache \
351 --without-swig \
352 --without-apxs \
353 --without-berkeley-db \
354%else
355 --disable-runtime-module-search \
356 --disable-mod-activation \
357%if %{with apache}
358 --with-apxs=%{_sbindir}/apxs \
359%else
360 --without-apache \
361 --without-apxs \
362 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
363%endif
364%if !%{with python} && !%{with perl} && !%{with ruby}
365 --without-swig \
366%endif
367 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
368%endif
369 --with-jdk="%{java_home}" \
370%if %{with serf}
371 --with-serf=%{_prefix} \
372 --without-neon \
373%else
374 --without-serf \
375 --with-neon=%{_prefix} \
376 --disable-neon-version-check \
377%endif
378 --with-apr=%{_bindir}/apr-1-config \
379 --with-apr-util=%{_bindir}/apu-1-config
380
381%{__make} -j1
382
383%if !%{with net_client_only}
384# python
385%if %{with python}
386%{__make} swig-py \
387 swig_pydir=%{py_sitedir}/libsvn \
388 swig_pydir_extra=%{py_sitedir}/svn
389%endif
390# perl
391%if %{with perl}
392%{__make} swig-pl-lib
393odir=$(pwd)
394cd subversion/bindings/swig/perl/native
395%{__perl} Makefile.PL INSTALLDIRS=vendor
396%{__make} -j1
397cd $odir
398%endif
399%if %{with javahl}
400%{__make} -j1 javahl \
401 javahl_javadir="%{_javadir}"
402%endif
403# ruby
404%if %{with ruby}
405%{__make} swig-rb
406%endif
407%endif
408
409%if %{with tests}
410%{__make} check
411%if %{with python}
412%{__make} check-swig-py
413%endif
414%if %{with perl}
415%{__make} check-swig-pl
416%endif
417%if %{with ruby}
418%{__make} check-swig-rb
419%endif
420%endif
421
422%install
423rm -rf $RPM_BUILD_ROOT
424install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
425 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
426 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
427 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
428
429%{__make} install -j1 \
430%if %{with javahl}
431 install-javahl \
432 javahl_javadir="%{_javadir}" \
433%endif
434%if !%{with net_client_only}
435%if %{with python}
436 install-swig-py \
437%endif
438%if %{with ruby}
439 install-swig-rb install-swig-rb-doc \
440%endif
441%endif
442 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
443 DESTDIR=$RPM_BUILD_ROOT \
444 swig_pydir=%{py_sitedir}/libsvn \
445 swig_pydir_extra=%{py_sitedir}/svn
446
447%if !%{with net_client_only} && %{with perl}
448%{__make} install-swig-pl-lib \
449 DESTDIR=$RPM_BUILD_ROOT
450%{__make} -C subversion/bindings/swig/perl/native install \
451 DESTDIR=$RPM_BUILD_ROOT \
452 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
453 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
454%endif
455
456%if %{with apache}
457install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
458install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
459install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
460install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
461%endif
462
463%if !%{with net_client_only}
464install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
465%if %{with python}
466%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
467%py_comp $RPM_BUILD_ROOT%{py_sitedir}
468find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
469install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
470%endif
471%endif
472
473install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
474install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
475
476%find_lang %{name}
477
478rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
479rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
480
481%clean
482rm -rf $RPM_BUILD_ROOT
483
484%pre svnserve
485%groupadd -g 86 svn
486%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
487
488%post libs -p /sbin/ldconfig
489%postun libs -p /sbin/ldconfig
490
491%post devel -p /sbin/postshell
492-/usr/sbin/fix-info-dir -c %{_infodir}
493
494%postun devel -p /sbin/postshell
495-/usr/sbin/fix-info-dir -c %{_infodir}
496
497%post -n perl-subversion -p /sbin/ldconfig
498%postun -n perl-subversion -p /sbin/ldconfig
499
500%post -n python-subversion -p /sbin/ldconfig
501%postun -n python-subversion -p /sbin/ldconfig
502
503%post svnserve
504/sbin/chkconfig --add svnserve
505%service svnserve restart "svnserve daemon"
506
507%preun svnserve
508if [ "$1" = "0" ]; then
509 %service svnserve stop
510 /sbin/chkconfig --del svnserve
511fi
512
513%postun svnserve
514if [ "$1" = "0" ]; then
515 %userremove svn
516 %groupremove svn
517fi
518
519%post -n apache-mod_dav_svn
520%service -q httpd restart
521
522%preun -n apache-mod_dav_svn
523if [ "$1" = "0" ]; then
524 %service -q httpd restart
525fi
526
527%files
528%defattr(644,root,root,755)
529%doc BUGS CHANGES COPYING INSTALL README
530%doc doc/*/*.html
531%doc tools/hook-scripts/*.{pl,py,example}
532%doc tools/hook-scripts/mailer/*.{py,example}
533%doc tools/xslt/*
534%attr(755,root,root) %{_bindir}/svn
535%attr(755,root,root) %{_bindir}/svnadmin
536%attr(755,root,root) %{_bindir}/svndumpfilter
537%attr(755,root,root) %{_bindir}/svnlook
538%attr(755,root,root) %{_bindir}/svnsync
539%attr(755,root,root) %{_bindir}/svnversion
540%{_mandir}/man1/svn.1*
541%{_mandir}/man1/svnadmin.1*
542%{_mandir}/man1/svndumpfilter.1*
543%{_mandir}/man1/svnlook.1*
544%{_mandir}/man1/svnsync.1*
545%{_mandir}/man1/svnversion.1*
546
547%files libs -f %{name}.lang
548%defattr(644,root,root,755)
549%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
550%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
551%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
552%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
553%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
554%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
555%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
556%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
557%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
558%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
559%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
560%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
561%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
562%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
563%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
564%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
565%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
566%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
567%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
568%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
569%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
570%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
571%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
572%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
573%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
574%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
575%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
576%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
577
578%files devel
579%defattr(644,root,root,755)
580%attr(755,root,root) %{_libdir}/libsvn_client-1.so
581%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
582%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
583%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
584%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
585%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
586%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
587%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
588%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
589%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
590%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
591%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
592%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
593%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
594%{_libdir}/libsvn_client-1.la
595%{_libdir}/libsvn_delta-1.la
596%{_libdir}/libsvn_diff-1.la
597%{_libdir}/libsvn_fs-1.la
598%{_libdir}/libsvn_fs_base-1.la
599%{_libdir}/libsvn_fs_fs-1.la
600%{_libdir}/libsvn_fs_util-1.la
601%{_libdir}/libsvn_ra-1.la
602%{_libdir}/libsvn_ra_local-1.la
603%{_libdir}/libsvn_ra_neon-1.la
604%{_libdir}/libsvn_ra_svn-1.la
605%{_libdir}/libsvn_repos-1.la
606%{_libdir}/libsvn_subr-1.la
607%{_libdir}/libsvn_wc-1.la
608%{_includedir}/%{name}-1
609%{_examplesdir}/%{name}-%{version}
610
611%files static
612%defattr(644,root,root,755)
613%{_libdir}/libsvn_client-1.a
614%{_libdir}/libsvn_delta-1.a
615%{_libdir}/libsvn_diff-1.a
616%{_libdir}/libsvn_fs-1.a
617%{_libdir}/libsvn_fs_base-1.a
618%{_libdir}/libsvn_fs_fs-1.a
619%{_libdir}/libsvn_fs_util-1.a
620%{_libdir}/libsvn_ra-1.a
621%{_libdir}/libsvn_ra_local-1.a
622%{_libdir}/libsvn_ra_neon-1.a
623%{_libdir}/libsvn_ra_svn-1.a
624%{_libdir}/libsvn_repos-1.a
625%{_libdir}/libsvn_subr-1.a
626%{_libdir}/libsvn_wc-1.a
627
628%if !%{with net_client_only}
629%files svnserve
630%defattr(644,root,root,755)
631%attr(755,root,root) %{_bindir}/svnserve
632%{_mandir}/man5/svnserve.conf.5*
633%{_mandir}/man8/svnserve.8*
634%dir %attr(750,svn,svn) /home/services/subversion
635%dir %attr(750,svn,svn) /home/services/subversion/repos
636%if %{with apache}
637%attr(754,root,root) /etc/rc.d/init.d/svnserve
638%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
639%endif
640
641%files tools
642%defattr(644,root,root,755)
643%attr(755,root,root) %{_bindir}/svn-hot-backup
644
645%files -n bash-completion-subversion
646%defattr(644,root,root,755)
647/etc/bash_completion.d/%{name}
648
649%if %{with javahl}
650%files -n java-subversion
651%defattr(644,root,root,755)
652%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
653%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
654%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
655%{_javadir}/svn-javahl.jar
656%endif
657
658%if %{with python}
659%files -n python-subversion
660%defattr(644,root,root,755)
661%doc tools/backup/*.py tools/examples/*.py
662%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
663%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
664%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
665%dir %{py_sitedir}/libsvn
666%{py_sitedir}/libsvn/*.py[co]
667%dir %{py_sitedir}/svn
668%{py_sitedir}/svn/*.py[co]
669%attr(755,root,root) %{py_sitedir}/libsvn/*.so
670%{_examplesdir}/python-%{name}-%{version}
671%endif
672
673%if %{with perl}
674%files -n perl-subversion
675%defattr(644,root,root,755)
676%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
677%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
678%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
679%{perl_vendorarch}/SVN
680%dir %{perl_vendorarch}/auto/SVN
681%dir %{perl_vendorarch}/auto/SVN/*
682%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
683%{perl_vendorarch}/auto/SVN/*/*.bs
684%{_mandir}/man3/*.3pm*
685%endif
686
687%if %{with ruby}
688%files -n ruby-subversion
689%defattr(644,root,root,755)
690%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
691%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
692%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
693%dir %{_libdir}/ruby/site_ruby/svn
694%{_libdir}/ruby/site_ruby/svn/*.rb
695%dir %{_libdir}/ruby/site_ruby/svn/ext
696%attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
697%{_datadir}/ri/*.*/system/OptionParser
698%{_datadir}/ri/*.*/system/Svn
699%{_datadir}/ri/*.*/system/Time
700%{_datadir}/ri/*.*/system/Uconv
701%{_datadir}/ri/*.*/system/*.rid
702%{_datadir}/ri/*.*/system/Kernel/*
703%endif
704
705%if %{with apache}
706%files -n apache-mod_dav_svn
707%defattr(644,root,root,755)
708%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
709%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
710
711%files -n apache-mod_authz_svn
712%defattr(644,root,root,755)
713%doc subversion/mod_authz_svn/INSTALL
714%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
715%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
716%endif
717
718%endif # net_client_only
This page took 0.087236 seconds and 4 git commands to generate.