]> git.pld-linux.org Git - packages/stunnel.git/blame_incremental - stunnel.spec
- release 2
[packages/stunnel.git] / stunnel.spec
... / ...
CommitLineData
1Summary: Universal SSL tunnel
2Summary(pl.UTF-8): Uniwersalne narzędzie do bezpiecznego tunelowania
3Name: stunnel
4Version: 4.34
5Release: 2
6License: GPL v2+
7Group: Networking/Daemons
8Source0: ftp://stunnel.mirt.net/stunnel/%{name}-%{version}.tar.gz
9# Source0-md5: bbd274e8364ea3ceca0ee5190e13edd1
10Source1: %{name}.init
11Source2: %{name}.sysconfig
12Source3: %{name}.inet
13Patch0: %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
14Patch1: %{name}-authpriv.patch
15Patch2: %{name}-ac_fixes.patch
16Patch3: %{name}-am.patch
17Patch4: %{name}-libwrap_srv_name_log.patch
18Patch5: %{name}-config.patch
19URL: http://www.stunnel.org/
20BuildRequires: autoconf
21BuildRequires: automake
22BuildRequires: libtool
23BuildRequires: libwrap-devel
24BuildRequires: openssl-devel >= 0.9.7d
25BuildRequires: openssl-tools >= 0.9.7d
26BuildRequires: rpmbuild(macros) >= 1.268
27Requires(postun): /sbin/ldconfig
28Requires(postun): /usr/sbin/groupdel
29Requires(postun): /usr/sbin/userdel
30Requires(pre): /bin/id
31Requires(pre): /usr/bin/getgid
32Requires(pre): /usr/sbin/groupadd
33Requires(pre): /usr/sbin/useradd
34Provides: group(stunnel)
35Provides: user(stunnel)
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39The stunnel program is designed to work as SSL encryption wrapper
40between remote client and local (inetd-startable) or remote server.
41The concept is that having non-SSL aware daemons running on your
42system you can easily setup them to communicate with clients over
43secure SSL channel. stunnel can be used to add SSL functionality to
44commonly used inetd daemons like POP-2, POP-3 and IMAP servers without
45any changes in the programs' code.
46
47%description -l pl.UTF-8
48Stunnel umożliwia stawianie silnie kodowanych tuneli pomiędzy serwerem
49a komputerem klienta. Przy jego użyciu można łatwo zrealizować usługi
50pop3s lub HTTPS.
51
52%package standalone
53Summary: stunnel acts as standalone server
54Summary(pl.UTF-8): stunnel działający jako samodzielny serwer
55Group: Networking/Daemons
56Requires(post,preun): /sbin/chkconfig
57Requires: %{name} = %{version}-%{release}
58Requires: rc-scripts
59Obsoletes: stunnel-inetd
60
61%description standalone
62stunnel acts as standalone server.
63
64%description standalone -l pl.UTF-8
65stunnel działający jako samodzielny serwer.
66
67%package inetd
68Summary: stunnel acts as inetd service
69Summary(pl.UTF-8): stunnel działający jako usługa inetd
70Group: Networking/Daemons
71Requires: %{name} = %{version}-%{release}
72Requires: rc-inetd
73Obsoletes: stunnel-standalone
74
75%description inetd
76stunnel acts as inetd service.
77
78%description inetd -l pl.UTF-8
79stunnel działający jako usługa inetd.
80
81%prep
82%setup -q
83%patch0 -p1
84%patch1 -p1
85%patch2 -p1
86%patch3 -p1
87%patch4 -p1
88%patch5 -p1
89
90%build
91%{__libtoolize}
92%{__aclocal}
93%{__autoconf}
94%{__automake}
95%configure
96%{__make}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig/rc-inetd},%{_mandir}/{pl,fr}/man8,%{_var}/run/stunnel}
101
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
104
105mv -f $RPM_BUILD_ROOT%{_mandir}/man8/stunnel.fr.8 $RPM_BUILD_ROOT%{_mandir}/fr/man8/stunnel.8
106mv -f $RPM_BUILD_ROOT%{_mandir}/man8/stunnel.pl.8 $RPM_BUILD_ROOT%{_mandir}/pl/man8/stunnel.8
107mv -f $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf-sample $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.conf
108
109install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/stunnel
110install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/stunnel
111install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/stunnel
112
113rm -rf $RPM_BUILD_ROOT%{_libdir}/stunnel
114rm -f $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
115rm -rf $RPM_BUILD_ROOT%{_docdir}/stunnel
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%pre
121%groupadd -g 130 stunnel
122%useradd -u 130 -d /var/run/stunnel -s /bin/false -c "stunnel User" -g stunnel stunnel
123
124%post -p /sbin/ldconfig
125
126%postun
127/sbin/ldconfig
128if [ "$1" = "0" ]; then
129 %userremove stunnel
130 %groupremove stunnel
131fi
132
133%post standalone
134/sbin/chkconfig --add stunnel
135%service stunnel restart "stunnel daemon"
136
137%preun standalone
138if [ "$1" = "0" ]; then
139 %service stunnel stop
140 /sbin/chkconfig --del stunnel
141fi
142
143%post inetd
144%service -q rc-inetd reload
145
146%postun inetd
147if [ "$1" = "0" ]; then
148 %service -q rc-inetd reload
149fi
150
151%files
152%defattr(644,root,root,755)
153# note: this COPYING contains general information not GPL text
154%doc AUTHORS BUGS COPYING CREDITS ChangeLog NEWS PORTS README TODO doc/en/* doc/stunnel.html
155%doc src/stunnel.exe tools/{ca.*,importCA.*}
156%doc %lang(fr) doc/stunnel.fr.html
157%doc %lang(pl) doc/pl/* doc/stunnel.pl.html
158%attr(750,stunnel,stunnel) %{_var}/run/stunnel
159%dir %{_sysconfdir}/stunnel
160%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/stunnel/stunnel.conf
161%attr(755,root,root) %{_bindir}/*
162%{_mandir}/man8/*
163%lang(fr) %{_mandir}/fr/man8/*
164%lang(pl) %{_mandir}/pl/man8/*
165
166%files standalone
167%defattr(644,root,root,755)
168%attr(754,root,root) /etc/rc.d/init.d/stunnel
169%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/stunnel
170
171%files inetd
172%defattr(644,root,root,755)
173%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/stunnel
This page took 0.425849 seconds and 4 git commands to generate.