]> git.pld-linux.org Git - packages/sqlite3.git/blame_incremental - sqlite3.spec
- rel 2
[packages/sqlite3.git] / sqlite3.spec
... / ...
CommitLineData
1# TODO:
2# - some tests fail with tcl8.5, it's tcl fault,
3# if someone REALLY cares (s)he can look into it
4# - enable --enable-load-extension?
5#
6# Conditional build:
7%bcond_with tests # run tests
8%bcond_with tcl # enable tcl extension
9%bcond_without doc # disable documentation building
10
11%ifarch alpha sparc %{x8664}
12%undefine with_tests
13%endif
14
15# disabling tcl currently breaks making test target,
16# some hack in Makefile needs to be done
17%if %{without tcl}
18%undefine with_tests
19%endif
20
21%define _ulibdir /usr/lib
22%define tclver 8.5
23
24Summary: SQLite library
25Summary(pl.UTF-8): Biblioteka SQLite
26Name: sqlite3
27Version: 3.6.22
28Release: 2
29License: LGPL
30Group: Libraries
31# Source0Download: http://www.sqlite.org/download.html
32Source0: http://www.sqlite.org/sqlite-%{version}.tar.gz
33# Source0-md5: a17bd53f1fde11f84adf79c6a1510ce5
34Patch0: %{name}-sign-function.patch
35URL: http://www.sqlite.org/
36BuildRequires: autoconf
37BuildRequires: automake
38BuildRequires: libtool
39BuildRequires: readline-devel
40BuildRequires: tcl
41%{?with_tcl:BuildRequires: tcl-devel}
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45SQLite is a C library that implements an SQL database engine. A large
46subset of SQL92 is supported. A complete database is stored in a
47single disk file. The API is designed for convenience and ease of use.
48Applications that link against SQLite can enjoy the power and
49flexiblity of an SQL database without the administrative hassles of
50supporting a separate database server. Because it omits the
51client-server interaction overhead and writes directly to disk, SQLite
52is also faster than the big database servers for most operations. In
53addition to the C library, the SQLite distribution includes a
54command-line tool for interacting with SQLite databases and SQLite
55bindings for Tcl/Tk.
56
57%description -l pl.UTF-8
58SQLite jest biblioteką języka C, która implementuje silnik baz danych
59SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
60przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
61bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
62danych bez konieczności utrzymywania osobnego serwera baz danych.
63Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
64bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
65bazodanowych przy większości operacji na bazie danych. Dodatkowo
66oprócz biblioteki języka C, dostarczany jest program do zarządzania
67bazami danych.
68
69%package devel
70Summary: Header files for SQLite development
71Summary(pl.UTF-8): Pliki nagłówkowe SQLite
72Group: Development/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description devel
76SQLite is a C library that implements an SQL database engine. A large
77subset of SQL92 is supported. A complete database is stored in a
78single disk file. The API is designed for convenience and ease of use.
79Applications that link against SQLite can enjoy the power and
80flexiblity of an SQL database without the administrative hassles of
81supporting a separate database server. Because it omits the
82client-server interaction overhead and writes directly to disk, SQLite
83is also faster than the big database servers for most operations. In
84addition to the C library, the SQLite distribution includes a
85command-line tool for interacting with SQLite databases and SQLite
86bindings for Tcl/Tk.
87
88This package contains the header files needed to develop programs that
89use these SQLite.
90
91%description devel -l pl.UTF-8
92SQLite jest biblioteką języka C, która implementuje silnik baz danych
93SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
94przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
95bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
96danych bez konieczności utrzymywania osobnego serwera baz danych.
97Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
98bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
99bazodanowych przy większości operacji na bazie danych. Dodatkowo
100oprócz biblioteki języka C, dostarczany jest program do zarządzania
101bazami danych.
102
103Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
104używających biblioteki SQLite.
105
106%package static
107Summary: Static libraries for SQLite development
108Summary(pl.UTF-8): Statyczne biblioteki SQLite
109Group: Development/Libraries
110Requires: %{name}-devel = %{version}-%{release}
111
112%description static
113SQLite is a C library that implements an SQL database engine. A large
114subset of SQL92 is supported. A complete database is stored in a
115single disk file. The API is designed for convenience and ease of use.
116Applications that link against SQLite can enjoy the power and
117flexiblity of an SQL database without the administrative hassles of
118supporting a separate database server. Because it omits the
119client-server interaction overhead and writes directly to disk, SQLite
120is also faster than the big database servers for most operations. In
121addition to the C library, the SQLite distribution includes a
122command-line tool for interacting with SQLite databases and SQLite
123bindings for Tcl/Tk.
124
125This package contains the static SQLite libraries.
126
127%description static -l pl.UTF-8
128SQLite jest biblioteką języka C, która implementuje silnik baz danych
129SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
130przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
131bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
132danych bez konieczności utrzymywania osobnego serwera baz danych.
133Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
134bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
135bazodanowych przy większości operacji na bazie danych. Dodatkowo
136oprócz biblioteki języka C, dostarczany jest program do zarządzania
137bazami danych.
138
139Pakiet zawiera statyczne biblioteki SQLite.
140
141%package -n tcl-%{name}
142Summary: sqlite3 tcl extension
143Summary(pl.UTF-8): Rozszerzenie sqlite3 dla Tcl
144Group: Development/Languages/Tcl
145
146%description -n tcl-%{name}
147sqlite3 tcl extension.
148
149%description -n tcl-%{name} -l pl.UTF-8
150Rozszerzenie sqlite3 dla Tcl.
151
152%prep
153%setup -q -n sqlite-%{version}
154%patch0 -p1
155
156%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
157
158%build
159%{__libtoolize}
160cp -f /usr/share/automake/config.sub .
161%{__aclocal}
162%{__autoconf}
163CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1"
164export CFLAGS
165%configure \
166 %{?with_tcl:--with-tcl=%{_ulibdir}} \
167 %{!?with_tcl:--disable-tcl} \
168 --enable-threadsafe
169%{__make}
170
171%if %{with doc}
172%{__make} doc
173%endif
174
175%{?with_tests:LC_ALL=C %{__make} test}
176
177%install
178rm -rf $RPM_BUILD_ROOT
179install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
180
181%{__make} install \
182 DESTDIR=$RPM_BUILD_ROOT \
183 TCLLIBDIR=%{_libdir}/tcl%{tclver}
184
185%if %{with tcl}
186sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
187%endif
188
189mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
190rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
191ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
192 $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
193
194cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
195
196%clean
197rm -rf $RPM_BUILD_ROOT
198
199%post -p /sbin/ldconfig
200%postun -p /sbin/ldconfig
201
202%files
203%defattr(644,root,root,755)
204%doc README
205%attr(755,root,root) %{_bindir}/sqlite3
206%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
207%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
208%{_mandir}/man1/sqlite3.1*
209
210%files devel
211%defattr(644,root,root,755)
212%attr(755,root,root) %{_libdir}/libsqlite3.so
213%{_libdir}/libsqlite3.la
214%{_includedir}/sqlite3.h
215%{_includedir}/sqlite3ext.h
216%{_pkgconfigdir}/sqlite3.pc
217
218%files static
219%defattr(644,root,root,755)
220%{_libdir}/libsqlite3.a
221
222%if %{with tcl}
223%files -n tcl-%{name}
224%defattr(644,root,root,755)
225%dir %{_libdir}/tcl*/sqlite3
226%attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
227%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
228%endif
This page took 0.063346 seconds and 4 git commands to generate.