]> git.pld-linux.org Git - packages/spice-space.git/blame_incremental - spice-space.spec
- release 2 (by relup.sh)
[packages/spice-space.git] / spice-space.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without opengl # OpenGL support
4#
5Summary: SPICE virtualization solution
6Summary(pl.UTF-8): System wirtualizacji SPICE
7# real package name (spice) is already occupied
8Name: spice-space
9# NOTE: 0.13.x is unstable (see DEVEL branch for it)
10Version: 0.14.0
11Release: 2
12License: LGPL v2.1+
13Group: Applications/Emulators
14Source0: https://www.spice-space.org/download/releases/spice-%{version}.tar.bz2
15# Source0-md5: 6622aa7dfb5cd026a4d0d7e659216d26
16Patch0: spice-am.patch
17URL: https://www.spice-space.org/
18%{?with_opengl:BuildRequires: OpenGL-devel}
19%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
20BuildRequires: alsa-lib-devel
21BuildRequires: asciidoc
22BuildRequires: autoconf >= 2.63
23BuildRequires: automake >= 1:1.11
24BuildRequires: celt051-devel >= 0.5.1.1
25BuildRequires: cyrus-sasl-devel >= 2
26BuildRequires: gcc >= 5:3.2
27BuildRequires: glib2-devel >= 1:2.28
28BuildRequires: libcacard-devel >= 0.1.2
29BuildRequires: libjpeg-devel
30BuildRequires: libstdc++-devel
31BuildRequires: libtool >= 2:2
32BuildRequires: lz4-devel
33BuildRequires: openssl-devel
34BuildRequires: opus-devel >= 0.9.14
35BuildRequires: pixman-devel >= 0.17.7
36BuildRequires: pkgconfig
37BuildRequires: python >= 2
38BuildRequires: python-pyparsing
39BuildRequires: python-six
40BuildRequires: rpmbuild(macros) >= 1.527
41BuildRequires: spice-protocol >= 0.12.13
42BuildRequires: xorg-lib-libX11-devel
43BuildRequires: xorg-lib-libXext-devel
44BuildRequires: xorg-lib-libXfixes-devel
45BuildRequires: xorg-lib-libXinerama-devel >= 1.0
46BuildRequires: xorg-lib-libXrandr-devel >= 1.2
47BuildRequires: xorg-lib-libXrender-devel
48BuildRequires: zlib-devel
49ExclusiveArch: %{ix86} %{x8664} x32 arm
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53Spice is an open remote computing solution, providing client access to
54remote machine display and devices (e.g., keyboard, mouse, audio).
55Spice achieves a user experience similar to an interaction with a
56local machine, while trying to offload most of the intensive CPU and
57GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
58without compromising on the user experience.
59
60%description -l pl.UTF-8
61Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
62kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
63dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
64próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
65na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
66poświęceń ze strony doznań użytkownika.
67
68%package -n spice-server-libs
69Summary: SPICE server library
70Summary(pl.UTF-8): Biblioteka serwera SPICE
71Group: Libraries
72Requires: celt051 >= 0.5.1.1
73Requires: opus >= 0.9.14
74Requires: glib2 >= 1:2.22
75Requires: pixman >= 0.17.7
76Obsoletes: spice-client
77
78%description -n spice-server-libs
79SPICE server library.
80
81%description -n spice-server-libs -l pl.UTF-8
82Biblioteka serwera SPICE.
83
84%package -n spice-server-devel
85Summary: Header files for SPICE server library
86Summary(pl.UTF-8): Pliki nagłówkowe biblioteki serwera SPICE
87Group: Development/Libraries
88Requires: celt051-devel >= 0.5.1.1
89Requires: glib2-devel >= 1:2.22
90Requires: openssl-devel
91Requires: pixman-devel >= 0.17.7
92Requires: spice-server-libs = %{version}-%{release}
93
94%description -n spice-server-devel
95Header files for SPICE server library.
96
97%description -n spice-server-devel -l pl.UTF-8
98Pliki nagłówkowe biblioteki serwera SPICE.
99
100%package -n spice-server-static
101Summary: Static SPICE server library
102Summary(pl.UTF-8): Statyczna biblioteka serwera SPICE
103Group: Development/Libraries
104Requires: spice-server-devel = %{version}-%{release}
105
106%description -n spice-server-static
107Static SPICE server library.
108
109%description -n spice-server-static -l pl.UTF-8
110Statyczna biblioteka serwera SPICE.
111
112%package -n spice-client
113Summary: SPICE client for X11
114Summary(pl.UTF-8): Klient SPICE dla X11
115Group: X11/Applications
116Requires: celt051 >= 0.5.1.1
117Requires: libcacard >= 0.1.2
118Requires: opus >= 0.9.14
119Requires: pixman >= 0.17.7
120Requires: xorg-lib-libXrandr >= 1.2
121Requires: xorg-lib-libXinerama >= 1.0
122
123%description -n spice-client
124SPICE client for X11.
125
126%description -n spice-client -l pl.UTF-8
127Klient SPICE dla X11.
128
129%prep
130%setup -q -n spice-%{version}
131%patch0 -p1
132
133%build
134%{__libtoolize}
135%{__aclocal} -I m4
136%{__autoconf}
137%{__autoheader}
138%{__automake}
139cd spice-common
140%{__libtoolize}
141%{__aclocal} -I m4
142%{__autoconf}
143%{__autoheader}
144%{__automake}
145cd ..
146%configure \
147 --disable-silent-rules \
148 --enable-client \
149 --enable-lz4 \
150 %{?with_opengl:--enable-opengl} \
151 --enable-smartcard \
152 --enable-static
153
154%{__make}
155
156%install
157rm -rf $RPM_BUILD_ROOT
158
159%{__make} install \
160 DESTDIR=$RPM_BUILD_ROOT
161
162# obsoleted by pkg-config
163%{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%post -n spice-server-libs -p /sbin/ldconfig
169%postun -n spice-server-libs -p /sbin/ldconfig
170
171%files -n spice-server-libs
172%defattr(644,root,root,755)
173%doc NEWS README
174%attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
175%attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
176
177%files -n spice-server-devel
178%defattr(644,root,root,755)
179%attr(755,root,root) %{_libdir}/libspice-server.so
180%{_includedir}/spice-server
181%{_pkgconfigdir}/spice-server.pc
182
183%files -n spice-server-static
184%defattr(644,root,root,755)
185%{_libdir}/libspice-server.a
This page took 0.198219 seconds and 4 git commands to generate.