]> git.pld-linux.org Git - packages/shfs.git/blame_incremental - shfs.spec
- drop grsec_kernel bcond
[packages/shfs.git] / shfs.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without dist_kernel # without distribution kernel
4%bcond_without kernel # don't build kernel modules
5%bcond_with verbose # verbose build (V=1)
6%bcond_without userspace # don't build userspace tools
7
8%ifarch sparc
9%undefine with_smp
10%endif
11
12%if %{without kernel}
13%undefine with_dist_kernel
14%endif
15%if "%{_alt_kernel}" != "%{nil}"
16%undefine with_userspace
17%endif
18
19%define rel 20
20Summary: (Secure) SHell FileSystem utilities
21Summary(pl.UTF-8): Narzędzia obsługujące system plików przez ssh
22Name: shfs
23Version: 0.35
24Release: %{rel}
25License: GPL v2
26Group: Applications/System
27Source0: http://dl.sourceforge.net/shfs/%{name}-%{version}.tar.gz
28# Source0-md5: 016f49d71bc32eee2b5d11fc1600cfbe
29Patch0: %{name}-opt.patch
30Patch1: %{name}-df.patch
31Patch2: %{name}-space_chars.patch
32Patch3: %{name}-uidgid32.patch
33Patch4: %{name}-gcc4.patch
34Patch5: %{name}-inode_oops.patch
35Patch6: %{name}-d_entry.patch
36Patch7: %{name}-shfs_get_sb.patch
37Patch8: %{name}-2.6.19.patch
38Patch9: %{name}-kmem_cache.patch
39URL: http://shfs.sourceforge.net/
40%if %{with kernel}
41%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
42BuildRequires: rpmbuild(macros) >= 1.379
43%endif
44%{?with_dist_kernel:Requires: kernel(shfs)}
45Obsoletes: shfsmount
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
49SHFS is a simple and easy to use Linux kernel 2.4.10+ and 2.6 module
50which allows you to mount remote filesystems using plain shell
51(ssh/rsh) connection. It supports some nice features like number of
52different caches for access speedup, target system optimisations, etc.
53
54This package contains utilities for SHFS.
55
56%description -l pl.UTF-8
57SHFS to prosty i łatwy w użyciu moduł jądra Linuksa 2.4.10+ i 2.6
58pozwalający montować zdalne systemy plików przy użyciu zwykłego
59połączenia ze zdalną powłoką (ssh lub rsh). Obsługuje pewne miłe
60cechy, takie jak różne sposoby buforowania dla przyspieszenia dostępu,
61optymalizacje pod kątem zdalnego systemu itp.
62
63Ten pakiet zawiera programy narzędziowe dla SHFS.
64
65%package -n kernel%{_alt_kernel}-fs-shfs
66Summary: SHell File System Linux kernel module
67Summary(pl.UTF-8): Moduł jądra Linuksa obsługujący powłokowy system plików
68Release: %{rel}@%{_kernel_ver_str}
69Group: Base/Kernel
70Requires(post,postun): /sbin/depmod
71%if %{with dist_kernel}
72%requires_releq_kernel
73Requires(postun): %releq_kernel
74%endif
75Provides: kernel(shfs)
76%if "%{_alt_kernel}" == "%{nil}"
77Obsoletes: kernel-misc-shfs
78%endif
79
80%description -n kernel%{_alt_kernel}-fs-shfs
81SHell File System Linux kernel module.
82
83%description -n kernel%{_alt_kernel}-fs-shfs -l pl.UTF-8
84Moduł jądra Linuksa obsługujący powłokowy system plików.
85
86%prep
87%setup -q
88%patch0 -p1
89%patch1 -p0
90%patch2 -p1
91%patch3 -p1
92%patch4 -p1
93%patch5 -p1
94%patch6 -p1
95%patch7 -p1
96%patch8 -p1
97%patch9 -p1
98
99cat > shfs/Linux-2.6/Makefile <<'EOF'
100obj-m := shfs.o
101shfs-objs := dcache.o dir.o fcache.o file.o inode.o \
102 ioctl.o proc.o shell.o symlink.o
103EOF
104
105%build
106%if %{with kernel}
107%build_kernel_modules -C shfs/Linux-2.6 -m shfs
108%endif
109
110%if %{with userspace}
111%{__make} -C shfsmount \
112 SHFS_VERSION="\"%{version}\"" \
113 CC="%{__cc} %{rpmcflags}" \
114 LINKER="%{__cc}" \
115 LDFLAGS="%{rpmldflags}"
116%{__make} docs
117%endif
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%if %{with kernel}
123%install_kernel_modules -m shfs/Linux-2.6/shfs -d kernel/fs/shfs
124%endif
125
126%if %{with userspace}
127%{__make} utils-install docs-install \
128 ROOT=$RPM_BUILD_ROOT \
129 MAN_PAGE_DIR=%{_mandir}
130%endif
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post -n kernel%{_alt_kernel}-fs-shfs
136%depmod %{_kernel_ver}
137
138%postun -n kernel%{_alt_kernel}-fs-shfs
139%depmod %{_kernel_ver}
140
141%if %{with userspace}
142%files
143%defattr(644,root,root,755)
144%doc COPYRIGHT Changelog TODO docs/html
145%attr(4754,root,wheel) %{_bindir}/shfsmount
146%attr(4754,root,wheel) %{_bindir}/shfsumount
147%attr(755,root,root) /sbin/*
148%{_mandir}/man8/*
149%endif
150
151%if %{with kernel}
152%files -n kernel%{_alt_kernel}-fs-shfs
153%defattr(644,root,root,755)
154%dir /lib/modules/%{_kernel_ver}/kernel/fs/shfs
155/lib/modules/%{_kernel_ver}/kernel/fs/shfs/shfs.ko*
156%endif
This page took 0.039102 seconds and 4 git commands to generate.