]> git.pld-linux.org Git - packages/rust.git/blame_incremental - rust.spec
rebuild with openssl 3.0.0
[packages/rust.git] / rust.spec
... / ...
CommitLineData
1# TODO
2# - unpackaged %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
3# - consider a rust-std package containing .../rustlib/$target
4# This might allow multilib cross-compilation to work naturally.
5# - package additional tools
6#
7# Conditional build:
8%bcond_with bootstrap # bootstrap using precompiled binaries
9%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
10%bcond_without system_llvm # system LLVM
11%bcond_with tests # build without tests
12
13# The channel can be stable, beta, or nightly
14%define channel stable
15
16%if "%{channel}" == "stable"
17%define rustc_package rustc-%{version}-src
18%else
19%define rustc_package rustc-%{channel}-src
20%endif
21
22# To bootstrap from scratch, set the channel and date from src/stage0.txt
23# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
24# or nightly wants some beta-YYYY-MM-DD
25%define bootstrap_rust 1.54.0
26%define bootstrap_cargo 1.54.0
27%define bootstrap_date 2021-07-29
28
29%ifarch x32
30%define with_cross 1
31%endif
32
33%if %{without full_debuginfo}
34%define _enable_debug_packages 0
35%endif
36
37Summary: The Rust Programming Language
38Summary(pl.UTF-8): Język programowania Rust
39Name: rust
40Version: 1.55.0
41Release: 2
42# Licenses: (rust itself) and (bundled libraries)
43License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
44Group: Development/Languages
45Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
46# Source0-md5: bb05ec6801c08eb1353fa7316e02ee26
47Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
48# Source1-md5: 12cfee7377dafd0583fe53d7ed5d45fb
49Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
50# Source2-md5: ec48712d83df42479eebca05bca06201
51Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
52# Source3-md5: b8c06e3435e8f37cfd8911273255019c
53Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
54# Source4-md5: ed4754c59f8476fa60e8266002b8f1ba
55Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
56# Source5-md5: 9ceab67a2b1299a9314756280d90548b
57URL: https://www.rust-lang.org/
58# for src/compiler-rt
59BuildRequires: cmake >= 3.4.3
60BuildRequires: curl
61# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
62BuildRequires: procps
63BuildRequires: python >= 1:2.7
64BuildRequires: rpmbuild(macros) >= 1.752
65%if %{without cross}
66BuildRequires: curl-devel
67BuildRequires: libgit2-devel >= 1.1.0
68BuildRequires: libstdc++-devel
69%{?with_system_llvm:BuildRequires: llvm-devel >= 10.0}
70BuildRequires: openssl-devel >= 1.0.1
71BuildRequires: tar >= 1:1.22
72BuildRequires: xz
73BuildRequires: zlib-devel
74%endif
75%if %{without bootstrap}
76BuildRequires: %{name} >= %{bootstrap_rust}
77BuildRequires: cargo >= %{bootstrap_cargo}
78BuildConflicts: %{name} > %{version}
79%endif
80%ifarch x32
81BuildRequires: glibc-devel(x86-64)
82BuildRequires: glibc-devel(x86-x32)
83%if "%{_host_cpu}" == "x86_64"
84# building on x86_64 host with --target x32-pld-linux
85BuildRequires: curl-devel
86BuildRequires: gcc-multilib-x32
87BuildRequires: libgit2-devel >= 1.1.0
88BuildRequires: libstdc++-devel
89%{?with_system_llvm:BuildRequires: llvm-devel >= 10.0}
90BuildRequires: openssl-devel >= 1.0.1
91BuildRequires: zlib-devel
92%else
93# building x86_64-hosted crosscompiler on x32 host
94BuildRequires: curl-devel(x86-64)
95BuildRequires: curl-devel(x86-x32)
96BuildRequires: gcc-multilib-64
97BuildRequires: libgit2-devel(x86-64) >= 1.1.0
98BuildRequires: libgit2-devel(x86-x32) >= 1.1.0
99BuildRequires: libstdc++-multilib-64-devel
100%if %{with system_llvm}
101BuildRequires: llvm-devel(x86-64) >= 10.0
102BuildRequires: llvm-devel(x86-x32) >= 10.0
103%endif
104BuildRequires: openssl-devel(x86-64)
105BuildRequires: openssl-devel(x86-x32)
106BuildRequires: zlib-devel(x86-64)
107BuildRequires: zlib-devel(x86-x32)
108%endif
109%endif
110# The C compiler is needed at runtime just for linking. Someday rustc might
111# invoke the linker directly, and then we'll only need binutils.
112# https://github.com/rust-lang/rust/issues/11937
113Requires: gcc
114Requires: %{name}-std%{?_isa} = %{version}-%{release}
115%ifarch x32
116Requires: %{name}-std(x86-64) = %{version}-%{release}
117%endif
118Obsoletes: rust-analyzer < 1.53.0
119# Only x86_64 and i686 are Tier 1 platforms at this time.
120# x32 is Tier 2, only rust-std is available (no rustc or cargo).
121# https://doc.rust-lang.org/nightly/rustc/platform-support.html
122ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
123BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125%ifarch x32
126%define rust_triple x86_64-unknown-linux-gnux32
127%define rust_host_triple x86_64-unknown-linux-gnu
128%define rust_bootstrap_triple x86_64-unknown-linux-gnu
129# libs in _libdir are x86_64 64bit
130%define _lib lib64
131%define _libdir %{_prefix}/lib64
132%else
133%ifarch armv6hl
134%define rust_triple arm-unknown-linux-gnueabihf
135%define rust_host_triple %{rust_triple}
136%define rust_bootstrap_triple %{rust_triple}
137%else
138%ifarch armv7hl armv7hnl
139%define rust_triple armv7-unknown-linux-gnueabihf
140%define rust_host_triple %{rust_triple}
141%define rust_bootstrap_triple %{rust_triple}
142%else
143%define rust_triple %{_target_cpu}-unknown-linux-gnu
144%define rust_host_triple %{rust_triple}
145%define rust_bootstrap_triple %{rust_triple}
146%endif
147%endif
148%endif
149
150%if %{without bootstrap}
151%define local_rust_root %{_prefix}
152%else
153%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
154%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
155%endif
156
157# We're going to override --libdir when configuring to get rustlib into a
158# common path, but we'll fix the shared libraries during install.
159# Without this ugly hack, rust would not be able to build itself
160# for non-bootstrap build, lib64 is just too complicated for it.
161%define common_libdir %{_prefix}/lib
162%define rustlibdir %{common_libdir}/rustlib
163
164# once_call/once_callable non-function libstdc++ symbols
165%define skip_post_check_so 'librustc.*llvm.*\.so.*'
166
167# ALL Rust libraries are private, because they don't keep an ABI.
168%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
169%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
170
171%define x_py { \
172 x_py() { \
173 local cmd="$1"; \
174 shift; \
175 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
176 }; x_py }
177
178
179%description
180Rust is a systems programming language that runs blazingly fast,
181prevents segfaults, and guarantees thread safety.
182
183This package includes the Rust compiler, standard library, and
184documentation generator.
185
186%description -l pl.UTF-8
187Rust to systemowy język programowania działający bardzo szybko,
188zapobiegający naruszeniom ochrony pamięci i gwarantujący
189bezpieczną wielowątkowość.
190
191%package analysis
192Summary: Metadata about the standard library
193Summary(pl.UTF-8): Metadane o standardowej bibliotece
194Group: Development/Tools
195Requires: %{name} = %{version}-%{release}
196
197%description analysis
198Metadata about the standard library.
199
200%description analysis -l pl.UTF-8
201Metadane o standardowej bibliotece.
202
203%package std
204Summary: Standard library for Rust
205Summary(pl.UTF-8): Standardowa biblioteka Rusta
206Group: Development/Tools
207Requires: %{name} = %{version}-%{release}
208
209%description std
210Standard library for Rust.
211
212%description std -l pl.UTF-8
213Standardowa biblioteka Rusta.
214
215%package debugger-common
216Summary: Common debugger pretty printers for Rust
217Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
218Group: Development/Debuggers
219BuildArch: noarch
220
221%description debugger-common
222This package includes the common functionality for rust-gdb and
223rust-lldb.
224
225%description debugger-common -l pl.UTF-8
226Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
227
228%package gdb
229Summary: GDB pretty printers for Rust
230Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
231Group: Development/Debuggers
232Requires: %{name}-debugger-common = %{version}-%{release}
233Requires: gdb
234BuildArch: noarch
235
236%description gdb
237This package includes the rust-gdb script, which allows easier
238debugging of Rust programs.
239
240%description gdb -l pl.UTF-8
241Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
242odpluskwianie programów w języku Rust.
243
244%package lldb
245Summary: LLDB pretty printers for Rust
246Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
247Group: Development/Debuggers
248Requires: %{name}-debugger-common = %{version}-%{release}
249Requires: lldb
250BuildArch: noarch
251
252%description lldb
253This package includes the rust-lldb script, which allows easier
254debugging of Rust programs.
255
256%description lldb -l pl.UTF-8
257Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
258odpluskwianie programów w języku Rust.
259
260%package rls
261Summary: Rust Language Server for IDE integration
262Summary(pl.UTF-8): Rust Language Server do integracji z IDE
263Group: Development/Tools
264Requires: %{name} = %{version}-%{release}
265Requires: %{name}-analysis = %{version}-%{release}
266
267%description rls
268Rust Language Server for IDE integration.
269
270%description rls -l pl.UTF-8
271Rust Language Server do integracji z IDE.
272
273%package doc
274Summary: Documentation for Rust
275Summary(pl.UTF-8): Dokumentacja do Rusta
276Group: Documentation
277BuildArch: noarch
278
279%description doc
280This package includes HTML documentation for the Rust programming
281language and its standard library.
282
283%description doc -l pl.UTF-8
284Ten pakiet zawiera dokumentację w formacie HTML do języka
285programowania Rust i jego biblioteki standardowej.
286
287%package -n cargo
288Summary: Rust's package manager and build tool
289Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
290Group: Development/Tools
291Requires: %{name}%{?_isa}
292
293%description -n cargo
294Cargo is a tool that allows Rust projects to declare their various
295dependencies and ensure that you'll always get a repeatable build.
296
297%description -n cargo -l pl.UTF-8
298Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
299zależności i zapewniające powtarzalność procesu budowania.
300
301%package -n bash-completion-cargo
302Summary: Bash completion for cargo command
303Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
304Group: Applications/Shells
305Requires: %{name} = %{version}-%{release}
306Requires: bash-completion
307
308%description -n bash-completion-cargo
309Bash completion for cargo command.
310
311%description -n bash-completion-cargo -l pl.UTF-8
312Bashowe dopełnianie parametrów polecenia cargo.
313
314%package -n zsh-completion-cargo
315Summary: Zsh completion for cargo command
316Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
317Group: Applications/Shells
318Requires: %{name} = %{version}-%{release}
319Requires: zsh
320
321%description -n zsh-completion-cargo
322Zsh completion for cargo command.
323
324%description -n zsh-completion-cargo -l pl.UTF-8
325Dopełnianie parametrów polecenia cargo w powłoce Zsh.
326
327%prep
328%setup -q -n %{rustc_package}
329
330%if %{with bootstrap}
331%ifarch %{x8664} x32
332tar xf %{SOURCE1}
333%endif
334%ifarch %{ix86}
335tar xf %{SOURCE2}
336%endif
337%ifarch aarch64
338tar xf %{SOURCE3}
339%endif
340%ifarch armv6hl
341tar xf %{SOURCE4}
342%endif
343%ifarch armv7hl armv7hnl
344tar xf %{SOURCE5}
345%endif
346%{__mv} %{bootstrap_root} %{bootstrap_root}-root
347%{bootstrap_root}-root/install.sh \
348 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
349 --prefix=%{local_rust_root} \
350 --disable-ldconfig
351test -f %{local_rust_root}/bin/cargo
352test -f %{local_rust_root}/bin/rustc
353%endif
354
355# unbundle
356# We're disabling jemalloc, but rust-src still wants it.
357#%{__rm} -r src/jemalloc
358%if %{with system_llvm}
359%{__rm} -r src/llvm-project
360mkdir -p src/llvm-project/libunwind
361%endif
362
363# extract bundled licenses for packaging
364sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
365 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
366
367# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
368sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
369 src/etc/rust-gdb
370
371# cargo has hardcoded libexec path - honour rpm _libexecdir
372%if "%{_libexecdir}" != "%{_prefix}/libexec"
373suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
374%{__sed} -i -e 's,"libexec","'${suffix}'",' \
375 src/bootstrap/dist.rs \
376 src/tools/cargo/src/cargo/ops/registry/auth.rs
377%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
378%endif
379
380# The configure macro will modify some autoconf-related files, which upsets
381# cargo when it tries to verify checksums in those files. If we just truncate
382# that file list, cargo won't have anything to complain about.
383find vendor -name .cargo-checksum.json \
384 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
385
386%build
387%configure \
388 --build=%{rust_bootstrap_triple} \
389 --host=%{rust_host_triple} \
390 --target=%{rust_triple} \
391 --libdir=%{common_libdir} \
392 --disable-codegen-tests \
393 --disable-debuginfo-lines \
394%if %{with full_debuginfo}
395 --disable-debuginfo-only-std \
396 --enable-debuginfo \
397%else
398 --enable-debuginfo-only-std \
399 --disable-debuginfo \
400%endif
401 --disable-jemalloc \
402 --disable-option-checking \
403 --disable-rpath \
404 --enable-extended \
405 --enable-llvm-link-shared \
406 --enable-vendor \
407 --local-rust-root=%{local_rust_root} \
408 --llvm-root=%{_prefix} \
409 --release-channel=%{channel}
410
411export RUST_BACKTRACE=full
412%x_py dist --verbose
413
414%{?with_tests:%x_py test}
415
416%install
417rm -rf $RPM_BUILD_ROOT
418
419export DESTDIR=$RPM_BUILD_ROOT
420%x_py install
421
422# Make sure the shared libraries are in the proper libdir
423%if "%{_libdir}" != "%{common_libdir}"
424mkdir -p %{buildroot}%{_libdir}
425find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
426 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
427%endif
428
429# The shared libraries should be executable for debuginfo extraction.
430find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
431
432# The libdir libraries are identical to those under rustlib/. It's easier on
433# library loading if we keep them in libdir, but we do need them in rustlib/
434# to support dynamic linking for compiler plugins, so we'll symlink.
435for l in libstd libtest ; do
436 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
437 libstd=$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib/${l}-*.so
438 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
439 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
440 fi
441done
442
443# Remove installer artifacts (manifests, uninstall scripts, etc.)
444find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
445
446# FIXME: __os_install_post will strip the rlibs
447# -- should we find a way to preserve debuginfo?
448
449# Remove unwanted documentation files (we already package them)
450%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
451%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
452%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
453%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
454
455# Sanitize the HTML documentation
456find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
457find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
458
459# Move rust-gdb's python scripts so they're noarch
460install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
461%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
462
463# We don't need stdlib source
464%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
465
466# Create the path for crate-devel packages
467install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
468
469%clean
470rm -rf $RPM_BUILD_ROOT
471
472%post -p /sbin/ldconfig
473%postun -p /sbin/ldconfig
474
475%files
476%defattr(644,root,root,755)
477%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
478%attr(755,root,root) %{_bindir}/rustc
479%attr(755,root,root) %{_bindir}/rustdoc
480%attr(755,root,root) %{_bindir}/rustfmt
481%attr(755,root,root) %{_libdir}/librustc_driver-*.so
482%attr(755,root,root) %{_libdir}/libstd-*.so
483%attr(755,root,root) %{_libdir}/libtest-*.so
484%{_mandir}/man1/rustc.1*
485%{_mandir}/man1/rustdoc.1*
486%dir %{rustlibdir}
487
488%files analysis
489%defattr(644,root,root,755)
490%{rustlibdir}/%{rust_triple}/analysis
491
492%files std
493%defattr(644,root,root,755)
494%dir %{rustlibdir}/%{rust_triple}
495%dir %{rustlibdir}/%{rust_triple}/lib
496%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
497%{rustlibdir}/%{rust_triple}/lib/*.rlib
498
499%files debugger-common
500%defattr(644,root,root,755)
501%dir %{_datadir}/%{name}
502%dir %{_datadir}/%{name}/etc
503%{_datadir}/%{name}/etc/lldb_commands
504%{_datadir}/%{name}/etc/rust_types.py
505
506%files lldb
507%defattr(644,root,root,755)
508%attr(755,root,root) %{_bindir}/rust-lldb
509%{_datadir}/%{name}/etc/lldb_*.py*
510
511%files gdb
512%defattr(644,root,root,755)
513%attr(755,root,root) %{_bindir}/rust-gdb
514%attr(755,root,root) %{_bindir}/rust-gdbgui
515%{_datadir}/%{name}/etc/gdb_*.py*
516
517%files rls
518%defattr(644,root,root,755)
519%attr(755,root,root) %{_bindir}/rls
520
521%files doc
522%defattr(644,root,root,755)
523%dir %{_docdir}/%{name}
524%doc %{_docdir}/%{name}/html
525
526%files -n cargo
527%defattr(644,root,root,755)
528%attr(755,root,root) %{_bindir}/cargo
529%attr(755,root,root) %{_bindir}/cargo-clippy
530%attr(755,root,root) %{_bindir}/cargo-fmt
531%attr(755,root,root) %{_bindir}/clippy-driver
532%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
533%{_mandir}/man1/cargo*.1*
534%dir %{_datadir}/cargo
535%dir %{_datadir}/cargo/registry
536
537%files -n bash-completion-cargo
538%defattr(644,root,root,755)
539%{_sysconfdir}/bash_completion.d/cargo
540
541%files -n zsh-completion-cargo
542%defattr(644,root,root,755)
543%{zsh_compdir}/_cargo
This page took 0.065548 seconds and 4 git commands to generate.