]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- explicitly enable KVM support
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1# TODO:
2# - merge missing bits from qemu-kvm
3#
4# Conditional build:
5%bcond_without sdl # SDL UI and audio support
6%bcond_without glx # OpenGL/GLX support
7%bcond_without ceph # Ceph/RBD support
8%bcond_without glusterfs # GlusterFS backend
9%bcond_without rdma # RDMA-based migration support
10%bcond_with gtk2 # GTK+ 2.x instead of 3.x
11%bcond_without spice # SPICE support
12%bcond_with esd # EsounD audio support
13%bcond_without oss # OSS audio support
14%bcond_without pulseaudio # PulseAudio audio support
15%bcond_without xen # Xen backend driver support
16
17Summary: QEMU CPU Emulator
18Summary(pl.UTF-8): QEMU - emulator procesora
19Name: qemu
20Version: 1.6.1
21Release: 3
22License: GPL v2+
23Group: Applications/Emulators
24Source0: http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
25# Source0-md5: 3a897d722457c5a895cd6ac79a28fda0
26Source11: qemu-guest-agent.service
27Source12: 99-qemu-guest-agent.rules
28Patch0: %{name}-cflags.patch
29Patch1: vgabios-widescreens.patch
30Patch2: %{name}-whitelist.patch
31Patch3: %{name}-system-libcacard.patch
32# Proof of concept, for reference, do not remove
33Patch4: %{name}-kde_virtual_workspaces_hack.patch
34URL: http://www.qemu-project.org/
35%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
36%{?with_sdl:BuildRequires: SDL-devel >= 1.2.1}
37BuildRequires: alsa-lib-devel
38BuildRequires: bcc
39BuildRequires: bluez-libs-devel
40BuildRequires: brlapi-devel
41%{?with_ceph:BuildRequires: ceph-devel}
42BuildRequires: curl-devel
43BuildRequires: cyrus-sasl-devel >= 2
44%{?with_esd:BuildRequires: esound-devel}
45BuildRequires: glib2-devel >= 1:2.12
46%{?with_glusterfs:BuildRequires: glusterfs-devel >= 3.4}
47BuildRequires: gnutls-devel
48BuildRequires: libaio-devel
49BuildRequires: libcacard-devel
50BuildRequires: libcap-devel
51BuildRequires: libcap-ng-devel
52BuildRequires: libfdt-devel
53%{?with_rdma:BuildRequires: libibverbs-devel}
54BuildRequires: libiscsi-devel
55BuildRequires: libjpeg-devel
56BuildRequires: libpng-devel
57%{?with_rdma:BuildRequires: librdmacm-devel}
58BuildRequires: libseccomp-devel
59BuildRequires: libssh2-devel >= 1.2.8
60# for usb passthrough, when available
61#BuildRequires: libusb-devel >= 1.0.13
62BuildRequires: libuuid-devel
63BuildRequires: ncurses-devel
64BuildRequires: nss-devel >= 3.12.8
65BuildRequires: perl-Encode
66BuildRequires: perl-tools-pod
67BuildRequires: pkgconfig
68%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
69BuildRequires: rpmbuild(macros) >= 1.202
70BuildRequires: sed >= 4.0
71%if %{with spice}
72BuildRequires: spice-protocol >= 0.12.0
73BuildRequires: spice-server-devel >= 0.12.0
74%endif
75BuildRequires: texi2html
76BuildRequires: texinfo
77BuildRequires: usbredir-devel >= 0.6
78BuildRequires: vde2-devel
79BuildRequires: which
80%{?with_xen:BuildRequires: xen-devel >= 3.4}
81BuildRequires: xfsprogs-devel
82BuildRequires: xorg-lib-libX11-devel
83BuildRequires: zlib-devel
84%if %{with gtk2}
85BuildRequires: gtk+2-devel >= 2:2.18.0
86BuildRequires: vte0-devel >= 0.24.0
87%else
88BuildRequires: gtk+3-devel >= 3.0.0
89BuildRequires: vte-devel >= 0.32.0
90%endif
91Requires: %{name}-img = %{version}-%{release}
92Requires: %{name}-system-alpha = %{version}-%{release}
93Requires: %{name}-system-arm = %{version}-%{release}
94Requires: %{name}-system-cris = %{version}-%{release}
95Requires: %{name}-system-lm32 = %{version}-%{release}
96Requires: %{name}-system-m68k = %{version}-%{release}
97Requires: %{name}-system-microblaze = %{version}-%{release}
98Requires: %{name}-system-mips = %{version}-%{release}
99Requires: %{name}-system-moxie = %{version}-%{release}
100Requires: %{name}-system-or32 = %{version}-%{release}
101Requires: %{name}-system-ppc = %{version}-%{release}
102Requires: %{name}-system-s390x = %{version}-%{release}
103Requires: %{name}-system-sh4 = %{version}-%{release}
104Requires: %{name}-system-sparc = %{version}-%{release}
105Requires: %{name}-system-unicore32 = %{version}-%{release}
106Requires: %{name}-system-x86 = %{version}-%{release}
107Requires: %{name}-system-xtensa = %{version}-%{release}
108Requires: %{name}-user = %{version}-%{release}
109Obsoletes: qemu-kvm
110BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112%define systempkg_req \
113Requires: SDL >= 1.2.1 \
114Requires: usbredir >= 0.6 \
115%if %{with gtk2} \
116Requires: gtk+2 >= 2:2.18.0 \
117Requires: vte0 >= 0.24.0 \
118%else \
119Requires: gtk+3 >= 3.0.0 \
120Requires: vte >= 0.32.0 \
121%endif
122
123# some PPC/SPARC boot image in ELF format
124%define _noautostrip .*%{_datadir}/qemu/.*-.*
125
126%description
127QEMU is a FAST! processor emulator. By using dynamic translation it
128achieves a reasonnable speed while being easy to port on new host
129CPUs. QEMU has two operating modes:
130
131- User mode emulation. In this mode, QEMU can launch Linux processes
132 compiled for one CPU on another CPU. Linux system calls are converted
133 because of endianness and 32/64 bit mismatches. Wine (Windows
134 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
135
136- Full system emulation. In this mode, QEMU emulates a full system,
137 including a processor and various peripherials. It can also be used to
138 provide virtual hosting of several virtual PC on a single server.
139
140%description -l pl.UTF-8
141QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
142tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
143aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
144
145- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
146 procesy linuksowe skompilowane dla jednego procesora na innym
147 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
148 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
149 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
150 cele QEMU.
151
152- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
153 włączając w to procesor i różne urządzenia peryferyjne. Może być także
154 używane do wirtualnego hostowania kilku wirtualnych pecetów na
155 pojedynczym serwerze.
156
157%package common
158Summary: QEMU common files needed by all QEMU targets
159Summary(pl.UTF-8): Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
160Group: Development/Tools
161Requires(postun): /usr/sbin/groupdel
162Requires(postun): /usr/sbin/userdel
163Requires(pre): /bin/id
164Requires(pre): /usr/bin/getgid
165Requires(pre): /usr/sbin/groupadd
166Requires(pre): /usr/sbin/useradd
167Requires: glib2 >= 1:2.12
168Requires: libssh2 >= 1.2.8
169Provides: group(qemu)
170Provides: user(qemu)
171Obsoletes: qemu-kvm-common
172Conflicts: qemu < 1.0-2
173
174%description common
175QEMU is a generic and open source processor emulator which achieves a
176good emulation speed by using dynamic translation.
177
178This package provides the common files needed by all QEMU targets.
179
180%description common -l pl.UTF-8
181QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
182dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
183
184Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
185środowiska QEMU.
186
187%package img
188Summary: QEMU command line tool for manipulating disk images
189Summary(pl.UTF-8): Narzędzie QEMU do operacji na obrazach dysków
190Group: Development/Tools
191Conflicts: qemu < 1.0-2
192Obsoletes: qemu-kvm-img
193
194%description img
195This package provides a command line tool for manipulating disk
196images.
197
198%description img -l pl.UTF-8
199Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
200na obrazach dysków.
201
202%package user
203Summary: QEMU user mode emulation of qemu targets
204Summary(pl.UTF-8): QEMU - emulacja trybu użytkownika środowisk qemu
205Group: Development/Tools
206Requires: %{name}-common = %{version}-%{release}
207Obsoletes: qemu-kvm-user
208
209%description user
210QEMU is a generic and open source processor emulator which achieves a
211good emulation speed by using dynamic translation.
212
213This package provides the user mode emulation of QEMU targets.
214
215%description user -l pl.UTF-8
216QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
217dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
218
219Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
220
221%package system-alpha
222Summary: QEMU system emulator for Alpha
223Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Alpha
224Group: Development/Tools
225Requires: %{name}-common = %{version}-%{release}
226%systempkg_req
227Obsoletes: qemu-kvm-system-alpha
228
229%description system-alpha
230QEMU is a generic and open source processor emulator which achieves a
231good emulation speed by using dynamic translation.
232
233This package provides the system emulator with Alpha CPU.
234
235%description system-alpha -l pl.UTF-8
236QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
237dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
238
239Ten pakiet zawiera emulator systemu z procesorem Alpha.
240
241%package system-arm
242Summary: QEMU system emulator for ARM
243Summary(pl.UTF-8): QEMU - emulator systemu z procesorem ARM
244Group: Development/Tools
245Requires: %{name}-common = %{version}-%{release}
246%systempkg_req
247Obsoletes: qemu-kvm-system-arm
248
249%description system-arm
250QEMU is a generic and open source processor emulator which achieves a
251good emulation speed by using dynamic translation.
252
253This package provides the system emulator for ARM.
254
255%description system-arm -l pl.UTF-8
256QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
257dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
258
259Ten pakiet zawiera emulator systemu z procesorem ARM.
260
261%package system-cris
262Summary: QEMU system emulator for CRIS
263Summary(pl.UTF-8): QEMU - emulator systemu z procesorem CRIS
264Group: Development/Tools
265Requires: %{name}-common = %{version}-%{release}
266%systempkg_req
267Obsoletes: qemu-kvm-system-cris
268
269%description system-cris
270QEMU is a generic and open source processor emulator which achieves a
271good emulation speed by using dynamic translation.
272
273This package provides the system emulator with CRIS CPU.
274
275%description system-cris -l pl.UTF-8
276QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
277dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
278
279Ten pakiet zawiera emulator systemu z procesorem CRIS.
280
281%package system-lm32
282Summary: QEMU system emulator for LM32
283Summary(pl.UTF-8): QEMU - emulator systemu z procesorem LM32
284Group: Development/Tools
285Requires: %{name}-common = %{version}-%{release}
286%systempkg_req
287Obsoletes: qemu-kvm-system-lm32
288
289%description system-lm32
290QEMU is a generic and open source processor emulator which achieves a
291good emulation speed by using dynamic translation.
292
293This package provides the system emulator with LM32 CPU.
294
295%description system-lm32 -l pl.UTF-8
296QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
297dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
298
299Ten pakiet zawiera emulator systemu z procesorem LM32.
300
301%package system-m68k
302Summary: QEMU system emulator for m68k
303Summary(pl.UTF-8): QEMU - emulator systemu z procesorem m68k
304Group: Development/Tools
305Requires: %{name}-common = %{version}-%{release}
306%systempkg_req
307Obsoletes: qemu-kvm-system-m68k
308
309%description system-m68k
310QEMU is a generic and open source processor emulator which achieves a
311good emulation speed by using dynamic translation.
312
313This package provides the system emulator with m68k CPU.
314
315%description system-m68k -l pl.UTF-8
316QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
317dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
318
319Ten pakiet zawiera emulator systemu z procesorem m68k.
320
321%package system-microblaze
322Summary: QEMU system emulator for MicroBlaze
323Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MicroBlaze
324Group: Development/Tools
325Requires: %{name}-common = %{version}-%{release}
326%systempkg_req
327Obsoletes: qemu-kvm-system-microblaze
328
329%description system-microblaze
330QEMU is a generic and open source processor emulator which achieves a
331good emulation speed by using dynamic translation.
332
333This package provides the system emulator with MicroBlaze CPU.
334
335%description system-microblaze -l pl.UTF-8
336QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
337dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
338
339Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
340
341%package system-mips
342Summary: QEMU system emulator for MIPS
343Summary(pl.UTF-8): QEMU - emulator systemu z procesorem MIPS
344Group: Development/Tools
345Requires: %{name}-common = %{version}-%{release}
346%systempkg_req
347Obsoletes: qemu-kvm-system-mips
348
349%description system-mips
350QEMU is a generic and open source processor emulator which achieves a
351good emulation speed by using dynamic translation.
352
353This package provides the system emulator with MIPS CPU.
354
355%description system-mips -l pl.UTF-8
356QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
357dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
358
359Ten pakiet zawiera emulator systemu z procesorem MIPS.
360
361%package system-moxie
362Summary: QEMU system emulator for Moxie
363Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Moxie
364Group: Development/Tools
365Requires: %{name}-common = %{version}-%{release}
366%systempkg_req
367
368%description system-moxie
369QEMU is a generic and open source processor emulator which achieves a
370good emulation speed by using dynamic translation.
371
372This package provides the system emulator with Moxie CPU.
373
374%description system-moxie -l pl.UTF-8
375QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
376dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
377
378Ten pakiet zawiera emulator systemu z procesorem Moxie.
379
380%package system-or32
381Summary: QEMU system emulator for OpenRISC
382Summary(pl.UTF-8): QEMU - emulator systemu z procesorem OpenRISC
383Group: Development/Tools
384Requires: %{name}-common = %{version}-%{release}
385%systempkg_req
386Obsoletes: qemu-kvm-system-or32
387
388%description system-or32
389QEMU is a generic and open source processor emulator which achieves a
390good emulation speed by using dynamic translation.
391
392This package provides the system emulator with OpenRISC CPU.
393
394%description system-or32 -l pl.UTF-8
395QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
396dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
397
398Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
399
400%package system-ppc
401Summary: QEMU system emulator for PowerPC
402Summary(pl.UTF-8): QEMU - emulator systemu z procesorem PowerPC
403Group: Development/Tools
404Requires: %{name}-common = %{version}-%{release}
405%systempkg_req
406Obsoletes: qemu-kvm-system-ppc
407
408%description system-ppc
409QEMU is a generic and open source processor emulator which achieves a
410good emulation speed by using dynamic translation.
411
412This package provides the system emulator with PowerPC CPU.
413
414%description system-ppc -l pl.UTF-8
415QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
416dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
417
418Ten pakiet zawiera emulator systemu z procesorem PowerPC.
419
420%package system-s390x
421Summary: QEMU system emulator for S390
422Summary(pl.UTF-8): QEMU - emulator systemu z procesorem S390
423Group: Development/Tools
424Requires: %{name}-common = %{version}-%{release}
425%systempkg_req
426Obsoletes: qemu-kvm-system-s390x
427
428%description system-s390x
429QEMU is a generic and open source processor emulator which achieves a
430good emulation speed by using dynamic translation.
431
432This package provides the system emulator with S390 CPU.
433
434%description system-s390x -l pl.UTF-8
435QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
436dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
437
438Ten pakiet zawiera emulator systemu z procesorem S390.
439
440%package system-sh4
441Summary: QEMU system emulator for SH4
442Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SH4
443Group: Development/Tools
444Requires: %{name}-common = %{version}-%{release}
445%systempkg_req
446Obsoletes: qemu-kvm-system-sh4
447
448%description system-sh4
449QEMU is a generic and open source processor emulator which achieves a
450good emulation speed by using dynamic translation.
451
452This package provides the system emulator with SH4 CPU.
453
454%description system-sh4 -l pl.UTF-8
455QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
456dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
457
458Ten pakiet zawiera emulator systemu z procesorem SH4.
459
460%package system-sparc
461Summary: QEMU system emulator for SPARC
462Summary(pl.UTF-8): QEMU - emulator systemu z procesorem SPARC
463Group: Development/Tools
464Requires: %{name}-common = %{version}-%{release}
465%systempkg_req
466Obsoletes: qemu-kvm-system-sparc
467
468%description system-sparc
469QEMU is a generic and open source processor emulator which achieves a
470good emulation speed by using dynamic translation.
471
472This package provides the system emulator with SPARC/SPARC64 CPU.
473
474%description system-sparc -l pl.UTF-8
475QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
476dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
477
478Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
479
480%package system-unicore32
481Summary: QEMU system emulator for UniCore32
482Summary(pl.UTF-8): QEMU - emulator systemu z procesorem UniCore32
483Group: Development/Tools
484Requires: %{name}-common = %{version}-%{release}
485%systempkg_req
486Obsoletes: qemu-kvm-system-unicore32
487
488%description system-unicore32
489QEMU is a generic and open source processor emulator which achieves a
490good emulation speed by using dynamic translation.
491
492This package provides the system emulator with UniCore32 CPU.
493
494%description system-unicore32 -l pl.UTF-8
495QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
496dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
497
498Ten pakiet zawiera emulator systemu z procesorem UniCore32.
499
500%package system-x86
501Summary: QEMU system emulator for x86
502Summary(pl.UTF-8): QEMU - emulator systemu z procesorem x86
503Group: Development/Tools
504Requires: %{name}-common = %{version}-%{release}
505%systempkg_req
506Obsoletes: qemu-kvm-system-x86
507
508%description system-x86
509QEMU is a generic and open source processor emulator which achieves a
510good emulation speed by using dynamic translation.
511
512%description system-x86 -l pl.UTF-8
513QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
514dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
515
516%package system-xtensa
517Summary: QEMU system emulator for Xtensa
518Summary(pl.UTF-8): QEMU - emulator systemu z procesorem Xtensa
519Group: Development/Tools
520Requires: %{name}-common = %{version}-%{release}
521%systempkg_req
522Obsoletes: qemu-kvm-system-xtensa
523
524%description system-xtensa
525QEMU is a generic and open source processor emulator which achieves a
526good emulation speed by using dynamic translation.
527
528This package provides the system emulator with Xtensa CPU.
529
530%description system-xtensa -l pl.UTF-8
531QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
532dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
533
534Ten pakiet zawiera emulator systemu z procesorem Xtensa.
535
536%package guest-agent
537Summary: QEMU guest agent
538Summary(pl.UTF-8): Agent gościa QEMU
539Group: Daemons
540Requires(post,preun,postun): systemd-units >= 38
541Requires: glib2 >= 1:2.12
542Requires: systemd-units >= 38
543Obsoletes: qemu-kvm-guest-agent
544
545%description guest-agent
546QEMU is a generic and open source processor emulator which achieves
547a good emulation speed by using dynamic translation.
548
549This package provides an agent to run inside guests, which
550communicates with the host over a virtio-serial channel named
551"org.qemu.guest_agent.0".
552
553This package does not need to be installed on the host OS.
554
555%description guest-agent -l pl.UTF-8
556QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
557dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
558
559Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
560systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
561"org.qemu.guest_agent.0".
562
563Ten pakiet nie musi być zainstalowany w systemie hosta.
564
565%prep
566%setup -q
567%patch0 -p1
568%patch1 -p1
569%patch2 -p0
570%patch3 -p1
571
572%{__mv} libcacard libcacard-use-system-lib
573
574# workaround for conflict with alsa/error.h
575ln -s ../error.h qapi/error.h
576
577%build
578./configure \
579 --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
580 --extra-ldflags="%{rpmldflags}" \
581 --prefix=%{_prefix} \
582 --sysconfdir=%{_sysconfdir} \
583 --cc="%{__cc}" \
584 --host-cc="%{__cc}" \
585 --disable-strip \
586 --enable-attr \
587 --enable-bluez \
588 --enable-brlapi \
589 --enable-cap-ng \
590 --enable-curl \
591 --enable-curses \
592 --enable-docs \
593 --enable-fdt \
594 %{__enable_disable glusterfs} \
595 --enable-libiscsi \
596 --enable-mixemu \
597 %{__enable_disable glx} \
598 %{__enable_disable ceph rbd} \
599 %{__enable_disable rdma} \
600 %{__enable_disable sdl} \
601 --enable-seccomp \
602 %{__enable_disable spice} \
603 --enable-smartcard-nss \
604 --enable-tpm \
605 --enable-usb-redir \
606 --enable-uuid \
607 --enable-vde \
608 --enable-virtfs \
609 --enable-vnc-jpeg \
610 --enable-vnc-png \
611 --enable-vnc-sasl \
612 --enable-vnc-tls \
613 --enable-kvm \
614 %{__enable_disable xen} \
615 --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
616 --interp-prefix=%{_libdir}/qemu/lib-%%M \
617 --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
618
619# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
620# --libexecdir in configure is nop
621%{__make} \
622 V=1 \
623 CONFIG_QEMU_HELPERDIR="%{_libdir}"
624
625# rebuild patched vesa tables with additional widescreen modes.
626%{__make} -C roms/vgabios stdvga-bios
627
628%install
629rm -rf $RPM_BUILD_ROOT
630install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
631 $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
632 $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
633
634%{__make} install \
635 DESTDIR=$RPM_BUILD_ROOT \
636 libexecdir=%{_libdir}
637
638install -d $RPM_BUILD_ROOT%{_sysconfdir}
639cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
640#!/bin/sh
641
642EOF
643
644# For the qemu-guest-agent subpackage install the systemd
645# service and udev rules.
646install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
647install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
648
649# already packaged
650%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
651%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
652
653# install patched vesa tables with additional widescreen modes.
654cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
655
656%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
657%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
658%find_lang %{name}
659
660%clean
661rm -rf $RPM_BUILD_ROOT
662
663%pre common
664%groupadd -g 276 qemu
665%useradd -u 276 -g qemu -c "QEMU User" qemu
666
667%postun common
668if [ "$1" = "0" ]; then
669 %userremove qemu
670 %groupremove qemu
671fi
672
673%post guest-agent
674%systemd_reload
675
676%preun guest-agent
677%systemd_preun qemu-guest-agent.service
678
679%postun guest-agent
680%systemd_reload
681
682%files
683%defattr(644,root,root,755)
684
685%files common -f %{name}.lang
686%defattr(644,root,root,755)
687%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
688%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
689%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
690%dir %{_sysconfdir}/qemu
691%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
692%attr(755,root,root) %{_bindir}/qemu-nbd
693%attr(755,root,root) %{_libdir}/qemu-bridge-helper
694%{_mandir}/man1/qemu.1*
695%{_mandir}/man1/virtfs-proxy-helper.1*
696%{_mandir}/man8/qemu-nbd.8*
697
698%dir %{_datadir}/qemu
699%{_datadir}/%{name}/keymaps
700%{_datadir}/%{name}/qemu-icon.bmp
701# various bios images
702%{_datadir}/%{name}/*.aml
703%{_datadir}/%{name}/*.bin
704%{_datadir}/%{name}/*.rom
705%{_datadir}/%{name}/*.dtb
706%{_datadir}/%{name}/qemu_logo_no_text.svg
707%{_datadir}/%{name}/openbios-ppc
708%{_datadir}/%{name}/openbios-sparc*
709%{_datadir}/%{name}/palcode-clipper
710%{_datadir}/%{name}/s390-ccw.img
711
712%files img
713%defattr(644,root,root,755)
714%attr(755,root,root) %{_bindir}/qemu-img
715%{_mandir}/man1/qemu-img.1*
716
717%files user
718%defattr(644,root,root,755)
719%attr(755,root,root) %{_bindir}/qemu-alpha
720%attr(755,root,root) %{_bindir}/qemu-arm
721%attr(755,root,root) %{_bindir}/qemu-armeb
722%attr(755,root,root) %{_bindir}/qemu-cris
723%attr(755,root,root) %{_bindir}/qemu-i386
724%attr(755,root,root) %{_bindir}/qemu-io
725%attr(755,root,root) %{_bindir}/qemu-m68k
726%attr(755,root,root) %{_bindir}/qemu-microblaze
727%attr(755,root,root) %{_bindir}/qemu-microblazeel
728%attr(755,root,root) %{_bindir}/qemu-mips
729%attr(755,root,root) %{_bindir}/qemu-mipsel
730%attr(755,root,root) %{_bindir}/qemu-mips64
731%attr(755,root,root) %{_bindir}/qemu-mips64el
732%attr(755,root,root) %{_bindir}/qemu-mipsn32
733%attr(755,root,root) %{_bindir}/qemu-mipsn32el
734%attr(755,root,root) %{_bindir}/qemu-or32
735%attr(755,root,root) %{_bindir}/qemu-ppc
736%attr(755,root,root) %{_bindir}/qemu-ppc64
737%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
738%attr(755,root,root) %{_bindir}/qemu-s390x
739%attr(755,root,root) %{_bindir}/qemu-sh4
740%attr(755,root,root) %{_bindir}/qemu-sh4eb
741%attr(755,root,root) %{_bindir}/qemu-sparc
742%attr(755,root,root) %{_bindir}/qemu-sparc32plus
743%attr(755,root,root) %{_bindir}/qemu-sparc64
744%attr(755,root,root) %{_bindir}/qemu-unicore32
745%attr(755,root,root) %{_bindir}/qemu-x86_64
746
747%files system-alpha
748%defattr(644,root,root,755)
749%attr(755,root,root) %{_bindir}/qemu-system-alpha
750
751%files system-arm
752%defattr(644,root,root,755)
753%attr(755,root,root) %{_bindir}/qemu-system-arm
754
755%files system-cris
756%defattr(644,root,root,755)
757%attr(755,root,root) %{_bindir}/qemu-system-cris
758
759%files system-lm32
760%defattr(644,root,root,755)
761%attr(755,root,root) %{_bindir}/qemu-system-lm32
762
763%files system-m68k
764%defattr(644,root,root,755)
765%attr(755,root,root) %{_bindir}/qemu-system-m68k
766
767%files system-microblaze
768%defattr(644,root,root,755)
769%attr(755,root,root) %{_bindir}/qemu-system-microblaze
770%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
771
772%files system-mips
773%defattr(644,root,root,755)
774%attr(755,root,root) %{_bindir}/qemu-system-mips
775%attr(755,root,root) %{_bindir}/qemu-system-mipsel
776%attr(755,root,root) %{_bindir}/qemu-system-mips64
777%attr(755,root,root) %{_bindir}/qemu-system-mips64el
778
779%files system-moxie
780%defattr(644,root,root,755)
781%attr(755,root,root) %{_bindir}/qemu-system-moxie
782
783%files system-or32
784%defattr(644,root,root,755)
785%attr(755,root,root) %{_bindir}/qemu-system-or32
786
787%files system-ppc
788%defattr(644,root,root,755)
789%attr(755,root,root) %{_bindir}/qemu-system-ppc
790%attr(755,root,root) %{_bindir}/qemu-system-ppc64
791%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
792
793%files system-s390x
794%defattr(644,root,root,755)
795%attr(755,root,root) %{_bindir}/qemu-system-s390x
796
797%files system-sh4
798%defattr(644,root,root,755)
799%attr(755,root,root) %{_bindir}/qemu-system-sh4
800%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
801
802%files system-sparc
803%defattr(644,root,root,755)
804%attr(755,root,root) %{_bindir}/qemu-system-sparc
805%attr(755,root,root) %{_bindir}/qemu-system-sparc64
806
807%files system-unicore32
808%defattr(644,root,root,755)
809%attr(755,root,root) %{_bindir}/qemu-system-unicore32
810
811%files system-x86
812%defattr(644,root,root,755)
813%attr(755,root,root) %{_bindir}/qemu-system-i386
814%attr(755,root,root) %{_bindir}/qemu-system-x86_64
815
816%files system-xtensa
817%defattr(644,root,root,755)
818%attr(755,root,root) %{_bindir}/qemu-system-xtensa
819%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
820
821%files guest-agent
822%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
823%{systemdunitdir}/qemu-guest-agent.service
824%attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.080891 seconds and 4 git commands to generate.