]> git.pld-linux.org Git - packages/python.git/blame_incremental - python.spec
- adjust for new lib64 patch
[packages/python.git] / python.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tkinter # disables tkinter module building
4%bcond_without tests # disables Python testing
5%bcond_with verbose_tests # runs tests in verbose mode
6#
7# tests which will not work on 64-bit platforms
8%define no64bit_tests test_audioop test_rgbimg test_imageop
9# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
10%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
11# tests which fail because of some unknown/unresolved reason (this list should be empty)
12%define broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
13# test_distutils fails for unknown reason:
14# AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
15
16%define py_ver 2.4
17%define py_prefix %{_prefix}
18%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
19%define py_incdir %{_includedir}/python%{py_ver}
20%define py_sitedir %{py_libdir}/site-packages
21%define py_dyndir %{py_libdir}/lib-dynload
22
23Summary: Very high level scripting language with X interface
24Summary(es): Lenguaje script de alto nivel con interfaz X
25