]> git.pld-linux.org Git - packages/python-pytest.git/blame_incremental - python-pytest.spec
- disable also tests requiring ptys (not available on builders)
[packages/python-pytest.git] / python-pytest.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without doc # HTML documentation build
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6%bcond_without tests # unit tests
7
8%define pylib_version 1.5.0
9%define module pytest
10Summary: Simple and popular testing tool for Python
11Summary(pl.UTF-8): Proste i popularne narzędzie testujące dla Pythona
12Name: python-%{module}
13Version: 4.6.11
14Release: 1
15License: MIT
16Group: Development/Languages/Python
17#Source0Download: https://pypi.org/simple/pytest/
18Source0: https://files.pythonhosted.org/packages/source/p/pytest/pytest-%{version}.tar.gz
19# Source0-md5: 26cf20887076ad8a7beccfb5e9c44d04
20Patch0: %{name}-tests.patch
21URL: https://pytest.org/
22%if %{with python2}
23BuildRequires: python-devel >= 1:2.7
24BuildRequires: python-modules >= 1:2.7
25BuildRequires: python-py >= %{pylib_version}
26BuildRequires: python-setuptools >= 1:40.0
27BuildRequires: python-setuptools_scm
28%if %{with tests}
29BuildRequires: pydoc >= 1:2.7
30BuildRequires: python-argcomplete
31BuildRequires: python-atomicwrites >= 1.0
32BuildRequires: python-attrs >= 17.4.0
33BuildRequires: python-funcsigs >= 1.0
34BuildRequires: python-hypothesis >= 3.56
35BuildRequires: python-importlib_metadata >= 0.12
36BuildRequires: python-mock
37BuildRequires: python-more_itertools >= 4.0.0
38BuildRequires: python-more_itertools < 6.0.0
39BuildRequires: python-nose
40BuildRequires: python-packaging
41BuildRequires: python-pathlib2 >= 2.2.0
42BuildRequires: python-pluggy >= 0.12
43BuildRequires: python-pluggy < 1.0
44BuildRequires: python-requests
45BuildRequires: python-six >= 1.10.0
46BuildRequires: python-wcwidth
47BuildConflicts: python-pytest-benchmark < 3.2.1
48# outdated
49BuildConflicts: python-pytest-catchlog
50# with xdist requires various modules source and breaks other things
51BuildConflicts: python-pytest-xdist
52%endif
53%endif
54%if %{with python3}
55BuildRequires: python3-devel >= 1:3.4
56BuildRequires: python3-modules >= 1:3.4
57BuildRequires: python3-py >= %{pylib_version}
58BuildRequires: python3-setuptools >= 1:40.0
59BuildRequires: python3-setuptools_scm
60%if %{with tests}
61BuildRequires: pydoc3 >= 1:3.4
62BuildRequires: python3-argcomplete
63BuildRequires: python3-atomicwrites >= 1.0
64BuildRequires: python3-attrs >= 17.4.0
65BuildRequires: python3-hypothesis >= 3.56
66%if "%{py3_ver}" < "3.8"
67BuildRequires: python3-importlib_metadata >= 0.12
68%endif
69BuildRequires: python3-more_itertools >= 4.0.0
70BuildRequires: python3-nose
71BuildRequires: python3-packaging
72%if "%{py3_ver}" < "3.6"
73BuildRequires: python3-pathlib2 >= 2.2.0
74%endif
75BuildRequires: python3-pluggy >= 0.12
76BuildRequires: python3-pluggy < 1.0
77BuildRequires: python3-requests
78BuildRequires: python3-six >= 1.10.0
79BuildRequires: python3-wcwidth
80BuildConflicts: python3-pytest-benchmark < 3.2.1
81# outdated
82BuildConflicts: python3-pytest-catchlog
83# seems to break things
84BuildConflicts: python3-pytest-xdist
85%endif
86%endif
87BuildRequires: rpm-pythonprov
88BuildRequires: rpmbuild(macros) >= 1.714
89BuildRequires: sed >= 4.0
90%if %{with doc}
91BuildRequires: python3-pygments_pytest
92BuildRequires: python3-sphinx_removed_in >= 0.2.0
93BuildRequires: python3-sphinxcontrib-trio
94BuildRequires: sphinx-pdg-3 >= 1.8.2
95%endif
96Requires: python-modules >= 1:2.7
97Requires: python-setuptools
98Obsoletes: python-pytest-cache < 1.1
99Obsoletes: python-pytest-catchlog < 1.2.3
100BuildArch: noarch
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103%description
104py.test is a simple and popular testing tool for Python.
105
106%description -l pl.UTF-8
107py.test to proste i popularne narzędzie testujące dla Pythona.
108
109%package -n python3-pytest
110Summary: Simple powerful testing with Python
111Summary(pl.UTF-8): Proste, ale funkcjonalne narzędzie testujące dla Pythona
112Group: Development/Languages
113Requires: python3-devel-tools >= 1:3.4
114Requires: python3-setuptools
115Obsoletes: python3-pytest-cache < 1.1
116Obsoletes: python3-pytest-catchlog < 1.2.3
117
118%description -n python3-pytest
119py.test provides simple, yet powerful testing for Python.
120
121%description -n python3-pytest -l pl.UTF-8
122py.test to proste, ale bardzo funkcjonalne narzędzie testujące dla
123Pythona.
124
125%package apidocs
126Summary: Documentation for py.test Pythona package
127Summary(pl.UTF-8): Dokumentacja pakietu Pythona py.test
128Group: Documentation
129
130%description apidocs
131Documentation for py.test Pythona package.
132
133%description apidocs -l pl.UTF-8
134Dokumentacja pakietu Pythona py.test.
135
136%prep
137%setup -q -n %{module}-%{version}
138%patch0 -p1
139
140%build
141export PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
142%if %{with python2}
143%py_build
144
145%if %{with tests}
146# test_pdb_custom_cls_with_settrace fails without preinstalled pytest
147# test_cache_writefail_permissions, test_cache_failure_warns makes tests unreliable due to post-test cleanup failures
148# test_pytester.py, test_terminal.py, test_unittest.py need ptys to spawn processes with terminal
149PYTHONPATH=$(pwd)/src \
150%{__python} -m pytest -k 'not (test_pdb or test_cache_writefail_permissions or test_cache_failure_warns or test_pytester or test_terminal or test_unittest)' testing
151%endif
152%endif
153
154%if %{with python3}
155%py3_build
156
157%if %{with tests}
158# test_pdb_custom_cls_with_settrace fails without preinstalled pytest
159# test_pdb_* which spawn pdb hang under some unclear conditions
160# test_cache_writefail_permissions, test_cache_failure_warns makes tests unreliable due to post-test cleanup failures
161# test_pytester.py, test_terminal.py, test_unittest.py need ptys to spawn processes with terminal
162PYTHONPATH=$(pwd)/src \
163%{__python3} -m pytest -k 'not (test_pdb or test_cache_writefail_permissions or test_cache_failure_warns or test_pytester or test_terminal or test_unittest)' testing
164%endif
165%endif
166
167%if %{with doc}
168for l in doc/*; do
169 PYTHONPATH=$(pwd)/src \
170 %{__make} -C $l html \
171 SPHINXBUILD=sphinx-build-3
172done
173%endif
174
175%install
176rm -rf $RPM_BUILD_ROOT
177
178%if %{with python3}
179%py3_install
180
181%{__mv} $RPM_BUILD_ROOT%{_bindir}/py.test{,-3}
182%{__mv} $RPM_BUILD_ROOT%{_bindir}/pytest{,-3}
183%endif
184
185%if %{with python2}
186%py_install
187
188ln $RPM_BUILD_ROOT%{_bindir}/py.test{,-2}
189ln $RPM_BUILD_ROOT%{_bindir}/pytest{,-2}
190
191# pytest.py source seems required for "monkeypatching" tests
192%py_postclean -x pytest.py
193%endif
194
195%clean
196rm -rf $RPM_BUILD_ROOT
197
198%if %{with python2}
199%files
200%defattr(644,root,root,755)
201%doc AUTHORS CHANGELOG.rst LICENSE README.rst
202%attr(755,root,root) %{_bindir}/py.test
203%attr(755,root,root) %{_bindir}/py.test-2
204%attr(755,root,root) %{_bindir}/pytest
205%attr(755,root,root) %{_bindir}/pytest-2
206%{py_sitescriptdir}/pytest.py*
207%{py_sitescriptdir}/_pytest
208%{py_sitescriptdir}/pytest-%{version}-py*.egg-info
209%endif
210
211%if %{with python3}
212%files -n python3-pytest
213%defattr(644,root,root,755)
214%doc AUTHORS CHANGELOG.rst LICENSE README.rst
215%attr(755,root,root) %{_bindir}/py.test-3
216%attr(755,root,root) %{_bindir}/pytest-3
217%{py3_sitescriptdir}/pytest.py
218%{py3_sitescriptdir}/_pytest
219%{py3_sitescriptdir}/__pycache__/pytest.*.py[co]
220%{py3_sitescriptdir}/pytest-%{version}-py*.egg-info
221%endif
222
223%if %{with doc}
224%files apidocs
225%defattr(644,root,root,755)
226%doc doc/en/_build/html/{_images,_modules,_static,announce,example,proposals,*.html,*.js}
227%endif
This page took 0.0508 seconds and 4 git commands to generate.