]> git.pld-linux.org Git - packages/python-cryptography.git/blame_incremental - python-cryptography.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-cryptography.git] / python-cryptography.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Crypthography library for Python 2
7Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 2
8Name: python-cryptography
9Version: 0.8.2
10Release: 4
11License: Apache v2.0 or BSD
12Group: Libraries/Python
13Source0: https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
14# Source0-md5: 7d33499e851300c194cbb0396de72462
15URL: https://cryptography.io/
16BuildRequires: openssl-devel >= 0.9.8
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.710
19%if %{with python2}
20BuildRequires: python-cffi >= 0.8
21BuildRequires: python-devel >= 1:2.6
22BuildRequires: python-enum34
23BuildRequires: python-pyasn1
24BuildRequires: python-setuptools
25BuildRequires: python-six >= 1.4.1
26%endif
27%if %{with python3}
28BuildRequires: python3-cffi >= 0.8
29BuildRequires: python3-devel >= 1:3.2
30BuildRequires: python3-pyasn1
31BuildRequires: python3-setuptools
32BuildRequires: python3-six >= 1.4.1
33%endif
34Requires: python-cffi >= 0.8
35Requires: python-six >= 1.4.1
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39cryptography is a package designed to expose cryptographic recipes and
40primitives to Python developers. Our goal is for it to be your
41"cryptographic standard library". It supports Python 2.6-2.7, Python
423.2+, and PyPy.
43
44cryptography includes both high level recipes, and low level
45interfaces to common cryptographic algorithms such as symmetric
46ciphers, message digests and key derivation functions.
47
48This package contains Python 2 modules.
49
50%description -l pl.UTF-8
51cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
52obiektów kryptograficznych programistom Pythona. Celem jest
53dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
54Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
55
56cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
57niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
58takich jak szyfry symetryczne, skróty wiadomości czy funkcje
59wyprowadzające klucze.
60
61Ten pakiet zawiera moduły Pythona 2.
62
63%package -n python3-cryptography
64Summary: Crypthography library for Python 3
65Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
66Group: Libraries/Python
67Requires: python3-cffi >= 0.8
68Requires: python3-six >= 1.4.1
69
70%description -n python3-cryptography
71cryptography is a package designed to expose cryptographic recipes and
72primitives to Python developers. Our goal is for it to be your
73"cryptographic standard library". It supports Python 2.6-2.7, Python
743.2+, and PyPy.
75
76cryptography includes both high level recipes, and low level
77interfaces to common cryptographic algorithms such as symmetric
78ciphers, message digests and key derivation functions.
79
80This package contains Python 3 modules.
81
82%description -n python3-cryptography -l pl.UTF-8
83cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
84obiektów kryptograficznych programistom Pythona. Celem jest
85dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
86Pythona 2.6-2.7, Pythona 3.2+ oraz PyPy.
87
88cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
89niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
90takich jak szyfry symetryczne, skróty wiadomości czy funkcje
91wyprowadzające klucze.
92
93Ten pakiet zawiera moduły Pythona 3.
94
95%prep
96%setup -q -n cryptography-%{version}
97
98%build
99export CFLAGS="%{rpmcflags}"
100
101%if %{with python2}
102%py_build \
103 --build-base build-2
104%endif
105
106%if %{with python2}
107%py3_build \
108 --build-base build-3
109%endif
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%if %{with python2}
115%py_install
116
117%py_postclean
118%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/bindings/__pycache__/*.c
119%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
120%endif
121
122%if %{with python3}
123%py3_install
124
125%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/cryptography/hazmat/primitives/src/*.[ch]
126%endif
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%if %{with python2}
132%files
133%defattr(644,root,root,755)
134%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
135%dir %{py_sitedir}/cryptography
136%attr(755,root,root) %{py_sitedir}/cryptography/_*_cffi_*.so
137%{py_sitedir}/cryptography/*.py[co]
138%dir %{py_sitedir}/cryptography/hazmat
139%{py_sitedir}/cryptography/hazmat/*.py[co]
140%dir %{py_sitedir}/cryptography/hazmat/backends
141%{py_sitedir}/cryptography/hazmat/backends/*.py[co]
142%dir %{py_sitedir}/cryptography/hazmat/backends/commoncrypto
143%{py_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py[co]
144%dir %{py_sitedir}/cryptography/hazmat/backends/openssl
145%{py_sitedir}/cryptography/hazmat/backends/openssl/*.py[co]
146%dir %{py_sitedir}/cryptography/hazmat/bindings
147%{py_sitedir}/cryptography/hazmat/bindings/*.py[co]
148%dir %{py_sitedir}/cryptography/hazmat/bindings/commoncrypto
149%{py_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py[co]
150%dir %{py_sitedir}/cryptography/hazmat/bindings/openssl
151%{py_sitedir}/cryptography/hazmat/bindings/openssl/*.py[co]
152%dir %{py_sitedir}/cryptography/hazmat/primitives/interfaces
153%{py_sitedir}/cryptography/hazmat/primitives/interfaces/*.py[co]
154%dir %{py_sitedir}/cryptography/hazmat/primitives
155%{py_sitedir}/cryptography/hazmat/primitives/*.py[co]
156%dir %{py_sitedir}/cryptography/hazmat/primitives/asymmetric
157%{py_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py[co]
158%dir %{py_sitedir}/cryptography/hazmat/primitives/ciphers
159%{py_sitedir}/cryptography/hazmat/primitives/ciphers/*.py[co]
160%dir %{py_sitedir}/cryptography/hazmat/primitives/kdf
161%{py_sitedir}/cryptography/hazmat/primitives/kdf/*.py[co]
162%dir %{py_sitedir}/cryptography/hazmat/primitives/twofactor
163%{py_sitedir}/cryptography/hazmat/primitives/twofactor/*.py[co]
164%{py_sitedir}/cryptography-%{version}-py*.egg-info
165%endif
166
167%if %{with python3}
168%files -n python3-cryptography
169%defattr(644,root,root,755)
170%doc AUTHORS.rst README.rst LICENSE.APACHE LICENSE.BSD
171%dir %{py3_sitedir}/cryptography
172%attr(755,root,root) %{py3_sitedir}/cryptography/_*_cffi_*.so
173%{py3_sitedir}/cryptography/*.py
174%{py3_sitedir}/cryptography/__pycache__
175%dir %{py3_sitedir}/cryptography/hazmat
176%{py3_sitedir}/cryptography/hazmat/*.py
177%{py3_sitedir}/cryptography/hazmat/__pycache__
178%dir %{py3_sitedir}/cryptography/hazmat/backends
179%{py3_sitedir}/cryptography/hazmat/backends/*.py
180%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
181%dir %{py3_sitedir}/cryptography/hazmat/backends/commoncrypto
182%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/*.py
183%{py3_sitedir}/cryptography/hazmat/backends/commoncrypto/__pycache__
184%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
185%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
186%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
187%dir %{py3_sitedir}/cryptography/hazmat/bindings
188%{py3_sitedir}/cryptography/hazmat/bindings/*.py
189%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
190%dir %{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto
191%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/*.py
192%{py3_sitedir}/cryptography/hazmat/bindings/commoncrypto/__pycache__
193%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
194%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
195%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
196%dir %{py3_sitedir}/cryptography/hazmat/primitives/interfaces
197%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/*.py
198%{py3_sitedir}/cryptography/hazmat/primitives/interfaces/__pycache__
199%dir %{py3_sitedir}/cryptography/hazmat/primitives
200%{py3_sitedir}/cryptography/hazmat/primitives/*.py
201%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
202%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
203%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
204%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
205%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
206%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
207%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
208%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
209%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
210%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
211%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
212%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
213%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
214%{py3_sitedir}/cryptography-%{version}-py*.egg-info
215%endif
This page took 0.18932 seconds and 4 git commands to generate.