]> git.pld-linux.org Git - packages/python-billiard.git/blame_incremental - python-billiard.spec
Release 6 (by relup.sh)
[packages/python-billiard.git] / python-billiard.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module billiard
9Summary: Multiprocessing Pool Extensions
10Summary(pl.UTF-8): Rozszerzenia puli procesów
11Name: python-%{module}
12# keep 3.x here for python2 support
13Version: 3.6.4.0
14Release: 6
15License: BSD
16Group: Libraries/Python
17#Source0Download: https://pypi.org/simple/billiard/
18Source0: https://files.pythonhosted.org/packages/source/b/billiard/%{module}-%{version}.tar.gz
19# Source0-md5: b49503b8a78743dcb6a86accea379357
20URL: https://github.com/celery/billiard
21BuildRequires: rpm-pythonprov
22BuildRequires: rpmbuild(macros) >= 1.752
23%if %{with python2}
24BuildRequires: python-devel >= 1:2.7
25BuildRequires: python-setuptools >= 1:40.0.0
26%if %{with tests}
27BuildRequires: python-case >= 1.3.1
28BuildRequires: python-psutil >= 5.8.0
29BuildRequires: python-pytest
30%endif
31%if %{with doc}
32BuildRequires: sphinx-pdg-2
33%endif
34%endif
35%if %{with python3}
36BuildRequires: python3-devel >= 1:3.5
37BuildRequires: python3-setuptools >= 1:40.0.0
38%if %{with tests}
39BuildRequires: python3-case >= 1.3.1
40BuildRequires: python3-psutil >= 5.8.0
41BuildRequires: python3-pytest
42%endif
43%endif
44Requires: python-modules >= 1:2.7
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
48billiard is a fork of the Python 2.7 multiprocessing package. The
49multiprocessing package itself is a renamed and updated version of R
50Oudkerk's pyprocessing package. This standalone variant draws its
51fixes/improvements from python-trunk and provides additional bug fixes
52and improvements.
53
54%description -l pl.UTF-8
55billiard to odgałęzienie pakietu multiprocessing z Pythona 2.7. Pakiet
56multiprocessing to uaktualniona wersja pakietu pyprocessing R Oudkerka
57ze zmienioną nazwą. Samodzielny wariant czerpie poprawki i
58usprawnienia z najświeższego Pythona, ponadto zawiera dodatkowe
59poprawki błędów i ulepszenia.
60
61%package -n python3-%{module}
62Summary: Multiprocessing Pool Extensions
63Summary(pl.UTF-8): Rozszerzenia puli procesów
64Group: Libraries/Python
65Requires: python3-modules >= 1:3.5
66BuildArch: noarch
67
68%description -n python3-%{module}
69billiard is a fork of the Python 2.7 multiprocessing package. The
70multiprocessing package itself is a renamed and updated version of R
71Oudkerk's pyprocessing package. This standalone variant draws its
72fixes/improvements from python-trunk and provides additional bug fixes
73and improvements.
74
75%description -n python3-%{module} -l pl.UTF-8
76billiard to odgałęzienie pakietu multiprocessing z Pythona 2.7. Pakiet
77multiprocessing to uaktualniona wersja pakietu pyprocessing R Oudkerka
78ze zmienioną nazwą. Samodzielny wariant czerpie poprawki i
79usprawnienia z najświeższego Pythona, ponadto zawiera dodatkowe
80poprawki błędów i ulepszenia.
81
82%package apidocs
83Summary: API documentation for billiard module
84Summary(pl.UTF-8): Dokumentacja API modułu billiard
85Group: Documentation
86BuildArch: noarch
87
88%description apidocs
89API documentation for billiard module.
90
91%description apidocs -l pl.UTF-8
92Dokumentacja API modułu billiard.
93
94%prep
95%setup -q -n %{module}-%{version}
96
97%build
98%if %{with python2}
99%py_build
100
101%if %{with tests}
102PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
103%{__python} -m pytest t/unit
104%endif
105%endif
106
107%if %{with python3}
108%py3_build
109
110%if %{with tests}
111PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
112%{__python3} -m pytest t/unit
113%endif
114%endif
115
116%if %{with doc}
117cd Doc
118PYTHONPATH=$(pwd)/../build-2/lib \
119sphinx-build-2 -b html -d .build/doctrees . .build/html
120cd ..
121%endif
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%if %{with python2}
127%py_install
128
129%py_postclean
130%endif
131
132%if %{with python3}
133%py3_install
134%endif
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%if %{with python2}
140%files
141%defattr(644,root,root,755)
142%doc CHANGES.txt LICENSE.txt README.rst
143%dir %{py_sitedir}/%{module}
144%{py_sitedir}/%{module}/*.py[co]
145%dir %{py_sitedir}/%{module}/dummy
146%{py_sitedir}/%{module}/dummy/*.py[co]
147%attr(755,root,root) %{py_sitedir}/_billiard.so
148%{py_sitedir}/%{module}-%{version}-py*.egg-info
149%endif
150
151%if %{with python3}
152%files -n python3-%{module}
153%defattr(644,root,root,755)
154%doc CHANGES.txt LICENSE.txt README.rst
155%{py3_sitescriptdir}/%{module}
156%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
157%endif
158
159%if %{with doc}
160%files apidocs
161%defattr(644,root,root,755)
162%doc Doc/.build/html/{_static,library,*.html,*.js}
163%endif
This page took 0.0384 seconds and 4 git commands to generate.