]> git.pld-linux.org Git - packages/phpMyAdmin.git/blame_incremental - phpMyAdmin.spec
- up to 3.3.9.1
[packages/phpMyAdmin.git] / phpMyAdmin.spec
... / ...
CommitLineData
1# TODO
2# - add codepress (http://codepress.org/index.php) patch
3Summary: phpMyAdmin - web-based MySQL administration
4Summary(pl.UTF-8): phpMyAdmin - administracja bazami MySQL przez WWW
5Name: phpMyAdmin
6Version: 3.3.9.1
7Release: 1
8License: GPL v2
9Group: Applications/Databases/Interfaces
10Source0: http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11# Source0-md5: 1f36fb2c66bdbe6f8d165d7ae9244999
12Source1: %{name}.conf
13Source2: %{name}-lighttpd.conf
14Patch0: %{name}-config.patch
15Patch1: %{name}-ServerSelectDisplayName.patch
16Patch2: %{name}-ServerSelectDisplayName-config.patch
17URL: http://www.phpmyadmin.net/
18BuildRequires: rpmbuild(macros) >= 1.268
19Requires(triggerpostun): sed >= 4.0
20Requires: php-common >= 4:5.2
21Requires: php-ctype
22Requires: php-mbstring
23Requires: php-mcrypt
24Requires: php-mysql
25Requires: php-pcre
26Requires: php-session
27Requires: php-simplexml
28Requires: webapps
29Requires: webserver(access)
30Requires: webserver(alias)
31Suggests: php-mysqli
32Suggests: webserver(indexfile)
33Suggests: webserver(php)
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%define _appdir %{_datadir}/%{name}
38%define _webapps /etc/webapps
39%define _webapp %{name}
40%define _sysconfdir %{_webapps}/%{_webapp}
41
42%description
43phpMyAdmin can administer a whole MySQL-server (needs a super-user)
44but also a single database. To accomplish the latter you'll need a
45properly set up MySQL-user who can read/write only the desired
46database. It's up to you to look up the appropiate part in the MySQL
47manual. Currently phpMyAdmin can:
48- create and drop databases
49- create, copy, drop and alter tables
50- delete, edit and add fields
51- execute any SQL-statement, even batch-queries
52- manage keys on fields
53- load text files into tables
54- create (*) and read dumps of tables
55- export (*) and import data to CSV values
56- administer multiple servers and single databases
57- check referencial integrity
58- create complex queries automatically connecting required tables
59- create PDF graphics of your database layout
60- communicate in more than 50 different languages
61
62%description -l pl.UTF-8
63phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
64uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
65Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
66baz, którymi chcemy administrować (więcej informacji w odpowiedniej
67podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
68- tworzyć i usuwać bazy
69- wykonywać create, copy, drop oraz alter na tabelach
70- dodawać, usuwać i modyfikować pola
71- wykonywać dowolne zapytania SQL
72- zarządzać kluczami na rekordach
73- wczytywać tekst z plików do tabel
74- obsługiwać ponad 20 języków
75- zarządzać wieloma serwerami i pojedynczymi bazami danych
76- eksportować i importować dane do wartości CSV
77- tworzyć i czytać zrzuty tabel
78
79%prep
80%setup -q -n %{name}-%{version}-all-languages
81%patch0 -p1
82%patch1 -p0
83%patch2 -p0
84
85%install
86rm -rf $RPM_BUILD_ROOT
87install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth/swekey,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
88
89install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
90install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
91cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
92cp -rf themes $RPM_BUILD_ROOT%{_appdir}
93cp -rf js $RPM_BUILD_ROOT%{_appdir}
94install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
95install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
96install libraries/auth/swekey/*.{php,crt} $RPM_BUILD_ROOT%{_appdir}/libraries/auth/swekey
97install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
98install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
99install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
100install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
101install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
102install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
103install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
104install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
105
106install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
107ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
108
109install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
110install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
111install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
112
113cp -f libraries/import/README{,-import}
114cp -f libraries/transformations/README{,-transformations}
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%triggerin -- apache1 < 1.3.37-3, apache1-base
120%webapp_register apache %{_webapp}
121
122%triggerun -- apache1 < 1.3.37-3, apache1-base
123%webapp_unregister apache %{_webapp}
124
125%triggerin -- apache < 2.2.0, apache-base
126%webapp_register httpd %{_webapp}
127
128%triggerun -- apache < 2.2.0, apache-base
129%webapp_unregister httpd %{_webapp}
130
131%triggerin -- lighttpd
132%webapp_register lighttpd %{_webapp}
133
134%triggerun -- lighttpd
135%webapp_unregister lighttpd %{_webapp}
136
137%files
138%defattr(644,root,root,755)
139%doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
140%dir %attr(750,root,http) %{_sysconfdir}
141%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
142%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
143%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
144%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
145%dir %{_appdir}
146%{_appdir}/js
147%{_appdir}/lang
148%{_appdir}/libraries
149%{_appdir}/pmd
150%{_appdir}/themes
151%{_appdir}/*.css
152%{_appdir}/*.html
153%{_appdir}/*.php
This page took 0.036893 seconds and 4 git commands to generate.