]> git.pld-linux.org Git - packages/php.git/blame_incremental - php.spec
- add --sysconfdir to php-config for rpm macros; rel 3
[packages/php.git] / php.spec
... / ...
CommitLineData
1# TODO:
2# - think of including support for:
3# - mcve,
4# - ovrimos,
5# - pfpro,
6# These extensions BuildRequires proprietary libraries...
7# - deal with modules removed from php and not moved to PECL
8# removed from php 5.2:
9# filepro, hw
10# - mime_magic can't handle new "string/*" entries in magic.mime
11# thus doesn't work with system magic.mime database
12# - make additional headers added by mail patch configurable
13# - apply -hardened patch by default ?
14# - modularize session, standard (output from pure php -m)?
15#
16# Conditional build:
17%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
18%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
19%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
20%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
21%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
22%bcond_without curl # without CURL extension module
23%bcond_without filter # without filter extension module
24%bcond_without imap # without IMAP extension module
25%bcond_with interbase # with InterBase extension module
26%bcond_without ldap # without LDAP extension module
27%bcond_without mhash # without mhash extension module
28%bcond_without mime_magic # without mime-magic module
29%bcond_without ming # without ming extension module
30%bcond_without mm # without mm support for session storage
31%bcond_without mssql # without MS SQL extension module
32%bcond_without mysqli # without mysqli support (Requires mysql > 4.1)
33%bcond_without odbc # without ODBC extension module
34%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
35%bcond_without pcre # without PCRE extension module
36%bcond_without pgsql # without PostgreSQL extension module
37%bcond_without pspell # without pspell extension module
38%bcond_without recode # without recode extension module
39%bcond_without snmp # without SNMP extension module
40%bcond_without sqlite # without SQLite extension module
41%bcond_without sybase # without Sybase extension module
42%bcond_without sybase_ct # without Sybase-CT extension module
43%bcond_without tidy # without Tidy extension module
44%bcond_without wddx # without WDDX extension module
45%bcond_without xmlrpc # without XML-RPC extension module
46%bcond_without apache1 # disable building apache 1.3.x module
47%bcond_without apache2 # disable building apache 2.x module
48%bcond_without fcgi # disable building FCGI SAPI
49%bcond_without zts # disable experimental-zts
50%bcond_with versioning # build with experimental versioning (to load php4/php5 into same apache)
51
52%define apxs1 /usr/sbin/apxs1
53%define apxs2 /usr/sbin/apxs
54
55# some problems with apache 2.x
56%if %{with apache2}
57%undefine with_mm
58%endif
59
60%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
61%undefine with_interbase
62%endif
63
64%if !%{with apache1} && !%{with apache2}
65ERROR: You need to select at least one Apache SAPI to build shared modules.
66%endif
67
68# filter depends on pcre
69%if %{without pcre}
70%undefine with_filter
71%endif
72
73%define _rel 3
74Summary: PHP: Hypertext Preprocessor
75Summary(fr): Le langage de script embarque-HTML PHP
76