]> git.pld-linux.org Git - packages/php.git/blame_incremental - php.spec
- prefer db-4.2
[packages/php.git] / php.spec
... / ...
CommitLineData
1#
2# TODO:
3# - fastcgi option in cgi SAPI? or separate fcgi SAPI?
4# - make sure that session-unregister patch is no longer needed
5# (any crash reports related to session modules?)
6#
7# Automatic pear requirements finding:
8%include /usr/lib/rpm/macros.php
9
10%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
11%define apxs /usr/sbin/apxs
12
13%if %{_apache2}
14%define _without_recode 1
15%define _without_mm 1
16%endif
17
18%ifnarch %{ix86}
19%define _without_interbase 1
20%define _without_msession 1
21%endif
22
23# Conditional build:
24# _with_db3 - use db3 packages instead of db (4.x) for Berkeley DB support
25# _with_fdf - with FDF (PDF forms) module (BR: proprietary lib)
26# _with_interbase_inst - use InterBase install., not Firebird (BR: proprietary libs)
27# _with_java - with Java extension module (BR: jdk)
28# _with_oci8 - with Oracle oci8 extension module (BR: proprietary libs)
29# _with_oracle - with oracle extension module (BR: proprietary libs)
30# _without_cpdf - without cpdf extension module
31# _without_curl - without CURL extension module
32# _without_domxslt - without DOM XSLT/EXSLT support in DOM XML extension module
33# _without_fribidi - without FriBiDi extension module
34# _without_gif - build GD extension module with gd library without GIF support
35# _without_imap - without IMAP extension module
36# _without_interbase - without InterBase extension module
37# _without_ldap - without LDAP extension module
38# _without_mhash - without mhash extension module
39# _without_ming - without ming extension module
40# _without_mm - without mm support for session storage
41# _without_mnogosearch - without mnogosearch extension module
42# _without_msession - without msession extension module
43# _without_mssql - without MS SQL extension module
44# _without_odbc - without ODBC extension module
45# _without_openssl - without OpenSSL support and OpenSSL extension (module)
46# _without_pcre - without PCRE extension module
47# _without_pdf - without PDF extension module
48# _without_pgsql - without PostgreSQL extension module
49# _without_aspell - without pspell extension module
50# _without_recode - without recode extension module
51# _without_qtdom - without QT DOM extension module
52# _without_snmp - without SNMP extension module
53# _without_sybase - without Sybase and Sybase-CT extension modules
54# _without_wddx - without WDDX extension module
55# _without_xmlrpc - without XML-RPC extension module
56# _without_xml - without XML and DOMXML extension modules
57# _without_xslt - without XSLT extension module
58# _without_yaz - without YAZ extension module
59
60Summary: The PHP HTML-embedded scripting language for use with Apache
61Summary(fr): Le langage de script embarque-HTML PHP pour Apache
62