]> git.pld-linux.org Git - packages/php-pecl-mono.git/blame_incremental - php-pecl-mono.spec
- converted to UTF-8
[packages/php-pecl-mono.git] / php-pecl-mono.spec
... / ...
CommitLineData
1# TODO
2# - doesn't compile
3# - php-pecl-mono-0.7/mono-0.7/php_mono.c:33:37: mono/metadata/tabledefs.h: No such file or directory
4# - package examples into examplesdir
5%define _modname mono
6%define _status beta
7Summary: Allows you to access .NET assemblies from PHP
8Summary(pl.UTF-8): Pozwala na dostęp do wstawek .NET w PHP
9Name: php-pecl-%{_modname}
10Version: 0.7
11Release: 0.2
12License: PHP 2.02
13Group: Development/Languages/PHP
14Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
15# Source0-md5: 23639443898018a743250a62b1873a89
16URL: http://pecl.php.net/package/mono/
17BuildRequires: mono-devel
18BuildRequires: php-devel >= 3:5.0.0
19BuildRequires: rpmbuild(macros) >= 1.344
20%{?requires_php_extension}
21Requires: php-common >= 4:5.0.4
22Obsoletes: php-mono
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26A C extension that interfaces with the mono library to allow access to
27.NET assemblies.
28
29In PECL status of this package is: %{_status}.
30
31%description -l pl.UTF-8
32Rozszerzenie w C, które jest interfejsem do biblioteki mono,
33pozwalającym na dostęp do wstawek w .NET.
34
35To rozszerzenie ma w PECL status: %{_status}.
36
37%prep
38%setup -q -c
39
40%build
41cd %{_modname}-%{version}
42phpize
43%configure \
44 --with-%{_modname}
45
46%{__make} \
47CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/" \
48 CFLAGS_CLEAN="%{rpmcflags}"
49
50%install
51rm -rf $RPM_BUILD_ROOT
52install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
53
54install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
55cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
56; Enable %{_modname} extension module
57extension=%{_modname}.so
58EOF
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%post
64%php_webserver_restart
65
66%postun
67if [ "$1" = 0 ]; then
68 %php_webserver_restart
69fi
70
71%files
72%defattr(644,root,root,755)
73%doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
74%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
75%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.062626 seconds and 4 git commands to generate.