]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blame_incremental - perl-IO-Socket-SSL.spec
up to 2.058
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test" - needs network connection
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir IO
7%define pnam Socket-SSL
8Summary: IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
9Summary(pl.UTF-8): IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
10Name: perl-IO-Socket-SSL
11Version: 2.058
12Release: 1
13Epoch: 1
14# same as perl
15License: GPL v1+ or Artistic
16Group: Development/Languages/Perl
17Source0: http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
18# Source0-md5: 5eb4091dc1e83d769cadbc925c721511
19URL: http://search.cpan.org/dist/IO-Socket-SSL/
20%if %{with tests}
21BuildRequires: perl-Net-SSLeay >= 1.46
22BuildRequires: perl-Scalar-List-Utils
23%endif
24BuildRequires: perl-devel >= 1:5.8.0
25BuildRequires: rpm-perlprov >= 4.1-13
26# actually Net::SSLeay using openssl >= 0.9.8
27Requires: openssl >= 0.9.8
28Suggests: perl-Net-IDN-Encode
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33This module is a true drop-in replacement for IO::Socket::INET that
34uses SSL to encrypt data before it is transferred to a remote server
35or client. IO::Socket::SSL supports all the extra features that one
36needs to write a full-featured SSL client or server application:
37multiple SSL contexts, cipher selection, certificate verification, and
38SSL version selection. As an extra bonus, it works perfectly with
39mod_perl.
40
41%description -l pl.UTF-8
42Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
43używającym SSL do kodowania danych przed przesyłaniem do zdalnego
44serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
45rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
46serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
47certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
48
49%prep
50%setup -q -n %{pdir}-%{pnam}-%{version}
51
52%build
53echo "n" | \
54%{__perl} Makefile.PL \
55 INSTALLDIRS=vendor
56%{__make}
57
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/Socket/SSL.pod
67
68install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
76%doc Changes README docs/*
77%{perl_vendorlib}/IO/Socket/SSL.pm
78%{perl_vendorlib}/IO/Socket/SSL
79%{_mandir}/man3/IO::Socket::SSL*.3pm*
80%{_examplesdir}/%{name}-%{version}
This page took 0.050232 seconds and 4 git commands to generate.