]> git.pld-linux.org Git - packages/perl-IO-Socket-SSL.git/blame_incremental - perl-IO-Socket-SSL.spec
- up to 2.024
[packages/perl-IO-Socket-SSL.git] / perl-IO-Socket-SSL.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test" - needs network connection
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir IO
7%define pnam Socket-SSL
8Summary: IO::Socket::SSL - nearly transparent SSL encapsulation for IO::Socket::INET
9Summary(pl.UTF-8): IO::Socket::SSL - prawie przezroczysta obudowa SSL dla IO::Socket::INET
10Name: perl-IO-Socket-SSL
11Version: 2.024
12Release: 1
13Epoch: 1
14# same as perl
15License: GPL v1+ or Artistic
16Group: Development/Languages/Perl
17Source0: http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
18# Source0-md5: 9d1be9159475fe67afa5f2e238808086
19URL: http://search.cpan.org/dist/IO-Socket-SSL/
20%if %{with tests}
21BuildRequires: perl-Net-SSLeay >= 1.46
22BuildRequires: perl-Scalar-List-Utils
23%endif
24BuildRequires: perl-devel >= 1:5.8.0
25BuildRequires: rpm-perlprov >= 4.1-13
26Suggests: perl-Net-IDN-Encode
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31This module is a true drop-in replacement for IO::Socket::INET that
32uses SSL to encrypt data before it is transferred to a remote server
33or client. IO::Socket::SSL supports all the extra features that one
34needs to write a full-featured SSL client or server application:
35multiple SSL contexts, cipher selection, certificate verification, and
36SSL version selection. As an extra bonus, it works perfectly with
37mod_perl.
38
39%description -l pl.UTF-8
40Ten moduł jest prawdziwym zamiennikiem dla IO::Socket::INET,
41używającym SSL do kodowania danych przed przesyłaniem do zdalnego
42serwera lub klienta. IO::Socket::SSL wspiera wszystkie dodatkowe
43rzeczy potrzebne do napisania w pełni funkcjonalnego klienta lub
44serwera SSL: wiele kontekstów SSL, wybór szyfru, weryfikacja
45certyfikatu, wybór wersji SSL. Ponadto wspaniale działa z mod_perlem.
46
47%prep
48%setup -q -n %{pdir}-%{pnam}-%{version}
49
50%build
51echo "n" | \
52%{__perl} Makefile.PL \
53 INSTALLDIRS=vendor
54%{__make}
55
56%{?with_tests:%{__make} test}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
63
64%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/IO/Socket/SSL.pod
65
66install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%files
73%defattr(644,root,root,755)
74%doc Changes README docs/*
75%{perl_vendorlib}/IO/Socket/SSL.pm
76%{perl_vendorlib}/IO/Socket/SSL
77%{_mandir}/man3/IO::Socket::SSL*.3pm*
78%{_examplesdir}/%{name}-%{version}
This page took 0.071758 seconds and 4 git commands to generate.