]> git.pld-linux.org Git - packages/perl-DateTime.git/blame_incremental - perl-DateTime.spec
- up to 0.72
[packages/perl-DateTime.git] / perl-DateTime.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # perform "make test"
4
5%define pdir DateTime
6%include /usr/lib/rpm/macros.perl
7Summary: DateTime - representation of date/time combinations
8Summary(pl.UTF-8): DateTime - reprezentacja kombinacji daty i czasu
9Name: perl-DateTime
10Version: 0.72
11Release: 1
12Epoch: 2
13License: Artistic 2.0
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/DateTime/DROLSKY/%{pdir}-%{version}.tar.gz
16# Source0-md5: f50b328919fe8bf2d2b16ca0df35c3f3
17URL: http://datetime.perl.org/
18BuildRequires: perl(Pod::Man) >= 1.14
19BuildRequires: perl-ExtUtils-CBuilder
20BuildRequires: perl-Module-Build >= 0.3601
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
23%if %{with tests}
24BuildRequires: perl(Time::Local) >= 1.04
25BuildRequires: perl-DateTime-Format-Strptime >= 1.2000
26BuildRequires: perl-DateTime-Locale >= 0.41
27BuildRequires: perl-DateTime-TimeZone >= 3:1.09
28BuildRequires: perl-Math-Round
29BuildRequires: perl-Params-Validate >= 0.76
30BuildRequires: perl-Test-Exception
31BuildRequires: perl-Test-Simple >= 0.88
32%endif
33Requires: perl-base >= 1:5.8.7-3
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37DateTime is a class for the representation of date/time combinations,
38and is part of the Perl DateTime project. For details on this project
39please see <http://datetime.perl.org/>. The DateTime site has a FAQ
40which may help answer many "how do I do X?" questions. The FAQ is at
41<http://datetime.perl.org/faq.html>.
42
43%description -l pl.UTF-8
44DateTime to klasa do reprezentowania kombinacji daty i czasu, będąca
45częścią perlowego projektu DateTime. Szczegóły dotyczące tego projektu
46można znaleźć pod adresem <http://datetime.perl.org/>. Serwis ten ma
47swoje FAQ, gdzie można znaleźć odpowiedzi na wiele pytań - dostępne
48pod <http://datetime.perl.org/faq.html>.
49
50%prep
51%setup -q -n %{pdir}-%{version}
52
53%build
54%{__perl} Build.PL \
55 installdirs=vendor \
56 --config cc="%{__cc}" \
57 --config ld="%{__cc}" \
58 --config optimize="%{rpmcflags}"
59
60./Build
61
62%{?with_tests:./Build test}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66
67./Build install \
68 destdir=$RPM_BUILD_ROOT
69
70# for noarch DateTime::* modules
71install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/{Event,Format}
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
78%doc Changes README CREDITS TODO leaptab.txt
79%dir %{perl_vendorlib}/DateTime/Event
80%dir %{perl_vendorlib}/DateTime/Format
81%{perl_vendorarch}/DateTime.pm
82%{perl_vendorarch}/DateTimePP.pm
83%{perl_vendorarch}/DateTimePPExtra.pm
84%{perl_vendorarch}/DateTime/*.pm
85%dir %{perl_vendorarch}/auto/DateTime
86%{perl_vendorarch}/auto/DateTime/DateTime.bs
87%attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
88%{_mandir}/man3/DateTime*.3pm*
This page took 0.073991 seconds and 4 git commands to generate.