]> git.pld-linux.org Git - packages/pdns.git/blame_incremental - pdns.spec
- release 2
[packages/pdns.git] / pdns.spec
... / ...
CommitLineData
1Summary: PowerDNS is a Versatile Database Driven Nameserver
2Summary(pl.UTF-8): PowerDNS to wielofunkcyjny serwer nazw korzystający z relacyjnych baz danych
3Name: pdns
4Version: 3.0.1
5Release: 2
6License: GPL
7Group: Networking/Daemons
8Source0: http://downloads.powerdns.com/releases/%{name}-%{version}.tar.gz
9# Source0-md5: a67763b2b45d9f3504a24607c5b4068d
10Source1: http://downloads.powerdns.com/documentation/%{name}.pdf
11# Source1-md5: cb69cd9655e4cb319c66adb2c733314d
12Source2: http://downloads.powerdns.com/documentation/%{name}.txt
13Source3: %{name}.init
14Source4: %{name}.conf
15Source5: %{name}.sysconfig
16Patch0: configure.ac.patch
17Patch1: %{name}-int16.patch
18Patch2: %{name}-openldap-2.3.patch
19Patch3: gcc4.patch
20URL: http://www.powerdns.com/
21BuildRequires: autoconf >= 2.52
22BuildRequires: automake
23BuildRequires: bison
24BuildRequires: boost-devel >= 1.35.0
25BuildRequires: flex
26BuildRequires: libpq++-devel
27BuildRequires: libstdc++-devel
28BuildRequires: libtool
29BuildRequires: lua51-devel
30BuildRequires: mysql-devel
31BuildRequires: openldap-devel >= 2.4.6
32BuildRequires: rpmbuild(macros) >= 1.268
33BuildRequires: sed >= 4.0
34BuildRequires: sqlite3-devel
35BuildRequires: zlib-devel
36Requires(post): sed >= 4.0
37Requires(post,preun): /sbin/chkconfig
38Requires(postun): /usr/sbin/groupdel
39Requires(postun): /usr/sbin/userdel
40Requires(pre): /bin/id
41Requires(pre): /usr/bin/getgid
42Requires(pre): /usr/sbin/groupadd
43Requires(pre): /usr/sbin/useradd
44Requires: rc-scripts
45Provides: group(djbdns)
46Provides: nameserver
47Provides: user(pdns)
48Obsoletes: powerdns
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52PowerDNS is a versatile nameserver which supports a large number of
53different backends ranging from simple zonefiles to relational
54databases and load balancing/failover algorithms.
55
56%description -l pl.UTF-8
57PowerDNS to wielofunkcyjny serwer nazw posiadający dużą liczbę wtyczek
58od prostych stref (a'la BIND) począwszy, a na relacyjnych bazach
59danych skończywszy oraz zawierający algorytmy zrównoważenia obciążenia
60i przełączania w wypadku awarii.
61
62%package backend-pipe
63Summary: PowerDNS support for custom pipe backend
64Summary(pl.UTF-8): Obsługa własnego mechanizmu przechowywania stref dla PowerDNS-a
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67
68%description backend-pipe
69This package allows creation of own backend using simple STDIN/STDOUT
70API. Example backend script in Perl is provided in package
71documentation.
72
73%description backend-pipe -l pl.UTF-8
74Ten pakiet pozwala na utworzenie własnego mechanizmu przechowywania
75stref za pomocą prostego interfejsu STDIN/STDOUT. Przykładowy skrypt w
76Perlu został dołączony do dokumentacji pakietu.
77
78%package backend-gpgsql
79Summary: PowerDNS support for PostgreSQL
80Summary(pl.UTF-8): Obsługa baz PostgreSQL dla PowerDNS-a
81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
83
84%description backend-gpgsql
85This package allows zone storage in PostgreSQL relational db tables.
86
87%description backend-gpgsql -l pl.UTF-8
88Ten pakiet pozwala na przechowywanie danych o strefach w tabelach
89relacyjnej bazy danych PostgreSQL.
90
91%package backend-gmysql
92Summary: PowerDNS support for MySQL
93Summary(pl.UTF-8): Obsługa baz MySQL dla PowerDNS-a
94Group: Development/Libraries
95Requires: %{name} = %{version}-%{release}
96
97%description backend-gmysql
98This package allows zone storage in MySQL relational db tables.
99
100%description backend-gmysql -l pl.UTF-8
101Ten pakiet pozwala na przechowywanie danych o strefach w tabelach
102relacyjnej bazy danych MySQL.
103
104%package backend-gsqlite3
105Summary: PowerDNS support for SQLite 3
106Summary(pl.UTF-8): Obsługa baz SQLite 3 dla PowerDNS-a
107Group: Development/Libraries
108Requires: %{name} = %{version}-%{release}
109
110%description backend-gsqlite3
111This package allows zone storage in SQLite 3 relational db tables.
112
113%description backend-gsqlite3 -l pl.UTF-8
114Ten pakiet pozwala na przechowywanie danych o strefach w tabelach
115relacyjnej bazy danych SQLite 3.
116
117%package backend-ldap
118Summary: PowerDNS support for LDAP
119Summary(pl.UTF-8): Obsługa LDAP dla PowerDNS-a
120Group: Development/Libraries
121Requires: %{name} = %{version}-%{release}
122
123%description backend-ldap
124This package allows zone storage in LDAP directory.
125
126%description backend-ldap -l pl.UTF-8
127Ten pakiet pozwala na przechowywanie danych o strefach w katalogu
128LDAP.
129
130%prep
131%setup -q
132%patch0 -p1
133%patch1 -p1
134%patch2 -p1
135%patch3 -p1
136cp %{SOURCE1} .
137cp %{SOURCE2} .
138cp %{SOURCE4} .
139
140%if "%{_lib}" != "lib"
141%{__sed} -i -e 's/module-dir=\/usr\/lib\/pdns/module-dir=\/usr\/%{_lib}\/pdns/' pdns.conf
142%endif
143
144%build
145CPPFLAGS="-DHAVE_NAMESPACE_STD -DHAVE_CXX_STRING_HEADER -DDLLIMPORT=\"\""
146%{__libtoolize}
147%{__aclocal} -I .
148%{__autoconf}
149%{__automake}
150%configure \
151 --libdir=%{_libdir}/%{name} \
152 --sysconfdir=%{_sysconfdir}/%{name} \
153 --disable-static \
154 --with-lua \
155 --with-pgsql-includes=%{_includedir} \
156 --with-pgsql-lib=%{_libdir} \
157 --with-mysql-includes=%{_includedir} \
158 --with-mysql-lib=%{_libdir} \
159 --with-dynmodules="gsqlite3 gmysql gpgsql pipe ldap" \
160 --with-modules="" \
161 --with-socketdir=/var/run
162
163%{__make}
164
165%install
166rm -rf $RPM_BUILD_ROOT
167install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/%{name},/etc/sysconfig}
168
169%{__make} install \
170 DESTDIR=$RPM_BUILD_ROOT
171
172install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
173install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
174install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/pdns
175
176# useless - modules are dlopened by *.so
177rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
178
179%clean
180rm -rf $RPM_BUILD_ROOT
181
182%pre
183%groupadd -g 32 djbdns
184%useradd -u 30 -d /var/lib/pdns -s /bin/false -c "pdns User" -g djbdns pdns
185
186%post
187# dirty hack so the config file is processed correctly, and server does not respawn
188sed -i -e 's/^ *//' /etc/pdns/pdns.conf
189
190/sbin/chkconfig --add pdns
191%service pdns restart
192
193%preun
194if [ "$1" = "0" ]; then
195 %service pdns stop
196 /sbin/chkconfig --del pdns
197fi
198
199%postun
200if [ "$1" = "0" ]; then
201 %userremove pdns
202 %groupremove djbdns
203fi
204
205%files
206%defattr(644,root,root,755)
207%doc ChangeLog HACKING INSTALL README TODO pdns.pdf pdns.txt
208%attr(754,root,root) /etc/rc.d/init.d/%{name}
209%dir %{_sysconfdir}/%{name}
210%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
211%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/pdns
212%attr(755,root,root) %{_sbindir}/*
213%attr(755,root,root) %{_bindir}/*
214%dir %{_libdir}/%{name}
215%{_mandir}/man8/*
216
217%files backend-gmysql
218%defattr(644,root,root,755)
219%attr(755,root,root) %{_libdir}/%{name}/*mysql*.so*
220
221%files backend-gpgsql
222%defattr(644,root,root,755)
223%attr(755,root,root) %{_libdir}/%{name}/*pgsql*.so*
224
225%files backend-gsqlite3
226%defattr(644,root,root,755)
227%attr(755,root,root) %{_libdir}/%{name}/*sqlite3*.so*
228
229%files backend-pipe
230%defattr(644,root,root,755)
231%attr(755,root,root) %{_libdir}/%{name}/*pipe*.so*
232
233%files backend-ldap
234%defattr(644,root,root,755)
235%attr(755,root,root) %{_libdir}/%{name}/*ldap*.so*
This page took 0.076764 seconds and 4 git commands to generate.