]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
Release 3 (by relup.sh)
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1# TODO:
2# - add trigger to enable this:
3# * sshd(8): This release turns on pre-auth sandboxing sshd by default for
4# new installs, by setting UsePrivilegeSeparation=sandbox in sshd_config.
5#
6# Conditional build:
7%bcond_without audit # sshd audit support
8%bcond_with gnome # gnome-askpass (GNOME 1.x) utility
9%bcond_without gtk # gnome-askpass (GTK+ 2.x) utility
10%bcond_without ldap # LDAP support
11%bcond_with ldns # DNSSEC support via libldns
12%bcond_without libedit # libedit (editline/history support in sftp client)
13%bcond_without kerberos5 # Kerberos5 support
14%bcond_without selinux # SELinux support
15%bcond_without libseccomp # use libseccomp for seccomp privsep (requires 3.5 kernel)
16%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
17%bcond_without tests # test suite
18%bcond_with tests_conch # run conch interoperability tests
19
20# gtk2-based gnome-askpass means no gnome1-based
21%{?with_gtk:%undefine with_gnome}
22
23%if "%{pld_release}" == "ac"
24%define pam_ver 0.79.0
25%else
26%define pam_ver 1:1.1.8-5
27%endif
28Summary: OpenSSH free Secure Shell (SSH) implementation
29Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
30Summary(es.UTF-8): Implementación libre de SSH
31Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
32Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
33Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
34Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
35Summary(pt_BR.UTF-8): Implementação livre do SSH
36Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
37Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
38Name: openssh
39Version: 9.7p1
40Release: 3
41Epoch: 2
42License: BSD
43Group: Applications/Networking
44Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
45# Source0-md5: 1100f170ca1bc669038ca3743e074094
46Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
47# Source1-md5: 66943d481cc422512b537bcc2c7400d1
48Source2: %{name}d.init
49Source3: %{name}d.pamd
50Source4: %{name}.sysconfig
51Source5: ssh-agent.sh
52Source6: ssh-agent.conf
53Source7: %{name}-lpk.schema
54Source9: sshd.service
55Source10: sshd-keygen
56Source11: sshd.socket
57Source12: sshd@.service
58Source13: pld-ssh_config
59Source14: pld-sshd_config
60Patch100: %{name}-git.patch
61# Patch100-md5: eb723cc4f21efc32752161d539c9c5e9
62Patch0: %{name}-no-pty-tests.patch
63Patch1: %{name}-tests-reuseport.patch
64Patch2: %{name}-pam_misc.patch
65Patch3: %{name}-sigpipe.patch
66# http://pkgs.fedoraproject.org/gitweb/?p=openssh.git;a=tree
67Patch4: %{name}-ldap.patch
68Patch5: %{name}-ldap-fixes.patch
69Patch6: ldap.conf.patch
70Patch7: %{name}-config.patch
71Patch8: ldap-helper-sigpipe.patch
72# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
73# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
74Patch9: %{name}-5.2p1-hpn13v6.diff
75
76Patch11: %{name}-chroot.patch
77
78Patch13: %{name}-skip-interop-tests.patch
79Patch14: %{name}-bind.patch
80Patch15: %{name}-disable_ldap.patch
81URL: http://www.openssh.com/portable.html
82BuildRequires: %{__perl}
83%{?with_audit:BuildRequires: audit-libs-devel}
84BuildRequires: autoconf >= 2.50
85BuildRequires: automake
86%{?with_gnome:BuildRequires: gnome-libs-devel}
87%{?with_gtk:BuildRequires: gtk+2-devel}
88%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
89%{?with_ldns:BuildRequires: ldns-devel}
90%{?with_libedit:BuildRequires: libedit-devel}
91BuildRequires: libfido2-devel >= 1.5.0
92%{?with_libseccomp:BuildRequires: libseccomp-devel}
93%{?with_selinux:BuildRequires: libselinux-devel}
94%{?with_ldap:BuildRequires: openldap-devel}
95BuildRequires: openssl-devel >= 1.1.1
96BuildRequires: pam-devel
97%{?with_gtk:BuildRequires: pkgconfig}
98%if %{with tests} && %{with tests_conch}
99BuildRequires: python-TwistedConch
100%endif
101BuildRequires: rpm >= 4.4.9-56
102BuildRequires: rpm-build >= 4.6
103BuildRequires: rpmbuild(macros) >= 1.752
104BuildRequires: sed >= 4.0
105BuildRequires: zlib-devel >= 1.2.3
106%if %{with tests} && 0%(id -u sshd >/dev/null 2>&1; echo $?)
107BuildRequires: %{name}-server
108%endif
109%if %{with tests} && %{with libseccomp}
110# libseccomp based sandbox requires NO_NEW_PRIVS prctl flag
111BuildRequires: uname(release) >= 3.5
112%endif
113Requires: zlib >= 1.2.3
114Obsoletes: ssh
115BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117%define _sysconfdir /etc/ssh
118%define _libexecdir %{_libdir}/%{name}
119%define _privsepdir /usr/share/empty
120%define schemadir /usr/share/openldap/schema
121
122%description
123Ssh (Secure Shell) a program for logging into a remote machine and for
124executing commands in a remote machine. It is intended to replace
125rlogin and rsh, and provide secure encrypted communications between
126two untrusted hosts over an insecure network. X11 connections and
127arbitrary TCP/IP ports can also be forwarded over the secure channel.
128
129OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
130it up to date in terms of security and features, as well as removing
131all patented algorithms to seperate libraries (OpenSSL).
132
133This package includes the core files necessary for both the OpenSSH
134client and server. To make this package useful, you should also
135install openssh-clients, openssh-server, or both.
136
137%if %{with hpn}
138This release includes High Performance SSH/SCP patches from
139http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
140increase throughput on fast connections with high RTT (20-150 msec).
141See the website for '-w' values for your connection and /proc/sys TCP
142values. BTW. in a LAN you have got generally RTT < 1 msec.
143%endif
144
145%description -l de.UTF-8
146OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
147ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
148verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
149über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
150andere TCP/IP Ports können ebenso über den sicheren Channel
151weitergeleitet werden.
152
153%description -l es.UTF-8
154SSH es un programa para accesar y ejecutar órdenes en computadores
155remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
156seguro entre dos servidores en una red insegura. Conexiones X11 y
157puertas TCP/IP arbitrárias también pueden ser usadas por el canal
158seguro.
159
160OpenSSH es el resultado del trabajo del equipo de OpenBSD para
161continuar la última versión gratuita de SSH, actualizándolo en
162términos de seguridad y recursos,así también eliminando todos los
163algoritmos patentados y colocándolos en bibliotecas separadas
164(OpenSSL).
165
166Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
167también el paquete openssh-clients u openssh-server o ambos.
168
169%description -l fr.UTF-8
170OpenSSH (Secure Shell) fournit un accès à un système distant. Il
171remplace telnet, rlogin, rexec et rsh, tout en assurant des
172communications cryptées securisées entre deux hôtes non fiabilisés sur
173un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
174arbitraires peuvent également être transmis sur le canal sécurisé.
175
176%description -l it.UTF-8
177OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
178Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
179sicure e crittate tra due host non fidati su una rete non sicura. Le
180connessioni X11 ad una porta TCP/IP arbitraria possono essere
181inoltrate attraverso un canale sicuro.
182
183%description -l pl.UTF-8
184Ssh (Secure Shell) to program służący do logowania się na zdalną
185maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
186zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
187pomiędzy dwoma hostami.
188
189Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
190klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
191co najmniej jeden z pakietów: openssh-clients lub openssh-server.
192
193%if %{with hpn}
194Ta wersja zawiera łaty z projektu High Performance SSH/SCP
195http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
196zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
197RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
198danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
199TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
200%endif
201
202%description -l pt.UTF-8
203OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
204telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
205cifradas entre duas máquinas sem confiança mútua sobre uma rede
206insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
207reenviados pelo canal seguro.
208
209%description -l pt_BR.UTF-8
210SSH é um programa para acessar e executar comandos em máquinas
211remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
212seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
213TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
214
215OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
216última versão gratuita do SSH, atualizando-o em termos de segurança e
217recursos, assim como removendo todos os algoritmos patenteados e
218colocando-os em bibliotecas separadas (OpenSSL).
219
220Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
221também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
222
223%description -l ru.UTF-8
224Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
225машину и для выполнения команд на удаленной машине. Она предназначена
226для замены rlogin и rsh и обеспечивает безопасную шифрованную
227коммуникацию между двумя хостами в сети, являющейся небезопасной.
228Соединения X11 и любые порты TCP/IP могут также быть проведены через
229безопасный канал.
230
231OpenSSH - это переделка командой разработчиков OpenBSD последней
232свободной версии SSH, доведенная до современного состояния в терминах
233уровня безопасности и поддерживаемых возможностей. Все патентованные
234алгоритмы вынесены в отдельные библиотеки (OpenSSL).
235
236Этот пакет содержит файлы, необходимые как для клиента, так и для
237сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
238openssh-server, или оба пакета.
239
240%description -l uk.UTF-8
241Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
242машини та для виконання команд на віддаленій машині. Вона призначена
243для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
244між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
245довільні порти TCP/IP можуть також бути проведені через безпечний
246канал.
247
248OpenSSH - це переробка командою розробників OpenBSD останньої вільної
249версії SSH, доведена до сучасного стану в термінах рівня безпеки та
250підтримуваних можливостей. Всі патентовані алгоритми винесені до
251окремих бібліотек (OpenSSL).
252
253Цей пакет містить файли, необхідні як для клієнта, так і для сервера
254OpenSSH. Вам потрібно буде ще встановити openssh-clients,
255openssh-server, чи обидва пакети.
256
257%package clients
258Summary: OpenSSH Secure Shell protocol clients
259Summary(es.UTF-8): Clientes de OpenSSH
260Summary(pl.UTF-8): Klienci protokołu Secure Shell
261Summary(pt_BR.UTF-8): Clientes do OpenSSH
262Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
263Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
264Group: Applications/Networking
265Requires: %{name} = %{epoch}:%{version}-%{release}
266Suggests: %{name}-clients-helper-fido = %{epoch}:%{version}-%{release}
267Provides: ssh-clients
268Obsoletes: ssh-clients
269%requires_eq_to openssl%{?_isa} openssl-devel
270
271%description clients
272Ssh (Secure Shell) a program for logging into a remote machine and for
273executing commands in a remote machine. It is intended to replace
274rlogin and rsh, and provide secure encrypted communications between
275two untrusted hosts over an insecure network. X11 connections and
276arbitrary TCP/IP ports can also be forwarded over the secure channel.
277
278OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
279it up to date in terms of security and features, as well as removing
280all patented algorithms to seperate libraries (OpenSSL).
281
282This package includes the clients necessary to make encrypted
283connections to SSH servers.
284
285%description clients -l es.UTF-8
286Este paquete incluye los clientes que se necesitan para hacer
287conexiones codificadas con servidores SSH.
288
289%description clients -l pl.UTF-8
290Ssh (Secure Shell) to program służący do logowania się na zdalną
291maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
292zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
293pomiędzy dwoma hostami.
294
295Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
296
297%description clients -l pt_BR.UTF-8
298Esse pacote inclui os clientes necessários para fazer conexões
299encriptadas com servidores SSH.
300
301%description clients -l ru.UTF-8
302Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
303машину и для выполнения команд на удаленной машине.
304
305Этот пакет содержит программы-клиенты, необходимые для установления
306зашифрованных соединений с серверами SSH.
307
308%description clients -l uk.UTF-8
309Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
310машини та для виконання команд на віддаленій машині.
311
312Цей пакет містить програми-клієнти, необхідні для встановлення
313зашифрованих з'єднань з серверами SSH.
314
315%package clients-agent-profile_d
316Summary: OpenSSH Secure Shell agent init script
317Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
318Group: Applications/Networking
319Requires: %{name}-clients = %{epoch}:%{version}-%{release}
320
321%description clients-agent-profile_d
322profile.d scripts for starting SSH agent.
323
324%description clients-agent-profile_d -l pl.UTF-8
325Skrypty profile.d do uruchamiania agenta SSH.
326
327%package clients-agent-xinitrc
328Summary: OpenSSH Secure Shell agent init script
329Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
330Group: Applications/Networking
331Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
332Requires: xinitrc
333
334%description clients-agent-xinitrc
335xinitrc scripts for starting SSH agent.
336
337%description clients-agent-xinitrc -l pl.UTF-8
338Skrypty xinitrc do uruchamiania agenta SSH.
339
340%package clients-helper-fido
341Summary: OpenSSH helper for FIDO authenticator
342Summary(pl.UTF-8): OpenSSH helper obsługujący klucz autoryzujący FIDO
343Group: Applications/Networking
344Requires: %{name}-clients = %{epoch}:%{version}-%{release}
345Requires: libfido2 >= 1.5.0
346
347%description clients-helper-fido
348OpenSSH helper for FIDO authenticator.
349
350%description clients-helper-fido -l pl.UTF-8
351OpenSSH helper obsługujący klucz autoryzujący FIDO.
352
353%package server
354Summary: OpenSSH Secure Shell protocol server (sshd)
355Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
356Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
357Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
358Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
359Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
360Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
361Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
362Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
363Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
364Group: Networking/Daemons
365Requires(post): /sbin/chkconfig
366Requires(post): grep
367Requires(post,preun): /sbin/chkconfig
368Requires(postun): /usr/sbin/userdel
369Requires(pre): /bin/id
370Requires(pre): /usr/sbin/useradd
371Requires(post,preun,postun): systemd-units >= 38
372Requires: %{name} = %{epoch}:%{version}-%{release}
373%if "%{pld_release}" == "ac"
374Requires: filesystem >= 2.0-1
375Requires: pam >= 0.79.0
376%else
377Requires: filesystem >= 3.0-11
378Requires: pam >= %{pam_ver}
379Suggests: xorg-app-xauth
380%endif
381Requires: rc-scripts >= 0.4.3.0
382Requires: systemd-units >= 38
383%{?with_libseccomp:Requires: uname(release) >= 3.5}
384Requires: util-linux
385%{?with_ldap:Suggests: %{name}-server-ldap}
386Suggests: /bin/login
387Suggests: xorg-app-xauth
388Provides: ssh-server
389Provides: user(sshd)
390%requires_eq_to openssl%{?_isa} openssl-devel
391
392%description server
393Ssh (Secure Shell) a program for logging into a remote machine and for
394executing commands in a remote machine. It is intended to replace
395rlogin and rsh, and provide secure encrypted communications between
396two untrusted hosts over an insecure network. X11 connections and
397arbitrary TCP/IP ports can also be forwarded over the secure channel.
398
399OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
400it up to date in terms of security and features, as well as removing
401all patented algorithms to seperate libraries (OpenSSL).
402
403This package contains the secure shell daemon. The sshd is the server
404part of the secure shell protocol and allows ssh clients to connect to
405your host.
406
407%description server -l de.UTF-8
408Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
409
410%description server -l es.UTF-8
411Este paquete contiene el servidor SSH. sshd es la parte servidor del
412protocolo secure shell y permite que clientes ssh se conecten a su
413servidor.
414
415%description server -l fr.UTF-8
416Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
417
418%description server -l it.UTF-8
419Questo pacchetto installa sshd, il server di OpenSSH.
420
421%description server -l pl.UTF-8
422Ssh (Secure Shell) to program służący do logowania się na zdalną
423maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
424zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
425pomiędzy dwoma hostami.
426
427Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
428ssh).
429
430%description server -l pt.UTF-8
431Este pacote intala o sshd, o servidor do OpenSSH.
432
433%description server -l pt_BR.UTF-8
434Esse pacote contém o servidor SSH. O sshd é a parte servidor do
435protocolo secure shell e permite que clientes ssh se conectem ao seu
436host.
437
438%description server -l ru.UTF-8
439Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
440машину и для выполнения команд на удаленной машине.
441
442Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
443часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
444вашим хостом.
445
446%description server -l uk.UTF-8
447Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
448машини та для виконання команд на віддаленій машині.
449
450Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
451частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
452з вашим хостом.
453
454%package server-ldap
455Summary: A LDAP support for open source SSH server daemon
456Summary(pl.UTF-8): Wsparcie LDAP dla serwera OpenSSH
457Group: Daemons
458Requires: %{name} = %{epoch}:%{version}-%{release}
459Requires: openldap-nss-config
460
461%description server-ldap
462OpenSSH LDAP backend is a way how to distribute the authorized tokens
463among the servers in the network.
464
465%description server-ldap -l pl.UTF-8
466Backend LDAP dla OpenSSH to metoda rozprowadzania autoryzowanych
467tokenów między serwerami w sieci.
468
469%package gnome-askpass
470Summary: OpenSSH GNOME passphrase dialog
471Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
472Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
473Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
474Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
475Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
476Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
477Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
478Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
479Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
480Group: Applications/Networking
481Requires: %{name} = %{epoch}:%{version}-%{release}
482Obsoletes: openssh-askpass
483Obsoletes: ssh-askpass
484Obsoletes: ssh-extras
485
486%description gnome-askpass
487Ssh (Secure Shell) a program for logging into a remote machine and for
488executing commands in a remote machine. It is intended to replace
489rlogin and rsh, and provide secure encrypted communications between
490two untrusted hosts over an insecure network. X11 connections and
491arbitrary TCP/IP ports can also be forwarded over the secure channel.
492
493OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
494it up to date in terms of security and features, as well as removing
495all patented algorithms to seperate libraries (OpenSSL).
496
497This package contains the GNOME passphrase dialog.
498
499%description gnome-askpass -l es.UTF-8
500Este paquete contiene un programa que abre una caja de diálogo para
501entrada de passphrase en GNOME.
502
503%description gnome-askpass -l pl.UTF-8
504Ssh (Secure Shell) to program służący do logowania się na zdalną
505maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
506zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
507pomiędzy dwoma hostami.
508
509Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
510
511%description gnome-askpass -l pt_BR.UTF-8
512Esse pacote contém um programa que abre uma caixa de diálogo para
513entrada de passphrase no GNOME.
514
515%description gnome-askpass -l ru.UTF-8
516Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
517машину и для выполнения команд на удаленной машине.
518
519Этот пакет содержит диалог ввода ключевой фразы для использования под
520GNOME.
521
522%description gnome-askpass -l uk.UTF-8
523Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
524машини та для виконання команд на віддаленій машині.
525
526Цей пакет містить діалог вводу ключової фрази для використання під
527GNOME.
528
529%package -n openldap-schema-openssh-lpk
530Summary: OpenSSH LDAP Public Key schema
531Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
532Group: Networking/Daemons
533Requires(post,postun): sed >= 4.0
534Requires: openldap-servers
535BuildArch: noarch
536
537%description -n openldap-schema-openssh-lpk
538This package contains OpenSSH LDAP Public Key schema for openldap.
539
540%description -n openldap-schema-openssh-lpk -l pl.UTF-8
541Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
542openldap-a.
543
544%prep
545%setup -q
546#%%patch100 -p1
547
548%patch0 -p1
549%patch1 -p1
550%patch2 -p1
551%patch3 -p1
552%patch4 -p1
553%patch5 -p1
554%patch6 -p1
555%patch7 -p1
556%patch8 -p1
557
558%{?with_hpn:%patch9 -p1}
559
560%patch11 -p1
561
562%patch13 -p1
563
564%patch14 -p1
565%{!?with_ldap:%patch15 -p1}
566
567%if "%{pld_release}" == "ac"
568# fix for missing x11.pc
569%{__sed} -i -e 's/\(`$(PKG_CONFIG) --libs gtk+-2.0\) x11`/\1` -lX11/' contrib/Makefile
570%endif
571
572# hack since arc4random from openbsd-compat needs symbols from libssh and vice versa
573sed -i -e 's#-lssh -lopenbsd-compat#-lssh -lopenbsd-compat -lssh -lopenbsd-compat#g' Makefile*
574
575grep -rl /usr/libexec/openssh/ssh-ldap-helper . | xargs \
576%{__sed} -i -e 's,/usr/libexec/openssh/ssh-ldap-helper,%{_libexecdir}/ssh-ldap-helper,'
577
578# prevent being ovewritten by aclocal calls
579%{__mv} aclocal.m4 acinclude.m4
580
581%build
582%{__aclocal}
583%{__autoconf}
584%{__autoheader}
585CPPFLAGS="%{rpmcppflags} -DCHROOT -std=gnu99"
586%configure \
587 PERL=%{__perl} \
588 --disable-strip \
589 --enable-utmpx \
590 --enable-wtmpx \
591 --with-4in6 \
592 %{?with_audit:--with-audit=linux} \
593 --with-ipaddr-display \
594 %{?with_kerberos5:--with-kerberos5=/usr} \
595 --with-ldap%{!?with_ldap:=no} \
596 %{?with_ldns:--with-ldns} \
597 %{?with_libedit:--with-libedit} \
598 --with-mantype=doc \
599 --with-md5-passwords \
600 --with-pam \
601 --with-pid-dir=%{_localstatedir}/run \
602 --with-privsep-path=%{_privsepdir} \
603 --with-privsep-user=sshd \
604 --with-security-key-builtin \
605 %{?with_selinux:--with-selinux} \
606%if "%{pld_release}" == "ac"
607 --with-xauth=/usr/X11R6/bin/xauth
608%else
609%if %{with libseccomp}
610 --with-sandbox=seccomp_filter \
611%else
612 --with-sandbox=rlimit \
613%endif
614 --with-xauth=%{_bindir}/xauth
615%endif
616
617echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
618
619%{__make}
620
621%if %{with tests}
622%{__make} -j1 tests \
623 TEST_SSH_PORT=$((4242 + ${RANDOM:-$$} % 1000)) \
624 TEST_SSH_TRACE="yes" \
625%if %{without tests_conch}
626 SKIP_LTESTS="conch-ciphers"
627%endif
628%endif
629
630cd contrib
631%if %{with gnome}
632%{__make} gnome-ssh-askpass1 \
633 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
634%endif
635%if %{with gtk}
636%{__make} gnome-ssh-askpass2 \
637 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
638%endif
639
640%install
641rm -rf $RPM_BUILD_ROOT
642install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
643 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir},%{systemdunitdir}}
644install -d $RPM_BUILD_ROOT%{_sysconfdir}/ssh{,d}_config.d
645install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
646
647%{__make} install \
648 DESTDIR=$RPM_BUILD_ROOT
649
650bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
651
652install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
653cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
654cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
655cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
656ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
657cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
658cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config.d/50-pld.conf
659cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config.d/50-pld.conf
660cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
661
662cp -p %{SOURCE9} %{SOURCE11} %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}
663install -p %{SOURCE10} $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
664
665%{__sed} -i -e 's|@@LIBEXECDIR@@|%{_libexecdir}|g' \
666 $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd \
667 $RPM_BUILD_ROOT%{systemdunitdir}/sshd.service \
668 $RPM_BUILD_ROOT%{systemdunitdir}/sshd@.service \
669 $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
670
671%if %{with gnome}
672install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
673%endif
674%if %{with gtk}
675install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
676%endif
677%if %{with gnome} || %{with gtk}
678cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
679#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
680EOF
681cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
682#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
683EOF
684ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
685%endif
686
687install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
688cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
689
690touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
691
692cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
693#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
694EOF
695
696%if "%{pld_release}" == "ac"
697# not present in ac, no point searching it
698%{__sed} -i -e '/pam_keyinit.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
699# openssl on ac does not have OPENSSL_HAS_ECC
700%{__sed} -i -e '/ecdsa/d' $RPM_BUILD_ROOT%{_libexecdir}/sshd-keygen
701%endif
702
703%if %{without audit}
704# remove recording user's login uid to the process attribute
705%{__sed} -i -e '/pam_loginuid.so/d' $RPM_BUILD_ROOT/etc/pam.d/sshd
706%endif
707
708%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
709%{?with_ldap:%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/ldap.conf}
710
711%clean
712rm -rf $RPM_BUILD_ROOT
713
714%post clients
715%env_update
716
717%postun clients
718%env_update
719
720%post gnome-askpass
721%env_update
722
723%postun gnome-askpass
724%env_update
725
726%pre server
727%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
728
729%post server
730/sbin/chkconfig --add sshd
731%service sshd reload "OpenSSH Daemon"
732NORESTART=1
733%systemd_post sshd.service
734
735%preun server
736if [ "$1" = "0" ]; then
737 %service sshd stop
738 /sbin/chkconfig --del sshd
739fi
740%systemd_preun sshd.service
741
742%postun server
743if [ "$1" = "0" ]; then
744 %userremove sshd
745fi
746%systemd_reload
747
748%triggerpostun server -- %{name}-server < 2:7.0p1-2
749%banner %{name}-server -e << EOF
750!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!
751! Starting from openssh 7.0 DSA keys are disabled !
752! on server and client side. You will NOT be able !
753! to use DSA keys for authentication. Please read !
754! about PubkeyAcceptedKeyTypes in man ssh_config. !
755!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
756EOF
757
758%triggerpostun server -- %{name}-server < 6.2p1-1
759cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
760sed -i -e 's#AuthorizedKeysCommandRunAs#AuthorizedKeysCommandUser##g' %{_sysconfdir}/sshd_config
761
762%triggerpostun server -- %{name}-server < 2:5.9p1-8
763# lpk.patch to ldap.patch
764if grep -qE '^(UseLPK|Lpk)' %{_sysconfdir}/sshd_config; then
765 echo >&2 "Migrating LPK patch to LDAP patch"
766 cp -f %{_sysconfdir}/sshd_config{,.rpmorig}
767 %{__sed} -i -e '
768 # disable old configs
769 # just UseLPK/LkpLdapConf supported for now
770 s/^\s*UseLPK/## Obsolete &/
771 s/^\s*Lpk/## Obsolete &/
772 # Enable new ones, assumes /etc/ldap.conf defaults, see HOWTO.ldap-keys
773 /UseLPK/iAuthorizedKeysCommand %{_libexecdir}/ssh-ldap-wrapper
774 ' %{_sysconfdir}/sshd_config
775 if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
776 /bin/systemctl try-restart sshd.service || :
777 else
778 %service -q sshd reload
779 fi
780fi
781%systemd_trigger sshd.service
782if [ -x /bin/systemd_booted ] && /bin/systemd_booted; then
783%banner %{name}-server -e << EOF
784!!!!!!!!!!!!!!!!!!!!!!! WARNING !!!!!!!!!!!!!!!!!!!!!!!!!
785! Native systemd support for sshd has been installed. !
786! Restarting sshd.service with systemctl WILL kill all !
787! active ssh sessions (daemon as such will be started). !
788!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
789EOF
790fi
791
792%post -n openldap-schema-openssh-lpk
793%openldap_schema_register %{schemadir}/openssh-lpk.schema
794%service -q ldap restart
795
796%postun -n openldap-schema-openssh-lpk
797if [ "$1" = "0" ]; then
798 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
799 %service -q ldap restart
800fi
801
802%files
803%defattr(644,root,root,755)
804%doc TODO README OVERVIEW CREDITS Change*
805%attr(755,root,root) %{_bindir}/ssh-key*
806#%attr(755,root,root) %{_bindir}/ssh-vulnkey*
807%{_mandir}/man1/ssh-key*.1*
808#%{_mandir}/man1/ssh-vulnkey*.1*
809%dir %{_sysconfdir}
810%dir %{_libexecdir}
811
812%files clients
813%defattr(644,root,root,755)
814%attr(755,root,root) %{_bindir}/ssh
815%attr(755,root,root) %{_bindir}/sftp
816%attr(755,root,root) %{_bindir}/ssh-agent
817%attr(755,root,root) %{_bindir}/ssh-add
818%attr(755,root,root) %{_bindir}/ssh-copy-id
819%attr(755,root,root) %{_bindir}/scp
820%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
821%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
822%dir %{_sysconfdir}/ssh_config.d
823%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config.d/50-pld.conf
824%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
825%{_mandir}/man1/scp.1*
826%{_mandir}/man1/ssh.1*
827%{_mandir}/man1/sftp.1*
828%{_mandir}/man1/ssh-agent.1*
829%{_mandir}/man1/ssh-add.1*
830%{_mandir}/man1/ssh-copy-id.1*
831%{_mandir}/man5/ssh_config.5*
832%{_mandir}/man8/ssh-pkcs11-helper.8*
833%lang(it) %{_mandir}/it/man1/ssh.1*
834%lang(it) %{_mandir}/it/man5/ssh_config.5*
835%lang(pl) %{_mandir}/pl/man1/scp.1*
836%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
837
838# for host-based auth (suid required for accessing private host key)
839#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
840#%{_mandir}/man8/ssh-keysign.8*
841
842%files clients-agent-profile_d
843%defattr(644,root,root,755)
844%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
845%attr(755,root,root) /etc/profile.d/ssh-agent.sh
846
847%files clients-agent-xinitrc
848%defattr(644,root,root,755)
849%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
850
851%files clients-helper-fido
852%defattr(644,root,root,755)
853%attr(755,root,root) %{_libexecdir}/ssh-sk-helper
854%{_mandir}/man8/ssh-sk-helper.8*
855
856%files server
857%defattr(644,root,root,755)
858%attr(755,root,root) %{_sbindir}/sshd
859%attr(755,root,root) %{_libexecdir}/sftp-server
860%attr(755,root,root) %{_libexecdir}/ssh-keysign
861%attr(755,root,root) %{_libexecdir}/sshd-keygen
862%{_mandir}/man8/sshd.8*
863%{_mandir}/man8/sftp-server.8*
864%{_mandir}/man8/ssh-keysign.8*
865%{_mandir}/man5/sshd_config.5*
866%{_mandir}/man5/moduli.5*
867%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
868%attr(750,root,root) %dir %{_sysconfdir}/sshd_config.d
869%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config.d/50-pld.conf
870%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
871%{_sysconfdir}/moduli
872%attr(754,root,root) /etc/rc.d/init.d/sshd
873%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
874%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
875%{systemdunitdir}/sshd.service
876%{systemdunitdir}/sshd.socket
877%{systemdunitdir}/sshd@.service
878
879%if %{with ldap}
880%files server-ldap
881%defattr(644,root,root,755)
882%doc HOWTO.ldap-keys ldap.conf
883%attr(755,root,root) %{_libexecdir}/ssh-ldap-helper
884%attr(755,root,root) %{_libexecdir}/ssh-ldap-wrapper
885%{_mandir}/man5/ssh-ldap.conf.5*
886%{_mandir}/man8/ssh-ldap-helper.8*
887%endif
888
889%if %{with gnome} || %{with gtk}
890%files gnome-askpass
891%defattr(644,root,root,755)
892%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
893%dir %{_libexecdir}/ssh
894%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
895%attr(755,root,root) %{_libexecdir}/ssh-askpass
896%endif
897
898%if %{with ldap}
899%files -n openldap-schema-openssh-lpk
900%defattr(644,root,root,755)
901%{schemadir}/openssh-lpk.schema
902%endif
This page took 0.045153 seconds and 5 git commands to generate.