]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- make rel to stand out from macros
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without chroot # without chrooted user environment support
4%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
5%bcond_without gtk # without GTK+ (2.x)
6%bcond_with ldap # with ldap support
7%bcond_without libedit # without libedit (editline/history support in sftp client)
8%bcond_without kerberos5 # without kerberos5 support
9%bcond_without selinux # build without SELinux support
10%bcond_with hpn # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11%bcond_with hpn_none # with hpn (above) and '-z' none cipher option
12#
13%if %{with hpn_none}
14%undefine with_hpn
15%endif
16# gtk2-based gnome-askpass means no gnome1-based
17%{?with_gtk:%undefine with_gnome}
18#
19%define _rel 5
20#
21Summary: OpenSSH free Secure Shell (SSH) implementation
22Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
23Summary(es.UTF-8): Implementación libre de SSH
24Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
25Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
26Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
27Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28Summary(pt_BR.UTF-8): Implementação livre do SSH
29Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
30Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31Name: openssh
32Version: 4.6p1
33Release: %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
34Epoch: 2
35License: BSD
36Group: Applications/Networking
37Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38# Source0-md5: 6a7fa99f44d9e1b5b04d15256e1405bb
39Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40# Source1-md5: 66943d481cc422512b537bcc2c7400d1
41Source2: %{name}d.init
42Source3: %{name}d.pamd
43Source4: %{name}.sysconfig
44Source5: ssh-agent.sh
45Source6: ssh-agent.conf
46Patch0: %{name}-no_libnsl.patch
47Patch1: %{name}-sshv1-openssl.patch
48Patch2: %{name}-linux-ipv6.patch
49Patch3: %{name}-pam_misc.patch
50Patch4: %{name}-sigpipe.patch
51# http://www.opendarwin.org/projects/openssh-lpk/
52Patch5: %{name}-lpk-4.3p1-0.3.7.patch
53Patch6: %{name}-config.patch
54Patch7: %{name}-pam-conv.patch
55# http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
56Patch8: %{name}-chroot.patch
57Patch9: %{name}-selinux.patch
58# HPN patches rediffed due sigpipe patch.
59# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
60# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
61Patch10: %{name}-4.3p1-hpn11.patch
62# Adds HPN (see p11) and an undocumented -z none cipher flag
63# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
64Patch11: %{name}-4.3p1-hpn11-none.patch
65Patch12: %{name}-include.patch
66URL: http://www.openssh.com/
67BuildRequires: %{__perl}
68BuildRequires: autoconf
69BuildRequires: automake
70%{?with_gnome:BuildRequires: gnome-libs-devel}
71%{?with_gtk:BuildRequires: gtk+2-devel}
72%{?with_kerberos5:BuildRequires: krb5-devel}
73%{?with_libedit:BuildRequires: libedit-devel}
74%{?with_selinux:BuildRequires: libselinux-devel}
75BuildRequires: libwrap-devel
76%{?with_ldap:BuildRequires: openldap-devel}
77BuildRequires: openssl-devel >= 0.9.7d
78BuildRequires: pam-devel
79%{?with_gtk:BuildRequires: pkgconfig}
80BuildRequires: rpmbuild(macros) >= 1.318
81BuildRequires: zlib-devel
82Requires: filesystem >= 3.0-11
83Requires: pam >= 0.99.7.1
84Obsoletes: ssh
85BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87%define _sysconfdir /etc/ssh
88%define _libexecdir %{_libdir}/%{name}
89%define _privsepdir /usr/share/empty
90
91%description
92Ssh (Secure Shell) a program for logging into a remote machine and for
93executing commands in a remote machine. It is intended to replace
94rlogin and rsh, and provide secure encrypted communications between
95two untrusted hosts over an insecure network. X11 connections and
96arbitrary TCP/IP ports can also be forwarded over the secure channel.
97
98OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
99it up to date in terms of security and features, as well as removing
100all patented algorithms to seperate libraries (OpenSSL).
101
102This package includes the core files necessary for both the OpenSSH
103client and server. To make this package useful, you should also
104install openssh-clients, openssh-server, or both.
105%if %{with hpn} || %{with hpn_none}
106This release includes High Performance SSH/SCP patches from
107http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
108to increase throughput on fast connections with high RTT (20-150 msec).
109See the website for '-w' values for your connection and /proc/sys TCP
110values. BTW. in a LAN you have got generally RTT < 1 msec.
111%endif
112%if %{with hpn_none}
113It also includes an undocumented '-z' option which switches
114the cipher to none after authentication is completed. Data is
115still secured from tampering and corruption in transit through
116the use of the Message Authentication Code (MAC).
117This option will significantly reduce the number of cpu cycles used
118by the SSH/SCP process. This may allow some users to see significant
119improvement in (sniffable) data tranfer rates.
120%endif
121
122%description -l de.UTF-8
123OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
124ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
125verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
126über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
127andere TCP/IP Ports können ebenso über den sicheren Channel
128weitergeleitet werden.
129
130%description -l es.UTF-8
131SSH es un programa para accesar y ejecutar órdenes en computadores
132remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
133seguro entre dos servidores en una red insegura. Conexiones X11 y
134puertas TCP/IP arbitrárias también pueden ser usadas por el canal
135seguro.
136
137OpenSSH es el resultado del trabajo del equipo de OpenBSD para
138continuar la última versión gratuita de SSH, actualizándolo en
139términos de seguridad y recursos,así también eliminando todos los
140algoritmos patentados y colocándolos en bibliotecas separadas
141(OpenSSL).
142
143Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
144también el paquete openssh-clients u openssh-server o ambos.
145
146%description -l fr.UTF-8
147OpenSSH (Secure Shell) fournit un accès à un système distant. Il
148remplace telnet, rlogin, rexec et rsh, tout en assurant des
149communications cryptées securisées entre deux hôtes non fiabilisés sur
150un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
151arbitraires peuvent également être transmis sur le canal sécurisé.
152
153%description -l it.UTF-8
154OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
155Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
156sicure e crittate tra due host non fidati su una rete non sicura. Le
157connessioni X11 ad una porta TCP/IP arbitraria possono essere
158inoltrate attraverso un canale sicuro.
159
160%description -l pl.UTF-8
161Ssh (Secure Shell) to program służący do logowania się na zdalną
162maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
163zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
164pomiędzy dwoma hostami.
165
166Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
167klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
168co najmniej jeden z pakietów: openssh-clients lub openssh-server.
169%if %{with hpn} || %{with hpn_none}
170Ta wersja zawiera łaty z projektu High Performance SSH/SCP
171http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
172zwiększenie przepustowości transmisji dla szybkich połączeń
173z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
174odpowednie dla danego połączenia wartości parametru '-w' oraz
175opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
176%endif
177%if %{with hpn_none}
178Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
179za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
180Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
181stosowanie Message Authentication Code (MAC).
182Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
183procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
184na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
185%endif
186
187%description -l pt.UTF-8
188OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
189telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
190cifradas entre duas máquinas sem confiança mútua sobre uma rede
191insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
192reenviados pelo canal seguro.
193
194%description -l pt_BR.UTF-8
195SSH é um programa para acessar e executar comandos em máquinas
196remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
197seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
198TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
199
200OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
201última versão gratuita do SSH, atualizando-o em termos de segurança e
202recursos, assim como removendo todos os algoritmos patenteados e
203colocando-os em bibliotecas separadas (OpenSSL).
204
205Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
206também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
207
208%description -l ru.UTF-8
209Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
210машину и для выполнения команд на удаленной машине. Она предназначена
211для замены rlogin и rsh и обеспечивает безопасную шифрованную
212коммуникацию между двумя хостами в сети, являющейся небезопасной.
213Соединения X11 и любые порты TCP/IP могут также быть проведены через
214безопасный канал.
215
216OpenSSH - это переделка командой разработчиков OpenBSD последней
217свободной версии SSH, доведенная до современного состояния в терминах
218уровня безопасности и поддерживаемых возможностей. Все патентованные
219алгоритмы вынесены в отдельные библиотеки (OpenSSL).
220
221Этот пакет содержит файлы, необходимые как для клиента, так и для
222сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
223openssh-server, или оба пакета.
224
225%description -l uk.UTF-8
226Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
227машини та для виконання команд на віддаленій машині. Вона призначена
228для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
229між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
230довільні порти TCP/IP можуть також бути проведені через безпечний
231канал.
232
233OpenSSH - це переробка командою розробників OpenBSD останньої вільної
234версії SSH, доведена до сучасного стану в термінах рівня безпеки та
235підтримуваних можливостей. Всі патентовані алгоритми винесені до
236окремих бібліотек (OpenSSL).
237
238Цей пакет містить файли, необхідні як для клієнта, так і для сервера
239OpenSSH. Вам потрібно буде ще встановити openssh-clients,
240openssh-server, чи обидва пакети.
241
242%package clients
243Summary: OpenSSH Secure Shell protocol clients
244Summary(es.UTF-8): Clientes de OpenSSH
245Summary(pl.UTF-8): Klienci protokołu Secure Shell
246Summary(pt_BR.UTF-8): Clientes do OpenSSH
247Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
248Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
249Group: Applications/Networking
250Requires: %{name} = %{epoch}:%{version}-%{release}
251Provides: ssh-clients
252Obsoletes: ssh-clients
253
254%description clients
255Ssh (Secure Shell) a program for logging into a remote machine and for
256executing commands in a remote machine. It is intended to replace
257rlogin and rsh, and provide secure encrypted communications between
258two untrusted hosts over an insecure network. X11 connections and
259arbitrary TCP/IP ports can also be forwarded over the secure channel.
260
261OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
262it up to date in terms of security and features, as well as removing
263all patented algorithms to seperate libraries (OpenSSL).
264
265This package includes the clients necessary to make encrypted
266connections to SSH servers.
267
268%description clients -l es.UTF-8
269Este paquete incluye los clientes que se necesitan para hacer
270conexiones codificadas con servidores SSH.
271
272%description clients -l pl.UTF-8
273Ssh (Secure Shell) to program służący do logowania się na zdalną
274maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
275zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
276pomiędzy dwoma hostami.
277
278Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
279
280%description clients -l pt_BR.UTF-8
281Esse pacote inclui os clientes necessários para fazer conexões
282encriptadas com servidores SSH.
283
284%description clients -l ru.UTF-8
285Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
286машину и для выполнения команд на удаленной машине.
287
288Этот пакет содержит программы-клиенты, необходимые для установления
289зашифрованных соединений с серверами SSH.
290
291%description clients -l uk.UTF-8
292Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
293машини та для виконання команд на віддаленій машині.
294
295Цей пакет містить програми-клієнти, необхідні для встановлення
296зашифрованих з'єднань з серверами SSH.
297
298%package clients-agent-profile_d
299Summary: OpenSSH Secure Shell agent init script
300Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
301Group: Applications/Networking
302Requires: %{name}-clients = %{epoch}:%{version}-%{release}
303
304%description clients-agent-profile_d
305profile.d scripts for starting SSH agent.
306
307%description clients-agent-profile_d -l pl.UTF-8
308Skrypty profile.d do uruchamiania agenta SSH.
309
310%package clients-agent-xinitrc
311Summary: OpenSSH Secure Shell agent init script
312Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
313Group: Applications/Networking
314Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
315Requires: xinitrc
316
317%description clients-agent-xinitrc
318xinitrc scripts for starting SSH agent.
319
320%description clients-agent-xinitrc -l pl.UTF-8
321Skrypty xinitrc do uruchamiania agenta SSH.
322
323%package server
324Summary: OpenSSH Secure Shell protocol server (sshd)
325Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
326Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
327Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
328Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
329Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
330Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
331Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
332Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
333Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
334Group: Networking/Daemons
335Requires(post): chkconfig >= 0.9
336Requires(post): grep
337Requires(post,preun): /sbin/chkconfig
338Requires(postun): /usr/sbin/userdel
339Requires(pre): /bin/id
340Requires(pre): /usr/sbin/useradd
341Requires: %{name} = %{epoch}:%{version}-%{release}
342Requires: /bin/login
343Requires: pam >= 0.99.7.1
344Requires: rc-scripts >= 0.4.0.18
345Requires: util-linux
346Provides: ssh-server
347Provides: user(sshd)
348
349%description server
350Ssh (Secure Shell) a program for logging into a remote machine and for
351executing commands in a remote machine. It is intended to replace
352rlogin and rsh, and provide secure encrypted communications between
353two untrusted hosts over an insecure network. X11 connections and
354arbitrary TCP/IP ports can also be forwarded over the secure channel.
355
356OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
357it up to date in terms of security and features, as well as removing
358all patented algorithms to seperate libraries (OpenSSL).
359
360This package contains the secure shell daemon. The sshd is the server
361part of the secure shell protocol and allows ssh clients to connect to
362your host.
363
364%description server -l de.UTF-8
365Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
366
367%description server -l es.UTF-8
368Este paquete contiene el servidor SSH. sshd es la parte servidor del
369protocolo secure shell y permite que clientes ssh se conecten a su
370servidor.
371
372%description server -l fr.UTF-8
373Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
374
375%description server -l it.UTF-8
376Questo pacchetto installa sshd, il server di OpenSSH.
377
378%description server -l pl.UTF-8
379Ssh (Secure Shell) to program służący do logowania się na zdalną
380maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
381zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
382pomiędzy dwoma hostami.
383
384Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
385ssh).
386
387%description server -l pt.UTF-8
388Este pacote intala o sshd, o servidor do OpenSSH.
389
390%description server -l pt_BR.UTF-8
391Esse pacote contém o servidor SSH. O sshd é a parte servidor do
392protocolo secure shell e permite que clientes ssh se conectem ao seu
393host.
394
395%description server -l ru.UTF-8
396Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
397машину и для выполнения команд на удаленной машине.
398
399Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
400часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
401вашим хостом.
402
403%description server -l uk.UTF-8
404Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
405машини та для виконання команд на віддаленій машині.
406
407Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
408частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
409з вашим хостом.
410
411%package gnome-askpass
412Summary: OpenSSH GNOME passphrase dialog
413Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
414Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
415Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
416Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
417Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
418Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
419Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
420Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
421Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
422Group: Applications/Networking
423Requires: %{name} = %{epoch}:%{version}-%{release}
424Obsoletes: openssh-askpass
425Obsoletes: ssh-askpass
426Obsoletes: ssh-extras
427
428%description gnome-askpass
429Ssh (Secure Shell) a program for logging into a remote machine and for
430executing commands in a remote machine. It is intended to replace
431rlogin and rsh, and provide secure encrypted communications between
432two untrusted hosts over an insecure network. X11 connections and
433arbitrary TCP/IP ports can also be forwarded over the secure channel.
434
435OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
436it up to date in terms of security and features, as well as removing
437all patented algorithms to seperate libraries (OpenSSL).
438
439This package contains the GNOME passphrase dialog.
440
441%description gnome-askpass -l es.UTF-8
442Este paquete contiene un programa que abre una caja de diálogo para
443entrada de passphrase en GNOME.
444
445%description gnome-askpass -l pl.UTF-8
446Ssh (Secure Shell) to program służący do logowania się na zdalną
447maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
448zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
449pomiędzy dwoma hostami.
450
451Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
452
453%description gnome-askpass -l pt_BR.UTF-8
454Esse pacote contém um programa que abre uma caixa de diálogo para
455entrada de passphrase no GNOME.
456
457%description gnome-askpass -l ru.UTF-8
458Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
459машину и для выполнения команд на удаленной машине.
460
461Этот пакет содержит диалог ввода ключевой фразы для использования под
462GNOME.
463
464%description gnome-askpass -l uk.UTF-8
465Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
466машини та для виконання команд на віддаленій машині.
467
468Цей пакет містить діалог вводу ключової фрази для використання під
469GNOME.
470
471%prep
472%setup -q
473%patch0 -p1
474%patch1 -p1
475%patch2 -p1
476%patch3 -p1
477%patch4 -p1
478%{?with_ldap:%patch5 -p1}
479%patch6 -p1
480#%patch7 -p1
481%patch8 -p1
482%patch9 -p1
483%{?with_hpn:%patch10 -p1}
484%{?with_hpn_none:%patch11 -p1}
485%patch12 -p1
486
487%build
488cp /usr/share/automake/config.sub .
489%{__aclocal}
490%{__autoconf}
491%{?with_chroot:CPPFLAGS="-DCHROOT"}
492%configure \
493 PERL=%{__perl} \
494 --with-dns \
495 --with-pam \
496 --with-mantype=man \
497 --with-md5-passwords \
498 --with-ipaddr-display \
499 %{?with_libedit:--with-libedit} \
500 --with-4in6 \
501 --disable-suid-ssh \
502 --with-tcp-wrappers \
503 %{?with_ldap:--with-libs="-lldap -llber"} \
504 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
505 %{?with_kerberos5:--with-kerberos5=/usr} \
506 --with-privsep-path=%{_privsepdir} \
507 --with-pid-dir=%{_localstatedir}/run \
508 --with-xauth=/usr/bin/xauth \
509 --enable-utmpx \
510 --enable-wtmpx
511
512echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
513
514%{__make}
515
516cd contrib
517%if %{with gnome}
518%{__make} gnome-ssh-askpass1 \
519 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
520%endif
521%if %{with gtk}
522%{__make} gnome-ssh-askpass2 \
523 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
524%endif
525
526%install
527rm -rf $RPM_BUILD_ROOT
528install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
529 $RPM_BUILD_ROOT%{_libexecdir}/ssh
530install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
531
532%{__make} install \
533 DESTDIR=$RPM_BUILD_ROOT
534
535bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
536
537install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
538install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
539install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
540install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
541ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
542install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
543
544%if %{with gnome}
545install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
546%endif
547%if %{with gtk}
548install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
549%endif
550%if %{with gnome} || %{with gtk}
551cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
552#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
553EOF
554cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
555#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
556EOF
557ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
558%endif
559
560rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
561echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
562
563touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
564
565%if "%{_lib}" != "lib"
566find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
567%endif
568
569cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
570#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
571EOF
572
573%clean
574rm -rf $RPM_BUILD_ROOT
575
576%post clients
577%env_update
578
579%postun clients
580%env_update
581
582%post gnome-askpass
583%env_update
584
585%postun gnome-askpass
586%env_update
587
588%pre server
589%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
590
591%post server
592/sbin/chkconfig --add sshd
593%service sshd reload "openssh daemon"
594if ! grep -qs ssh /etc/security/passwd.conf ; then
595 umask 022
596 echo "ssh" >> /etc/security/passwd.conf
597fi
598
599%preun server
600if [ "$1" = "0" ]; then
601 %service sshd stop
602 /sbin/chkconfig --del sshd
603fi
604
605%postun server
606if [ "$1" = "0" ]; then
607 %userremove sshd
608fi
609
610%files
611%defattr(644,root,root,755)
612%doc *.RNG TODO README OVERVIEW CREDITS Change*
613%attr(755,root,root) %{_bindir}/ssh-key*
614%{_mandir}/man1/ssh-key*.1*
615%dir %{_sysconfdir}
616%dir %{_libexecdir}
617
618%files clients
619%defattr(644,root,root,755)
620%attr(755,root,root) %{_bindir}/ssh
621%attr(755,root,root) %{_bindir}/slogin
622%attr(755,root,root) %{_bindir}/sftp
623%attr(755,root,root) %{_bindir}/ssh-agent
624%attr(755,root,root) %{_bindir}/ssh-add
625%attr(755,root,root) %{_bindir}/scp
626%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
627%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
628%{_mandir}/man1/scp.1*
629%{_mandir}/man1/ssh.1*
630%{_mandir}/man1/slogin.1*
631%{_mandir}/man1/sftp.1*
632%{_mandir}/man1/ssh-agent.1*
633%{_mandir}/man1/ssh-add.1*
634%{_mandir}/man5/ssh_config.5*
635%lang(it) %{_mandir}/it/man1/ssh.1*
636%lang(it) %{_mandir}/it/man5/ssh_config.5*
637%lang(pl) %{_mandir}/pl/man1/scp.1*
638%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
639
640# for host-based auth (suid required for accessing private host key)
641#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
642#%{_mandir}/man8/ssh-keysign.8*
643
644%files clients-agent-profile_d
645%defattr(644,root,root,755)
646%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
647%attr(755,root,root) /etc/profile.d/ssh-agent.sh
648
649%files clients-agent-xinitrc
650%defattr(644,root,root,755)
651%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
652
653%files server
654%defattr(644,root,root,755)
655%attr(755,root,root) %{_sbindir}/sshd
656%attr(755,root,root) %{_libexecdir}/sftp-server
657%attr(755,root,root) %{_libexecdir}/ssh-keysign
658%{_mandir}/man8/sshd.8*
659%{_mandir}/man8/sftp-server.8*
660%{_mandir}/man8/ssh-keysign.8*
661%{_mandir}/man5/sshd_config.5*
662%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
663%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
664%attr(640,root,root) %{_sysconfdir}/moduli
665%attr(754,root,root) /etc/rc.d/init.d/sshd
666%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
667%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
668
669%if %{with gnome} || %{with gtk}
670%files gnome-askpass
671%defattr(644,root,root,755)
672%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
673%dir %{_libexecdir}/ssh
674%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
675%attr(755,root,root) %{_libexecdir}/ssh-askpass
676%endif
This page took 0.047399 seconds and 4 git commands to generate.