]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
openssl rebuild, rel 8
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
4%bcond_without gtk # without GTK+ (2.x)
5%bcond_without ldap # with ldap support
6%bcond_without libedit # without libedit (editline/history support in sftp client)
7%bcond_without kerberos5 # without kerberos5 support
8%bcond_without selinux # build without SELinux support
9%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11# gtk2-based gnome-askpass means no gnome1-based
12%{?with_gtk:%undefine with_gnome}
13
14%if "%{pld_release}" == "ac"
15%define pam_ver 0.79.0
16%else
17%define pam_ver 0.99.7.1
18%endif
19
20Summary: OpenSSH free Secure Shell (SSH) implementation
21Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
22Summary(es.UTF-8): Implementación libre de SSH
23Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
24Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
25Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
26Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27Summary(pt_BR.UTF-8): Implementação livre do SSH
28Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
29Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
30Name: openssh
31Version: 5.8p1
32Release: 8
33Epoch: 2
34License: BSD
35Group: Applications/Networking
36Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37# Source0-md5: 86f5e1c23b4c4845f23b9b7b493fb53d
38Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39# Source1-md5: 66943d481cc422512b537bcc2c7400d1
40Source2: %{name}d.init
41Source3: %{name}d.pamd
42Source4: %{name}.sysconfig
43Source5: ssh-agent.sh
44Source6: ssh-agent.conf
45Source7: %{name}-lpk.schema
46Source8: %{name}d.upstart
47Patch100: %{name}-heimdal.patch
48Patch0: %{name}-no_libnsl.patch
49Patch2: %{name}-pam_misc.patch
50Patch3: %{name}-sigpipe.patch
51# http://code.google.com/p/openssh-lpk/
52Patch4: %{name}-lpk.patch
53Patch5: %{name}-config.patch
54# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
55# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
56Patch9: %{name}-5.2p1-hpn13v6.diff
57Patch10: %{name}-include.patch
58Patch11: %{name}-chroot.patch
59# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
60Patch12: %{name}-blacklist.diff
61Patch13: %{name}-kuserok.patch
62URL: http://www.openssh.com/portable.html
63BuildRequires: %{__perl}
64BuildRequires: autoconf
65BuildRequires: automake
66%{?with_gnome:BuildRequires: gnome-libs-devel}
67%{?with_gtk:BuildRequires: gtk+2-devel}
68%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
69%{?with_libedit:BuildRequires: libedit-devel}
70%{?with_selinux:BuildRequires: libselinux-devel}
71BuildRequires: libwrap-devel
72%{?with_ldap:BuildRequires: openldap-devel}
73BuildRequires: openssl-devel >= 0.9.7d
74BuildRequires: pam-devel
75%{?with_gtk:BuildRequires: pkgconfig}
76BuildRequires: rpm >= 4.4.9-56
77BuildRequires: rpmbuild(macros) >= 1.318
78BuildRequires: sed >= 4.0
79BuildRequires: zlib-devel
80%if "%{pld_release}" == "ac"
81Requires: filesystem >= 2.0-1
82Requires: pam >= 0.79.0
83%else
84Requires: filesystem >= 3.0-11
85Requires: pam >= %{pam_ver}
86Suggests: openssh-blacklist
87Suggests: xorg-app-xauth
88%endif
89Obsoletes: ssh
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92%define _sysconfdir /etc/ssh
93%define _libexecdir %{_libdir}/%{name}
94%define _privsepdir /usr/share/empty
95%define schemadir /usr/share/openldap/schema
96
97## to be moved to rpm-build-macros
98## TODO: handle RPM_SKIP_AUTO_RESTART
99
100# migrate from init script to upstart job
101%define upstart_post() \
102 if [ -f /var/lock/subsys/"%1" ] ; then \
103 /sbin/service --no-upstart "%1" stop \
104 /sbin/service "%1" start \
105 else \
106 /sbin/service "%1" try-restart \
107 fi
108
109# restart the job after upgrade or migrate to init script on removal
110%define upstart_postun() \
111 if [ -x /sbin/initctl ] && /sbin/initctl status "%1" 2>/dev/null | grep -q 'running' ; then \
112 /sbin/initctl stop "%1" 2>/dev/null \
113 [ -f "/etc/rc.d/init.d/%1" -o -f "/etc/init/%1.conf" ] && /sbin/service "%1" start \
114 fi
115
116
117%description
118Ssh (Secure Shell) a program for logging into a remote machine and for
119executing commands in a remote machine. It is intended to replace
120rlogin and rsh, and provide secure encrypted communications between
121two untrusted hosts over an insecure network. X11 connections and
122arbitrary TCP/IP ports can also be forwarded over the secure channel.
123
124OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
125it up to date in terms of security and features, as well as removing
126all patented algorithms to seperate libraries (OpenSSL).
127
128This package includes the core files necessary for both the OpenSSH
129client and server. To make this package useful, you should also
130install openssh-clients, openssh-server, or both.
131
132%if %{with hpn}
133This release includes High Performance SSH/SCP patches from
134http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
135increase throughput on fast connections with high RTT (20-150 msec).
136See the website for '-w' values for your connection and /proc/sys TCP
137values. BTW. in a LAN you have got generally RTT < 1 msec.
138%endif
139
140%description -l de.UTF-8
141OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
142ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
143verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
144über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
145andere TCP/IP Ports können ebenso über den sicheren Channel
146weitergeleitet werden.
147
148%description -l es.UTF-8
149SSH es un programa para accesar y ejecutar órdenes en computadores
150remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
151seguro entre dos servidores en una red insegura. Conexiones X11 y
152puertas TCP/IP arbitrárias también pueden ser usadas por el canal
153seguro.
154
155OpenSSH es el resultado del trabajo del equipo de OpenBSD para
156continuar la última versión gratuita de SSH, actualizándolo en
157términos de seguridad y recursos,así también eliminando todos los
158algoritmos patentados y colocándolos en bibliotecas separadas
159(OpenSSL).
160
161Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
162también el paquete openssh-clients u openssh-server o ambos.
163
164%description -l fr.UTF-8
165OpenSSH (Secure Shell) fournit un accès à un système distant. Il
166remplace telnet, rlogin, rexec et rsh, tout en assurant des
167communications cryptées securisées entre deux hôtes non fiabilisés sur
168un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
169arbitraires peuvent également être transmis sur le canal sécurisé.
170
171%description -l it.UTF-8
172OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
173Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
174sicure e crittate tra due host non fidati su una rete non sicura. Le
175connessioni X11 ad una porta TCP/IP arbitraria possono essere
176inoltrate attraverso un canale sicuro.
177
178%description -l pl.UTF-8
179Ssh (Secure Shell) to program służący do logowania się na zdalną
180maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
181zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
182pomiędzy dwoma hostami.
183
184Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
185klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
186co najmniej jeden z pakietów: openssh-clients lub openssh-server.
187
188%if %{with hpn}
189Ta wersja zawiera łaty z projektu High Performance SSH/SCP
190http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
191zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
192RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
193danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
194TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
195%endif
196
197%description -l pt.UTF-8
198OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
199telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
200cifradas entre duas máquinas sem confiança mútua sobre uma rede
201insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
202reenviados pelo canal seguro.
203
204%description -l pt_BR.UTF-8
205SSH é um programa para acessar e executar comandos em máquinas
206remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
207seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
208TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
209
210OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
211última versão gratuita do SSH, atualizando-o em termos de segurança e
212recursos, assim como removendo todos os algoritmos patenteados e
213colocando-os em bibliotecas separadas (OpenSSL).
214
215Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
216também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
217
218%description -l ru.UTF-8
219Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
220машину и для выполнения команд на удаленной машине. Она предназначена
221для замены rlogin и rsh и обеспечивает безопасную шифрованную
222коммуникацию между двумя хостами в сети, являющейся небезопасной.
223Соединения X11 и любые порты TCP/IP могут также быть проведены через
224безопасный канал.
225
226OpenSSH - это переделка командой разработчиков OpenBSD последней
227свободной версии SSH, доведенная до современного состояния в терминах
228уровня безопасности и поддерживаемых возможностей. Все патентованные
229алгоритмы вынесены в отдельные библиотеки (OpenSSL).
230
231Этот пакет содержит файлы, необходимые как для клиента, так и для
232сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
233openssh-server, или оба пакета.
234
235%description -l uk.UTF-8
236Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
237машини та для виконання команд на віддаленій машині. Вона призначена
238для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
239між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
240довільні порти TCP/IP можуть також бути проведені через безпечний
241канал.
242
243OpenSSH - це переробка командою розробників OpenBSD останньої вільної
244версії SSH, доведена до сучасного стану в термінах рівня безпеки та
245підтримуваних можливостей. Всі патентовані алгоритми винесені до
246окремих бібліотек (OpenSSL).
247
248Цей пакет містить файли, необхідні як для клієнта, так і для сервера
249OpenSSH. Вам потрібно буде ще встановити openssh-clients,
250openssh-server, чи обидва пакети.
251
252%package clients
253Summary: OpenSSH Secure Shell protocol clients
254Summary(es.UTF-8): Clientes de OpenSSH
255Summary(pl.UTF-8): Klienci protokołu Secure Shell
256Summary(pt_BR.UTF-8): Clientes do OpenSSH
257Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
258Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
259Group: Applications/Networking
260Requires: %{name}
261Provides: ssh-clients
262Obsoletes: ssh-clients
263
264%description clients
265Ssh (Secure Shell) a program for logging into a remote machine and for
266executing commands in a remote machine. It is intended to replace
267rlogin and rsh, and provide secure encrypted communications between
268two untrusted hosts over an insecure network. X11 connections and
269arbitrary TCP/IP ports can also be forwarded over the secure channel.
270
271OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
272it up to date in terms of security and features, as well as removing
273all patented algorithms to seperate libraries (OpenSSL).
274
275This package includes the clients necessary to make encrypted
276connections to SSH servers.
277
278%description clients -l es.UTF-8
279Este paquete incluye los clientes que se necesitan para hacer
280conexiones codificadas con servidores SSH.
281
282%description clients -l pl.UTF-8
283Ssh (Secure Shell) to program służący do logowania się na zdalną
284maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
285zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
286pomiędzy dwoma hostami.
287
288Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
289
290%description clients -l pt_BR.UTF-8
291Esse pacote inclui os clientes necessários para fazer conexões
292encriptadas com servidores SSH.
293
294%description clients -l ru.UTF-8
295Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
296машину и для выполнения команд на удаленной машине.
297
298Этот пакет содержит программы-клиенты, необходимые для установления
299зашифрованных соединений с серверами SSH.
300
301%description clients -l uk.UTF-8
302Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
303машини та для виконання команд на віддаленій машині.
304
305Цей пакет містить програми-клієнти, необхідні для встановлення
306зашифрованих з'єднань з серверами SSH.
307
308%package clients-agent-profile_d
309Summary: OpenSSH Secure Shell agent init script
310Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
311Group: Applications/Networking
312Requires: %{name}-clients = %{epoch}:%{version}-%{release}
313
314%description clients-agent-profile_d
315profile.d scripts for starting SSH agent.
316
317%description clients-agent-profile_d -l pl.UTF-8
318Skrypty profile.d do uruchamiania agenta SSH.
319
320%package clients-agent-xinitrc
321Summary: OpenSSH Secure Shell agent init script
322Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
323Group: Applications/Networking
324Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
325Requires: xinitrc
326
327%description clients-agent-xinitrc
328xinitrc scripts for starting SSH agent.
329
330%description clients-agent-xinitrc -l pl.UTF-8
331Skrypty xinitrc do uruchamiania agenta SSH.
332
333%package server
334Summary: OpenSSH Secure Shell protocol server (sshd)
335Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
336Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
337Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
338Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
339Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
340Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
341Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
342Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
343Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
344Group: Networking/Daemons
345Requires(post): /sbin/chkconfig
346Requires(post): grep
347Requires(post,preun): /sbin/chkconfig
348Requires(postun): /usr/sbin/userdel
349Requires(pre): /bin/id
350Requires(pre): /usr/sbin/useradd
351Requires: %{name} = %{epoch}:%{version}-%{release}
352Requires: pam >= %{pam_ver}
353Requires: rc-scripts >= 0.4.3.0
354Requires: util-linux
355Suggests: /bin/login
356Provides: ssh-server
357Provides: user(sshd)
358
359%description server
360Ssh (Secure Shell) a program for logging into a remote machine and for
361executing commands in a remote machine. It is intended to replace
362rlogin and rsh, and provide secure encrypted communications between
363two untrusted hosts over an insecure network. X11 connections and
364arbitrary TCP/IP ports can also be forwarded over the secure channel.
365
366OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
367it up to date in terms of security and features, as well as removing
368all patented algorithms to seperate libraries (OpenSSL).
369
370This package contains the secure shell daemon. The sshd is the server
371part of the secure shell protocol and allows ssh clients to connect to
372your host.
373
374%description server -l de.UTF-8
375Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
376
377%description server -l es.UTF-8
378Este paquete contiene el servidor SSH. sshd es la parte servidor del
379protocolo secure shell y permite que clientes ssh se conecten a su
380servidor.
381
382%description server -l fr.UTF-8
383Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
384
385%description server -l it.UTF-8
386Questo pacchetto installa sshd, il server di OpenSSH.
387
388%description server -l pl.UTF-8
389Ssh (Secure Shell) to program służący do logowania się na zdalną
390maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
391zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
392pomiędzy dwoma hostami.
393
394Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
395ssh).
396
397%description server -l pt.UTF-8
398Este pacote intala o sshd, o servidor do OpenSSH.
399
400%description server -l pt_BR.UTF-8
401Esse pacote contém o servidor SSH. O sshd é a parte servidor do
402protocolo secure shell e permite que clientes ssh se conectem ao seu
403host.
404
405%description server -l ru.UTF-8
406Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
407машину и для выполнения команд на удаленной машине.
408
409Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
410часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
411вашим хостом.
412
413%description server -l uk.UTF-8
414Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
415машини та для виконання команд на віддаленій машині.
416
417Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
418частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
419з вашим хостом.
420
421%package server-upstart
422Summary: Upstart job description for OpenSSH server
423Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
424Group: Daemons
425Requires: %{name}-server = %{epoch}:%{version}-%{release}
426Requires: upstart >= 0.6
427
428%description server-upstart
429Upstart job description for OpenSSH.
430
431%description server-upstart -l pl.UTF-8
432Opis zadania Upstart dla OpenSSH.
433
434%package gnome-askpass
435Summary: OpenSSH GNOME passphrase dialog
436Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
437Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
438Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
439Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
440Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
441Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
442Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
443Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
444Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
445Group: Applications/Networking
446Requires: %{name} = %{epoch}:%{version}-%{release}
447Obsoletes: openssh-askpass
448Obsoletes: ssh-askpass
449Obsoletes: ssh-extras
450
451%description gnome-askpass
452Ssh (Secure Shell) a program for logging into a remote machine and for
453executing commands in a remote machine. It is intended to replace
454rlogin and rsh, and provide secure encrypted communications between
455two untrusted hosts over an insecure network. X11 connections and
456arbitrary TCP/IP ports can also be forwarded over the secure channel.
457
458OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
459it up to date in terms of security and features, as well as removing
460all patented algorithms to seperate libraries (OpenSSL).
461
462This package contains the GNOME passphrase dialog.
463
464%description gnome-askpass -l es.UTF-8
465Este paquete contiene un programa que abre una caja de diálogo para
466entrada de passphrase en GNOME.
467
468%description gnome-askpass -l pl.UTF-8
469Ssh (Secure Shell) to program służący do logowania się na zdalną
470maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
471zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
472pomiędzy dwoma hostami.
473
474Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
475
476%description gnome-askpass -l pt_BR.UTF-8
477Esse pacote contém um programa que abre uma caixa de diálogo para
478entrada de passphrase no GNOME.
479
480%description gnome-askpass -l ru.UTF-8
481Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
482машину и для выполнения команд на удаленной машине.
483
484Этот пакет содержит диалог ввода ключевой фразы для использования под
485GNOME.
486
487%description gnome-askpass -l uk.UTF-8
488Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
489машини та для виконання команд на віддаленій машині.
490
491Цей пакет містить діалог вводу ключової фрази для використання під
492GNOME.
493
494%package -n openldap-schema-openssh-lpk
495Summary: OpenSSH LDAP Public Key schema
496Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
497Group: Networking/Daemons
498Requires(post,postun): sed >= 4.0
499Requires: openldap-servers
500
501%description -n openldap-schema-openssh-lpk
502This package contains OpenSSH LDAP Public Key schema for openldap.
503
504%description -n openldap-schema-openssh-lpk -l pl.UTF-8
505Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
506openldap-a.
507
508%prep
509%setup -q
510%{?with_kerberos5:%patch100 -p1}
511%patch0 -p1
512%patch2 -p1
513%patch3 -p1
514%{?with_ldap:%patch4 -p1}
515%patch5 -p1
516%{?with_hpn:%patch9 -p1}
517%patch10 -p1
518%patch11 -p1
519%patch12 -p1
520%patch13 -p1
521
522cp -p %{SOURCE3} sshd.pam
523install -p %{SOURCE2} sshd.init
524
525%if "%{pld_release}" == "ac"
526# fix for missing x11.pc
527%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
528# not present in ac, no point searching it
529%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
530%endif
531
532%build
533cp /usr/share/automake/config.sub .
534%{__aclocal}
535%{__autoconf}
536CPPFLAGS="-DCHROOT"
537%configure \
538 PERL=%{__perl} \
539 --with-pam \
540 --with-mantype=man \
541 --with-md5-passwords \
542 --with-ipaddr-display \
543 %{?with_libedit:--with-libedit} \
544 --with-4in6 \
545 --with-tcp-wrappers \
546 %{?with_ldap:--with-libs="-lldap -llber"} \
547 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
548 %{?with_kerberos5:--with-kerberos5=/usr} \
549 --with-privsep-path=%{_privsepdir} \
550 --with-pid-dir=%{_localstatedir}/run \
551%if "%{pld_release}" == "ac"
552 --with-xauth=/usr/X11R6/bin/xauth \
553%else
554 --with-xauth=%{_bindir}/xauth \
555%endif
556 --enable-utmpx \
557 --enable-wtmpx
558
559echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
560
561%{__make}
562
563cd contrib
564%if %{with gnome}
565%{__make} gnome-ssh-askpass1 \
566 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
567%endif
568%if %{with gtk}
569%{__make} gnome-ssh-askpass2 \
570 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
571%endif
572
573%install
574rm -rf $RPM_BUILD_ROOT
575install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
576 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
577install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
578
579%{__make} install \
580 DESTDIR=$RPM_BUILD_ROOT
581
582bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
583
584install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
585cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
586cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
587cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
588ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
589cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
590cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
591cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
592
593%if %{with gnome}
594install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
595%endif
596%if %{with gtk}
597install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
598%endif
599%if %{with gnome} || %{with gtk}
600cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
601#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
602EOF
603cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
604#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
605EOF
606ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
607%endif
608
609install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
610cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
611
612rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
613echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
614
615touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
616
617cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
618#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
619EOF
620
621rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
622rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
623
624%clean
625rm -rf $RPM_BUILD_ROOT
626
627%post clients
628%env_update
629
630%postun clients
631%env_update
632
633%post gnome-askpass
634%env_update
635
636%postun gnome-askpass
637%env_update
638
639%pre server
640%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
641
642%post server
643/sbin/chkconfig --add sshd
644%service sshd reload "openssh daemon"
645if ! grep -qs ssh /etc/security/passwd.conf ; then
646 umask 022
647 echo "ssh" >> /etc/security/passwd.conf
648fi
649
650%preun server
651if [ "$1" = "0" ]; then
652 %service sshd stop
653 /sbin/chkconfig --del sshd
654fi
655
656%postun server
657if [ "$1" = "0" ]; then
658 %userremove sshd
659fi
660
661%post server-upstart
662%upstart_post sshd
663
664%postun server-upstart
665%upstart_postun sshd
666
667%post -n openldap-schema-openssh-lpk
668%openldap_schema_register %{schemadir}/openssh-lpk.schema
669%service -q ldap restart
670
671%postun -n openldap-schema-openssh-lpk
672if [ "$1" = "0" ]; then
673 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
674 %service -q ldap restart
675fi
676
677%files
678%defattr(644,root,root,755)
679%doc *.RNG TODO README OVERVIEW CREDITS Change*
680%attr(755,root,root) %{_bindir}/ssh-key*
681%attr(755,root,root) %{_bindir}/ssh-vulnkey*
682%{_mandir}/man1/ssh-key*.1*
683%{_mandir}/man1/ssh-vulnkey*.1*
684%dir %{_sysconfdir}
685%dir %{_libexecdir}
686
687%files clients
688%defattr(644,root,root,755)
689%attr(755,root,root) %{_bindir}/ssh
690%attr(755,root,root) %{_bindir}/slogin
691%attr(755,root,root) %{_bindir}/sftp
692%attr(755,root,root) %{_bindir}/ssh-agent
693%attr(755,root,root) %{_bindir}/ssh-add
694%attr(755,root,root) %{_bindir}/ssh-copy-id
695%attr(755,root,root) %{_bindir}/scp
696%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
697%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
698%{_mandir}/man1/scp.1*
699%{_mandir}/man1/ssh.1*
700%{_mandir}/man1/slogin.1*
701%{_mandir}/man1/sftp.1*
702%{_mandir}/man1/ssh-agent.1*
703%{_mandir}/man1/ssh-add.1*
704%{_mandir}/man1/ssh-copy-id.1*
705%{_mandir}/man5/ssh_config.5*
706%lang(it) %{_mandir}/it/man1/ssh.1*
707%lang(it) %{_mandir}/it/man5/ssh_config.5*
708%lang(pl) %{_mandir}/pl/man1/scp.1*
709%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
710
711# for host-based auth (suid required for accessing private host key)
712#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
713#%{_mandir}/man8/ssh-keysign.8*
714
715%files clients-agent-profile_d
716%defattr(644,root,root,755)
717%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
718%attr(755,root,root) /etc/profile.d/ssh-agent.sh
719
720%files clients-agent-xinitrc
721%defattr(644,root,root,755)
722%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
723
724%files server
725%defattr(644,root,root,755)
726%attr(755,root,root) %{_sbindir}/sshd
727%attr(755,root,root) %{_libexecdir}/sftp-server
728%attr(755,root,root) %{_libexecdir}/ssh-keysign
729%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
730%{_mandir}/man8/sshd.8*
731%{_mandir}/man8/sftp-server.8*
732%{_mandir}/man8/ssh-keysign.8*
733%{_mandir}/man8/ssh-pkcs11-helper.8*
734%{_mandir}/man5/sshd_config.5*
735%{_mandir}/man5/moduli.5*
736%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
737%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
738%attr(640,root,root) %{_sysconfdir}/moduli
739%attr(754,root,root) /etc/rc.d/init.d/sshd
740%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
741%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
742
743%if %{with gnome} || %{with gtk}
744%files gnome-askpass
745%defattr(644,root,root,755)
746%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
747%dir %{_libexecdir}/ssh
748%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
749%attr(755,root,root) %{_libexecdir}/ssh-askpass
750%endif
751
752%if %{with ldap}
753%files -n openldap-schema-openssh-lpk
754%defattr(644,root,root,755)
755%{schemadir}/openssh-lpk.schema
756%endif
757
758%if "%{pld_release}" != "ti"
759%files server-upstart
760%defattr(644,root,root,755)
761%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
762%endif
This page took 0.096525 seconds and 4 git commands to generate.