]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- outdated, remaining part looks bogus now
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without chroot # without chrooted user environment support
4%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
5%bcond_without gtk # without GTK+ (2.x)
6%bcond_with ldap # with ldap support
7%bcond_without libedit # without libedit (editline/history support in sftp client)
8%bcond_without kerberos5 # without kerberos5 support
9%bcond_without selinux # build without SELinux support
10%bcond_with hpn # with High Performance SSH/SCP - HPN-SSH (see patch comment)
11%bcond_with hpn_none # with hpn (above) and '-z' none cipher option
12#
13%if %{with hpn_none}
14%undefine with_hpn
15%endif
16# gtk2-based gnome-askpass means no gnome1-based
17%{?with_gtk:%undefine with_gnome}
18#
19%define _rel 1
20#
21Summary: OpenSSH free Secure Shell (SSH) implementation
22Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
23Summary(es.UTF-8): Implementación libre de SSH
24Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
25Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
26Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
27Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
28Summary(pt_BR.UTF-8): Implementação livre do SSH
29Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
30Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
31Name: openssh
32Version: 4.7p1
33Release: %{_rel}%{?with_hpn:hpn}%{?with_hpn_none:hpn_none}
34Epoch: 2
35License: BSD
36Group: Applications/Networking
37Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
38# Source0-md5: 50a800fd2c6def9e9a53068837e87b91
39Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
40# Source1-md5: 66943d481cc422512b537bcc2c7400d1
41Source2: %{name}d.init
42Source3: %{name}d.pamd
43Source4: %{name}.sysconfig
44Source5: ssh-agent.sh
45Source6: ssh-agent.conf
46Patch0: %{name}-no_libnsl.patch
47Patch2: %{name}-linux-ipv6.patch
48Patch3: %{name}-pam_misc.patch
49Patch4: %{name}-sigpipe.patch
50# http://www.opendarwin.org/projects/openssh-lpk/
51Patch5: %{name}-lpk-4.3p1-0.3.7.patch
52Patch6: %{name}-config.patch
53Patch7: %{name}-pam-conv.patch
54# http://chrootssh.sourceforge.net/download/osshChroot-3.7.1p2.diff
55Patch8: %{name}-chroot.patch
56Patch9: %{name}-selinux.patch
57# HPN patches rediffed due sigpipe patch.
58# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
59# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11.diff
60Patch10: %{name}-4.3p1-hpn11.patch
61# Adds HPN (see p11) and an undocumented -z none cipher flag
62# http://www.psc.edu/networking/projects/hpn-ssh/openssh-4.2p1-hpn11-none.diff
63Patch11: %{name}-4.3p1-hpn11-none.patch
64Patch12: %{name}-include.patch
65URL: http://www.openssh.com/
66BuildRequires: %{__perl}
67BuildRequires: autoconf
68BuildRequires: automake
69%{?with_gnome:BuildRequires: gnome-libs-devel}
70%{?with_gtk:BuildRequires: gtk+2-devel}
71%{?with_kerberos5:BuildRequires: krb5-devel}
72%{?with_libedit:BuildRequires: libedit-devel}
73%{?with_selinux:BuildRequires: libselinux-devel}
74BuildRequires: libwrap-devel
75%{?with_ldap:BuildRequires: openldap-devel}
76BuildRequires: openssl-devel >= 0.9.7d
77BuildRequires: pam-devel
78%{?with_gtk:BuildRequires: pkgconfig}
79BuildRequires: rpmbuild(macros) >= 1.318
80BuildRequires: zlib-devel
81Requires: filesystem >= 3.0-11
82Requires: pam >= 0.99.7.1
83Obsoletes: ssh
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86%define _sysconfdir /etc/ssh
87%define _libexecdir %{_libdir}/%{name}
88%define _privsepdir /usr/share/empty
89
90%description
91Ssh (Secure Shell) a program for logging into a remote machine and for
92executing commands in a remote machine. It is intended to replace
93rlogin and rsh, and provide secure encrypted communications between
94two untrusted hosts over an insecure network. X11 connections and
95arbitrary TCP/IP ports can also be forwarded over the secure channel.
96
97OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
98it up to date in terms of security and features, as well as removing
99all patented algorithms to seperate libraries (OpenSSL).
100
101This package includes the core files necessary for both the OpenSSH
102client and server. To make this package useful, you should also
103install openssh-clients, openssh-server, or both.
104%if %{with hpn} || %{with hpn_none}
105This release includes High Performance SSH/SCP patches from
106http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
107to increase throughput on fast connections with high RTT (20-150 msec).
108See the website for '-w' values for your connection and /proc/sys TCP
109values. BTW. in a LAN you have got generally RTT < 1 msec.
110%endif
111%if %{with hpn_none}
112It also includes an undocumented '-z' option which switches
113the cipher to none after authentication is completed. Data is
114still secured from tampering and corruption in transit through
115the use of the Message Authentication Code (MAC).
116This option will significantly reduce the number of cpu cycles used
117by the SSH/SCP process. This may allow some users to see significant
118improvement in (sniffable) data tranfer rates.
119%endif
120
121%description -l de.UTF-8
122OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
123ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
124verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
125über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
126andere TCP/IP Ports können ebenso über den sicheren Channel
127weitergeleitet werden.
128
129%description -l es.UTF-8
130SSH es un programa para accesar y ejecutar órdenes en computadores
131remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
132seguro entre dos servidores en una red insegura. Conexiones X11 y
133puertas TCP/IP arbitrárias también pueden ser usadas por el canal
134seguro.
135
136OpenSSH es el resultado del trabajo del equipo de OpenBSD para
137continuar la última versión gratuita de SSH, actualizándolo en
138términos de seguridad y recursos,así también eliminando todos los
139algoritmos patentados y colocándolos en bibliotecas separadas
140(OpenSSL).
141
142Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
143también el paquete openssh-clients u openssh-server o ambos.
144
145%description -l fr.UTF-8
146OpenSSH (Secure Shell) fournit un accès à un système distant. Il
147remplace telnet, rlogin, rexec et rsh, tout en assurant des
148communications cryptées securisées entre deux hôtes non fiabilisés sur
149un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
150arbitraires peuvent également être transmis sur le canal sécurisé.
151
152%description -l it.UTF-8
153OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
154Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
155sicure e crittate tra due host non fidati su una rete non sicura. Le
156connessioni X11 ad una porta TCP/IP arbitraria possono essere
157inoltrate attraverso un canale sicuro.
158
159%description -l pl.UTF-8
160Ssh (Secure Shell) to program służący do logowania się na zdalną
161maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
162zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
163pomiędzy dwoma hostami.
164
165Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
166klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
167co najmniej jeden z pakietów: openssh-clients lub openssh-server.
168%if %{with hpn} || %{with hpn_none}
169Ta wersja zawiera łaty z projektu High Performance SSH/SCP
170http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
171zwiększenie przepustowości transmisji dla szybkich połączeń
172z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
173odpowednie dla danego połączenia wartości parametru '-w' oraz
174opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
175%endif
176%if %{with hpn_none}
177Obsługiwana jest również nieudokumentowana opcja '-z' odpowiedzialna
178za wyłączenie szyfrowania danych po zakończeniu procesu uwierzytelniania.
179Dane są zabezpieczone przed modyfikacją lub uszkodzeniem przez
180stosowanie Message Authentication Code (MAC).
181Opcja ta znacznie redukuje liczbę cykli procesora zużywanych przez
182procesy SSH/SCP. W wybranych zastosowaniach może ona wpłynąć
183na wyraźne przyspieszenie (podsłuchiwalnej) transmisji danych.
184%endif
185
186%description -l pt.UTF-8
187OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
188telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
189cifradas entre duas máquinas sem confiança mútua sobre uma rede
190insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
191reenviados pelo canal seguro.
192
193%description -l pt_BR.UTF-8
194SSH é um programa para acessar e executar comandos em máquinas
195remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
196seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
197TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
198
199OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
200última versão gratuita do SSH, atualizando-o em termos de segurança e
201recursos, assim como removendo todos os algoritmos patenteados e
202colocando-os em bibliotecas separadas (OpenSSL).
203
204Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
205também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
206
207%description -l ru.UTF-8
208Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
209машину и для выполнения команд на удаленной машине. Она предназначена
210для замены rlogin и rsh и обеспечивает безопасную шифрованную
211коммуникацию между двумя хостами в сети, являющейся небезопасной.
212Соединения X11 и любые порты TCP/IP могут также быть проведены через
213безопасный канал.
214
215OpenSSH - это переделка командой разработчиков OpenBSD последней
216свободной версии SSH, доведенная до современного состояния в терминах
217уровня безопасности и поддерживаемых возможностей. Все патентованные
218алгоритмы вынесены в отдельные библиотеки (OpenSSL).
219
220Этот пакет содержит файлы, необходимые как для клиента, так и для
221сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
222openssh-server, или оба пакета.
223
224%description -l uk.UTF-8
225Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
226машини та для виконання команд на віддаленій машині. Вона призначена
227для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
228між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
229довільні порти TCP/IP можуть також бути проведені через безпечний
230канал.
231
232OpenSSH - це переробка командою розробників OpenBSD останньої вільної
233версії SSH, доведена до сучасного стану в термінах рівня безпеки та
234підтримуваних можливостей. Всі патентовані алгоритми винесені до
235окремих бібліотек (OpenSSL).
236
237Цей пакет містить файли, необхідні як для клієнта, так і для сервера
238OpenSSH. Вам потрібно буде ще встановити openssh-clients,
239openssh-server, чи обидва пакети.
240
241%package clients
242Summary: OpenSSH Secure Shell protocol clients
243Summary(es.UTF-8): Clientes de OpenSSH
244Summary(pl.UTF-8): Klienci protokołu Secure Shell
245Summary(pt_BR.UTF-8): Clientes do OpenSSH
246Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
247Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
248Group: Applications/Networking
249Provides: ssh-clients
250Requires: %{name} = %{epoch}:%{version}-%{release}
251Obsoletes: ssh-clients
252
253%description clients
254Ssh (Secure Shell) a program for logging into a remote machine and for
255executing commands in a remote machine. It is intended to replace
256rlogin and rsh, and provide secure encrypted communications between
257two untrusted hosts over an insecure network. X11 connections and
258arbitrary TCP/IP ports can also be forwarded over the secure channel.
259
260OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
261it up to date in terms of security and features, as well as removing
262all patented algorithms to seperate libraries (OpenSSL).
263
264This package includes the clients necessary to make encrypted
265connections to SSH servers.
266
267%description clients -l es.UTF-8
268Este paquete incluye los clientes que se necesitan para hacer
269conexiones codificadas con servidores SSH.
270
271%description clients -l pl.UTF-8
272Ssh (Secure Shell) to program służący do logowania się na zdalną
273maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
274zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
275pomiędzy dwoma hostami.
276
277Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
278
279%description clients -l pt_BR.UTF-8
280Esse pacote inclui os clientes necessários para fazer conexões
281encriptadas com servidores SSH.
282
283%description clients -l ru.UTF-8
284Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
285машину и для выполнения команд на удаленной машине.
286
287Этот пакет содержит программы-клиенты, необходимые для установления
288зашифрованных соединений с серверами SSH.
289
290%description clients -l uk.UTF-8
291Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
292машини та для виконання команд на віддаленій машині.
293
294Цей пакет містить програми-клієнти, необхідні для встановлення
295зашифрованих з'єднань з серверами SSH.
296
297%package clients-agent-profile_d
298Summary: OpenSSH Secure Shell agent init script
299Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
300Group: Applications/Networking
301Requires: %{name}-clients = %{epoch}:%{version}-%{release}
302
303%description clients-agent-profile_d
304profile.d scripts for starting SSH agent.
305
306%description clients-agent-profile_d -l pl.UTF-8
307Skrypty profile.d do uruchamiania agenta SSH.
308
309%package clients-agent-xinitrc
310Summary: OpenSSH Secure Shell agent init script
311Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
312Group: Applications/Networking
313Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
314Requires: xinitrc
315
316%description clients-agent-xinitrc
317xinitrc scripts for starting SSH agent.
318
319%description clients-agent-xinitrc -l pl.UTF-8
320Skrypty xinitrc do uruchamiania agenta SSH.
321
322%package server
323Summary: OpenSSH Secure Shell protocol server (sshd)
324Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
325Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
326Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
327Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
328Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
329Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
330Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
331Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
332Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
333Group: Networking/Daemons
334Provides: ssh-server
335Provides: user(sshd)
336Requires(post): chkconfig >= 0.9
337Requires(post): grep
338Requires(post,preun): /sbin/chkconfig
339Requires(postun): /usr/sbin/userdel
340Requires(pre): /bin/id
341Requires(pre): /usr/sbin/useradd
342Requires: %{name} = %{epoch}:%{version}-%{release}
343Requires: /bin/login
344Requires: pam >= 0.99.7.1
345Requires: rc-scripts >= 0.4.0.18
346Requires: util-linux
347
348%description server
349Ssh (Secure Shell) a program for logging into a remote machine and for
350executing commands in a remote machine. It is intended to replace
351rlogin and rsh, and provide secure encrypted communications between
352two untrusted hosts over an insecure network. X11 connections and
353arbitrary TCP/IP ports can also be forwarded over the secure channel.
354
355OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
356it up to date in terms of security and features, as well as removing
357all patented algorithms to seperate libraries (OpenSSL).
358
359This package contains the secure shell daemon. The sshd is the server
360part of the secure shell protocol and allows ssh clients to connect to
361your host.
362
363%description server -l de.UTF-8
364Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
365
366%description server -l es.UTF-8
367Este paquete contiene el servidor SSH. sshd es la parte servidor del
368protocolo secure shell y permite que clientes ssh se conecten a su
369servidor.
370
371%description server -l fr.UTF-8
372Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
373
374%description server -l it.UTF-8
375Questo pacchetto installa sshd, il server di OpenSSH.
376
377%description server -l pl.UTF-8
378Ssh (Secure Shell) to program służący do logowania się na zdalną
379maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
380zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
381pomiędzy dwoma hostami.
382
383Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
384ssh).
385
386%description server -l pt.UTF-8
387Este pacote intala o sshd, o servidor do OpenSSH.
388
389%description server -l pt_BR.UTF-8
390Esse pacote contém o servidor SSH. O sshd é a parte servidor do
391protocolo secure shell e permite que clientes ssh se conectem ao seu
392host.
393
394%description server -l ru.UTF-8
395Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
396машину и для выполнения команд на удаленной машине.
397
398Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
399часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
400вашим хостом.
401
402%description server -l uk.UTF-8
403Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
404машини та для виконання команд на віддаленій машині.
405
406Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
407частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
408з вашим хостом.
409
410%package gnome-askpass
411Summary: OpenSSH GNOME passphrase dialog
412Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
413Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
414Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
415Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
416Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
417Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
418Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
419Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
420Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
421Group: Applications/Networking
422Requires: %{name} = %{epoch}:%{version}-%{release}
423Obsoletes: openssh-askpass
424Obsoletes: ssh-askpass
425Obsoletes: ssh-extras
426
427%description gnome-askpass
428Ssh (Secure Shell) a program for logging into a remote machine and for
429executing commands in a remote machine. It is intended to replace
430rlogin and rsh, and provide secure encrypted communications between
431two untrusted hosts over an insecure network. X11 connections and
432arbitrary TCP/IP ports can also be forwarded over the secure channel.
433
434OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
435it up to date in terms of security and features, as well as removing
436all patented algorithms to seperate libraries (OpenSSL).
437
438This package contains the GNOME passphrase dialog.
439
440%description gnome-askpass -l es.UTF-8
441Este paquete contiene un programa que abre una caja de diálogo para
442entrada de passphrase en GNOME.
443
444%description gnome-askpass -l pl.UTF-8
445Ssh (Secure Shell) to program służący do logowania się na zdalną
446maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
447zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
448pomiędzy dwoma hostami.
449
450Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
451
452%description gnome-askpass -l pt_BR.UTF-8
453Esse pacote contém um programa que abre uma caixa de diálogo para
454entrada de passphrase no GNOME.
455
456%description gnome-askpass -l ru.UTF-8
457Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
458машину и для выполнения команд на удаленной машине.
459
460Этот пакет содержит диалог ввода ключевой фразы для использования под
461GNOME.
462
463%description gnome-askpass -l uk.UTF-8
464Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
465машини та для виконання команд на віддаленій машині.
466
467Цей пакет містить діалог вводу ключової фрази для використання під
468GNOME.
469
470%prep
471%setup -q
472%patch0 -p1
473%patch2 -p1
474%patch3 -p1
475%patch4 -p1
476%{?with_ldap:%patch5 -p1}
477%patch6 -p1
478#%patch7 -p1
479%patch8 -p1
480%patch9 -p1
481%{?with_hpn:%patch10 -p1}
482%{?with_hpn_none:%patch11 -p1}
483%patch12 -p1
484
485%build
486cp /usr/share/automake/config.sub .
487%{__aclocal}
488%{__autoconf}
489%{?with_chroot:CPPFLAGS="-DCHROOT"}
490%configure \
491 PERL=%{__perl} \
492 --with-dns \
493 --with-pam \
494 --with-mantype=man \
495 --with-md5-passwords \
496 --with-ipaddr-display \
497 %{?with_libedit:--with-libedit} \
498 --with-4in6 \
499 --disable-suid-ssh \
500 --with-tcp-wrappers \
501 %{?with_ldap:--with-libs="-lldap -llber"} \
502 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
503 %{?with_kerberos5:--with-kerberos5=/usr} \
504 --with-privsep-path=%{_privsepdir} \
505 --with-pid-dir=%{_localstatedir}/run \
506 --with-xauth=/usr/bin/xauth \
507 --enable-utmpx \
508 --enable-wtmpx
509
510echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
511
512%{__make}
513
514cd contrib
515%if %{with gnome}
516%{__make} gnome-ssh-askpass1 \
517 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
518%endif
519%if %{with gtk}
520%{__make} gnome-ssh-askpass2 \
521 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
522%endif
523
524%install
525rm -rf $RPM_BUILD_ROOT
526install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
527 $RPM_BUILD_ROOT%{_libexecdir}/ssh
528install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
529
530%{__make} install \
531 DESTDIR=$RPM_BUILD_ROOT
532
533bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
534
535install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
536install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
537install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
538install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
539ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
540install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
541
542%if %{with gnome}
543install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
544%endif
545%if %{with gtk}
546install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
547%endif
548%if %{with gnome} || %{with gtk}
549cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
550#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
551EOF
552cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
553#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
554EOF
555ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
556%endif
557
558rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
559echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
560
561touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
562
563%if "%{_lib}" != "lib"
564find $RPM_BUILD_ROOT%{_sysconfdir} -type f -print0 | xargs -0 sed -i -e 's#%{_prefix}/lib#%{_libdir}#'
565%endif
566
567cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
568#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
569EOF
570
571rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
572rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
573
574%clean
575rm -rf $RPM_BUILD_ROOT
576
577%post clients
578%env_update
579
580%postun clients
581%env_update
582
583%post gnome-askpass
584%env_update
585
586%postun gnome-askpass
587%env_update
588
589%pre server
590%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
591
592%post server
593/sbin/chkconfig --add sshd
594%service sshd reload "openssh daemon"
595if ! grep -qs ssh /etc/security/passwd.conf ; then
596 umask 022
597 echo "ssh" >> /etc/security/passwd.conf
598fi
599
600%preun server
601if [ "$1" = "0" ]; then
602 %service sshd stop
603 /sbin/chkconfig --del sshd
604fi
605
606%postun server
607if [ "$1" = "0" ]; then
608 %userremove sshd
609fi
610
611%files
612%defattr(644,root,root,755)
613%doc *.RNG TODO README OVERVIEW CREDITS Change*
614%attr(755,root,root) %{_bindir}/ssh-key*
615%{_mandir}/man1/ssh-key*.1*
616%dir %{_sysconfdir}
617%dir %{_libexecdir}
618
619%files clients
620%defattr(644,root,root,755)
621%attr(755,root,root) %{_bindir}/ssh
622%attr(755,root,root) %{_bindir}/slogin
623%attr(755,root,root) %{_bindir}/sftp
624%attr(755,root,root) %{_bindir}/ssh-agent
625%attr(755,root,root) %{_bindir}/ssh-add
626%attr(755,root,root) %{_bindir}/scp
627%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
628%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
629%{_mandir}/man1/scp.1*
630%{_mandir}/man1/ssh.1*
631%{_mandir}/man1/slogin.1*
632%{_mandir}/man1/sftp.1*
633%{_mandir}/man1/ssh-agent.1*
634%{_mandir}/man1/ssh-add.1*
635%{_mandir}/man5/ssh_config.5*
636%lang(it) %{_mandir}/it/man1/ssh.1*
637%lang(it) %{_mandir}/it/man5/ssh_config.5*
638%lang(pl) %{_mandir}/pl/man1/scp.1*
639%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
640
641# for host-based auth (suid required for accessing private host key)
642#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
643#%{_mandir}/man8/ssh-keysign.8*
644
645%files clients-agent-profile_d
646%defattr(644,root,root,755)
647%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
648%attr(755,root,root) /etc/profile.d/ssh-agent.sh
649
650%files clients-agent-xinitrc
651%defattr(644,root,root,755)
652%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
653
654%files server
655%defattr(644,root,root,755)
656%attr(755,root,root) %{_sbindir}/sshd
657%attr(755,root,root) %{_libexecdir}/sftp-server
658%attr(755,root,root) %{_libexecdir}/ssh-keysign
659%{_mandir}/man8/sshd.8*
660%{_mandir}/man8/sftp-server.8*
661%{_mandir}/man8/ssh-keysign.8*
662%{_mandir}/man5/sshd_config.5*
663%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
664%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
665%attr(640,root,root) %{_sysconfdir}/moduli
666%attr(754,root,root) /etc/rc.d/init.d/sshd
667%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
668%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
669
670%if %{with gnome} || %{with gtk}
671%files gnome-askpass
672%defattr(644,root,root,755)
673%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
674%dir %{_libexecdir}/ssh
675%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
676%attr(755,root,root) %{_libexecdir}/ssh-askpass
677%endif
This page took 0.071842 seconds and 4 git commands to generate.