]> git.pld-linux.org Git - packages/openssh.git/blame_incremental - openssh.spec
- SERVICE=syslog replaced with SERVICE_syslog=y in upstart job
[packages/openssh.git] / openssh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
4%bcond_without gtk # without GTK+ (2.x)
5%bcond_without ldap # with ldap support
6%bcond_without libedit # without libedit (editline/history support in sftp client)
7%bcond_without kerberos5 # without kerberos5 support
8%bcond_without selinux # build without SELinux support
9%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
10
11# gtk2-based gnome-askpass means no gnome1-based
12%{?with_gtk:%undefine with_gnome}
13
14%if "%{pld_release}" == "ac"
15%define pam_ver 0.79.0
16%else
17%define pam_ver 0.99.7.1
18%endif
19
20Summary: OpenSSH free Secure Shell (SSH) implementation
21Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
22Summary(es.UTF-8): Implementación libre de SSH
23Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
24Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
25Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
26Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27Summary(pt_BR.UTF-8): Implementação livre do SSH
28Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
29Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
30Name: openssh
31Version: 5.8p2
32Release: 2
33Epoch: 2
34License: BSD
35Group: Applications/Networking
36Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
37# Source0-md5: 88a4a83b0e0e60cd545430d4e4bd7e0c
38Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39# Source1-md5: 66943d481cc422512b537bcc2c7400d1
40Source2: %{name}d.init
41Source3: %{name}d.pamd
42Source4: %{name}.sysconfig
43Source5: ssh-agent.sh
44Source6: ssh-agent.conf
45Source7: %{name}-lpk.schema
46Source8: %{name}d.upstart
47Patch100: %{name}-heimdal.patch
48Patch0: %{name}-no_libnsl.patch
49Patch2: %{name}-pam_misc.patch
50Patch3: %{name}-sigpipe.patch
51# http://code.google.com/p/openssh-lpk/
52Patch4: %{name}-lpk.patch
53Patch5: %{name}-config.patch
54# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
55# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
56Patch9: %{name}-5.2p1-hpn13v6.diff
57Patch10: %{name}-include.patch
58Patch11: %{name}-chroot.patch
59# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
60Patch12: %{name}-blacklist.diff
61Patch13: %{name}-kuserok.patch
62URL: http://www.openssh.com/portable.html
63BuildRequires: %{__perl}
64BuildRequires: autoconf
65BuildRequires: automake
66%{?with_gnome:BuildRequires: gnome-libs-devel}
67%{?with_gtk:BuildRequires: gtk+2-devel}
68%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
69%{?with_libedit:BuildRequires: libedit-devel}
70%{?with_selinux:BuildRequires: libselinux-devel}
71BuildRequires: libwrap-devel
72%{?with_ldap:BuildRequires: openldap-devel}
73BuildRequires: openssl-devel >= 0.9.7d
74BuildRequires: pam-devel
75%{?with_gtk:BuildRequires: pkgconfig}
76BuildRequires: rpm >= 4.4.9-56
77BuildRequires: rpmbuild(macros) >= 1.318
78BuildRequires: sed >= 4.0
79BuildRequires: zlib-devel
80%if "%{pld_release}" == "ac"
81Requires: filesystem >= 2.0-1
82Requires: pam >= 0.79.0
83%else
84Requires: filesystem >= 3.0-11
85Requires: pam >= %{pam_ver}
86Suggests: openssh-blacklist
87Suggests: xorg-app-xauth
88%endif
89Obsoletes: ssh
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92%define _sysconfdir /etc/ssh
93%define _libexecdir %{_libdir}/%{name}
94%define _privsepdir /usr/share/empty
95%define schemadir /usr/share/openldap/schema
96
97%description
98Ssh (Secure Shell) a program for logging into a remote machine and for
99executing commands in a remote machine. It is intended to replace
100rlogin and rsh, and provide secure encrypted communications between
101two untrusted hosts over an insecure network. X11 connections and
102arbitrary TCP/IP ports can also be forwarded over the secure channel.
103
104OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
105it up to date in terms of security and features, as well as removing
106all patented algorithms to seperate libraries (OpenSSL).
107
108This package includes the core files necessary for both the OpenSSH
109client and server. To make this package useful, you should also
110install openssh-clients, openssh-server, or both.
111
112%if %{with hpn}
113This release includes High Performance SSH/SCP patches from
114http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
115increase throughput on fast connections with high RTT (20-150 msec).
116See the website for '-w' values for your connection and /proc/sys TCP
117values. BTW. in a LAN you have got generally RTT < 1 msec.
118%endif
119
120%description -l de.UTF-8
121OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
122ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
123verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
124über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
125andere TCP/IP Ports können ebenso über den sicheren Channel
126weitergeleitet werden.
127
128%description -l es.UTF-8
129SSH es un programa para accesar y ejecutar órdenes en computadores
130remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
131seguro entre dos servidores en una red insegura. Conexiones X11 y
132puertas TCP/IP arbitrárias también pueden ser usadas por el canal
133seguro.
134
135OpenSSH es el resultado del trabajo del equipo de OpenBSD para
136continuar la última versión gratuita de SSH, actualizándolo en
137términos de seguridad y recursos,así también eliminando todos los
138algoritmos patentados y colocándolos en bibliotecas separadas
139(OpenSSL).
140
141Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
142también el paquete openssh-clients u openssh-server o ambos.
143
144%description -l fr.UTF-8
145OpenSSH (Secure Shell) fournit un accès à un système distant. Il
146remplace telnet, rlogin, rexec et rsh, tout en assurant des
147communications cryptées securisées entre deux hôtes non fiabilisés sur
148un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
149arbitraires peuvent également être transmis sur le canal sécurisé.
150
151%description -l it.UTF-8
152OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
153Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
154sicure e crittate tra due host non fidati su una rete non sicura. Le
155connessioni X11 ad una porta TCP/IP arbitraria possono essere
156inoltrate attraverso un canale sicuro.
157
158%description -l pl.UTF-8
159Ssh (Secure Shell) to program służący do logowania się na zdalną
160maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
161zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
162pomiędzy dwoma hostami.
163
164Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
165klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
166co najmniej jeden z pakietów: openssh-clients lub openssh-server.
167
168%if %{with hpn}
169Ta wersja zawiera łaty z projektu High Performance SSH/SCP
170http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
171zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
172RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
173danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
174TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
175%endif
176
177%description -l pt.UTF-8
178OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
179telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
180cifradas entre duas máquinas sem confiança mútua sobre uma rede
181insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
182reenviados pelo canal seguro.
183
184%description -l pt_BR.UTF-8
185SSH é um programa para acessar e executar comandos em máquinas
186remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
187seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
188TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
189
190OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
191última versão gratuita do SSH, atualizando-o em termos de segurança e
192recursos, assim como removendo todos os algoritmos patenteados e
193colocando-os em bibliotecas separadas (OpenSSL).
194
195Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
196também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
197
198%description -l ru.UTF-8
199Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
200машину и для выполнения команд на удаленной машине. Она предназначена
201для замены rlogin и rsh и обеспечивает безопасную шифрованную
202коммуникацию между двумя хостами в сети, являющейся небезопасной.
203Соединения X11 и любые порты TCP/IP могут также быть проведены через
204безопасный канал.
205
206OpenSSH - это переделка командой разработчиков OpenBSD последней
207свободной версии SSH, доведенная до современного состояния в терминах
208уровня безопасности и поддерживаемых возможностей. Все патентованные
209алгоритмы вынесены в отдельные библиотеки (OpenSSL).
210
211Этот пакет содержит файлы, необходимые как для клиента, так и для
212сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
213openssh-server, или оба пакета.
214
215%description -l uk.UTF-8
216Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
217машини та для виконання команд на віддаленій машині. Вона призначена
218для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
219між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
220довільні порти TCP/IP можуть також бути проведені через безпечний
221канал.
222
223OpenSSH - це переробка командою розробників OpenBSD останньої вільної
224версії SSH, доведена до сучасного стану в термінах рівня безпеки та
225підтримуваних можливостей. Всі патентовані алгоритми винесені до
226окремих бібліотек (OpenSSL).
227
228Цей пакет містить файли, необхідні як для клієнта, так і для сервера
229OpenSSH. Вам потрібно буде ще встановити openssh-clients,
230openssh-server, чи обидва пакети.
231
232%package clients
233Summary: OpenSSH Secure Shell protocol clients
234Summary(es.UTF-8): Clientes de OpenSSH
235Summary(pl.UTF-8): Klienci protokołu Secure Shell
236Summary(pt_BR.UTF-8): Clientes do OpenSSH
237Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
238Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
239Group: Applications/Networking
240Requires: %{name}
241Provides: ssh-clients
242Obsoletes: ssh-clients
243
244%description clients
245Ssh (Secure Shell) a program for logging into a remote machine and for
246executing commands in a remote machine. It is intended to replace
247rlogin and rsh, and provide secure encrypted communications between
248two untrusted hosts over an insecure network. X11 connections and
249arbitrary TCP/IP ports can also be forwarded over the secure channel.
250
251OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
252it up to date in terms of security and features, as well as removing
253all patented algorithms to seperate libraries (OpenSSL).
254
255This package includes the clients necessary to make encrypted
256connections to SSH servers.
257
258%description clients -l es.UTF-8
259Este paquete incluye los clientes que se necesitan para hacer
260conexiones codificadas con servidores SSH.
261
262%description clients -l pl.UTF-8
263Ssh (Secure Shell) to program służący do logowania się na zdalną
264maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
265zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
266pomiędzy dwoma hostami.
267
268Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
269
270%description clients -l pt_BR.UTF-8
271Esse pacote inclui os clientes necessários para fazer conexões
272encriptadas com servidores SSH.
273
274%description clients -l ru.UTF-8
275Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
276машину и для выполнения команд на удаленной машине.
277
278Этот пакет содержит программы-клиенты, необходимые для установления
279зашифрованных соединений с серверами SSH.
280
281%description clients -l uk.UTF-8
282Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
283машини та для виконання команд на віддаленій машині.
284
285Цей пакет містить програми-клієнти, необхідні для встановлення
286зашифрованих з'єднань з серверами SSH.
287
288%package clients-agent-profile_d
289Summary: OpenSSH Secure Shell agent init script
290Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
291Group: Applications/Networking
292Requires: %{name}-clients = %{epoch}:%{version}-%{release}
293
294%description clients-agent-profile_d
295profile.d scripts for starting SSH agent.
296
297%description clients-agent-profile_d -l pl.UTF-8
298Skrypty profile.d do uruchamiania agenta SSH.
299
300%package clients-agent-xinitrc
301Summary: OpenSSH Secure Shell agent init script
302Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
303Group: Applications/Networking
304Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
305Requires: xinitrc
306
307%description clients-agent-xinitrc
308xinitrc scripts for starting SSH agent.
309
310%description clients-agent-xinitrc -l pl.UTF-8
311Skrypty xinitrc do uruchamiania agenta SSH.
312
313%package server
314Summary: OpenSSH Secure Shell protocol server (sshd)
315Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
316Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
317Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
318Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
319Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
320Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
321Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
322Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
323Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
324Group: Networking/Daemons
325Requires(post): /sbin/chkconfig
326Requires(post): grep
327Requires(post,preun): /sbin/chkconfig
328Requires(postun): /usr/sbin/userdel
329Requires(pre): /bin/id
330Requires(pre): /usr/sbin/useradd
331Requires: %{name} = %{epoch}:%{version}-%{release}
332Requires: pam >= %{pam_ver}
333Requires: rc-scripts >= 0.4.3.0
334Requires: util-linux
335Suggests: /bin/login
336Provides: ssh-server
337Provides: user(sshd)
338
339%description server
340Ssh (Secure Shell) a program for logging into a remote machine and for
341executing commands in a remote machine. It is intended to replace
342rlogin and rsh, and provide secure encrypted communications between
343two untrusted hosts over an insecure network. X11 connections and
344arbitrary TCP/IP ports can also be forwarded over the secure channel.
345
346OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
347it up to date in terms of security and features, as well as removing
348all patented algorithms to seperate libraries (OpenSSL).
349
350This package contains the secure shell daemon. The sshd is the server
351part of the secure shell protocol and allows ssh clients to connect to
352your host.
353
354%description server -l de.UTF-8
355Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
356
357%description server -l es.UTF-8
358Este paquete contiene el servidor SSH. sshd es la parte servidor del
359protocolo secure shell y permite que clientes ssh se conecten a su
360servidor.
361
362%description server -l fr.UTF-8
363Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
364
365%description server -l it.UTF-8
366Questo pacchetto installa sshd, il server di OpenSSH.
367
368%description server -l pl.UTF-8
369Ssh (Secure Shell) to program służący do logowania się na zdalną
370maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
371zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
372pomiędzy dwoma hostami.
373
374Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
375ssh).
376
377%description server -l pt.UTF-8
378Este pacote intala o sshd, o servidor do OpenSSH.
379
380%description server -l pt_BR.UTF-8
381Esse pacote contém o servidor SSH. O sshd é a parte servidor do
382protocolo secure shell e permite que clientes ssh se conectem ao seu
383host.
384
385%description server -l ru.UTF-8
386Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
387машину и для выполнения команд на удаленной машине.
388
389Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
390часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
391вашим хостом.
392
393%description server -l uk.UTF-8
394Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
395машини та для виконання команд на віддаленій машині.
396
397Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
398частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
399з вашим хостом.
400
401%package server-upstart
402Summary: Upstart job description for OpenSSH server
403Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
404Group: Daemons
405Requires: %{name}-server = %{epoch}:%{version}-%{release}
406Requires: upstart >= 0.6
407Conflicts: syslog-ng < 3.2.4-1
408
409%description server-upstart
410Upstart job description for OpenSSH.
411
412%description server-upstart -l pl.UTF-8
413Opis zadania Upstart dla OpenSSH.
414
415%package gnome-askpass
416Summary: OpenSSH GNOME passphrase dialog
417Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
418Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
419Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
420Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
421Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
422Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
423Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
424Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
425Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
426Group: Applications/Networking
427Requires: %{name} = %{epoch}:%{version}-%{release}
428Obsoletes: openssh-askpass
429Obsoletes: ssh-askpass
430Obsoletes: ssh-extras
431
432%description gnome-askpass
433Ssh (Secure Shell) a program for logging into a remote machine and for
434executing commands in a remote machine. It is intended to replace
435rlogin and rsh, and provide secure encrypted communications between
436two untrusted hosts over an insecure network. X11 connections and
437arbitrary TCP/IP ports can also be forwarded over the secure channel.
438
439OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
440it up to date in terms of security and features, as well as removing
441all patented algorithms to seperate libraries (OpenSSL).
442
443This package contains the GNOME passphrase dialog.
444
445%description gnome-askpass -l es.UTF-8
446Este paquete contiene un programa que abre una caja de diálogo para
447entrada de passphrase en GNOME.
448
449%description gnome-askpass -l pl.UTF-8
450Ssh (Secure Shell) to program służący do logowania się na zdalną
451maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
452zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
453pomiędzy dwoma hostami.
454
455Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
456
457%description gnome-askpass -l pt_BR.UTF-8
458Esse pacote contém um programa que abre uma caixa de diálogo para
459entrada de passphrase no GNOME.
460
461%description gnome-askpass -l ru.UTF-8
462Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
463машину и для выполнения команд на удаленной машине.
464
465Этот пакет содержит диалог ввода ключевой фразы для использования под
466GNOME.
467
468%description gnome-askpass -l uk.UTF-8
469Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
470машини та для виконання команд на віддаленій машині.
471
472Цей пакет містить діалог вводу ключової фрази для використання під
473GNOME.
474
475%package -n openldap-schema-openssh-lpk
476Summary: OpenSSH LDAP Public Key schema
477Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
478Group: Networking/Daemons
479Requires(post,postun): sed >= 4.0
480Requires: openldap-servers
481
482%description -n openldap-schema-openssh-lpk
483This package contains OpenSSH LDAP Public Key schema for openldap.
484
485%description -n openldap-schema-openssh-lpk -l pl.UTF-8
486Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
487openldap-a.
488
489%prep
490%setup -q
491%{?with_kerberos5:%patch100 -p1}
492%patch0 -p1
493%patch2 -p1
494%patch3 -p1
495%{?with_ldap:%patch4 -p1}
496%patch5 -p1
497%{?with_hpn:%patch9 -p1}
498%patch10 -p1
499%patch11 -p1
500%patch12 -p1
501%patch13 -p1
502
503cp -p %{SOURCE3} sshd.pam
504install -p %{SOURCE2} sshd.init
505
506%if "%{pld_release}" == "ac"
507# fix for missing x11.pc
508%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
509# not present in ac, no point searching it
510%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
511
512# openssl on ac does not have OPENSSL_HAS_ECC
513%{__sed} -i -e '/ecdsa/d' sshd.init
514%endif
515
516%build
517cp /usr/share/automake/config.sub .
518%{__aclocal}
519%{__autoconf}
520CPPFLAGS="-DCHROOT"
521%configure \
522 PERL=%{__perl} \
523 --with-pam \
524 --with-mantype=man \
525 --with-md5-passwords \
526 --with-ipaddr-display \
527 %{?with_libedit:--with-libedit} \
528 --with-4in6 \
529 --with-tcp-wrappers \
530 %{?with_ldap:--with-libs="-lldap -llber"} \
531 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
532 %{?with_kerberos5:--with-kerberos5=/usr} \
533 --with-privsep-path=%{_privsepdir} \
534 --with-pid-dir=%{_localstatedir}/run \
535%if "%{pld_release}" == "ac"
536 --with-xauth=/usr/X11R6/bin/xauth \
537%else
538 --with-xauth=%{_bindir}/xauth \
539%endif
540 --enable-utmpx \
541 --enable-wtmpx
542
543echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
544
545%{__make}
546
547cd contrib
548%if %{with gnome}
549%{__make} gnome-ssh-askpass1 \
550 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
551%endif
552%if %{with gtk}
553%{__make} gnome-ssh-askpass2 \
554 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
555%endif
556
557%install
558rm -rf $RPM_BUILD_ROOT
559install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
560 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
561install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
562
563%{__make} install \
564 DESTDIR=$RPM_BUILD_ROOT
565
566bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
567
568install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
569cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
570cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
571cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
572ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
573cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
574cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
575cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
576
577%if %{with gnome}
578install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
579%endif
580%if %{with gtk}
581install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
582%endif
583%if %{with gnome} || %{with gtk}
584cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
585#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
586EOF
587cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
588#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
589EOF
590ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
591%endif
592
593install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
594cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
595
596rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
597echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
598
599touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
600
601cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
602#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
603EOF
604
605rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
606rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
607
608%clean
609rm -rf $RPM_BUILD_ROOT
610
611%post clients
612%env_update
613
614%postun clients
615%env_update
616
617%post gnome-askpass
618%env_update
619
620%postun gnome-askpass
621%env_update
622
623%pre server
624%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
625
626%post server
627/sbin/chkconfig --add sshd
628%service sshd reload "openssh daemon"
629if ! grep -qs ssh /etc/security/passwd.conf ; then
630 umask 022
631 echo "ssh" >> /etc/security/passwd.conf
632fi
633
634%preun server
635if [ "$1" = "0" ]; then
636 %service sshd stop
637 /sbin/chkconfig --del sshd
638fi
639
640%postun server
641if [ "$1" = "0" ]; then
642 %userremove sshd
643fi
644
645%post server-upstart
646%upstart_post sshd
647
648%postun server-upstart
649%upstart_postun sshd
650
651%post -n openldap-schema-openssh-lpk
652%openldap_schema_register %{schemadir}/openssh-lpk.schema
653%service -q ldap restart
654
655%postun -n openldap-schema-openssh-lpk
656if [ "$1" = "0" ]; then
657 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
658 %service -q ldap restart
659fi
660
661%files
662%defattr(644,root,root,755)
663%doc *.RNG TODO README OVERVIEW CREDITS Change*
664%attr(755,root,root) %{_bindir}/ssh-key*
665%attr(755,root,root) %{_bindir}/ssh-vulnkey*
666%{_mandir}/man1/ssh-key*.1*
667%{_mandir}/man1/ssh-vulnkey*.1*
668%dir %{_sysconfdir}
669%dir %{_libexecdir}
670
671%files clients
672%defattr(644,root,root,755)
673%attr(755,root,root) %{_bindir}/ssh
674%attr(755,root,root) %{_bindir}/slogin
675%attr(755,root,root) %{_bindir}/sftp
676%attr(755,root,root) %{_bindir}/ssh-agent
677%attr(755,root,root) %{_bindir}/ssh-add
678%attr(755,root,root) %{_bindir}/ssh-copy-id
679%attr(755,root,root) %{_bindir}/scp
680%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
681%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
682%{_mandir}/man1/scp.1*
683%{_mandir}/man1/ssh.1*
684%{_mandir}/man1/slogin.1*
685%{_mandir}/man1/sftp.1*
686%{_mandir}/man1/ssh-agent.1*
687%{_mandir}/man1/ssh-add.1*
688%{_mandir}/man1/ssh-copy-id.1*
689%{_mandir}/man5/ssh_config.5*
690%lang(it) %{_mandir}/it/man1/ssh.1*
691%lang(it) %{_mandir}/it/man5/ssh_config.5*
692%lang(pl) %{_mandir}/pl/man1/scp.1*
693%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
694
695# for host-based auth (suid required for accessing private host key)
696#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
697#%{_mandir}/man8/ssh-keysign.8*
698
699%files clients-agent-profile_d
700%defattr(644,root,root,755)
701%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
702%attr(755,root,root) /etc/profile.d/ssh-agent.sh
703
704%files clients-agent-xinitrc
705%defattr(644,root,root,755)
706%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
707
708%files server
709%defattr(644,root,root,755)
710%attr(755,root,root) %{_sbindir}/sshd
711%attr(755,root,root) %{_libexecdir}/sftp-server
712%attr(755,root,root) %{_libexecdir}/ssh-keysign
713%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
714%{_mandir}/man8/sshd.8*
715%{_mandir}/man8/sftp-server.8*
716%{_mandir}/man8/ssh-keysign.8*
717%{_mandir}/man8/ssh-pkcs11-helper.8*
718%{_mandir}/man5/sshd_config.5*
719%{_mandir}/man5/moduli.5*
720%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
721%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
722%attr(640,root,root) %{_sysconfdir}/moduli
723%attr(754,root,root) /etc/rc.d/init.d/sshd
724%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
725%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
726
727%if %{with gnome} || %{with gtk}
728%files gnome-askpass
729%defattr(644,root,root,755)
730%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
731%dir %{_libexecdir}/ssh
732%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
733%attr(755,root,root) %{_libexecdir}/ssh-askpass
734%endif
735
736%if %{with ldap}
737%files -n openldap-schema-openssh-lpk
738%defattr(644,root,root,755)
739%{schemadir}/openssh-lpk.schema
740%endif
741
742%if "%{pld_release}" != "ti"
743%files server-upstart
744%defattr(644,root,root,755)
745%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
746%endif
This page took 0.042995 seconds and 4 git commands to generate.