]> git.pld-linux.org Git - packages/nginx.git/blame_incremental - nginx.spec
- should work without make clean - make clean breaks build if --without perl
[packages/nginx.git] / nginx.spec
... / ...
CommitLineData
1# TODO
2# - /etc/sysconfig/nginx file
3# - missing perl build/install requires
4# - prepare pld style like nginx.conf
5# - maybe -with-cpu-opt=CPU (pentium, pentiumpro, pentium3, pentium4, athlon, opteron, amd64, sparc32, sparc64, ppc64)
6#
7# Conditional build for nginx:
8%bcond_without light # don't build light version
9%bcond_without mail # don't build imap/mail proxy
10%bcond_without perl # don't build with perl module
11%bcond_without addition # adds module
12%bcond_without dav # WebDAV
13%bcond_without flv # FLV stream
14%bcond_without sub # ngx_http_sub_module
15%bcond_without poll # poll
16%bcond_without realip # real ip (behind proxy)
17%bcond_without rtsig # rtsig
18%bcond_without select # select
19%bcond_without status # stats module
20%bcond_without ssl # ssl support
21%bcond_with http_browser # header "User-agent" parser
22#
23Summary: High perfomance HTTP and reverse proxy server
24Summary(pl.UTF-8): Serwer HTTP i odwrotne proxy o wysokiej wydajności
25Name: nginx
26Version: 0.5.33
27Release: 0.7
28License: BSD-like
29Group: Networking/Daemons
30Source0: http://sysoev.ru/nginx/%{name}-%{version}.tar.gz
31# Source0-md5: a78be74b4fd8e009545ef02488fcac86
32Source1: http://www.nginx.eu/favicon.ico
33# Source1-md5: 2aaf2115c752cbdbfb8a2f0b3c3189ab
34Source2: http://www.nginx.eu/download/proxy.conf
35# Source2-md5: f5263ae01c2edb18f46d5d1df2d3a5cd
36Source3: %{name}.logrotate
37Source4: %{name}.mime
38Source5: %{name}-light.conf
39Source6: %{name}-light.monitrc
40Source7: %{name}-light.init
41Source8: %{name}-mail.conf
42Source9: %{name}-mail.monitrc
43Source10: %{name}-mail.init
44Source11: %{name}-perl.conf
45Source12: %{name}-perl.monitrc
46Source13: %{name}-perl.init
47Source14: %{name}-standard.conf
48Source15: %{name}-standard.monitrc
49Source15: %{name}-standard.init
50Source16: %{name}-mime.types.sh
51Patch0: %{name}-config.patch
52URL: http://nginx.net/
53BuildRequires: mailcap
54BuildRequires: openssl-devel
55BuildRequires: pcre-devel
56%{?with_perl:BuildRequires: perl-CGI}
57%{?with_perl:BuildRequires: perl-devel}
58%{?with_perl:BuildRequires: rpm-perlprov}
59BuildRequires: rpmbuild(macros) >= 1.268
60BuildRequires: zlib-devel
61Requires(post,preun): /sbin/chkconfig
62Requires(postun): /usr/sbin/groupdel
63Requires(postun): /usr/sbin/userdel
64Requires(pre): /bin/id
65Requires(pre): /usr/bin/getgid
66Requires(pre): /usr/sbin/groupadd
67Requires(pre): /usr/sbin/useradd
68Requires: nginx-daemon
69Requires: openssl
70Requires: pcre
71Requires: rc-scripts >= 0.2.0
72Requires: zlib
73Provides: group(http)
74Provides: group(nginx)
75Provides: user(nginx)
76Provides: webserver
77Suggests: nginx-standard
78Conflicts: logrotate < 3.7-4
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81%define _sysconfdir /etc/%{name}
82%define _nginxdir /home/services/%{name}
83
84%description
85Nginx ("engine x") is a high-performance HTTP server and reverse
86proxy, as well as an IMAP/POP3 proxy server. Nginx was written by Igor
87Sysoev for Rambler.ru, Russia's second-most visited website, where it
88has been running in production for over two and a half years. Igor has
89released the source code under a BSD-like license. Although still in
90beta, Nginx is known for its stability, rich feature set, simple
91configuration, and low resource consumption.
92
93Common files for Nginx daemon.
94
95%description -l pl.UTF-8
96Nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
97a także IMAP/POP3 proxy. Nginx został napisany przez Igora Sysoev'a
98na potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
99odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
100opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle
101