]> git.pld-linux.org Git - packages/mpfr.git/blame_incremental - mpfr.spec
- updated to 3.1.5
[packages/mpfr.git] / mpfr.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make check
4#
5Summary: Multiple-precision floating-point computations library
6Summary(pl.UTF-8): Biblioteka obliczeń zmiennoprzecinkowych wielokrotnej precyzji
7Name: mpfr
8Version: 3.1.5
9Release: 1
10License: LGPL v3+
11Group: Libraries
12Source0: http://www.mpfr.org/mpfr-current/%{name}-%{version}.tar.xz
13# Source0-md5: c4ac246cf9795a4491e7766002cd528f
14Patch0: %{name}-info.patch
15URL: http://www.mpfr.org/
16BuildRequires: autoconf >= 2.50
17BuildRequires: automake >= 1:1.13
18BuildRequires: gmp-devel >= 4.1.0
19BuildRequires: libtool
20BuildRequires: tar >= 1:1.22
21BuildRequires: texinfo
22BuildRequires: xz
23Requires: gmp >= 4.1.0
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27The MPFR library is a C library for multiple-precision floating-point
28computations with exact rounding (also called correct rounding). It is
29based on the GMP multiple-precision library. The main goal of MPFR is
30to provide a library for multiple-precision floating-point computation
31which is both efficient and has a well-defined semantics. It copies
32the good ideas from the ANSI/IEEE-754 standard for double-precision
33floating-point arithmetic (53-bit mantissa).
34
35%description -l pl.UTF-8
36Biblioteka MPFR to biblioteka C do obliczeń zmiennoprzecinkowych z
37wielokrotną precyzją i dokładnym zaokrąglaniem (zwanym także poprawnym
38zaokrąglaniem). Jest oparta na bibliotece GMP wielokrotnej precyzji.
39Głównym celem MPFR jest dostarczenie biblioteki do obliczeń
40zmiennoprzecinkowych wielokrotnej precyzji, która jest wydajna i ma
41dobrze zdefiniowaną semantykę. Powiela dobre idee ze standardu
42ANSI/IEEE-754 dla arytmetyki zmiennoprzecinkowej podwójnej precyzji (z
4353-bitową mantysą).
44
45%package devel
46Summary: Header files for MPFR library
47Summary(pl.UTF-8): Pliki nagłówkowe biblioteki MPFR
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: gmp-devel >= 4.1.0
51Obsoletes: libmpfr-devel
52
53%description devel
54Header files for MPFR library.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe biblioteki MPFR.
58
59%package static
60Summary: Static MPFR library
61Summary(pl.UTF-8): Statyczna biblioteka MPFR
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66Static MPFR library.
67
68%description static -l pl.UTF-8
69Statyczna biblioteka MPFR.
70
71%prep
72%setup -q
73%patch0 -p1
74
75# triggers bug in gold (as of binutils-2.21.53.0.2-1.i686)
76mkdir my-ld
77if [ -x /usr/bin/ld.bfd ]; then
78 ln -s /usr/bin/ld.bfd my-ld/ld
79fi
80
81%build
82export PATH=$PWD/my-ld:$PATH
83%{__libtoolize}
84%{__aclocal} -I m4
85%{__autoconf}
86%{__automake}
87%configure \
88 --enable-shared
89
90# make -j4 creates truncated .lo files
91%{__make} -j1 all
92
93%if %{with tests}
94%{__make} check
95%endif
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100%{__make} install \
101 DESTDIR=$RPM_BUILD_ROOT
102
103rm -f $RPM_BUILD_ROOT%{_infodir}/dir
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%post devel -p /sbin/postshell
112-/usr/sbin/fix-info-dir -c %{_infodir}
113
114%postun devel -p /sbin/postshell
115-/usr/sbin/fix-info-dir -c %{_infodir}
116
117%files
118%defattr(644,root,root,755)
119%doc AUTHORS BUGS ChangeLog NEWS README TODO doc/FAQ.html
120%attr(755,root,root) %{_libdir}/libmpfr.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libmpfr.so.4
122
123%files devel
124%defattr(644,root,root,755)
125%attr(755,root,root) %{_libdir}/libmpfr.so
126%{_libdir}/libmpfr.la
127%{_includedir}/mpfr.h
128%{_includedir}/mpf2mpfr.h
129%{_infodir}/mpfr.info*
130
131%files static
132%defattr(644,root,root,755)
133%{_libdir}/libmpfr.a
This page took 0.408758 seconds and 4 git commands to generate.